“The real voyage of discovery consists not in seeking new landscapes, but in having new eyes.”

Marcel Proust
# Contents

**JMP User Guide**

<table>
<thead>
<tr>
<th>1</th>
<th>Preliminaries</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>JMP Statistical Discovery</strong></td>
<td>1</td>
</tr>
<tr>
<td>What You Need to Know</td>
<td>3</td>
</tr>
<tr>
<td>Learning About JMP</td>
<td>3</td>
</tr>
<tr>
<td>Using Tutorials</td>
<td>3</td>
</tr>
<tr>
<td>Searching in Help</td>
<td>3</td>
</tr>
<tr>
<td>Learning About Statistical and JSL Terms</td>
<td>4</td>
</tr>
<tr>
<td>Using the Context-Sensitive Help</td>
<td>5</td>
</tr>
<tr>
<td>Learning JMP Tips &amp; Tricks</td>
<td>6</td>
</tr>
<tr>
<td>Using This Book in Combination with Other Included Books</td>
<td>6</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>2</th>
<th>Creating and Opening Files</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Tables, Scripts, and Journals</td>
<td>7</td>
</tr>
<tr>
<td>Before You Start</td>
<td>9</td>
</tr>
<tr>
<td>The Tip of the Day Window</td>
<td>9</td>
</tr>
<tr>
<td>The JMP Starter Window</td>
<td>10</td>
</tr>
<tr>
<td>Creating New Data Tables</td>
<td>10</td>
</tr>
<tr>
<td>Opening Existing JMP Files</td>
<td>11</td>
</tr>
<tr>
<td>Importing Data</td>
<td>13</td>
</tr>
<tr>
<td>Opening Text Files</td>
<td>13</td>
</tr>
<tr>
<td>Opening a Text File in a Text Editing Window</td>
<td>18</td>
</tr>
<tr>
<td>Importing Text as Data</td>
<td>20</td>
</tr>
<tr>
<td>Opening Excel and OpenOffice Files</td>
<td>21</td>
</tr>
<tr>
<td>Opening SAS Datasets</td>
<td>22</td>
</tr>
<tr>
<td>Opening SAS Transport Files</td>
<td>24</td>
</tr>
<tr>
<td>Opening Data from a Database</td>
<td>25</td>
</tr>
<tr>
<td>Retrieving Data Using SQL Statements</td>
<td>27</td>
</tr>
<tr>
<td>Structured Query Language (SQL): A Reference</td>
<td>28</td>
</tr>
<tr>
<td>Using the WHERE Clause Editor</td>
<td>32</td>
</tr>
<tr>
<td>Reading in Real-Time Data (Windows and Linux Only)</td>
<td>34</td>
</tr>
<tr>
<td>Opening a File Using the Internet</td>
<td>34</td>
</tr>
<tr>
<td>Emailing Tables and Reports (Windows Only)</td>
<td>39</td>
</tr>
<tr>
<td>Creating Journals</td>
<td>39</td>
</tr>
</tbody>
</table>
The Data Filter
The Data Filter Control Panel
Adding Additional Groups of Variables to the Control Panel
Check Box Modes
Using Nominal or Ordinal Variables as Filter Columns
Selecting Continuous Values as Filters
Changing the Data Table After Making Data Filter Selections
Data Filter Menu Commands

4 How To Save Tables, Reports & Sessions
Different Saving Methods
Saving Data Tables
Saving .jmp Files for use in JMP 5.1.2 or Earlier
Saving as a Text File
Saving as a SAS Transport File
Saving as a SAS Dataset (Windows Only)
Saving as a Microsoft Excel File (Windows and Macintosh Only)
Saving Data Tables to a Database
Saving Reports
Saving Using the Journal Command
Saving Using the Layout Command
Saving Parts of a Report in a Graphic Format
Pasting Reports into Another Program
Saving JMP Sessions
Saving Sessions Upon Exiting
Saving Sessions Manually
Working with JMP Projects (Windows Only)
Creating a JMP Project
Saving and Closing a JMP Project
Adding Items to a JMP Project
Customizing the Project
Saving a Log Window
Specifying Where to Save Files (Windows Only)

5 Properties & Characteristics of Data
Customizing Columns and Rows
Assigning Characteristics to Rows and Columns
Excluding Rows and Columns
Hiding Rows and Columns
Labeling Rows and Columns
Giving Rows a Color
Adding Markers to Rows .................................................................................................................. 135
Assigning Colors or Markers to Rows According to Column Values .............................................. 135
Deleting All Row Characteristics ...................................................................................................... 137
Locking Columns in Place .................................................................................................................. 137
Giving Columns a Preselected Analysis Role .................................................................................... 138
Iconic Indicators ................................................................................................................................. 139
Assigning Properties to Columns ...................................................................................................... 140
Giving Columns a Formula to Compute Values ................................................................................ 141
Locking Columns ............................................................................................................................... 142
Adding Notes to Columns .................................................................................................................. 142
Validating Column Data .................................................................................................................... 143
Using Value Labels ............................................................................................................................ 146
Ordering Values in Columns .............................................................................................................. 147
Assigning Value Color Ranges .......................................................................................................... 149
Changing Columns’ Default Axis Settings .......................................................................................... 150
Defining Low and High Values (DOE Coding) for Columns ............................................................... 152
Setting Columns as Factors for Mixture Experiments ....................................................................... 153
Specifying How Rows Appear in Analysis Reports .......................................................................... 153
Entering Specification, Control, and Response Limits ...................................................................... 154
Giving Columns a Design Role .......................................................................................................... 156
Identifying Factor Changes ............................................................................................................... 157
Assigning Sigma Values to Columns .................................................................................................. 158
Specifying Columns’ Measuring Units ............................................................................................... 159
Creating Your Own Column Property .............................................................................................. 160
Removing Properties ......................................................................................................................... 160
Standardizing Attributes and Properties Across Columns ............................................................... 161
Adding Attributes and Properties ...................................................................................................... 161
Deleting Properties ............................................................................................................................. 162
Using Row State Columns ................................................................................................................ 162
Permanently Highlighting Cells ......................................................................................................... 165

6 Output Reports
How to Use the Report Window ......................................................................................................... 167
Editing Reports .................................................................................................................................... 169
Accessing General Report Formatting Options ................................................................................. 169
Showing and Hiding Parts of a Report ............................................................................................... 171
Renaming a Report ............................................................................................................................. 172
Increasing Font Sizes ........................................................................................................................ 173
Saving Results as Column Values ...................................................................................................... 173
Editing Data Table Rows from a Report ............................................................................................ 173
Understanding the $p$-value Indicator ............................................................................................... 174
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Printing Reports</td>
<td>175</td>
</tr>
<tr>
<td>Pasting Reports into Another Program</td>
<td>175</td>
</tr>
<tr>
<td>Adding Options and Working with Analyses</td>
<td>176</td>
</tr>
<tr>
<td>How to Access Analysis Options</td>
<td>176</td>
</tr>
<tr>
<td>Rerunning An Analysis</td>
<td>177</td>
</tr>
<tr>
<td>Saving Your Steps as a Script</td>
<td>177</td>
</tr>
<tr>
<td>Formatting Report Tables</td>
<td>179</td>
</tr>
<tr>
<td>Reordering Rows (Sorting)</td>
<td>179</td>
</tr>
<tr>
<td>Showing and Hiding Columns</td>
<td>180</td>
</tr>
<tr>
<td>Adding Outlines and Borders</td>
<td>180</td>
</tr>
<tr>
<td>Changing Numeric Formats and Field Widths</td>
<td>181</td>
</tr>
<tr>
<td>Changing Table Names and Column Headings</td>
<td>182</td>
</tr>
<tr>
<td>Turning a Report Table Into a Data Table</td>
<td>182</td>
</tr>
<tr>
<td>Turning a Report Table Into a Matrix</td>
<td>183</td>
</tr>
<tr>
<td>Selecting Points in Plots</td>
<td>184</td>
</tr>
<tr>
<td>Selecting Rows and Columns in Plots, Charts, and Graphs</td>
<td>184</td>
</tr>
<tr>
<td>Selecting a Rectangular Area of Points</td>
<td>184</td>
</tr>
<tr>
<td>Selecting an Irregular-Shaped Area of Points</td>
<td>185</td>
</tr>
<tr>
<td>Using Markers</td>
<td>186</td>
</tr>
<tr>
<td>Changing Marker Shape</td>
<td>186</td>
</tr>
<tr>
<td>Changing Marker Colors</td>
<td>186</td>
</tr>
<tr>
<td>Changing Marker Size</td>
<td>187</td>
</tr>
<tr>
<td>Changing the Marker Drawing Mode and Transparency</td>
<td>188</td>
</tr>
<tr>
<td>Adding Outlines Around Markers</td>
<td>188</td>
</tr>
<tr>
<td>Specifying Marker Transparency</td>
<td>189</td>
</tr>
<tr>
<td>Excluding and Hiding Markers</td>
<td>190</td>
</tr>
<tr>
<td>Adding Labels to Markers</td>
<td>190</td>
</tr>
<tr>
<td>Changing Marker Shape or Colors Based On Values</td>
<td>192</td>
</tr>
<tr>
<td>Removing the Legend</td>
<td>193</td>
</tr>
<tr>
<td>Altering Plot and Chart Appearances</td>
<td>194</td>
</tr>
<tr>
<td>Resizing Plots and Graphs</td>
<td>194</td>
</tr>
<tr>
<td>Zooming In and Out</td>
<td>195</td>
</tr>
<tr>
<td>Changing Line Widths</td>
<td>196</td>
</tr>
<tr>
<td>Changing the Background or Histogram Bar Color</td>
<td>196</td>
</tr>
<tr>
<td>Displaying Axis Coordinates</td>
<td>198</td>
</tr>
<tr>
<td>Scrolling and Scaling Axes</td>
<td>198</td>
</tr>
<tr>
<td>Customizing Axes and Axis Labels</td>
<td>199</td>
</tr>
<tr>
<td>Changing the Values’ Order</td>
<td>204</td>
</tr>
<tr>
<td>Customizing Tick Marks and Tick Mark Labels</td>
<td>204</td>
</tr>
<tr>
<td>Adding Reference Lines</td>
<td>209</td>
</tr>
</tbody>
</table>
Adding Elements to a Report .............................................. 210
Adding an Annotative Note ........................................... 210
Adding Shapes .............................................................. 212
Adding Graphics (Windows and Macintosh Only) ............... 215
Adding and Editing Graphics Scripts ................................. 215

7 Reshaping Data
Subset, Concatenate, Join, and More .............................. 221
Creating a Subset Table ............................................... 223
Creating a Subset Table from a Report .......................... 224
Sorting Data Tables ...................................................... 225
Stacking Columns .......................................................... 227
Example of Stacking into One Column ......................... 228
Example of Stacking Into More Than One Column (Using the Multiple Series Stack Option) 229
Splitting Columns .......................................................... 230
Example of Splitting Columns ....................................... 232
Transposing Rows and Columns ..................................... 232
Examples of Transposing ............................................... 234
Attaching Tables (Concatenating) ................................... 236
Example of Concatenating Tables with Same Column Names 237
Example of Concatenating Tables with Different Column Names 237
Joining Tables .............................................................. 238
How to Join Tables ....................................................... 238
Examples of Joining Tables ........................................... 241
Updating a Table ........................................................... 250
Example of Updating a Table ........................................ 251

8 Summarizing Data
The Summarize and Tabulate Commands ....................... 255
Summarizing Columns ...................................................... 257
Creating a Summary Table ........................................... 258
Adding a Statistics Column to an Existing Summary Table .......................................................... 259
Explanation of Statistics ................................................ 260
Example of Adding a Statistics Column ......................... 261
Tabulating Data ............................................................. 262
How to Create a Table in Tabulate ................................. 263
Elements of a Table in Tabulate ..................................... 264
Clicking and Dragging Items ......................................... 267
Inserting a Grouping Column ........................................ 268
Inserting an Analysis Column ...................................... 268
Using the Dialog ............................................................ 268
# The Formula Editor

## Constructing a Formula

- Creating a Formula .................................................. 277
- Referencing Columns and Table Variables ...................... 279
- Using Local Variables .................................................. 280
  - Incorporating Parameters ........................................ 281
- Inserting Constants .................................................... 282
- Adding Operators ....................................................... 283
- Using Functions ......................................................... 286
  - Referencing Rows ..................................................... 287
  - Adding Numeric Functions ....................................... 288
  - Inserting Logarithmic or Trigonometric Functions .......... 289
  - Adding Character Arguments and Returning Character Strings 290
- Comparing Values ...................................................... 291
- Calculating Quantiles and Probabilities ....................... 293
- Computing Statistical Functions .................................. 294
- Generating Random Numbers ...................................... 294
- Using Dates and Times ............................................... 295
- Processing Row State Data ........................................... 296
- Using Assignment Functions ....................................... 298
- Ordering Expressions in Formulas ................................. 299
  - Building a Formula in Order of Precedence ............... 299
- Using Formula Editor Options ..................................... 300
  - Calculating Derivatives .......................................... 300
  - Simplifying Complex Formulas ................................ 301
  - Evaluating Formulas ............................................... 302
  - Ignoring Errors ..................................................... 303
  - Viewing a Formula's Values from the Formula Editor .... 303
  - Viewing a Formula in JSL ......................................... 304
- Editing Formulas ....................................................... 304
  - Correcting Mistakes ............................................... 304
  - Selecting Expressions ............................................. 305
  - Deleting Functions ................................................ 305
  - Cutting, Copying, and Pasting .................................. 306
  - Clicking and Dragging ............................................. 306
- Customizing Formulas .................................................. 307
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Changing the Font Size</td>
<td>307</td>
</tr>
<tr>
<td>Hiding and Showing Boxing</td>
<td>307</td>
</tr>
<tr>
<td>Changing a Formula's Orientation</td>
<td>308</td>
</tr>
<tr>
<td>Opening and Closing Arguments</td>
<td>309</td>
</tr>
<tr>
<td>Examples and Tutorials</td>
<td>310</td>
</tr>
<tr>
<td>Using Basic Formula Editor Features</td>
<td>310</td>
</tr>
<tr>
<td>Using Local Variables in a Formula</td>
<td>312</td>
</tr>
<tr>
<td>Using the Munger Function</td>
<td>313</td>
</tr>
<tr>
<td>Using the Match Conditional Function</td>
<td>314</td>
</tr>
<tr>
<td>Using Keyboard Shortcuts</td>
<td>315</td>
</tr>
<tr>
<td>Glossary of Terms</td>
<td>315</td>
</tr>
<tr>
<td><strong>10 Personalizing JMP</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Customize Preferences, Toolbars, and Menus</strong></td>
<td>319</td>
</tr>
<tr>
<td>Changing Startup Preferences</td>
<td>321</td>
</tr>
<tr>
<td>Tip of the Day Window</td>
<td>321</td>
</tr>
<tr>
<td>Splash Window</td>
<td>321</td>
</tr>
<tr>
<td>JMP Starter Window</td>
<td>321</td>
</tr>
<tr>
<td>The Window List (Windows Only)</td>
<td>322</td>
</tr>
<tr>
<td>Preferences for Opening Excel Files</td>
<td>322</td>
</tr>
<tr>
<td>Importing Excel Labels as JMP Column Names (Windows and Macintosh Only)</td>
<td>323</td>
</tr>
<tr>
<td>Excel Workbook/Worksheet Selection (Windows and Macintosh Only)</td>
<td>323</td>
</tr>
<tr>
<td>Changing Formula and Scripting Options</td>
<td>324</td>
</tr>
<tr>
<td>Formula Evaluation</td>
<td>324</td>
</tr>
<tr>
<td>Script Evaluation</td>
<td>324</td>
</tr>
<tr>
<td>Auto Bracket Matching</td>
<td>324</td>
</tr>
<tr>
<td>Saving Scripts in Different Languages</td>
<td>325</td>
</tr>
<tr>
<td>Changing Data Table Options</td>
<td>325</td>
</tr>
<tr>
<td>Highlight Movement</td>
<td>325</td>
</tr>
<tr>
<td>Scroll Bar Styles (Windows Only)</td>
<td>326</td>
</tr>
<tr>
<td>Numeric Formats</td>
<td>326</td>
</tr>
<tr>
<td>Data Table Print Format</td>
<td>327</td>
</tr>
<tr>
<td>Toolbar Positions (Windows Only)</td>
<td>327</td>
</tr>
<tr>
<td>Changing Report Options</td>
<td>327</td>
</tr>
<tr>
<td>Customizing Analysis Settings</td>
<td>327</td>
</tr>
<tr>
<td>Report Explanations</td>
<td>328</td>
</tr>
<tr>
<td>Menu Tips (Windows and Linux Only)</td>
<td>328</td>
</tr>
<tr>
<td>Dates, Times, Names and Notes</td>
<td>328</td>
</tr>
<tr>
<td>Table Styles</td>
<td>329</td>
</tr>
<tr>
<td>Marker Sizes</td>
<td>329</td>
</tr>
<tr>
<td>Closing and Saving Sessions</td>
<td>329</td>
</tr>
</tbody>
</table>
Contents

Closing and Saving Reports ............................................ 330
Laser Pointer Options .................................................. 330
Marker Drawing Speed Threshold ..................................... 331
Saving Text Files Without Using Unicode ........................... 331

Changing Color Schemes ............................................ 332

Changing Graph Colors ................................................ 332
Changing Window Colors (Windows and Linux Only) .......... 332
Changing Title Bar Colors (Windows Only) ......................... 333

Customizing Fonts and Languages .................................. 333

Changing Font Types and Sizes ...................................... 333
Using Underlines and Strikeouts on Windows ..................... 334
Using Greek Letters and Math Symbols ............................. 334
Switching Between English and Japanese (Japanese Windows Only) ........................................... 335

Specifying Graphic Formats .......................................... 335
Adjusting Communications Settings (Windows and Linux Only) ................................................ 336
Adjusting Proxy Settings (Linux Only) ............................... 337

Specifying File Locations and Associations ....................... 337

Specifying File Locations (Windows and Linux Only) ........ 338
Resetting the File Associations (Windows Only) .............. 339

Customizing Text Import/Export Options ......................... 339

Specifying Settings for SAS Integration ......................... 340

Personalizing Toolbars (Macintosh) ............................... 342
Personalizing Toolbars (Windows and Linux) .................... 343

Showing/Hiding Toolbars ............................................ 343
Rearranging Toolbars ................................................ 345
Rearranging Buttons .................................................. 345
Deleting Toolbars ...................................................... 347
Deleting Buttons ....................................................... 348
Adding Toolbars ....................................................... 348
Adding Buttons ........................................................ 349

Importing Customized Toolbars (Windows Only) ............ 352

Customizing Menus (Windows and Linux Only) ................. 353

Rearranging Menu Items ............................................. 353
Deleting Menus ........................................................ 355
Adding Menus .......................................................... 356
Adding Menu Items .................................................... 356
Renaming Menu Items ................................................ 360

Saving Menus/Toolbars (Windows and Linux) .................. 360

Using a Separate Customized File (Windows Only) ............ 360
Changing the Default Location of .jmpmenu File .............. 361
11 SAS Integration
Working with SAS data from JMP .................................................. 363
  Connecting to SAS ................................................................. 365
    Connect to a SAS Metadata Server ...................................... 365
    Connect to a SAS Server on a Remote Machine .................... 367
    Connect to SAS on Your Local Machine (Windows Only) ........ 368
  Opening SAS Data Sets ......................................................... 369
  SAS Data Information ............................................................ 370
    Open a SAS Data Set in JMP ............................................... 371
  Running Stored Processes ..................................................... 374
  Submitting SAS Code ............................................................ 376

A The JMP Starter
A Review of Categories and Buttons .......................................... 377
  Overview of the JMP Starter Window ...................................... 379
  The File Category .................................................................. 379
  The Basic Category .............................................................. 381
  The Model Category .............................................................. 382
  The Multivariate Category ...................................................... 384
  The Survival Category ........................................................ 386
  The Graph Category ............................................................. 386
  The Surface Category .......................................................... 388
  The Measure Category ........................................................ 389
  The Control Category .......................................................... 391
  The DOE Category ................................................................ 392
  The Tables Category ............................................................ 394
  The SAS Category ................................................................ 395

B The Main Menu
A Description of Commands ....................................................... 397
  The JMP Menu (Macintosh Only) ............................................ 399
  The File Menu ..................................................................... 399
  The Edit Menu ..................................................................... 402
  The Tables Menu .................................................................. 405
  The Rows Menu ................................................................... 406
  The Cols Menu .................................................................... 408
  The DOE Menu ................................................................... 410
  The Analyze Menu .............................................................. 412
  The Graph Menu .................................................................. 417
  The Tools Menu .................................................................... 422
  The View Menu .................................................................... 424
Contents

On Microsoft Windows and Linux .............................................. 424
On Macintosh ........................................................................... 425
The Window Menu ................................................................. 425
   On Microsoft Windows and Linux ...................................... 425
   On Macintosh .................................................................. 427
The Help Menu ......................................................................... 428
The Layout Menu ..................................................................... 429

C
Formula Functions Reference
A Description of Functions Available in JMP .................................. 431
Row Functions ......................................................................... 433
Numeric Functions .................................................................... 435
Transcendental Functions .......................................................... 435
Trigonometric Functions ............................................................. 437
Character Functions ................................................................ 438
Character Pattern Functions ....................................................... 442
Comparison Functions ............................................................... 444
Conditional Functions ............................................................... 445
Probability Functions ................................................................. 449
Statistical Functions ................................................................ 457
Random Functions ................................................................... 461
Date Time Functions .................................................................. 464
Row State Functions .................................................................. 466
Assignment Functions ............................................................... 469
Parametric Model Functions ....................................................... 470

Index
JMP User Guide ......................................................................... 471
Credits and Acknowledgments

Origin
JMP was developed by SAS Institute Inc., Cary, NC. JMP is not a part of the SAS System, though portions of JMP were adapted from routines in the SAS System, particularly for linear algebra and probability calculations. Version 1 of JMP went into production in October, 1989.

Credits
JMP was conceived and started by John Sall. Design and development were done by John Sall, Chung-Wei Ng, Michael Hecht, Richard Potter, Brian Corcoran, Annie Dudley Zangi, Bradley Jones, Craig Hales, Chris Gotwalt, Paul Nelson, Xan Gregg, Jianfeng Ding, Eric Hill, John Schroedl, Laura Lancaster, Scott McQuiggan, and Peng Liu.

In the SAS Institute Technical Support division, Wendy Murphrey and Toby Trott provide technical support and conduct test site administration. Statistical technical support is provided by Craig DeVault, Duane Hayes, Elizabeth Edwards, Kathleen Kiernan, and Tonya Mauldin.

Nicole Jones, Jim Borek, Kyoko Keener, Hui Di, Joseph Morgan, Wenjun Bao, Fang Chen, Susan Shao, Hugh Crews, Yusuke Ono and Kelci Miclaus provide ongoing quality assurance. Additional testing and technical support is done by Noriki Inoue, Kyoko Takenaka, and Masakazu Okada from SAS Japan.

Bob Hickey is the release engineer.

The JMP manuals were written by Ann Lehman, Lee Creighton, John Sall, Bradley Jones, Erin Vang, Melanie Drake, and Meredith Blackwelder, with contributions from Annie Dudley Zangi and Brian Corcoran. Creative services and production was done by SAS Publications. Melanie Drake implemented the help system.

Jon Weisz and Jeff Perkinson provided project management. Also thanks to Lou Valente, Ian Cox, Mark Bailey, and Malcolm Moore for technical advice.

Thanks also to Georges Guirguis, Warren Sarle, Gordon Johnston, Duane Hayes, Russell Wolfinger, Randall Tobias, Robert N. Rodriguez, Ying So, Warren Kuhfeld, George Mackensie, Bob Lucas, Warren Kuhfeld, Mike Leonard, and Padraic Neville for statistical R&D support. Thanks are also due to Doug Melzer, Bryan Wolfe, Vincent DelGobbo, Biff Beers, Russell Gonsalves, Mitchel Soltys, Dave Mackie, and Stephanie Smith, who helped us get started with SAS Foundation Services from JMP.

Acknowledgments
We owe special gratitude to the people that encouraged us to start JMP, to the alpha and beta testers of JMP, and to the reviewers of the documentation. In particular we thank Michael Benson, Howard Yetter (d), Andy Mauro Mostakos, Al Best, Stan Young, Robert Muenchen, Lenore Herzenberg, Ramon Leon, Tom Lange, Homer Hegedus, Skip Weed, Michael Emptage, Pat Spagan, Paul Wenz, Mike Bowen, Lori Gates, Georgia Morgan, David Tanaka, Zoe Jewell, Sky Alibhai, David Coleman, Linda
Blazek, Michael Friendly, Joe Hockman, Frank Shen, J.H. Goodman, David Iklé, Barry Hembree, Dan Obermiller, Jeff Sweeney, Lynn Vanatta, and Kris Ghosh.

Also, we thank Dick DeVeaux, Gray McQuarrie, Robert Stine, George Fraction, Avigdor Cahaner, José Ramirez, Gudmundur Axelsson, Al Fulmer, Cary Tuckfield, Ron Thisted, Nancy McDermott, Veronica Czitrom, Tom Johnson, Cy Wegman, Paul Dwyer, DaRon Huffaker, Kevin Norwood, Mike Thompson, Jack Reese, Francois Mainville, and John Wass.

We also thank the following individuals for expert advice in their statistical specialties: R. Hocking and P. Spector for advice on effective hypotheses; Robert Mee for screening design generators; Greg Piepel, Peter Goos, J. Stuart Hunter, Dennis Lin, Doug Montgomery, and Chris Nachtsheim for advice on design of experiments; Jason Hsu for advice on multiple comparisons methods (not all of which we were able to incorporate in JMP); Ralph O’Brien for advice on homogeneity of variance tests; Ralph O’Brien and S. Paul Wright for advice on statistical power; Keith Muller for advice in multivariate methods, Harry Martz, Wayne Nelson, Ramon Leon, Dave Trindade, Paul Tobias, and William Q. Meeker for advice on reliability plots; Lijian Yang and J.S. Marron for bivariate smoothing design; George Milliken and Yuriii Bulavski for development of mixed models; Will Potts and Cathy Maahs-Fladung for data mining; Clay Thompson for advice on contour plotting algorithms; and Tom Little, Damon Stoddard, Blanton Godfrey, Tim Clapp, and Joe Ficalora for advice in the area of Six Sigma; and Josef Schmee and Alan Bowman for advice on simulation and tolerance design.

For sample data, thanks to Patrice Strahle for Pareto examples, the Texas air control board for the pollution data, and David Coleman for the pollen (eureka) data.

Translations

Erin Vang coordinated localization. Noriki Inoue, Kyoko Takenaka, and Masakazu Okada of SAS Japan were indispensable throughout the project. Special thanks to Professor Toshiro Haga (retired, Science University of Tokyo) and Professor Hirohiko Asano (Tokyo Metropolitan University) for reviewing our Japanese translation. Special thanks to Dr. Fengshan Bai, Dr. Xuan Lu, and Dr. Jianguo Li, professors at Tsinghua University in Beijing, and their assistants Rui Guo, Shan Jiang, Zhicheng Wan, and Qiang Zhao, for reviewing the Simplified Chinese translation. Finally, thanks to all the members of our outstanding translation teams.

Past Support

Many people were important in the evolution of JMP. Special thanks to David DeLong, Mary Cole, Kristin Nauta, Aaron Walker, Ike Walker, Eric Gjertsen, Dave Tilley, Ruth Lee, Annette Sanders, Tim Christensen, Jeff Polzin, Eric Wasserman, Charles Soper, Wenjie Bao, and Junji Kishimoto. Thanks to SAS Institute quality assurance by Jeanne Martin, Fouad Younan, and Frank Lassiter. Additional testing for Versions 3 and 4 was done by Li Yang, Brenda Sun, Katrina Hauser, and Andrea Ritter.

Also thanks to Jenny Kendall, John Hansen, Eddie Routten, David Schlotzhauer, and James Mulherin. Thanks to Steve Shack, Greg Weier, and Maura Stokes for testing JMP Version 1.

Thanks for support from Charles Shipp, Harold Gugel (d), Jim Winters, Matthew Lay, Tim Rey, Rubin Gabriel, Brian Ruff, William Lisowski, David Morganstein, Tom Esposito, Susan West, Chris Fehily, Dan Chilko, Jim Shook, Ken Bodner, Rick Blahunka, Dana C. Aultman, and William Fehlner.

Technology License Notices

The ImageMan DLL is used with permission of Data Techniques, Inc.
Scintilla is Copyright 1998-2003 by Neil Hodgson <neilh@scintilla.org>. NEIL HODGSON DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL NEIL HODGSON BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

XRender is Copyright © 2002 Keith Packard. KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
JMP is statistical software that gives you an extraordinary graphical interface to display and analyze data. JMP is for interactive statistical graphics and includes:

- A spreadsheet for viewing, editing, entering, and manipulating data
- A broad range of graphical and statistical methods for data analysis
- Extensive design of experiments
- Options to select and display subsets of the data
- Data management tools for sorting and combining tables
- A calculator for each table column to compute values
- A way to group data and computing summary statistics
- Special plots, charts, and communication capability for quality improvement techniques
- Tools for moving analysis results between applications and for printing
- A scripting language for saving frequently used routines

JMP is easy to learn. Statistics are organized into logical areas with appropriate graphs and tables, which help you find patterns in data, identify outlying points, or fit models. Appropriate analyses are defined and performed for you, based on the types of variables you have and the roles they play.

JMP offers descriptive statistics and simple analyses for beginning statisticians and complex model fitting for advanced researchers. Standard statistical analysis and specialty platforms for design of experiments, statistical quality control, ternary and contour plotting, and survival analysis provide the tools you need to analyze data and see results quickly.
Contents

What You Need to Know ................................................................. 3
Learning About JMP ....................................................................... 3
  Using Tutorials ............................................................................. 3
Searching in Help .......................................................................... 3
Learning About Statistical and JSL Terms ..................................... 4
Using the Context-Sensitive Help ..................................................... 5
Learning JMP Tips & Tricks ............................................................ 6
Using This Book in Combination with Other Included Books ............... 6
What You Need to Know

Before you begin using JMP, you should be familiar with:

- Standard operations and terminology such as click, double-click, Ctrl-click and Alt-click (Command-click and Option-click on the Macintosh and Shift-Alt-click on Linux), Shift-click, drag, select, copy, and paste.

- How to use menu bars and scroll bars, how to move and resize windows, and how to manipulate files in the desktop. If you are using your computer for the first time, consult the reference guides that came with it for details.

- Minimal statistics. Even though JMP has many advanced features, you only need a minimal background of formal statistical training. All analysis platforms include graphs with options that help you review and interpret the results. Each platform also includes access to help windows that offer general help and some statistical details.

Learning About JMP

If you are familiar with JMP, you might want to know only what’s new. The JMP New Features document gives a summary of general changes and additions. To learn more about JMP, use the recommendations in the following sections.

Using Tutorials

JMP provides three types of tutorials:

- **Beginners Tutorial** The beginner’s tutorial steps you through the JMP interface and explains the basics of how to use JMP. It is accessible through JMP’s Tip of the Day window, which appears when you start JMP. To start the tutorial from the Tip of the Day window, click Enter Beginners Tutorial. Or, from within JMP, start the tutorial by selecting Help > Tutorials > Beginner’s Tutorial.

- **Specific Analysis Tutorials** Tutorials that step you through creating an analysis in JMP are found under Help > Tutorials. Tutorials describe how to create a chart, how to run a design of experiment (DOE), and more.

- **JMP Introductory Guide** The JMP Introductory Guide is a collection of tutorials designed to help you learn JMP strategies. If you did not receive a printed copy of this book, view the .pdf file by selecting Help > Books > Introductory Guide. By following along with these step-by-step examples, you can quickly become familiar with JMP menus, options, and report windows.

Searching in Help

You might want help on a specific topic, and you want to search JMP’s online help for that topic. The main menu bar contains a Help menu, which provides the appropriate searching capabilities:
On Windows and Linux, the Help > Contents, Help > Search, and Help > Index commands access the JMP help system. The help system provides navigable online JMP documentation.

On the Macintosh, the Help > JMP Help command displays a list of JMP help items with search capabilities and a table of contents.

Learning About Statistical and JSL Terms

The Help > Indexes menu displays the following sources for your reference:

- **Statistics Index**  Accesses references that give definitions of statistical terms.

Once you are in the Statistics Index window, click the Topic Help button to go to the place in the online help that describes the highlighted topic. Click the Script button to view or hide the
script associated with the highlighted topic. Click **Launch** to run the script that corresponds to the item you have highlighted in the list. Click **Example** to view an example of the highlighted topic.

**JSL Operators Index**  Presents a list of JSL operators, such as Sin, Cos, Sqrt, and Abbrev Date that you would use when writing JSL. Highlight an operator name to see a description of the operator appear in the window on the right. Click the **Topic Help** button to locate the topic in the online help.

**Object Scripting Index**  Presents a list of JSL objects. These are scriptable JSL building blocks. Highlight an object name and messages the object recognizes appear in the window on the right.

**DisplayBox Scripting Index**  Presents a list of the elements that make up a JMP report. These elements are the JSL building blocks with which you build output. Highlight a Display Box and available messages for each object appear in the window on the right.

**Using the Context-Sensitive Help**

To use JMP’s online help system, select one of the following methods:

- Select **Help** from analysis construction windows (as shown in Figure 1.1) and report windows.  
  **Figure 1.1**  Help Is Available

  ![Help Is Available](image)

- Select the help tool (❓) from the **Tools** menu and click a place in a data table or report on which you need assistance (Figure 1.2). Context-sensitive help tells about the items in the area you clicked.  
  **Figure 1.2**  Use the Help Tool for Context-Sensitive Help

  ![Use the Help Tool for Context-Sensitive Help](image)

- In some reports, make a small circle with your cursor to reveal information about the item in the area.
Figure 1.3 Making a Circle with the Cursor Displays Help

- In some menus, hold the cursor on menu items to reveal information about the menu item.

Figure 1.4 Display a Description of Menu Items

Learning JMP Tips & Tricks

When you first start JMP, you see the Tip of the Day window. This window provides tips about using JMP that you might not know.


Also use the JMP Quick Reference Guide to learn more advanced commands in JMP. View this document by selecting Help > Books > JMP Quick Reference Guide.

Using This Book in Combination with Other Included Books

The book you are reading now is the JMP User Guide. It gives you reference material for creating data tables, working with analysis reports, a description of all JMP menus, an explanation of data table manipulation, and a description of the formula editor and how to use it. See the following manuals for further documentation of JMP:

- The JMP Introductory Guide provides a tutorial and walks you through examples using JMP.
- The JMP Statistics and Graphics Guide gives documentation of the Analyze and Graph menus.
- The JMP Design of Experiments covers the DOE menu, the experimental design analysis in JMP.
- The JMP Scripting Guide is a reference guide to the JMP Scripting Language (JSL) that lets you automate action sequences.

If you did not receive printed copies of these books, view the .pdf files by selecting Help > Books.
Chapter 2
Creating and Opening Files
Data Tables, Scripts, and Journals

The first thing to do in JMP is open or create a JMP data table:

- To import an existing file into JMP, either click the Open Data Table button in the JMP Starter or select File > Open. See “Opening Existing JMP Files,” p. 11, for details.
- To manually type data into JMP, either click the New Data Table button in the JMP Starter or select File > New. This creates an empty JMP data table, and you can start typing in your data. See “Creating New Data Tables,” p. 10, for details.

This chapter tells you more about creating a new data table, how to import data into new tables, how to export data, and how to get further assistance.
Contents

Before You Start ......................................................................................... 9
The Tip of the Day Window ................................................................. 9
The JMP Starter Window ..................................................................... 10
Creating New Data Tables .................................................................. 10
Opening Existing JMP Files .............................................................. 11
Importing Data .....................................................................................
  Opening Text Files ........................................................................... 13
  Opening a Text File in a Text Editing Window .............................. 18
  Importing Text as Data .................................................................. 20
  Opening Excel and OpenOffice Files .......................................... 21
  Opening SAS Datasets .................................................................. 22
  Opening SAS Transport Files ....................................................... 24
Opening Data from a Database ......................................................... 25
Retrieving Data Using SQL Statements .......................................... 27
Structured Query Language (SQL): A Reference .......................... 28
Using the WHERE Clause Editor ....................................................... 32
Reading in Real-Time Data (Windows and Linux Only) ............... 34
Opening a File Using the Internet ..................................................... 34
Emailing Tables and Reports (Windows Only) ................................. 39
Creating Journals .............................................................................. 39
  Example: Making a Journal for a Presentation ......................... 41
Encrypting and Decrypting Scripts ................................................... 45
Before You Start

Before you begin using JMP, familiarize yourself with its initial windows: the Tip of the Day window and the JMP Starter window.

The Tip of the Day Window

When JMP opens, you see the Tip of the Day window. This window provides tips about using JMP that you might not know. Some tips are basic introductory information, and others give hidden power features that you should learn after getting comfortable with the basics.

The Tip of the Day window has the following features:

- **Show tips at startup** When checked, displays the Tip of the Day window each time you start JMP. This option is also accessible in File (Edit on the Macintosh) > Preferences > General > Show Tip of the Day at Startup.
- **Enter Beginner’s Tutorial** Click to start the beginner’s tutorial. This tutorial introduces beginners to JMP and how its commands and controls work. To access JMP’s other tutorials, select Help > Tutorials.
- **Previous Tip** Returns to the previous tip in the Tip of the Day window.
- **Next Tip** Advances to the next tip in the Tip of the Day window.

The Tip of the Day folder, which was installed when you installed JMP, contains HTML files and images that are used for producing the Tip of the Day window at startup. Add your own items by naming them tipXX.htm, where XX is the next unused number in a tip file name.

To open the Tip of the Day window after closing it, select Help > Tip of the Day.
The JMP Starter Window

Upon startup, the JMP Starter window is located behind the Tip of the Day window. Most of the commands found on the JMP Starter are a duplication of commands found in the main menu and toolbars. The JMP Starter provides a way to access commands without using the main menu. Using the main menu to access specific types of analyses sometimes requires you to make adjustments to the window before starting the analysis. The JMP Starter's shortcut buttons, found on the Graph and Control pages, take you to the window with the correct setup already in place.

See “Overview of the JMP Starter Window,” p. 379, for details.

To open and close the JMP Starter, select View (Window on the Macintosh) > JMP Starter. You can also stop the JMP Starter from appearing upon startup by selecting File (JMP on the Macintosh) > Preferences and unchecking Initial JMP Starter Window.

Creating New Data Tables

To analyze data, you must first create a data table.

To create a new data table:

1. Select File > New. This displays an empty data table with no rows and one numeric column, labeled Column 1.
2. Move the cursor onto a cell.
3. Click the cell. The cursor becomes an I-beam ( ), as shown in Figure 2.1.
4. Enter a value.
There are several ways to fill a table with values:

- Create new rows and columns and type or paste data into the data grid (see “Adding and Deleting Rows,” p. 66).
- Construct a formula to calculate column values (see “Creating a Formula,” p. 279).
- Import data from another application (see “Importing Data,” p. 13).
- Copy values from another application and paste them into the table.
- Use a measuring instrument to read external measures (see “Reading in Real-Time Data (Windows and Linux Only),” p. 34).
- Drag columns from one table to another.

See “Enter, Edit, and Manage Data,” p. 47, for details on how to format, edit, and work with data tables.

---

**Opening Existing JMP Files**

If you want to import a file that is a JMP data table (.jmp), script (.jsl), journal (.jrn), or report (.jrp):

1. Select **File > Open**.
2. Select the file type from the window that appears:
### Opening Existing JMP Files

<table>
<thead>
<tr>
<th>File Type</th>
<th>Operating System</th>
<th>Instructions for Opening</th>
</tr>
</thead>
<tbody>
<tr>
<td>JMP data table</td>
<td>Windows</td>
<td>From the Files of type list, select <strong>JMP Data Tables</strong>. The highlighted table's notes and number of rows and columns appear at the bottom of the dialog. Click the box beside <strong>Select Columns</strong> to display only certain columns in the data table when opened.</td>
</tr>
<tr>
<td></td>
<td>Macintosh</td>
<td>From the Enable list, select <strong>JMP Data Tables</strong>. The highlighted table's notes and number of rows and columns appear at the bottom of the dialog. Click the box beside <strong>Select columns before opening</strong> to display only certain columns in the data table when opened.</td>
</tr>
<tr>
<td></td>
<td>Linux</td>
<td>From the Filter list, select *<strong>.jmp (JMP Data Table)</strong>. Note that if you select a file or folder and click Next, you see the highlighted table's notes and number of rows and columns. Click the box beside column names to display them in the data table when opened.</td>
</tr>
</tbody>
</table>
| JMP script                 | Windows           | 1 From the Files of type list, select **JMP Files** or **JSL Scripts**.  
2 After selecting a script, the **Run this script after opening** option appears at the bottom of the dialog. Check it to automatically begin running the script when it is opened. |
|                            | Macintosh         | 1 From the Enable list, select **JMP Scripts**.  
2 After selecting a script, the **Run after opening** option appears at the bottom of the dialog. Check it to automatically begin running the script when it is opened. |
|                            | Linux             | From the Filter list, select ***.jsl (JSL Script)**. |
| JMP journal, report, or project | Windows           | From the Files of type list, select **Journal Files**, **Report Files**, or **Project**. |
|                            | Macintosh         | From the Enable list, select **JMP Journals** or **JMP Reports**. |
|                            | Linux             | From the Filter list, select ***.jrn (JMP Journal)** or ***.jrp (JMP Report)**. |

3 Highlight the name of the file you would like to open.  
4 Click **Open** (**Finish** on Linux).  

**Note:** JMP can open JMP files that are version 3 and later.
Importing Data

If you have data that exists in a format other than a .jmp file, you can import it and save it as a JMP data table. The list below gives the file types you can import into JMP:

- Microsoft Excel (.xls)
- Text (.txt)
- Text with comma separated values (.csv)
- SAS transport (.xpt, .stx) files
- FACS (.fcs)
- Microsoft Access Database (.mdb) on Windows with a V2+ compliant ODBC driver
- Database (dBASE) (.dbf, .ndx, .mdx) on Windows with a V2+ compliant ODBC driver
- MySQL, Oracle, and PostgreSQL on Linux with a compliant ODBC driver
- OpenOffice spreadsheets (.sxc) on Linux
- Data (.dat) files
- HTML (.htm, .html) on Windows
- SAS versions 5-9 (.sd2, .sd5, .sd7, .sas7bdat) on Windows
- SAS version 6 (.sas7bdat, .ssd, .ssd01, .saseb$data) on Macintosh and Linux

Opening Text Files

You can open text data files with the extensions .txt, .dat, and .csv. Text files can be delimited using almost any character, or they can be fixed width files. JMP provides three different ways to open these files: by determining the data arrangement for you, by allowing you to determine the data arrangement, or by opening the file in a text editor within JMP.

Table 2.1 lists the steps involved in opening text files.
## Table 2.1 Opening Text Files

<table>
<thead>
<tr>
<th>Windows</th>
<th>Manually Specifying Data Arrangement</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Select <strong>File &gt; Open</strong>.</td>
<td>1 Select <strong>File &gt; Open</strong>.</td>
</tr>
<tr>
<td>2 From the <strong>Files of type</strong> field, select <strong>Text Import Files</strong>.</td>
<td>2 From the <strong>Files of type</strong> field, select <strong>Text Import Preview</strong>.</td>
</tr>
<tr>
<td>3 To use the import rules as set in Preferences, (see “Customizing Text Import/Export Options,” p. 339), select <strong>Use Text Import Preferences</strong>.</td>
<td>3 Select the file you wish to open.</td>
</tr>
<tr>
<td></td>
<td>4 Click <strong>Open</strong>.</td>
</tr>
<tr>
<td>4 To allow JMP to use its best guess to arrange the data, select <strong>Attempt To Discern Format</strong>. Note that <strong>Attempt To Discern Format</strong> usually formats fixed width text files better.</td>
<td>5 Complete the Text Import Preview window. See “Understanding the Text Import Preview/Options Window,” p. 15, for details. Make sure to click <strong>Specify Fields</strong> and then highlight values. Click <strong>Set Field</strong> to specify column widths when opening a fixed width file.</td>
</tr>
<tr>
<td>5 Select the file you wish to open.</td>
<td>6 Click <strong>OK</strong>.</td>
</tr>
<tr>
<td>6 Click <strong>Open</strong>.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Macintosh</th>
<th>Manually Specifying Data Arrangement</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Select <strong>File &gt; Open</strong>.</td>
<td>1 Select <strong>File &gt; Open</strong>.</td>
</tr>
<tr>
<td>2 From the <strong>Enable</strong> field, select <strong>All Text Documents</strong>.</td>
<td>2 From the <strong>Enable</strong> field, select <strong>All Text Documents</strong>.</td>
</tr>
<tr>
<td>3 Select the file you wish to open.</td>
<td>3 Select the file you wish to open.</td>
</tr>
<tr>
<td>4 From the <strong>Open As</strong> field (if available), select <strong>Data (Best Guess)</strong> or <strong>Data (Using Preferences)</strong>.</td>
<td>4 From the <strong>Open As</strong> field (if available), select <strong>Data (Using Preview)</strong>.</td>
</tr>
<tr>
<td>5 Click <strong>Open</strong>.</td>
<td>5 Click <strong>Open</strong>.</td>
</tr>
<tr>
<td></td>
<td>6 Complete the Text Import Preview window. See “Understanding the Text Import Preview/Options Window,” p. 15, for details.</td>
</tr>
<tr>
<td></td>
<td>7 Click <strong>OK</strong>.</td>
</tr>
</tbody>
</table>
Understanding the Text Import Preview/Options Window

Access the Text Import Preview windows by selecting File > Open and then selecting Text Import Preview (Windows), Data (Using Preview) (Macintosh), or *.txt (Fixed Width Text) or *.txt*.csv (Delimited Text) (Linux). Then click OK or Finish.

The Text Import Preview window allows you to specify how you want JMP to arrange the data. Two types of Text Import Preview windows are:

- Fixed Width window (Figure 2.2)
- Delimited window (Figure 2.3)

When you open a file, JMP detects the file’s structure and displays the appropriate Text Import Preview window type. If JMP opens the wrong type of window, such as the Fixed Width window when your file is delimited, click the Try Delimited or Try Fixed Width button to access the other window type.

Below are descriptions of the windows’ elements.

Table 2.1 Opening Text Files  (continued)

<table>
<thead>
<tr>
<th>Linux</th>
<th>Automatically Determining Data Arrangement</th>
<th>Manually Specifying Data Arrangement</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Select File &gt; Open.</td>
<td>1 Select File &gt; Open.</td>
</tr>
<tr>
<td>2</td>
<td>From the Filter field, select</td>
<td>2 From the Filter field, select</td>
</tr>
<tr>
<td></td>
<td>* .txt (Fixed Width Text) if your file</td>
<td>- * .txt (Fixed Width Text) if your</td>
</tr>
<tr>
<td></td>
<td>has fixed text line widths, or</td>
<td>file has fixed text line widths, or</td>
</tr>
<tr>
<td></td>
<td>* .txt*.csv (Delimited Text) if your file</td>
<td>- * .txt*.csv (Delimited Text) if</td>
</tr>
<tr>
<td></td>
<td>contains delimiters (characters that</td>
<td>your file contains delimiters</td>
</tr>
<tr>
<td></td>
<td>signify the end of a text line)</td>
<td>(characters that signify the end of</td>
</tr>
<tr>
<td>3</td>
<td>Select the file you wish to open.</td>
<td>a text line)</td>
</tr>
<tr>
<td>4</td>
<td>Click Finish.</td>
<td>6 Click Finish.</td>
</tr>
</tbody>
</table>

Automatically Determining Data Arrangement

- * .txt (Fixed Width Text) if your file has fixed text line widths, or
- * .txt*.csv (Delimited Text) if your file contains delimiters (characters that signify the end of a text line)

Manually Specifying Data Arrangement

1 Select File > Open.
2 From the Filter field, select
- * .txt (Fixed Width Text) if your file has fixed text line widths, or
- * .txt*.csv (Delimited Text) if your file contains delimiters (characters that signify the end of a text line)
3 Select the file you wish to open.
4 Click Finish.
5 Complete the Text Import Options window. See “Understanding the Text Import Preview/Options Window,” p. 15, for details.
6 If your file contains fixed widths, make sure to click Specify Fields and then highlight values and click Set Field to specify column widths.

Understanding the Text Import Preview/Options Window

Access the Text Import Preview windows by selecting File > Open and then selecting Text Import Preview (Windows), Data (Using Preview) (Macintosh), or *.txt (Fixed Width Text) or *.txt*.csv (Delimited Text) (Linux). Then click OK or Finish.

The Text Import Preview window allows you to specify how you want JMP to arrange the data. Two types of Text Import Preview windows are:

- Fixed Width window (Figure 2.2)
- Delimited window (Figure 2.3)

When you open a file, JMP detects the file’s structure and displays the appropriate Text Import Preview window type. If JMP opens the wrong type of window, such as the Fixed Width window when your file is delimited, click the Try Delimited or Try Fixed Width button to access the other window type.

Below are descriptions of the windows’ elements.
Figure 2.2 The Text Import Preview for Fixed Width Files

Figure 2.3 The Text Import Preview for Delimited Files

**End of Field** (Available only in the Text Import Preview Delimited window) Click the box beside the character found in the text file that serves as the delimiter signifying the end of a field. Click the box beside Other and enter a character if the appropriate character is not listed.

**End of Line** (Available only in the Text Import Preview Delimited window) Click the box beside the character found in the text file that serves as the delimiter signifying the end of a line (row). Click the box beside Other and enter a character if the appropriate character is not listed. Note that if double-quotes are encountered when importing text data, the delimiter rules change to look for an end double-quote. Other text delimiters, including spaces embedded within the quotes, are ignored and treated as part of the text string.

**Strip enclosing quotes** Click this box if you want JMP to remove quotation marks that enclose data in the text file.
**Two-digit year rule** Use the drop-down menu to specify if you want to use:

- **10-90 (default)** Use the table below to understand how the 10-90 rule works in JMP.

<table>
<thead>
<tr>
<th>Last Two Digits of Current Year (as Shown on Your Computer)</th>
<th>Two-Digit Date in Text File</th>
<th>JMP Display Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Between 11 and 89</td>
<td>n/a</td>
<td>The current century will be used as the first two digits.</td>
</tr>
<tr>
<td>Between 00 and 10</td>
<td>Less than 90</td>
<td>The current century will be used as the first two digits.</td>
</tr>
<tr>
<td></td>
<td>Between 90 and 99</td>
<td>The previous century will be used as the first two digits.</td>
</tr>
<tr>
<td>Between 90 and 00</td>
<td>Between 0 and 10</td>
<td>The next century will be used as the first two digits.</td>
</tr>
<tr>
<td></td>
<td>Between 11 and 99</td>
<td>The current century will be used as the first two digits.</td>
</tr>
</tbody>
</table>

- **19xx**  
  JMP adds 19 before dates in the file that only have two digits that indicate the year.

- **20xx**  
  JMP adds 20 before dates in the file that only have two digits that indicate the year.

- **Custom**  
  Lets you open and implement a JSL script that customizes how JMP handles dates.

**Table contains column headers** Click this box if you want the JMP data table to use the first row in the imported file as the data table headers. If this box is not clicked, JMP assumes that the imported file has no headers and labels them `Column1`, `Column2`, etc.

**Number of columns** Specify the number of columns the imported file contains.

**Number of Lines** Specify the number of lines (rows) the imported file contains.

**Column Names are on line** Tell JMP where to find data to use as column names. For example, if the column names in your text file are on line (row) 3, type 3 in the box. Otherwise, JMP uses the data in the first line of the imported file as the column name in the JMP data table.

**Data starts on line** Tell JMP where to begin importing data. For example, if you want JMP to import data starting from the fifth line of the imported file, type 5 in the box.

**Specify Fields** (Windows and Linux only)  
( Available only in the Text Import Preview Fixed Width window) Click this button to tell JMP how wide to make column(s) in the data table. Highlight a value and click **Set Field** to assign a column the width of the highlighted value.

**Specify Columns** After you have finalized all other settings in the window, click this button to reveal a list of columns contained in the text file. From this list, place a check next to the columns you want to import into the JMP data table.

**Column ID** Labels the columns in the preview table as 1, 2, 3, 4, etc. This row does not appear in the JMP data table.

The bottom of the Text Import Preview window (Windows and Macintosh) and the Text Import Options window (Linux) shows a preview of the text file as it will appear when imported into a JMP
data file. As you make changes, click **Apply Settings** to see how your changes affect the appearance of the data table. Use the << and >> buttons to scroll right and left through the previewed data. The previewed data table contains the following fields:

**Name**  Shows what column name will be given in the JMP data table. To change the column name, click the cell and type a new name. This new name will override the column name JMP found in the text file. Use the << and >> buttons to scroll left and right through the previewed data. Note that the maximum length for a column name is 255 characters.

**Data Type**  Use the drop-down menus to specify if the data type is a character, numeric, date, etc. Use the << and >> buttons to scroll left and right through the previewed data.

**Data Row1 and Data Row2**  Displays the data that will appear in the JMP data table rows. Use the << and >> buttons to scroll left and right through the previewed data.

**Try Delimited or Try Fixed Width**  When you open a file, JMP detects the file’s structure and displays the appropriate Text Import Preview window type. If JMP opens the wrong type of window, such as the Fixed Width window when your file is delimited, click the **Try Delimited** or **Try Fixed Width** button to access the other window type.

### Opening a Text File in a Text Editing Window

On Macintosh and Windows, JMP allows you to open a text file in a simple text editing window instead of a JMP data table.

To open a text file in a text editing window on Windows:

1. Select **File > Open**.
2. From the **Files of type** list (Figure 2.4), select **Plain Text Files**, which is the type of file you want to import. This selection influences how the data will appear in JMP.
To set the default so the next time you reach this window the default option in the Files of Type list will be Plain Text Files, click the box beside Select this filter the next time this dialog is invoked.

4 Highlight the name of the file you would like to open.

5 Click Open.

To open a text file in a text editing window on the Macintosh:

1 Select File > Open.

2 Select All Text documents from the Enable drop-down menu.
3 Highlight the name of the file you would like to open.
4 Click Open.

**Importing Text as Data**

Importing text as JMP data tables is quick and useful for situations where text was first pasted into a text window, then subsequently formatted and adjusted in preparation for import into a data table.

**To import text as a data table:**
1 Open the script or text in JMP as a script and make sure it is the active window.
2 Select **File > Import as Data** (Windows and Linux) or **Edit > Import as Data** (Macintosh).
3 The text is imported into a JMP data table using the settings from the Text Import preferences (found under **File > Preferences > Text Data Files** (Windows and Linux) or **JMP > Preferences > Text Data Files** (Macintosh)).

Importing text as JMP data tables is also useful when extracting tabular information from a web page.

**To import data from a web page:**
1 Highlight the information on a web page and copy it to the clipboard.
2 Open a new script window in JMP by selecting **New > Script**.
3 Paste the information to the script window.
4 Select **File > Import as Data** (Windows and Linux) or **Edit > Import as Data** (Macintosh).
The limitations on the size of imported files are:

- a limit of 10,000 columns can be imported per table
- a limit of 128K per line (row) of data can be imported

The size limit of a file to be imported is restricted by the amount of free RAM/virtual memory that the system possesses. For example, JMP doesn't import a 1 GB file into a system that has a combined 500MB of RAM/virtual memory. For reasonable performance, the size of the file to import should be less than the physical RAM present in the machine.

## Opening Excel and OpenOffice Files

You can open Microsoft Excel files on JMP for Windows and Macintosh. You can open OpenOffice spreadsheets on Linux:

1. Select **File > Open**.
2. On Windows: From the **Files of type** field, select **Excel Files (*.XLS)**.
   
   On Macintosh: From the **Enable** menu, select **All Data Documents**.
   
   On Linux: From the **Filter** field, select ***.sxc (OpenOffice Spreadsheet)**.
3. Select the file you wish to open.

   **Note:** On Windows, the Open Data File window contains several options that are specific to opening Excel files:

   - If your file’s column headers are found in row one of the Excel spreadsheet, click the box beside **Excel table has labels in row 1**.
   - If your file contains multiple worksheets and you only want to open certain ones, check the box beside **Allow individual worksheet selection**. If you want this option to be checked each time you open an Excel file, select **File > Preferences** and check **Select Individual Excel Worksheets** in the General category.

4. On Linux, click **Next** to see these options:

   - If your file’s column headers are found in row one of the OpenOffice spreadsheet, click the box beside **First Row Column Headings**.
   - If your file contains multiple worksheets and you only want to open certain ones, check the boxes beside the sheets in the **Select Sheets to Open** area.

5. On Windows and Macintosh, click **Open**. On Linux, click **Finish**.
Opening SAS Datasets

SAS datasets are files that were saved in one of many SAS formats. On Windows, JMP can open files that are SAS version 5 or later. On the Macintosh and Linux, JMP can open files that are SAS version 6.

- On Windows, JMP uses SAS labels as JMP data table column names by default. You can override the default and request that JMP uses SAS variable names as JMP column names (see step 4 below).
- On the Macintosh, JMP uses SAS variable names as table column names by default. Once in an imported JMP data table, you can view the SAS labels by double-clicking the column name. The SAS label appears as a Notes property. You can also replace the table column names with the SAS labels by running the script JMP automatically created when it opened the data table (it is located in the tables panel under the data table name).
- On Linux, JMP uses SAS labels as JMP data table column names by default.

To open a SAS dataset:

1. Select File > Open.
2. On Windows, select SAS Datasets or Data Files from the Files of type dropdown menu, as shown in Figure 2.7
   On the Macintosh, select All Readable Documents from the Enable list.
   On Linux, select *.sd2 (SAS Data Set) from the Filter list.
3. Highlight the file you would like to open.
4 (Optional and available on Windows only) Select any of the following:

- **Select this filter the next time this dialog is invoked**  Sets the default file type choice to the option you select in the Files of Type list. If clicked, the default file type will be SAS Datasets the next time you reach this window.

- **Use SAS Variable Names for Column Names**  Uses the SAS variable names (instead of the labels) as the column names in the JMP data table.

- **Dataset is Password Protected**  Click this box if you know the file is password protected. See “Opening Password-Protected Datasets,” p. 23, for details.

5 Click **Open** (Windows and Macintosh) or **Finish** (Linux).

**Note:** If you are importing date variables from a SAS file, JMP looks for a SAS date format and translates it to a JMP date column.

### Opening Password-Protected Datasets

On Windows, JMP can open SAS version 6 or 7 datasets that are password protected.

To **open password-protected datasets:**

1. Select **File > Open**.
2. Select **SAS Datasets** from the Files of type drop-down menu.
3. Click the box beside **Dataset is Password Protected.**
4. Highlight the file you would like to open.
5 (Optional) Select any of the following:

- **Select this filter the next time this dialog is invoked**  Sets the default file type choice to the option you select in the Files of Type list. If clicked, the default file type will be **SAS Datasets** the next time you reach this window.

- **Use SAS Variable Names for Column Names**  Uses the SAS variable names (instead of the labels) as the column names in the JMP data table.

6 Click **Open**.

### Opening SAS Transport Files

JMP can open SAS transport files that were saved using SAS’s XPORT engine. For example, below is sample code that creates a transport file called **test**. *(Note: misc and work are SAS libref names.)*

```sas
data test;
  input name $ age weight;
cards;
nicole 12 72
meredith 10 68
;libname misc xport 'C:test.xpt';
proc copy in=work out=misc;
run;
```

To open a SAS transport file:

1 Select **File > Open**. Figure 2.7 above shows the window that will appear.

2 On Windows, select **SAS Transport Files** from the **Files of type** dropdown menu, as shown in Figure 2.8.

   On the Macintosh, select **All Readable Documents** from the **Enable** list.

   On Linux, select ***.xpt (SAS Transport)** from the **Filter** list.

3 Highlight the name of the file you would like to open.

4 On Linux, click **Next**.
5  (Optional and available on Windows and Linux only) Select any of the following:

Select this filter the next time this dialog is invoked  (Windows only) Sets the default file type choice to the option you select in the Files of Type list. If clicked, the default file type will be SAS Transport Files the next time you reach this window.

Select Member  Lets you type the name of a specific member, or table, for JMP to open.

Open all members  Opens all members, or tables, in the transport file.

Save all members  Saves the file as a JMP file as soon as you open it. The file is saved to the same directory where the SAS transport file was opened.

Select Columns  Tells JMP to open only certain columns from the transport file. When you click Open (Windows) or Finish (Linux), JMP provides a list of columns with checks next to the columns it intends to open. Add or remove checks to modify the list.

Opening Data from a Database

You can import data from a database if you have an ODBC (Open Database Connectivity) driver for the database.

Your operating system provides an interface for JMP to communicate with databases using ODBC data sources. Data sources can be created and configured with operating system software: For example, on Windows XP, use Control Panel > Administrative Tools > Data Sources; on the Macintosh, use Applications > Utilities > OpenLink ODBC Administrator; on Linux, ODBC connectivity is provided by UNIX ODBC, so see your UNIX ODBC documentation for details.
To import data from a database:

1. Select **File > Database > Open Table** to display the window shown in Figure 2.9. The Connections box lists data sources to which JMP is connected. The Tables box lists database tables for the currently selected data source connection.

   **Figure 2.9** Initial Window Given by Database Open Command

   ![Database Open Table Window](image)

   When one or more database connections are made, the list of connections shows in the **Connections** list.

   If there are tables in the selected database file or directory, they are displayed in the **Tables** list.

2. If the desired data source is not listed in the Connections box, click **Connect** to choose a data source. The method of choosing a data source depends on your operating system. Figure 2.10 shows the data source chooser for Windows. Select a data source and click **OK**.

   **Figure 2.10** Select a Database Source (Windows)

   ![Select Data Source Window](image)

3. Select the desired data source in the Connections box. The tables list in the Tables box updates accordingly. The update may take a several seconds, depending on the number of tables and the speed of the connection to the database.

4. To control which tables are listed by choosing the options in the **Include in Table List** group of
checkboxes. Different drivers interpret these labels differently. Your options are:

**User Tables** When clicked, displays all available user tables in the **Tables** list. User tables are specific to which user is logged on to the computer.

**Views** When clicked, displays “views” in the **Tables** list along with all other file types that can be opened. “Views” are virtual tables that are query result sets updated each time you open them. They are used to extract and combine information from one or more tables.

**System Tables** When clicked, displays all available system tables in the **Tables** list. System tables are tables that can be used by all users or by a system-wide service.

**Synonyms** When clicked, displays all available ORACLE synonyms in the **Tables** list.

5  Select the desired table from the **Tables** list.
6  Click **Open Table** to import all the data in the selected table, or click **Advanced** to specify a subset of the table to be imported.

**Note:** If you are connected to a dBase database, select the database **folder** to which you would like to connect (instead of selecting individual files, which are greyed out and cannot be selected).

### Retrieving Data Using SQL Statements

You can use Structured Query Language (SQL) statements to control what you import from a database. When you open a database file in JMP, you are actually sending an SQL statement to the database. By default, this statement gets all files and records in the database table. In some cases, this is too much data. When you are only interested in a subset of the table’s data, you can customize the SQL request to only request the data you want. After you execute a SQL query, the code for the query is stored in the data table in the SQL table variable. To retrieve data using SQL statements:

1  Connect to a database by following the steps in “**Opening Data from a Database,”** p. 25.
2  From the **Database Open Table** window, shown in Figure 2.11, click the **Advanced** button.

**Figure 2.11**  Click the Advanced Button
3 Either type in any valid SQL statement, or modify the default statement. Figure 2.12 shows a default SQL Select statement appropriate for the selected file. See “Structured Query Language (SQL): A Reference,” p. 28, for a description of SQL statements you can use. Alternately, you can add expressions by clicking the Where button and using the Where Clause editor to create expressions. See “Using the WHERE Clause Editor,” p. 32, for details.

Figure 2.12  Reading All Variables From the Big Class Table Stored in an Excel Directory

4 Click Execute SQL. The SQL statement becomes an SQL table variable in the JMP data table (see “Adding Table Variables,” p. 84, for details).

For example, if you want to import only the name and age of females older than 14, then you would modify the SQL in Figure 2.12 from SELECT * FROM Bigclass to SELECT NAME, AGE FROM Bigclass where AGE>14 and SEX='F'. After you click Execute SQL, a JMP data table appears and has columns Name and Age.

Note that you can enter any valid SQL statement and click Execute SQL to execute the command. Valid SQL varies with the data source and ODBC driver.

Structured Query Language (SQL): A Reference

The following sections are a brief introduction to SQL. They give you insight to the power of queries, and they are not meant to be a comprehensive reference.

Using the SELECT Statement

The fundamental SQL statement in JMP is the SELECT statement. It tells the database which rows to fetch from the data source. When you completed the process described in “Opening Data from a Database,” p. 25, you were actually sending the following SQL statement to your data source.

SELECT * FROM Solubil

The * operator is an abbreviation for “all columns.” So, this statement sends a request to the database to return all columns from the specified data table.
Rather than returning all rows, you can replace the * with specific column names from the data table. In the case of the Solubility data table example, you could select the ETH, OCT, and CCL4 columns only by submitting this statement:

```
SELECT ETH, OCT, CCL4 FROM Solubil
```

**Note:** JMP does not require you to end SQL statements with a semicolon.

JMP provides a graphical way of constructing simple SELECT statements without typing actual SQL. To select certain columns from a data source, highlight them in the list of columns (Figure 2.12).

**To highlight several rows,**

- Shift-click to select a range of column names
- Ctrl-click (Windows and Linux) or Command-click (Macintosh) to select individual column names.

Note that the SQL statement changes appropriately with your selections.

Sometimes, you are interested in fetching only unique records from the data source. That is, you want to eliminate duplicate records. To enable this, use the DISTINCT keyword.

```
SELECT DISTINCT ETH, OCT, CCL4 FROM Solubil
```

**Sorting Results**

You can have the results sorted by one or more fields of the database. Specify the variables to sort by using the ORDER BY command.

```
SELECT * FROM Solubil ORDER BY LABELS
```

selects all fields, with the resulting data table sorted by the LABELS variable. If you want to specify further variables to sort by, add them in a comma-separated list.

```
SELECT * FROM Solubil ORDER BY LABELS, ETH, OCT
```

**Using the WHERE Statement**

The WHERE statement allows you to fetch certain rows of a data table based on conditions. For example, you may want to select all rows where the column ETH has values greater than 1.

```
SELECT * FROM Solubil WHERE ETH > 1
```

The WHERE statement is placed after the FROM statement and can use any of the following logical operators.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equal to</td>
</tr>
<tr>
<td>!= or &lt;&gt;</td>
<td>Not equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less Than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
</tr>
</tbody>
</table>
When evaluating conditions, NOT statements are processed for the entire statement first, followed by AND statements, then OR statements. Therefore

\[
\text{SELECT * FROM Solubil WHERE ETH > -2 OR OCT < 1 AND CCL4 > 0}
\]

is equivalent to

\[
\text{SELECT * FROM Solubil WHERE ETH > -2 OR (OCT < 1 AND CCL4 > 0)}
\]

### Using the IN and BETWEEN Statements

To specify a range of values to fetch, use the **IN** and **BETWEEN** statements in conjunction with **WHERE**. **IN** statements specify a list of values and **BETWEEN** lets you specify a range of values. For example,

\[
\text{SELECT * FROM Solubil WHERE LABEL IN ('Methanol', 'Ethanol', 'Propanol')}
\]

fetches all rows that have values of the **LABEL** column Methanol, Ethanol, or Propanol.

\[
\text{SELECT * FROM Solubil WHERE ETH BETWEEN 0 AND 2}
\]

fetches all rows that have **ETH** values between 0 and 2.

### Using the LIKE Statement

The **LIKE** statement allows you to select values similar to a given string. Use % to represent a string of characters that can take on any value. For example, you may want to select chemicals out of the **Solubil** data that are alcohols, that is, have the –ol ending. The following SQL statement accomplishes this task.

\[
\text{SELECT * FROM Solubil WHERE LABELS LIKE '%OL'}
\]

The % operator can be placed anywhere in the **LIKE** statement. The following example extracts all rows that have labels starting with M and ending in OL:

\[
\text{SELECT * FROM Solubil WHERE LABELS LIKE 'M%OL'}
\]

### Using Aggregate Functions

Aggregate functions are used to fetch summaries of data rather than the data itself. Use any of the following aggregate functions in a **SELECT** statement.

### Table 2.3 SELECT Statement Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>SUM( )</td>
<td>Sum of the column</td>
</tr>
<tr>
<td>AVG( )</td>
<td>Average of the column</td>
</tr>
<tr>
<td>MAX( )</td>
<td>Maximum of the column</td>
</tr>
<tr>
<td>MIN( )</td>
<td>Minimum of the column</td>
</tr>
<tr>
<td>COUNT( )</td>
<td>Number of rows in the column</td>
</tr>
</tbody>
</table>
Some examples include:

- The following statement requests the sum of the ETH and OCT columns:
  `SELECT SUM(ETH), SUM(OCT) FROM Solubil`  
- This statement returns the number of rows that have ETH values greater than one:
  `SELECT COUNT(*) FROM Solubil WHERE ETH > 1`  
- The following statement lets you know the average OCT value for the data that are alcohols:
  `SELECT AVG(OCT) FROM Solubil WHERE LABELS LIKE 'OL'`

**Note:** When using aggregate functions, the column names in the resulting JMP data table are Expr1000, Expr1001, and so on. You’ll probably want to rename them after the fetch is completed.

### The GROUP BY and HAVING Commands

The `GROUP BY` and `HAVING` commands are especially useful with the aggregate functions. They allow you to execute the aggregate function multiple times based on the value of a field in the data set.

For example, you may want to count the number of records in the data table that have ETH=0, ETH=1, and so on, for each value of ETH.

- `SELECT COUNT(ETH) FROM Solubil GROUP BY (ETH)` returns a single column of data, with each entry corresponding to one level of ETH.
- `SELECT COUNT(ETH) FROM Solubil GROUP BY (ETH) WHERE OCT > 0` does the same thing as the above statement, but only for rows where OCT > 0.

When using `GROUP BY` with an aggregate function of a column, include the column itself in the `SELECT` statement. For example,

```sql
SELECT ETH, COUNT(ETH) FROM Solubil GROUP BY (ETH)
```

returns a column containing the levels of ETH in addition to the counts.

### Using Subqueries

Aggregate functions are also useful for computing values to use in a `WHERE` statement. For example, you may want to fetch all values that have greater-than-average values of ETH. In other words, we want to find the average value of ETH, then select only those records that have values greater than this average.

Remember that `SELECT AVG(ETH) FROM Solubil` fetches the average we are interested in. So, the appropriate SQL command uses this statement in the `WHERE` conditional:

```sql
SELECT * FROM Solubil WHERE ETH > (SELECT AVG(ETH) FROM Solubil)
```

### Saving and Loading SQL Queries

After constructing a query, you may want to repeat the query at a later time. You do not have to hand-type the query each time you want to use it. Instead, you can export the query to an external file. To do this, click the **Export SQL** button in the dialog shown in Figure 2.12. This brings up a dialog that lets you save your SQL query as a text file.

To load a saved query, click the **Import SQL** button in the dialog shown in Figure 2.12. This brings up a dialog that lets you navigate to your saved query. When you open the query, it is loaded into the dialog.
Using the WHERE Clause Editor

JMP provides help building WHERE clauses for SQL queries during ODBC import. It provides a WHERE clause editor that helps you build basic expressions using common SQL features, allowing vendor-specific functions. For example, you do not need to know whether SQL uses ‘=’ or ‘==’ for comparison, or `avg()` or `average()` for averaging.

In addition, string literals should be enclosed by single quotes (‘string’) rather than double quotes (“string”).

To open the WHERE Clause Editor:

1. Connect to a database by following the steps in “Opening Data from a Database,” p. 25.
2. From the Database Open Table window, shown in Figure 2.11, click the Advanced button.
3. Click the Where button.

USE the WHERE Clause Editor to add expressions, functions, and/or terms from the work panel. They are applied to the highlighted red box:

1. Click the Table Name Browser (Figure 2.13) to select a table. The columns in that table appear in the list.
2. Click the SQL Vendor Name Browser (Figure 2.13) to select the type of SQL you want to use: GenericSQL, Access, DB2, MySQL, Oracle, SQL Server, or all of the above. Perform an action by clicking a function/operator in the list and selecting an operator from the list that appears.
3. Select an empty formula element (Figure 2.13) in the formula editing area by clicking it. It is selected when there is a red outline around it. All terms within the smallest nesting box relative to the place you clicked become selected. The subsequent actions apply to those combined elements.
4. Add operators (Figure 2.13) to an expression by clicking buttons on the keypad.

The WHERE clause editor works similarly to the formula editor, which is described in “The Formula Editor,” p. 277.
There are several ways you can customize expressions, functions, and/or terms in the WHERE clause editor. To change font size, show and hide boxing, change the orientation of the formula, and close arguments:

1. Build an expression, function, and/or term.
2. Click the red triangle icon above the keypad and select and option from the menu that appears, as shown in Figure 2.14.

Figure 2.13 The WHERE Clause Editor

Figure 2.14 Select Show Boxing from the Keypad Menu Commands
Reading in Real-Time Data (Windows and Linux Only)

The term live data feed describes the way an external data source sends information via a physical or a logical communication link to another device. You can connect JMP to a live data feed through the serial port of your Windows or Linux computer in order to read, in real-time, a stream of incoming data. Remember that:

- The data feed must come through a standard nine-pin serial port. Data cannot be read through a USB port.
- You need to know the exact baud rate, parity, stop bits, and data bits for the attached device.

Once you obtain the numbers for your device, enter them into the open Datafeed() command in the script below. (The 4800, even, 2, and 7 in the script below are examples, so replace them with your information). Then connect the data feed to your computer and open and run the script:

```r
streamScript = expr( line = feed <<Get Line; show(line);
    len = length(line); show(len);
    if (length(line)>=1, show("Hi"); show(line);
        field = substr(line,5,8); show(field);
        x = Num(field); show(x);
        if (!IsMissing(x), current data table()<<add row({:Column1=x});
            show(x);
    ));

feed = open DataFeed(Baud Rate(4800), parity(even), Stop bits(2), Data bits(7));

feed<<Set Script(streamScript);
feed<<Connect;
```

To ensure harmony between the communications settings for JMP and the instrument reading data from an external source, select File > Preferences > Communications. Refer to the documentation for your instrument to find the appropriate settings.

Opening a File Using the Internet

You can import data from Internet sites, Intranet sites, servers, and FTP addresses by selecting File > Internet Open. You should only use this command for files that must be delivered through an Internet protocol such as HTTP or FTP. To open a file from a mounted server, use File > Open.

If you are using a proxy server to connect to the Internet on Linux, set up your proxy settings before selecting File > Internet Open. See “Adjusting Proxy Settings (Linux Only),” p. 337, for details.

Opening a File from the Internet or Intranet

To open or import data from a file that is on the Internet or an Intranet:

1. Select File > Internet Open. The window in Figure 2.15 appears. (The window in Linux looks a little different than Figure 2.15. Also, on Linux, Internet Open will not work successfully if a firewall or secure socket is present.)
2. Click the drop-down menu on the left, and select HTTP://.
3. Type in the URL.
4 Click the drop-down menu under **Open As**, and select how you would like JMP to display the imported data:

- **Browse HTML Page**  
  Opens the web page in a browser.

- **Edit HTML or Text Page**  
  Opens the web page or text file in a text editor, displaying the HTML tags of a .html file.

- **Edit HTML with Tags Stripped**  
  Opens the web page in a text editor, displaying the contents of the page (no HTML tags).

- **Open JMP File**  
  Opens the web page in a data table. This option should only be used if a JMP data table (a .jmp file) resides at the web address you enter.

- **Extract HTML Table as JMP File**  
  Opens the web page in a data table. This option should be used only if an HTML table is located at the web address you enter. To create a meaningful data table, the HTML table information must consist of cells of data only. HTML tables that are created for page formatting or that include headers do not result in meaningful JMP tables.

- **Run JSL File**  
  Opens the JSL (JMP Scripting Language) file and runs the script.

5 Click **Open** or **Begin**. On Windows, the URL from which the table came is included in the data table as a note property if the table did not already contain a note.

Also on Windows, you can display the Browser toolbar (containing standard browser buttons: Back, Forward, Home, Refresh, and Stop) and URL List toolbar (containing a box to enter a URL address):

1 Select **View > Show Toolbars**. The window in Figure 2.16 appears.
2 Click the boxes beside both Browser and URL_List.
3 Click OK.

The toolbars appear at the top of the JMP application.

The Browser toolbar, as shown in Figure 2.17, contains standard browser buttons: Back, Forward, Home, Refresh, and Stop.

Opening a JMP File from an FTP Site

To open .jmp files from an FTP address:

In Windows
1 Select File > Internet Open.
2 Click the drop-down menu on the left, and select FTP://, as shown in Figure 2.19.
3 Type the file path in the **JMP File Path/Name** text box (for example, `techsup/download/jmp/Fitness.jmp`, as shown in Figure 2.19).

**Note:** This path is case-sensitive.

4 Type the Machine ID in the **Machine ID** text box (for example, `ftp.sas.com`).
5 Click **Open**. The window in Figure 2.20 appears.

**Figure 2.20** JMP:UserID/Password-Empty means Anonymous Window

6 If you have an anonymous account, click **OK**. For a typical login, enter your user ID and password.

**Note:** Some anonymous FTP servers require a user ID. If the data table does not open, try typing either `ftp` or `anonymous` in the **User ID** text box. Leave the **Password** text box empty and click **OK**.

**In Linux**
1 Select `ftp://` from the **URL** drop-down menu, as shown in Figure 2.21.
2 Type the Machine ID with the file path in the **URL** text box (for example, `ftp.sas.com/techsup/download/jmp/Fitness.jmp`, as shown in Figure 2.21).
3 Select **Open JMP file** from the **Open As** menu.
4 Click **Begin**.
Creating and Opening Files

Chapter 2

Importing Data

Figure 2.21 Linux Internet Open Window

On Macintosh

1. Select FTP:// from the URL drop-down menu, as shown in Figure 2.22.
2. Type the Machine ID with the file path in the URL text box (for example, ftp.sas.com/techsup/download/jmp/Fitness.jmp, as shown in Figure 2.22).
3. Select Open JMP File from the Open As drop-down menu.
4. Click Begin.

Figure 2.22 Macintosh Internet Open Window

Opening a File from a Server or Another Computer (Windows Only)

To import data from a file that is on a server or on another computer:

1. Select File > Internet Open.
2. Click the drop-down menu on the left, and select FILE://, as shown in Figure 2.23.
3. Type the file path in the URL text box.

Figure 2.23 Internet Open Window

4. Click the drop-down menu under Open As, and select how you would like JMP to display the file.
Emailing Tables and Reports (Windows Only)

If you are using a Windows operating system, JMP gives you a one-click method of emailing a data table and report.

To send email from JMP:
1. Open a data table or create a report.
2. Select File > Send. The open window is submitted to the default email application as defined in your operating system. A window appears containing the forms necessary for emailing.

Creating Journals

Producing an empty journal window and customizing it helps you with your JMP projects. It becomes a type of reference file: within the journal you can save text items, hyperlinks to other files, URLs, scripts, and directories of files.

You can even create and save a script that contains links to all relevant reports and data tables. The script stores the session as a .jsl file with links to tables and reports.

A journal can be thought of as an empty piece of paper—it is a customizable, flexible window for you to include elements such as graphs, tables, text, links to URLs, links to data tables, and other files. It can also be thought of as a repository for all pieces of a project or task.

Figure 2.24 shows an example of how you can structure a journal for a sample project.
To create a new journal:

1. Select **File > New > Journal**. Or, from the JMP Starter window, select **New Journal**.
2. Add and edit journal items, as explained below.

<table>
<thead>
<tr>
<th>Task</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add an item to the journal</td>
<td>Right-click an empty space in the journal window and select an option, as shown in Figure 2.25.</td>
</tr>
<tr>
<td>Add a journal note</td>
<td>Double-click an empty space in the journal window and type into the box that appears.</td>
</tr>
<tr>
<td>Add a graphic</td>
<td>Copy a graphic from within JMP or from a graphic application and paste it into the journal using <strong>Edit &gt; Paste</strong>. JMP places the graphic at the end of the journal.</td>
</tr>
</tbody>
</table>
3 Save the journal by selecting **File > Save As**. If you save the journal as a .html file, buttons and links are available when the file is viewed in a web browser.

You can edit the journal to improve it in a number of ways:

- To click and drag journal items to different positions, select the selection (large plus) cursor icon. As you drag items, JMP highlights the destination seams to indicate where items can be inserted.
- To adjust text wrapping, right-click a text box and select **Set Wrap** from the menu that appears. Enter the number of desired pixels per line.
- When adding links to other files, consider changing absolute file paths to relative file paths, which start relative to where the journal file is stored. Then, if you move the location of the journal, the links will continue to work because the referenced files are in the same place relative to the journal file.
- When adding links to files in the Sample Data folder that was installed when you installed JMP, use the path name $SAMPLE_DATA/xx where xx is the relative path from the Sample Data directory.
- See “Customizing JMP Journals,” p. 116, for more ways to edit journals.

### Example: Making a Journal for a Presentation

Most people use a presentation application like PowerPoint to visually aid a presentation. With JMP journals, it is possible to avoid using a presentation application, since all your bullet points can be entered into a journal and combined with live links and buttons to help automate the analyses you want.

Follow along with this example to create a sample presentation using a journal:

1. Select **File > New > Journal**.
2. Right-click in the journal. Start your outline by selecting **Add Outline Item**.
Figure 2.27 Right-click in the Journal

3. Enter the title of the presentation.

Figure 2.28 Enter the Title

A presentation should have outline nodes, which are nested, opened, and closed in sequence, as you give the presentation.

4. Add bullet points into the outline by clicking the red triangle in the My Bivariate Demo title bar and selecting **Add Text Item**.
Now add file references as links. These will allow you to open a file with one click during the presentation.

5 Click the red triangle in the My Bivariate Demo title bar and select Add Window Reference. Or, right-click the blue disclosure icon to access the same menu. Note that you must have other data table or report windows open before selecting Add Window Reference.

6 Select an open window and click OK.

7 Verify that clicking the link will open the file by right-clicking it and selecting Set Script to view the path to the file (Figure 2.30).
8. Change the appearance of the link so it is displayed as a button rather than hypertext by selecting **Underline Style** from the menu. The result should look like that in Figure 2.31.

**Figure 2.31** Changing the Link to a Button

---

**Note:** Another way to create a button is to click the red triangle menu on the My Bivariate Demo title bar, select **Add File Reference** command and navigate to the file.
Encrypting and Decrypting Scripts

If you want to protect a JMP Scripting Language (JSL) file, you can encrypt it so only someone who knows the password can run it, or both view and run it. This is useful in situations when you want to implement controlled sharing of a script.

JMP allows you to encrypt a script by making it either run-only or view-and-run. To encrypt a script:

1. Open the script you want to encrypt.
2. Select Edit > Encrypt Script. Figure 2.32 appears.

**Figure 2.32** The Script Encryption Dialog

3. Assign password(s) to encrypt the files:
   - To encrypt a script so that a user can run it without a password, but needs a password to view it, supply JMP with only a decrypt password.
   - To encrypt a script so that a user must enter one password to run it and another password to view it, supply JMP with both a run and a decrypt password.

**Note:** The password must consist of single-byte characters; using a text Input Method Editor (IME) will not work.

4. The encrypted script appears in a new window, as shown in Figure 2.33.

**Figure 2.33** Example of Encrypted Script

5. Save the encrypted script.

To view an encrypted JSL script by first decrypting it:

1. Select File > Open to open the script in JMP.
2. Select **Edit > Decrypt** Script. Figure 2.34 appears.

*Figure 2.34* Decrypting a Script

3. Enter the decrypt password to see the script in a new window.

To **run an encrypted** JSL script:

1. Select **File > Open** to open the script in JMP.
2. Select **Edit > Run Script**. Figure 2.35 appears

*Figure 2.35* Running an Encrypted Script
After you import data into JMP or create a new data table, you need to format your data and the table so it will be ready for analysis.

This chapter contains information that helps you:

- Understand parts of a JMP data table
- Specify data types and modeling types
- Select your data's format
- Edit data tables
- Lock data tables
- Select rows and columns
Contents

Elements of JMP Data Tables .......................................................... 49
Specifying Data Types and Modeling Types ..................................... 57
Entering Data ................................................................................. 65
Editing Data and Tables .................................................................. 71
  Editing Cells .............................................................................. 71
  Editing Column Names ............................................................... 71
  Recoding Data ........................................................................... 72
  Viewing Patterns of Missing Data .................................................. 73
  Finding and Replacing Cell Values ............................................... 74
  Reordering Columns ................................................................... 77
  Rows and Columns Context Menus ............................................... 78
  Copying, Cutting, and Pasting ...................................................... 78
  Moving and Duplicating Values .................................................... 79
  Using the Row Editor ................................................................... 80
  Changing Table Names ............................................................... 82
  Locking Tables ........................................................................... 82
  Adding Table Variables ............................................................... 83
  Creating Scripts ......................................................................... 86
Selecting Rows and Columns ................................................................. 89
  Selecting Excluded, Hidden, or Labeled Rows .............................. 90
  Selecting Cells with Specific Values ............................................ 91
  Selecting a Particular Row or Column .......................................... 93
  Randomly Selecting Rows .......................................................... 94
  Inversely Selecting and Selecting All Rows .................................... 95
  Locating Next and Previously-Selected Rows .................................. 95
The Data Filter .................................................................................. 96
  The Data Filter Control Panel ..................................................... 96
  Adding Additional Groups of Variables to the Control Panel ........... 98
  Check Box Modes ....................................................................... 99
  Using Nominal or Ordinal Variables as Filter Columns ................ 99
  Selecting Continuous Values as Filters ........................................ 100
  Changing the Data Table After Making Data Filter Selections ....... 101
  Data Filter Menu Commands ...................................................... 101
Elements of JMP Data Tables

JMP data are organized into rows and columns referred to as the data table. A data table has two parts, as shown in Figure 3.1: the data table panels and the data grid.

Figure 3.1 Parts of a Data Table

The data table has the following characteristics:

- Column names can contain any keyboard character, including spaces, and can be up to 255 characters long.
- The maximum length of the data table’s name depends on your computer’s operating system.
- Change the default size and font for names and values selecting File > Preferences > Fonts. (On the Macintosh, select JMP > Preferences > Fonts.)
- Column names automatically wrap in the column name area to accommodate the column width you specify.
- Move column boundaries and enlarge the column to view long values. Adjust widths of all selected columns at once by pressing the Alt key (Option key on the Macintosh and Shift-Alt on Linux) as you drag the double arrow cursor on any of the selected column boundaries.
- There is no limit to the number of rows or columns in a data table. However, the table must fit in your computer’s memory.
The Data Table Panels

There are three data table panels—the table panel, the columns panel, and the rows panel. The data table panels are arranged to the left of the data grid, as shown in Figure 3.2. These panels contain information about the table and its contents. Each have interactive components, as shown in Figure 3.2.

**Figure 3.2 Interacting with Data Table Panels**

<table>
<thead>
<tr>
<th>Click to view table menus and properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click to view the columns menu</td>
</tr>
<tr>
<td>Click to view the rows menu</td>
</tr>
<tr>
<td>Click to close the panels</td>
</tr>
<tr>
<td>Click and drag to adjust height and width of panels</td>
</tr>
</tbody>
</table>

The Table Panel

The table panel contains the data table name, a small red triangle icon, and a list of any table properties/scripts. In Figure 3.3, the table variables are scripts named Distribution, Bivariate, Oneway, etc. To access table commands, click the red triangle icon to the left of the data table name, as shown in Figure 3.3.

<table>
<thead>
<tr>
<th>Big Class</th>
<th>name</th>
<th>age</th>
<th>sex</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>KATE</td>
<td>12</td>
<td>F</td>
</tr>
<tr>
<td></td>
<td>LOUISE</td>
<td>12</td>
<td>F</td>
</tr>
<tr>
<td></td>
<td>JANE</td>
<td>12</td>
<td>F</td>
</tr>
<tr>
<td></td>
<td>JACLYN</td>
<td>12</td>
<td>F</td>
</tr>
<tr>
<td></td>
<td>LILLIE</td>
<td>12</td>
<td>F</td>
</tr>
<tr>
<td></td>
<td>TM</td>
<td>12</td>
<td>M</td>
</tr>
<tr>
<td></td>
<td>JAMES</td>
<td>12</td>
<td>M</td>
</tr>
<tr>
<td></td>
<td>ROBERT</td>
<td>12</td>
<td>M</td>
</tr>
<tr>
<td></td>
<td>BARRIE</td>
<td>13</td>
<td>F</td>
</tr>
<tr>
<td></td>
<td>ALICE</td>
<td>13</td>
<td>F</td>
</tr>
<tr>
<td></td>
<td>SUSAN</td>
<td>13</td>
<td>F</td>
</tr>
<tr>
<td></td>
<td>JOHNN</td>
<td>13</td>
<td>M</td>
</tr>
<tr>
<td></td>
<td>JOE</td>
<td>13</td>
<td>M</td>
</tr>
<tr>
<td></td>
<td>MICHAEL</td>
<td>13</td>
<td>M</td>
</tr>
<tr>
<td></td>
<td>DAVID</td>
<td>13</td>
<td>M</td>
</tr>
<tr>
<td></td>
<td>JUDY</td>
<td>14</td>
<td>F</td>
</tr>
<tr>
<td></td>
<td>ELIZABETH</td>
<td>14</td>
<td>F</td>
</tr>
</tbody>
</table>
Clicking the red triangle icon in the table panel gives you these options:

**Tables**  Gives you the same options as selecting the **Tables** command from the main menu, which is discussed in detail in “Reshaping Data,” p. 221.

**New Table Variable**  Lets you create a new table variable, which can be text or any other constant character value that you always want to be available in the data table. Table variables are mostly used to document tables. You can also access them when you are using the formula editor so they can be incorporated into formulas or JSL scripts. JMP sometimes automatically creates table variables, such as:

- If you open a data table created by an earlier release of JMP and the table has table notes in it, a table variable called **Notes** appears with the note’s text (see “Adding Table Variables,” p. 83, for an example).

- If you create a design table with the Design of Experiments (DOE) commands, JMP creates a table variable named **Design** with the name of the design type as its value.

**New Property/Script**  Lets you create a JSL script (a table property) to save with the data table. You can also access properties or scripts when you are using the formula editor so they can be incorporated into formulas that calculate column values (see “Creating a Formula,” p. 279, for details). After selecting this command, name the script and type in the value (the JSL commands), as shown on the left in Figure 3.4. After you click **OK**, the new script is listed in the table panel and you can click its red triangle icon to run, edit, or delete it, as shown on the right in Figure 3.4. See “Creating Scripts,” p. 86, for details.
Figure 3.4  Create a New Script

**Run Script**  Lets you run the highlighted script (if available) that is listed under the data table name. If no script is highlighted, the Run Script option is not available.

**Edit**  Lets you edit the highlighted script (if available) that is listed under the data table name. If no script is highlighted, the Edit option is not available.

**Delete**  Lets you delete the highlighted script (if available) that is listed under the data table name. If no script is highlighted, the Delete option is not available.

**Suppress Formula Eval**  Turns off the feature that automatically evaluates formulas. You can turn off evaluation and build sections of a formula, then turn evaluation on to test the formula.

**Lock Data Table**  Locks the data table so values cannot be edited or added. You will still be able to run analyses, assign characteristics, add rows and columns, etc. See “Locking Tables,” p. 82, for details.

In addition to clicking the table panel’s icon and selecting from the menu, there are other actions you can take, as illustrated in Figure 3.5.

**Figure 3.5**  Actions That Can be Performed on the Table Panel

Click the data table name to edit it

Double-click the table variable or property name to edit the variable’s name and content

Click the red triangle icon to access options available to the table variable, including running a script, if the variable is a script
The Columns Panel

The columns panel (Figure 3.6) contains a list of columns found in the data table, each column’s modeling type, and any attributes assigned to the columns.

To access column commands, click the small red triangular icon to the left of the word Columns, as shown in Figure 3.6. These commands give you the same options as selecting the Cols command from the main menu, which is discussed in “The Cols Menu,” p. 408.

Icons to the left of each column name indicate the column’s modeling type: continuous, ordinal, or nominal, as shown in Figure 3.6. Modeling types tell JMP how to use the column values in an analysis. To change the modeling type, click the icon and select a different type. See “About Modeling Types,” p. 57, for details.

Figure 3.6 The Columns Panel

Icons to the right of each column name, as shown in Figure 3.7, indicate characteristics and properties the columns contain. See “Assigning Characteristics to Rows and Columns,” p. 129 and “Assigning Properties to Columns,” p. 140, for details. To change the name of a column, double-click its name in the column panel and begin typing. Or, highlight the entire column in the data grid and begin typing.
Figure 3.7 Elements Indicating Column Characteristics and Properties

- Italics indicates that the column is locked into the first column of the table. When you scroll horizontally, the column remains visible.
- X, Y, W, or F indicates the column has been assigned a preselected role so, in analyses, it will always appear as the x, y, weight, or frequency role.
- Yellow tag indicates that points on plots corresponding to the column will be identified by the value instead of the row number.
- Mask indicates that the column is hidden in the data grid.
- Circle with a strikethrough indicates that the column will be excluded from any analyses you run.
- Lock indicates that the column has been locked and cannot be edited.
- Asterisk indicates that the column contains one or more properties. Click to reveal a list of properties the column contains.
- A plus sign indicates that the values in the column result from a formula. When formula evaluation is suppressed (see “Using Formula Editor Options,” p. 300, for details), part of the icon becomes grey. Double-click to view and edit the formula.
- Range check icon indicates that the column can only contain values within a range of numbers. Click to view and edit the range.
- List check icon indicates that the column can only contain individual values. Click to view and edit the list.

The Rows Panel

The rows panel (Figure 3.8) shows the number of total rows, selected (or highlighted) rows, excluded rows, hidden rows, and labelled rows.

To access row commands, click the small red triangular icon to the left of the word Rows, as shown in Figure 3.8. These commands give you the same options as selecting the Rows command from the main menu, which is discussed in “The Rows Menu,” p. 406.
Chapter 3

Enter, Edit, and Manage Data

Elements of JMP Data Tables

Figure 3.8 Rows Panel

The Data Grid

Figure 3.9 illustrates how to select rows and columns, find rows, and use keyboard arrows. See “Selecting Rows and Columns,” p. 89, for details on making selections.

Figure 3.9 The Data Grid

Click to view/hide the data table panels

Click to deselect all selected rows. Shift-click to select all rows.

Click to view the rows menu

Click to select the row

Click to deselect all selected columns. Shift-click to select all columns.

Click to view the columns menu

Click to select the column, double-click to view the Column Info window, or right-click for specific column options

Double-click to edit column name

Click and drag to adjust the width of the column. To simultaneously adjust widths of all selected columns, press and hold the Alt key (Option on the Macintosh and Shift-Alt on Linux) as you click and drag.
Cursor Forms

The cursor has different forms, and the actions it performs depend on its location in the data grid. See “The Tools Menu,” p. 422, for details on cursor forms.

**Arrow Cursor** The cursor is the standard arrow when it is in the panels area to the left of the data table, in the triangular rows and columns area in the upper-left corner of the data grid, or on the title bar of the tables panel.

- To select a column using the arrow cursor, click its name in the columns panel.
- Click the table name on the title bar of the tables panel to edit it.
- Double-click a column name in the column panel to edit it.
- Click the triangular areas in the upper-left corner of the data grid to deselect rows and columns.
- Click and drag to draw a temporary line. When you release, the line disappears.

**Selection (Large Plus) Cursor** When the cursor is within a column heading or a row number area, it becomes a large plus, indicating it is available to select rows or columns. When you click, that row or column is highlighted. Click and drag to highlight multiple rows or columns, and Ctrl-click (Command-click on the Macintosh) to select discontiguous rows or columns.

- Double-click a column heading area to see the Column Info window for that column.
- Select a column to change the column name. The column highlights. Begin typing (if it is not in a locked column or locked data table).
- Double-click the row number area to edit the rows using the row editor.

**Standard I-beam Cursor** When you select editable text, the cursor becomes a standard I-beam. To edit text, position the I-beam within highlighted text. Click to mark an insertion point, or drag to select text for replacement. The I-beam deposits a blinking vertical bar to indicate a text insertion point or a highlighted area of text to be replaced.

**Double Arrow Cursor** The cursor changes to a double arrow when it is on a column boundary. Drag this cursor left or right to change the width of a column. Changing the width of a column does not affect the column field width specified in the Column Info window (accessed by double-clicking a column name).

**Note:** You can adjust widths of all selected columns at once by pressing the Alt key (Option key on the Macintosh and Shift-Alt on Linux) as you drag the double arrow cursor on any of the selected column boundaries.

**List Check and Range Check Cursors** The cursor changes form when you move the mouse over values in columns that have data validation in effect. It becomes a small, downward-pointing arrow on a column with list checking, and a large I-beam on a column with range checking. When you click, the value is highlighted and the cursor becomes the standard I-beam; you enter or edit data as usual with any values defined as valid text or valid numbers. List check and range check values can be found by right-clicking the column name and selecting **Validation**, **The Tools Menu**,
then selecting either List Check or Range Check. See “Validating Column Data,” p. 143, for details.

Popup Pointer Cursor The cursor changes to a pointer over any red triangle icon or diamond-shaped disclosure button (↑ on Windows/Linux and ▲ on the Macintosh). Click to select a menu item or to open or close a panel.

### Specifying Data Types and Modeling Types

A column in a JMP table can contain different kinds of information. However, all information in a single column must be of the same data and modeling types.

- When you import data into JMP, it guesses which data and modeling types to use. Therefore, you should check to make sure JMP guessed correctly.
- When you manually insert data into JMP, you should assign a data type and a modeling type as you insert the data.

### About Data Types

The data type of a column determines how its values are formatted in the data grid, how they are stored internally, and whether they can be used in calculations. The three data types are:

- **Numeric**  Columns only contain numbers, with or without a decimal point.
- **Character**  Columns contain any characters, including numbers. In character columns, numbers are seen as characters only and are treated as discrete values instead of continuous values. The maximum field width for character values is 32,766 bytes.
- **Row State**  Columns contain row state information—information that tells you if the rows are excluded, hidden, labeled, colored, or marked. See “Using Row State Columns,” p. 162, for details.

### About Modeling Types

The modeling type of a column applies only to columns whose data types are numeric or character. The modeling type tells JMP how to treat its values during analyses. Changing the modeling type lets you look at a variable in different ways in an analysis. The three modeling types are:
Continuous  Columns only contain numeric data types. Continuous values are treated as continuous measurement values. JMP uses the numeric values directly in computations.

Ordinal  Columns contain either numeric or character data types. JMP analyses treat ordinal values as discrete categorical values that have an order. If the values are numbers, the order is the numeric magnitude. If the values are character, the order is the sorting sequence.

Nominal  Columns contain either numeric or character data types. All values are treated in JMP analyses as though they are discrete values with no implicit order.

Possible combinations of data and modeling types are listed in Table 3.1.

Table 3.1  Combinations of Data and Modeling Types

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Continuous</th>
<th>Ordinal</th>
<th>Nominal</th>
</tr>
</thead>
<tbody>
<tr>
<td>Numeric</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Character</td>
<td>no</td>
<td>yes</td>
<td>yes</td>
</tr>
</tbody>
</table>

How to Assign Data and Modeling Types

There are three methods to assign data and modeling types or to make sure JMP has automatically given your data the correct types. The following sections describe these three methods.

Method 1: Create a New Column

One way to assign data and modeling types is when you create a new column. When you create a new column (by selecting Cols > New Column), the New Column window appears, as shown in Figure 3.10. Specify the data type and modeling type in this window.
Figure 3.10 Add a New Column and Specify Data and Modeling Type

Method 2: Double-click the Area Above an Existing Column Name

If your data is already in JMP and you want to assign data and modeling types, double-click the empty area above the name of the column. The Column Info window appears, as shown in Figure 3.11. Specify the data type and modeling type in this window.

Figure 3.11 Double-click an Existing Column and Specify Data and Modeling Type

Method 3: Use the Columns Panel Icons

If your data is already in JMP, click the icon beside the column name in the column panel that indicates the modeling type it possesses. Select a different type from the drop-down menu.

Note: You can select Continuous only if your data type is numeric. If Continuous is greyed on the menu and you want to make the column continuous, first change its data type in the Column Info window (access this window by highlighting the column and selecting Cols > Column Info).
Using Short-Integer Format

JMP has the ability to store numeric data in as few as 8 bits (one byte). To implement this, you need to tell JMP to first make short-integer formats available to you in the Column Info window’s Data Type drop-down menu. Then you should specify how many bytes you want the integers to hold. When you use the correct short-integer format for your data, you will not see any difference in how the numbers display, but they will occupy less disk space.

To store numeric data in short-integer format:

1. Select File > Preferences and click the Tables option on the left panel.
2. Click the Allow Short Numeric option.
3. Click OK to return to the data table.
4. Double-click the column name whose values you want to be short-integer. The Column Info window appears.
5. Click the Data Type drop-down menu, and select 1-byte integer, 2-byte integer, or 4-byte integer. JMP will now store values as integers in the range corresponding to your selection. For example, when 1-byte integer is selected, the range of numbers you can enter is from -126 to 127. When 2-byte integer is selected, the range of numbers you can enter is from -32,766 to 32,767. When 4-byte integer is selected, the range of numbers you can enter is from -2,147,483,646 to 2,147,483,647.

Choosing Numeric Formats

When you assign a variable’s data type to be numeric, you can also specify the display format for it to use. To select the numeric format:

1. SelectCols > Column Info or double-click the area above the name of the column in the data grid. Or, if you are creating a new column, selectCols > New Column.
2. Click the drop-down menu beside Format, as shown in Figure 3.12, and select how you want JMP to display numeric values. See “Numeric Format Options,” p. 61, for descriptions of options.

Figure 3.12 Column Info Window and Date-Time Formats

3. If you selected:
   - Date or Time from the Format drop-down menu in Step 2, click the Input format menu that appears, as shown in Figure 3.13, and select which format dates or times will have when they are entered into JMP. See “Numeric Format Options,” p. 61, for descriptions of options. See “Changing the Numeric Format of an Axis,” p. 200, for a description of how to change the way a date or time appears in a graph without changing the way it appears in a data table.
Figure 3.13 The Input Format Option

- Fixed Dec from the Format drop-down menu in Step 2, the Dec text box appears, as shown in Figure 3.14. Type the number of decimal places you want JMP to display in the data table. If the value doesn't have as many numbers after the decimal as the number you specify, JMP adds zeros to the number to give it that many decimal places. For example, if a value is 1.23 and you type 5 in the Dec box, JMP displays the number with five decimal places: 1.23000.

Figure 3.14 Specifying a Fixed Decimal

4 In the Width text box, type the number of characters you want the cell in the data table to accommodate. Be sure to type a number that is the largest number of digits or characters you think a value in the column could have. If your format is Fixed Dec and you set the width of the cell to be smaller than the number of decimal places you want in the values, JMP ignores the number of decimal places you specify and sets the column width to the number of characters you specify in the Width box.

Figure 3.15 Specifying a Fixed Width

5 Click OK.

Numeric Format Options

The options in the Format (Figure 3.16) and Input Format drop-down menus are numeric formats that tell JMP how to display numbers in the data grid.
Available options are:

- **Best**  
  Lets JMP consider the precision of each cell value and select the best way to show it. By default, the physical width of the column is 10 characters. You can increase the column width to show large values with many decimal places by typing the number of characters needed in the **Width** text box found in the Column Info window.

- **Fixed Dec**  
  Displays all column values rounded to the number of decimal places you specify. You can set the number of decimal places to zero to see only whole numbers. Type the number of decimal places you want JMP to display into the **Dec** text box in the Column Info window.

- **Percent**  
  Multiplies numeric values by 100 and displays the result followed by a percent sign.

- **PValue**  
  Displays probability values. It has a default width of six and shows four decimal places. If a number is less than 0.0001, the number is displayed as <.0001. The format is mostly used in JSL scripts and rarely needed for a data table column.

- **Scientific**  
  Displays a number in standard scientific notation. If you enter the number 123456, it appears as 1.23456e+5.

- **Currency**  
  Formats values with two decimal positions, commas as needed, and the dollar sign ($) prefix. If you enter the number 123456, it shows in the data table as $123,456.00. The default width of the **Currency** format is 10. If you have a number that requires a wider field width, the format defaults to the **Best** format. You can increase the column width to show large values with many decimal places by typing the number of characters needed in the **Width** text box found in the Column Info window. Note that the **Currency** format is not used on axes of graphs.

- **Date**  
  Displays all column values as a date. If you assign a date format to a numeric column without choosing a data format, JMP assumes its numeric values are the number of seconds since January 1, 1904. For example, if you entered the date February 13, 1943, JMP would show the value of 1,234,567,890. As shown in Figure 3.17, you can leave the date values displayed as described above, or select one of these formats: (The examples below show formats for reading or displaying the date, December 31, 2004. Its unformatted (numeric) value is 3,187,296,600.)
Figure 3.17 Date Formats

- m/d/y has the form of mm/dd/yyyy, giving 12/31/2004.
- mmddyyyy has the form of mmddyyyy, giving 12312004.
- m/y has the form of mm/yyyy, giving 12/2004.
- d/m/y has the form of dd/mm/yyyy, giving 31/12/2004.
- ddmmyyyy has the form of ddmmyyyy, giving 31/12/2004.
- ddMonyyyy has the form of ddMonyyyy, giving 31Dec2004.
- Monddyyyy has the form Monddyyyy, giving Dec312004.
- y/m/d has the form yyyy/mm/dd, giving 2004/12/31.
- yyyymmdd has the form yyyymmdd, giving 20041231.
- yyyy-mm-dd has the form yyyy-mm-dd, giving 2004-12-31.
- Date Long shows a date value as weekday, month day, year, which gives Tuesday, December 31, 2004. When using this option, you might need to increase the column width to see the formatted value in its entirety. Do this by double-clicking the column name and entering the needed number of digits or characters into the box labeled Width.
- Date Abbrev is the same as the Long format except that weekday and month have three-character abbreviations, such as Tue, Dec 31, 2004. When using this option, you might need to increase the column width to see the formatted value in its entirety. Do this by double-clicking the column name and entering the needed number of digits or characters into the box labeled Width.
- Locale date displays a JMP date value according to the settings of your operating system. For example, the local OS setting for date in the United states is the format mm/dd/yyyy.
Time displays all column values as an instance in time using one of these formats (shown in Figure 3.18). An example of an instance is a specific date in time, such as 12/2/03 at 2:23 PM.

Figure 3.18 Time Formats

- \text{m/d/y h:m, m/d/y h:m:s, d/m/y h:m, y/m/d h:m, y/m/d h:m:s, ddMonyyyy h:m, ddMonyyyyh:m:s, Mondddyyy h:m, Mondddyyy h:m:s} show the number of hours, minutes, and seconds after midnight of the prepended date. The date appears in the formats described above. The hours, minutes, and seconds are separated by a colon. This example (12/31/2004) has no hours or minutes. Examples of its formatted values with zero hours minutes and seconds are 12/31/2004 12:00 AM and 12/31/2004 12:00:00 AM.

- \text{:day:hr:m, :day:hr:m:s} show the number of days, hours, minutes, and seconds since January 1, 1904. The results for December 31, 2004 are :36890:00:00: and :36890:00:00:00.

- \text{h:m:s, d h:m} gives hours, minutes, and seconds portion of the date in the date field. The example used here (December 31, 2004) has no time entered, so the result is 00:00:00.

- \text{yyyy-mm-ddThh:mm, yyyy-mm-ddThh:mm:ss} show the year, month, day, and time. For example, 2004-12-31T17:34:54. T is a literal, representing itself.

- \text{Locale Date Time h:m} and \text{Locale Date Time h:m:s} display a JMP time value according to the settings of your operating system. For example, the local OS formats for time in the United states are the formats mon/dd/yyyy h:mm and mon/dd/yyyy hh:mm:ss.

Duration displays all column values as a duration of time using one of these formats (shown in Figure 3.19). An example of duration is hours, minutes, and seconds.
Figure 3.19 Duration Formats

- **:day:hr:m, :day:hr:m:** show a duration of time, such as 52:03:01:30 (:day:hr:m:s), which reads fifty two days, three hours, and one minute, and thirty seconds.

- **h:m, h:m:s, m:s** shows a duration of time, such as 17:37 (h:m), which reads seventeen hours and thirty seven minutes.

**Working With International Formats**

If you are importing or entering data that contains formatting specific to country standards, you may need to make sure your number formats are interpreted correctly. To do this on Windows, access the Control Panel’s time/region and language option, and select the country for which the number should be formatted. On the Macintosh, select **System Preferences** from the apple menu, then select **International**, then select **Numbers**, and select the correct country. On Red Hat 7.x, under KDE, select **Preferences > Personalization > Country & Language**. On Red Hat 9 in both KDE and GNOME’s main menu, select **System Settings > Language**.

---

**Entering Data**

The following sections describe how to enter data into a table, including entering data one cell at the time or adding rows and columns of data at once.

**Adding and Deleting Rows**

To add new empty rows, take one of the following actions:

- Select **Rows > Add Rows**. Then enter the number and location of rows you want to add. By default, new rows appear at the end of the table.

- Click in a cell anywhere below the last row in a table and begin typing. Then press Enter (or Return) to automatically generate new rows up to and including the row with the value you typed.
• Double-click an empty row number area below the last row to add that many empty rows.
• Double-click the lower triangular area in the upper-left corner of the data grid, as shown in Figure 3.20. Then enter the number of rows to add and specify where you would like to add them.

**Figure 3.20** Double-click the Lower Triangular Area

To delete rows from the data grid:
1. Highlight the rows you want to delete.
2. Select **Rows > Delete Rows**, or right-click (Ctrl-click on the Macintosh) the rows and select **Delete Rows**.
3. If you mistakenly delete rows, select **Edit > Undo Delete Rows**.

**Adding and Deleting Columns**

To add new empty columns, take one of the following actions:

• Double-click the empty space to the right of the last data table column and begin typing.
• Select **Cols > New Column**. The window in Figure 3.21 prompts you to name the new column and provide column characteristics, including the type of data with which you initially want to fill the column. Then click **Next** to add another column and click **OK** to see the new column(s) appear in the data table. The New Column window also gives options of assigning properties to columns using the **Column Properties** button. See “Assigning Properties to Columns,” p. 140, for details.

**Figure 3.21** The New Column Window
• Select Cols > Add Multiple Cols. Using the Add Multiple Columns command to define multiple columns is different than using the New Column command because all columns you add with the Add Multiple Columns window will have the same data characteristics. By default, the new column names are Column 1, Column 2, etc. However, you can specify other text that becomes the prefix of the new column names by typing into the Column prefix box. Then, as shown in Figure 3.22, enter the number of columns to add, their location, a data type (see “About Data Types,” p. 57, for details), and a field width.

Figure 3.22 The Add Multiple Columns Window Accessed Through the Cols Menu

• Double-click the upper triangular area in the upper-left corner of the data grid. The window shown in Figure 3.23 appears. By default, the new column names are Column 1, Column 2, etc. However, you can specify other text that becomes the prefix of the new column names by typing into the Column prefix box. Then, enter the number of columns to add, a data type (see “About Data Types,” p. 57, for details), and a field width.
To delete columns from the data table:
1. Highlight the columns to delete.
2. Select Cols > Delete Columns.
3. If you mistakenly delete columns, select Edit > Undo Delete Columns.

Setting Up Initial Data Values

When you add a new column to a data table (select Cols > New Column), you can specify the type of data values you want to appear in the column, as shown in Figure 3.24.

**Figure 3.24** Initial Data Values

- **Missing/Empty** Places missing values in the column, represented by a black dot (●) for numeric data and a blank for character data.
- **Constant** Places one number in all the column's rows for numeric data. Select Constant, then specify what number you would like to use by typing it into the box that appears. For character data, any number of characters can be entered into this box.
**Sequence Data**  Inserts sequential data based on the parameters you specify in the boxes that appear. For numeric data, as shown in Figure 3.25, select **Numeric** in the Data Type box and select **Sequence Data** for the Initial Data Values. Assign a starting and ending point in the **From** and **To** boxes, then assign the sequence in the **Step** box. For example, if you want the column to contain even numbers from 2 to 60, type **2** in the **From** box, **60** in the **To** box, and **2** in the **Step** box. In the **Repeat each value N times** box, type the number of times you want each numeric value repeated. Click **OK**.

Figure 3.25  Entering Numeric Details for Sequence Data

![Figure 3.25](image)

For character data, as shown in Figure 3.26, select **Character** in the Data Type box and select **Sequence Data** for the Initial Data Values. In the box next to Add, type the character data and click **Add**. In the **Repeat each value N times** box, type the number of times you want each character value (such as red) repeated. Click **OK**.

Figure 3.26  Entering Character Details for Sequence Data

![Figure 3.26](image)

- **Random**  Inserts random data into the column. Click the button beside the type of random number you want to use, then enter either a range for random integers and random uniform numbers or the mean and standard deviation for random normal numbers (Figure 3.27).

Figure 3.27  Entering Details for Random Data

![Figure 3.27](image)
Filling Columns with Sequential Data

You can fill a column with either a repeating sequence of data or with a continuation of values:

1. Create a sequence of data in a column, as shown in Figure 3.28.

Figure 3.28 Sequence of Data

2. Highlight the cells containing the sequence of data.

3. Right-click (Ctrl-click on the Macintosh) the selected cells and select an option shown in Figure 3.29.

Figure 3.29 Data Filling Options

- **Repeat sequence to end of table**: Cells below the selection are filled with repeats of the selected cells.
- **Continue sequence to end of table**: Cells below the selection are filled with a continuation of the pattern found in the selected cells. For example, if the selected cells contain the numbers 1 and 2, then the remaining cells will be filled with 3, 4, 5, 6, and so on. If the selected cells contain the numbers 2 and 4, then the remaining cells will be filled with 6, 8, 10, 12, and so on.
- **Repeat sequence to... you specify**: JMP repeats the pattern found in the selected cells to the row number you specify.
- **Continue sequence to... number you specify**: JMP continues the pattern found in the selected cells to the row number you specify.

Entering Cell Formulas

In numeric columns, you can enter cell expressions preceded by an equal sign (=). JMP immediately evaluates the expression and stores the new number as the cell’s value. Unlike column formulas, a cell expression is not stored.

Cell expressions can contain operators, constants, and global and column variables.
To enter an expression:
1. Click the cell in which you want to enter the expression.
2. Type an equal sign (=).
3. Enter the expression.
4. Press Enter or Return on your keyboard.

<table>
<thead>
<tr>
<th>Example expression</th>
<th>Cell value</th>
</tr>
</thead>
<tbody>
<tr>
<td>=sqrt(2)</td>
<td>1.41</td>
</tr>
<tr>
<td>=456+890</td>
<td>1346</td>
</tr>
<tr>
<td>=height+weight</td>
<td>Sums the values of cells in columns height and weight located in the same row as the cell you entered the expression.</td>
</tr>
<tr>
<td>=height[1]</td>
<td>Displays the value found in row 1 of the height column</td>
</tr>
</tbody>
</table>

**Editing Data and Tables**

The following sections describe how to edit data that is in a table, including editing cells themselves and making changes to rows and columns.

**Editing Cells**

To edit the contents of a cell:
1. Click a cell that already has a value. It is highlighted, as shown in Figure 3.30

**Figure 3.30** Editing the Contents of a Cell

2. Click it a second time. The cursor becomes a flashing text insertion bar.
3. Edit its value.

**Editing Column Names**

There are many ways to edit a column name. Choose a way from the list below:

- Select the column and begin typing.
- Select the column, then click the column name and edit.
• Double-click or right-click the empty area around the column name and select Column Info. Edit the name in the Column Info window that appears.

• Double-click the column name in the column panel and begin typing.

Recoding Data

If you have data that is coded incorrectly (for example, contains typos or incorrect wording), you can quickly recode it so it adheres to a consistent format. You can also use recode to replace missing or empty values.

JMP displays a window that contains selected columns’ unique values and allows you to enter new values to replace them:

1. Highlight the column(s) that contain data you would like to recode.
2. Select Cols > Recode. The Recode window appears (Figure 3.31). In this window, the Count column lists the number of occurrences each value has in the data table.

Figure 3.31 Enter New Values

3. Type the new value in the text box corresponding to the old value you want to change.
4. Click OK.

Tip: If you want to apply the same new value to several old values, type the value once, then copy and paste into the other text boxes.

Command Options

The first three commands apply to all items in the data table list.

Convert to Titlecase converts to title case, that is, an initial uppercase character and subsequent lowercase characters.

Convert to Uppercase converts all items to uppercase

Convert to Lowercase converts items to lowercase.

Often, when importing data tables, tab characters, space characters, and line separators are imported with the data table. These two commands are used to remove these characters.

• Trim Whitespace removes leading and trailing whitespace. For example, if an extra space was imported before and after the name John, this command would delete the spaces.

• Collapse Whitespace trims leading and trailing whitespace and removes duplicate interior white spaces. That is, if more than one white space character is present, the Collapse Whitespace command replaces the two spaces with one space.
The drop-down menu allows you to apply the recode changes to three options. **In Place** applies any change to the original data column. **New column** creates a new column for the changed data. **Formula Column** creates a new column with the changes as a formula.

### Viewing Patterns of Missing Data

If your data table contains missing data, you may want to see if there is a pattern that the missing data creates. The pattern may help you make discoveries about your data. Selecting **Tables > Missing Data Pattern** shows you this pattern in a data table format:

1. Select **Tables > Missing Data Pattern**. The Missing Data Pattern window appears (Figure 3.32).

   **Figure 3.32** The Missing Data Pattern Window

2. Highlight the columns from which you would like to find missing data.

3. Click **Add Columns**, then click **OK**. The Missing Data Pattern table (Figure 3.33) appears.

   **Figure 3.33** A Missing Data Pattern Table

There are two instances where all rows in Trial 1, Trial 2, Trial 3, and Trial 4 have no missing values

There are two rows in the source table whose one missing value is in the Trial 4 column

There are two rows in the source table whose missing values are in the Trial 3 and Trial 4 columns

There is one row in the source table whose three missing values are in the Trial 2, Trial 3, and Trial 4 columns
In the Missing Data Pattern table, JMP automatically assigns the Count column the analysis role of frequency. Now if you use the Missing Data Pattern data table to run an analysis, JMP automatically uses Count as a frequency so you do not have to specify its role each time. See “Giving Columns a Preselected Analysis Role,” p. 138, for details.

Finding and Replacing Cell Values

Selecting Edit > Search gives you many search options, as shown in Figure 3.34. The following rules apply to searching for values:

- To find values in hidden columns or locked tables, unhide the column or unlock the table.
- Values found in locked columns can not be modified.
- The Undo command works only with Replace and Replace & Find Next. You cannot undo Replace All.
- If your data table contains value labels (see “Using Value Labels,” p. 146), using the Search commands will search for actual values, but will not search for labels.

Figure 3.34 Search Choices

To find (or find and replace) values:

1. Select Edit > Search > Find. The window in Figure 3.35 appears.
2. Enter a value in the Find what box.

Note: To find missing character values, leave the Find field empty and check Match whole words only. To find missing numeric values, insert a period into the Find field and check Match whole words only.
3 Enter a value in the **Replace with** box, if you would like to replace the values found with a different value.

4 Refine your search. Select any of the following:

- **Match Case**  
  Gives a case sensitive search, useful for locating proper nouns or other capitalized words.

- **Match whole words only**  
  Detects empty spaces, which lets you search for a series of words in a character column, or locate strings with unwanted leading or trailing empty spaces. Using the **Match whole words only** checkbox also locates words with at least one leading and one trailing empty space.

- **Restrict to selected rows**  
  restricts the search to selected rows.

- **Restrict to selected columns**  
  restricts the search to selected columns.

- **Search Data**  
  searches only data cells (omitting column names).

- **Search Column Names**  
  searches only column names (omitting data cells).

- **Use Regular Expressions**  
  assumes the find string to be a regular expression instead of the literal string you enter in the Find What box. JMP’s regular expression support follows standard semantics.

- **Direction By column**  
  searches the table column by column, from top to bottom, until it reaches the last cell in the rightmost column, or until you stop the search. **By row** searches the data table row by row from left to right, to the rightmost cell in the last row or until you stop the search.

5 Use the table below to start searching:

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search the active table for the find value</td>
<td>Click the Find button. The search begins with the first cell in the first column and searches every cell until it locates the value or reaches the end of the table.</td>
</tr>
<tr>
<td>Action</td>
<td>Instructions</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Replace the currently highlighted cell value with the contents of the Replace with box, which contains the replace value</td>
<td>Click the <strong>Replace</strong> button. Or, if the Search window is closed, select <strong>Edit &gt; Search &gt; Replace</strong>. If the replace value is a missing value, the currently highlighted cell content becomes a missing value.</td>
</tr>
<tr>
<td>Replace all occurrences of the specified value with another value</td>
<td>Click the <strong>Replace All</strong> button. Or, if the Search window is closed, select <strong>Edit &gt; Search &gt; Replace All</strong>.</td>
</tr>
<tr>
<td>Automatically replace the value and search for the next value</td>
<td>On Windows and Macintosh, first ensure there is a value in the Search window (accessed by <strong>Edit &gt; Search &gt; Find</strong>). Then select <strong>Edit &gt; Search &gt; Replace and Find Next</strong>. Or use Ctrl-L (Windows) or Command-L (Macintosh). On Linux, click the <strong>Find</strong> button in the Search window, then click the <strong>Replace &amp; Find Next</strong> button.</td>
</tr>
<tr>
<td>Exit the Find window but keep the search value in memory so the values you entered will appear the next time you open the window (Windows and Macintosh only)</td>
<td>Click the <strong>Don’t Find</strong> button (Windows and Macintosh only).</td>
</tr>
<tr>
<td>Find the next value in the table when the Find window is closed</td>
<td>Select <strong>Edit &gt; Search &gt; Find Next</strong>. Or, use Ctrl-G (Windows) or Command-G (Macintosh).</td>
</tr>
<tr>
<td>Find a missing value</td>
<td>In the Search window, choose from these options: To find missing character values, leave the <strong>Find</strong> field empty and check <strong>Match whole words only</strong>. To find missing numeric values, type a period into the <strong>Find what</strong> text box and check <strong>Match whole words only</strong>. <strong>Note:</strong> Typing a period into the text box without clicking the <strong>Match whole words only</strong> box searches for a period.</td>
</tr>
</tbody>
</table>
Reordering Columns

You can rearrange, or sort data table columns by their name, data type, or modeling type, or you can reverse their current order. You can also move selected columns to a particular place in the data table.

To reorder columns:

1. Select Cols > Reorder Columns.
2. Make a selection from the submenu, as shown in Figure 3.36.

Figure 3.36 Choices for Reordering Columns

---

**Move Selected Columns** Moves the selected columns to a particular place in the data table. When you select **Move Selected Columns**, the Move Selected Columns window shown below appears with the following choices:

- **To first:** Moves the selected columns so they are in the left-most position in the data table.
- **To last:** Moves the selected columns so they are in the right-most position in the data table.
- **After:** Moves the selected columns so they are after a column you identify

**Original Order** Returns the columns to the order they were in at the time the data table was last saved.

**Reorder by Name** Arranges the columns (except for row state columns) from left to right in alphabetical order by column name.

**Reorder By Data Type** Arranges the columns from left to right in alphabetic order by data type (character, numeric, row state).

**Reorder By Modeling Type** Arranges the columns from left to right in alphabetic order by modeling type (continuous, ordinal, nominal). Row state columns have no modeling type, and are shown last.

**Reverse Order** Reverses the order of the data table columns.

If you mistakenly move one or more columns, select **Edit > Undo Move Columns** (**Edit > Undo** on Linux) to restore the previous order.
Rows and Columns Context Menus

When you right click (Ctrl-click on the Mac) in the row number area, or at the top of a column in the column name area, the context menus shown in Figure 3.37 appear. These menus give you quick access to selected Rows and Columns menu commands. Documentation of all the Rows and Cols menu command can be found in Appendix B, “The Main Menu,” p. 397.

Note: The Sort command in the context menu for columns gives you a quick way to sort a data table by a single column in ascending values of that column. The context menu Sort command does not display a dialog with sort options. Currently, there is no Undo command for this column sort.

Figure 3.37 Context Menus for Rows and Columns

Copying, Cutting, and Pasting

You can copy or cut and paste in JMP data tables by selecting Edit > Copy or Edit > Cut, and then Edit > Paste. Data you cut or copy to the clipboard can be pasted into data tables or other applications.

- If one cell is selected, Edit commands apply only to that cell. If no columns are selected, Edit commands apply to all rows. Likewise, if no rows are selected, Edit commands apply to all columns. If you select both rows and columns, Copy copies the subset of cells defined by their intersection.
- The Edit commands affect all values in selected rows if no columns are selected. They affect all values in selected columns (except the header field) if no rows are selected.
- When both rows and columns are selected, Edit commands affect the subset of cells defined by the intersection of those rows and columns.

The Copy and Paste commands in the Edit menu function as listed in Table 3.3:

Table 3.3 Using Copy and Paste

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy highlighted rows, columns, a single cell, or combination of cells from the active data table to the clipboard</td>
<td>Select Edit &gt; Copy. On the clipboard, fields are delimited by tab characters and a return character indicates an end of row.</td>
</tr>
<tr>
<td>Paste information from the clipboard to the highlighted area in a JMP data table</td>
<td>Select Edit &gt; Paste. This command can be used with the Copy command to duplicate rows, columns, or any subset of cells defined by highlighted rows and columns.</td>
</tr>
</tbody>
</table>
### Table 3.3 Using Copy and Paste

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Duplicate an entire row or column</td>
<td>Highlight the row or column to be duplicated and select <strong>Edit &gt; Copy</strong>. Then highlight an existing row or column to receive the values select <strong>Edit &gt; Paste</strong>.</td>
</tr>
<tr>
<td>Duplicate a subset of values</td>
<td>Highlight the cells and select <strong>Edit &gt; Copy</strong>. Then highlight an existing row or column to receive the values and select <strong>Edit &gt; Paste</strong>. You must highlight the same arrangement of rows and columns to receive the copied values as originally contained them.</td>
</tr>
<tr>
<td></td>
<td>• If you paste data with fewer rows into a destination with more rows, the source values recycle until all receiving rows are filled.</td>
</tr>
<tr>
<td></td>
<td>• If you paste more rows or columns than you have highlighted, the excess values are lost unless you are pasting to the end of a data table.</td>
</tr>
<tr>
<td></td>
<td>• If you highlight no rows or columns before you paste, rows and columns are added as needed.</td>
</tr>
<tr>
<td>Transfer data from another application into a JMP data table by copying and pasting</td>
<td>First copy the data to the clipboard from within the other application. Then select <strong>Edit &gt; Paste</strong> to paste the values into JMP. Pasting automatically creates rows and columns as needed.</td>
</tr>
<tr>
<td>Paste using the first line of data as column headers</td>
<td>Press the Shift key and select <strong>Edit &gt; Paste</strong>. On the Macintosh, press Shift-Option and select <strong>Edit &gt; Paste with Labels</strong>.</td>
</tr>
</tbody>
</table>

### Moving and Duplicating Values

Drag and drop is a convenient way to move or duplicate values in a data table.

![Image of data table]

**Click and drag column names in the data table or in the Columns Panel to move them.**

**To move columns, cells, or rows:**

1. In either the data table or in the columns panel, highlight the columns, cells, or rows you want to move. To rearrange several columns, cells, or rows, Shift-click or Ctrl-click (Option-click on the Macintosh). Release the mouse.
1. Click the highlighted columns, cells, or rows and drag to the new position. If you do this with discontinuous columns, cells, or rows, they become contiguous when dropped.

   Note that when dragging and dropping **cells**:
   - They retain all of their characteristics and column properties.
   - They leave missing values in the original cells, and they replace the values at their destination if the data types are the same.
   - If you drag a set of cells to an empty area of the table, new columns are automatically created.

   Also note that another way to move **rows** is to:
   1. Highlight the rows you wish to move.
   2. Select **Rows > Move Rows**.
   3. Specify where you would like to move highlighted rows to the beginning of the table (**At start**), to the end of the table (**At end**), or after a specific row number (**After row**).

   ![JMP: Move Rows](image)

   **To duplicate columns, cells, or rows:**
   1. In either the data table or in the columns panel, highlight the columns, cells, or rows you want to duplicate. To duplicate several columns, cells, or rows, Shift-click or Ctrl-click (Option-click on the Macintosh). Release the mouse.
   2. Ctrl-click (Option-click on the Macintosh) the highlighted columns, cells, or rows and drag to the new position. If you do this with discontinuous columns, cells, or rows, they become contiguous when dropped. Note that:
      - The new columns have the original columns’ display format, but not necessarily their modeling types.
      - If you drag a set of cells to an empty area of the table, new columns are automatically created.
      Your values are copied to the destination, leaving the original values intact.

### Using the Row Editor

The row editor lets you browse or edit cells one row at a time. You can access the row editor from an output report (see “**Pasting Reports into Another Program,**” p. 175) or from the data table. To use the row editor from the data table:

1. Highlight a row in the data table.
2. Select **Rows > Row Editor** or double-click a row to display information about the current row.
Note: If you are inside of a plot instead of a data table, right-click (Ctrl-click on the Macintosh) inside the plot and select Row Editor to access the row editor.

3 Edit the data. Note that if your data table contains value labels (see “Using Value Labels,” p. 146) the row editor will display the label, and when the cell is highlighted for editing, it will show the actual value.

4 Click the arrow buttons to browse through selected rows or the entire data set if no rows are selected. Figure 3.38 shows the function of each button.

Figure 3.38 The Row Editor

5 Click the red triangle icon in the row editor to select one of the following:

- **Next Selected**  Displays information for the selected row that is located after the current one.
- **Prev Selected**  Displays information for the selected row that is located before the current one.
- **Next**  Displays information for the row that is located after the current one, regardless of whether the row is selected.
- **Previous**  Displays information for the row that is located before the current one, regardless of whether the row is selected.
- **Save**  Saves the data table and any changes you have made to it via the row editor.
- **New Row**  Creates a new row in the data table.
- **Find**  Displays the same window as if you had selected Rows > Row Selection > Select Where. Click the option under Currently Selected Rows you wish to use, then highlight the column whose rows you wish to select. Type in the value for which you want JMP to search. See “Selecting Cells with Specific Values,” p. 91, for details.
- **Blink**  Causes the current row’s highlight to flash at a rapid rate.
Note: Text in a locked column or a locked data table cannot be edited. See “Locking Columns,” p. 142, and “Locking Tables,” p. 82, for details.

Changing Table Names

A data table's name is found at the top of its window, in the table panel, and on all analysis reports. It is the name by which it has or will be saved.

To change a table's name:

1. Click the table name in the table panel. It is highlighted, as shown in Figure 3.38.

Figure 3.39 Changing a Table's Name

2. Click it a second time. The cursor becomes a flashing text insertion bar.
3. Type name you want.

On Windows, you can also change a data table's name by selecting Window > Set Title.

Locking Tables

There are two ways you can lock a JMP data table:

- You can lock a table so its values cannot be edited. However, you can run analyses, assign characteristics, etc. To do this, select Lock Data Table from the table panel menu (Figure 3.40).
Figure 3.40  Lock the Table so Values Cannot be Edited

To unlock the file, select **Lock Data Table** again.

- You can lock a table so it can be edited but not saved. To do this, change the file's properties according to your computer's operating system. For example, change the file to be “Read-Only.” Then, when you open it in JMP, you will see **Locked File** in the table panel underneath the table's name, as shown in Figure 3.41.

Figure 3.41  A Locked File

---

**Note:** You can lock a column in place so when you scroll horizontally, the column remains visible. See “**Locking Columns in Place,**” p. 137, for details.

---

**Adding Table Variables**

Table variables are character strings that are available to the entire table. They are any constant value that is always available in the data table. Table variable names are displayed in the table panel at the left of the data grid, as shown in Figure 3.42.
Table variables are mostly used to document tables. For example, when you installed JMP, a folder named Sample Data was also installed. Many files in the Sample Data folder contain a table variable called Notes, which contain descriptive information. The example in Figure 3.42 shows a data table that contains Notes as one of its table variables. JMP also automatically creates table variables when you create a design table with the Design of Experiments commands in JMP. The design table has a table variable named Design with the name of the design type as its value.

Table variables can also be incorporated in formulas you build using the formula editor, as shown in Figure 3.43. These formulas calculate values for a column by referring to a table variable. See “Inserting Constants,” p. 282, for details on constructing a formula that uses table variables.

Another use for table variables is to incorporate them into JSL scripts. See the JMP Scripting Guide for details.

Adding New Table Variables

1. Click the red triangle icon to the left of the data table name in the tables panel.
2. Select New Table Variable from the drop-down menu, as shown in Figure 3.44.
3 Give the variable a name and value in the boxes labeled Name and Value, as shown in Figure 3.45.

4 Click OK. The table variable appears in the tables panel.

**Viewing or Editing Table Variables**

1 Click the information you entered as the variable's value. The value is highlighted, as shown in Figure 3.46.

2 Click it a second time. The cursor becomes an I-beam cursor.

3 Edit its value.

**Editing Table Variable Names**

1 Double-click its name. Or, right-click (Command-click on the Macintosh) its name or value and select Edit. The window in Figure 3.45 appears.

2 Edit its name.
To delete a table variable, right-click (Command-click on the Macintosh) its name or value and select Delete.

Example of Using a Table Variable

Table variables can be especially useful when you need to combine two or more data tables. For example, suppose two trials were conducted at two different hospitals. One of the trials’ data is in a table called Cancer1.jmp, and the other is in Cancer2.jmp. To consolidate the data into one table, select Tables > Concatenate (see "Attaching Tables (Concatenating)," p. 236, for details). If you created table variables in Cancer1.jmp and Cancer2.jmp then those variables are also concatenated and appear as columns in the concatenated table, as shown in Figure 3.47.

Figure 3.47 The Data and Table Variables From Cancer1.jmp and Cancer2.jmp (Top Tables) Concatenated Into a Column in Untitled 11.jmp (Bottom Table)

Creating Scripts

You can create a JSL script to save with the data table (Figure 3.48). These scripts are used to automatically complete various tasks and analyses. For full explanations of scripts, see the JMP Scripting Guide.
Adding Scripts to Data Tables

1. Click the red triangle icon (see Figure 3.49) to the left of the data table name in the tables panel.
2. Select New Property/Script from the drop-down menu.

Figure 3.49 Creating a Script

3. Give the script a name by typing it into the box beside Name, as shown in Figure 3.50.
4. Give the script a value by typing JSL code into the box beside Value.

Figure 3.50 Naming and Defining the Script

5. Click OK. The script appears in the tables panel.

Adding Scripts without Typing JSL Code

1. Run an analysis and create an output report using the steps you would like the script to duplicate.
2. Click the red triangle icon beside the report title name, as shown in Figure 3.51.
3 Select **Script > Save Script to Data Table**. The script is created and added to the tables panel.

**Running Scripts**

1 Click the red triangle icon beside the script’s name.
2 From the menu, select **Run Script**.

**Viewing or Editing Scripts**

1 Double-click its name. Or, click the red triangle icon beside the script’s name, as shown in Figure 3.52, and select **Edit**. The window in Figure 3.45 appears.

**Editing Script Names**

1 Double-click its name. Or, click the red triangle icon beside the script’s name, as shown in Figure 3.52, and select **Edit**. The window in Figure 3.45 appears.
2 Edit its name.

To delete a script, click the red triangle icon beside the script’s name or right-click (Command-click on the Macintosh) its name, as shown in Figure 3.46, and select **Delete**.
Selecting Rows and Columns

You can select rows, columns, or both rows and columns, as shown in Figure 3.53.

**Figure 3.53** Example of Selected Rows and Columns

![Selected Rows and Columns](image)

Use the instructions in Table 3.4 to select rows.

**Table 3.4 Selecting Rows**

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select an entire row</td>
<td>Click the empty space that contains the row number.</td>
</tr>
<tr>
<td>Select multiple rows</td>
<td>• Click and drag the cursor over the row number in the data grid.  &lt;br&gt; • Shift-click the first and last rows of the desired range.  &lt;br&gt; • To make a discontiguous selection, Ctrl-click (Windows/Linux) or Command-click (Macintosh) each row. These commands are also toggles that deselect previously-selected rows.</td>
</tr>
<tr>
<td>Select/deselect all rows</td>
<td>Select <strong>Rows &gt; Row Selection &gt; Select All Rows</strong>. Or, Shift-click the lower triangular area in the upper-left corner of the data grid to select. Click again to deselect all rows. To clear all highlights in the data table, press the Esc key on your keyboard.</td>
</tr>
<tr>
<td>Select a block of cells</td>
<td>Drag the cross cursor diagonally across the cells.</td>
</tr>
<tr>
<td>formed by the intersection of rows and columns</td>
<td></td>
</tr>
<tr>
<td>Select a certain row number</td>
<td>Select <strong>Rows &gt; Row Selection &gt; Go to Row</strong> and type in the desired row number.</td>
</tr>
<tr>
<td>Invert the row selection</td>
<td>Select <strong>Rows &gt; Row Selection &gt; Invert Row Selection</strong>.</td>
</tr>
<tr>
<td>Select random rows</td>
<td>Select <strong>Rows &gt; Row Selection &gt; Select Randomly</strong>. See “Randomly Selecting Rows,” p. 94, for details.</td>
</tr>
</tbody>
</table>

Use the instructions in Table 3.5 to select columns.
Selecting Excluded, Hidden, or Labeled Rows

Sometimes you need to automatically highlight, or select, certain types of rows so you can see or manipulate them among the many rows of a data table. To select rows that have been marked as excluded, hidden, or labeled:

1. Select **Rows > Row Selection** (Figure 3.54).

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
</table>
| Select a column | • Click the empty space around the column name.  
• Click the column name in the column panel to the left of the data grid. |
| Select multiple columns | • Click and drag the cursor over the column name in the data grid.  
• Shift-click the first and last columns of the desired range.  
• To make a discontiguous selection, Ctrl-click (Windows/Linux) or Command-click (Macintosh) the desired columns. These commands are also toggles that deselect previously-selected columns. |
| Extend a selection of columns | • Shift-click the first and last column of the desired range.  
• To make a discontiguous selection, Ctrl-click (Windows/Linux) or Command-click (Macintosh) the desired columns. These commands are also toggles that deselect previously-selected columns. |
| To select/deselect all columns at once | Shift-click the upper triangular area in the upper-left corner of the data grid to select. Click in the upper-left corner to deselect all columns. To clear all highlights in the data table, press the Esc key on your keyboard. |
| Make a discontiguous selection | Ctrl-click (Windows/Linux) or Command-click (Macintosh) each column. |
| Select a block of cells formed by the intersection of rows and columns | Drag the cross cursor diagonally across the cells. |
2 Select one of the following:

Select Excluded  Selects all excluded rows regardless of their current selection status and deselects any other previously selected rows.

Select Hidden  Selects all hidden rows regardless of their current selection status and deselects any other previously selected rows.

Select Labeled  Selects all labeled rows regardless of their current selection status and deselects any other previously selected rows.

Selecting Cells with Specific Values

If you are looking for a specific value in a data table, there are several ways to quickly select it, as explained in the sections below.

Selecting Cells That Match the Currently-Highlighted One

JMP can find all cells whose values are the same as the one(s) you currently have highlighted. You can do this within one data table or throughout all open data tables. To select cells that contain the same values as highlighted ones:

1 Highlight the cells that contain the value(s) you want to locate.

2 To find all matching cells within the active data table, select Rows > Row Selection > Select Matching Cells. Or, right-click (Ctrl-click on the Macintosh) one of the highlighted row numbers and select Select Matching Cells.

To find all matching cells across all open data tables, select Select All Matching Cells.

3 The row(s) that contain the same values as the highlighted ones will highlight.

4 For example, suppose you wanted to select all cells in the age column that contain the highlighted age 28 (on the left in Figure 3.55). You would select Rows > Row Selection > Select Matching Cells, and the data table would appear, as shown on the right in Figure 3.55.
Selecting Cells That Contain Specific Values

JMP can search for a specific value (or text string) and highlight all cells in the data table containing that value.

To select cells that contain specific values:

1. Select Rows > Row Selection > Select Where. The window in Figure 3.56 appears.

2. If you currently have rows selected in the data table, click an option under Currently Selected Rows to tell JMP how to handle that current selection:

   - **Clear Current Selection** Removes the highlight from currently-selected rows and selects all rows that contain the specified value.
   - **Extend Current Selection** Keeps the currently-selected rows selected and also selects the rows in which the specified value has been found.
   - **Select From Current Selection** Selects the rows in the currently-selected array that contain the specified values.

3. From the list, highlight the name of the column whose rows you wish to select.
4 Use the drop-down menu to select a condition from the list (equals, does not equal, and so forth), as shown in Figure 3.56.

5 Type the value for which you want JMP to search. To search for missing values, leave the box empty.

6 (Optional) If you would like the search to be case-sensitive, click the box beside Match Case.

7 Click Add Condition.

If you would like to add more conditions to the search, repeat steps 3-7, and click the appropriate item in the Select Rows area to specify if you would like JMP to select rows only if all conditions are met, or if any of the conditions are met.

8 Click OK.

**Using the Search/Find Command**

You can also select rows by selecting Edit > Search. To find (or find and replace) values:

1 Select Edit > Search > Find, as shown in Figure 3.57.

**Figure 3.57 Search Choices**

2 Enter a value in the Find what box. To find missing character values, leave the Find field empty and check Match Whole Words Only. See “Locking Tables,” p. 82, for details.

**Selecting a Particular Row or Column**

If you know the number of the row you want to highlight, instead of scrolling through many rows to find it, you can quickly find a row number using the Go to Row command.

To find a row:

1 Select Rows > Row Selection > Go to Row. The window in Figure 3.58 appears.
Figure 3.58 The Go to Row Window

2. Enter the row number and click OK.

To find a column:

1. Select Cols > Go to. The window in Figure 3.59 appears.

Figure 3.59 The Go to Window

2. Enter the column number or name and click OK.

Randomly Selecting Rows

You can have JMP randomly select a specific number of rows or a percentage of the total rows:

1. Select Rows > Row Selection > Select Randomly, as shown in Figure 3.60. The window in Figure 3.61 appears.

Figure 3.60 Selecting Randomly

2. To randomly select a specific number of rows, enter the absolute sample size in the text edit box. Or, to randomly select a percentage of the total rows, enter the proportional sample size, as shown in Figure 3.61. If you enter a number less than one, JMP assumes that the number is a proportion and you want to randomly select that percentage of rows. If you enter a number more than one, it assumes that the number you entered is the number of rows you want randomly selected. For exam-
ple, entering 10 randomly selects 10 rows. Entering 0.1 randomly selects 10% of the rows.

Figure 3.61 The Select Randomly Window

Inversely Selecting and Selecting All Rows

To select all rows in a JMP data table, select **Rows > Row Selection > Select All Rows**.
To deselect all selected rows and select all previously deselected rows, select **Rows > Invert Row Selection**.

Locating Next and Previously-Selected Rows

You can locate the next selected row after the current row and cause it to flash by selecting **Rows > Next Selected**. Similarly, you can locate the previously-selected row before the current row and cause it to flash by selecting **Rows > Previous Selected**.

Each time you select **Rows > Next Selected** or **Rows > Previous Selected**, the next or previously-selected row is found and flashes. A beep signals when the last selected row is located.
The Data Filter

The Data Filter command in the Rows menu gives a variety of ways to identify subsets of data. Using Data Filter commands and options, you interactively select complex subsets of data, hide these subsets in plots, or exclude them from analyses.

When you choose Rows > Data Filter, the Data Filter window shown in Figure 3.62 appears. The initial Data Filter window shows the Add Filter Columns panel that lists all the variables in the current data table. You select columns in this list whose values you want to use as filters that identify subsets of data. You can open the Add Filter Columns panel and add more filter variables to the process at any time. (Figure 3.62).

Figure 3.62 Data Filter Window and Options

The Data Filter Control Panel

To use the Data Filter, select one or more variables in the Add Filter Columns list whose values you want to use as filters and click Add. You now see the initial Data Filter control panel shown on the left in Figure 3.63.

- The values of the variables you chose are in boxes in the lower part of the panel.
- Above the variable are three check boxes that determine the display modes of the values you select.
- The Clear button at the top of the panel clears all selections you have made.
- The large plus button ( ) at the bottom of the panel opens the Add Filter Columns list again at any time so that you can add variables to the filter process.
- The Start Over button ( ) removes all the filter columns.
When you click in a variable box, it highlights. Right-click in a variable box (not on a value) to see the context menu, illustrated on the middle example of Figure 3.63. The menu command affects only the highlighted variable.

Nominal and ordinal variables have these commands:

- **Delete**: removes the variable from the Data Filter control panel.
- **Use List Display**: lists the values, as shown on the right in Figure 3.63. This kind of display is especially useful if a variable has many values, making it hard to see in the bar format.
- **Order by Count**: orders the variable values by frequency of occurrence whether the variable is shown as a bar of values or in list form.
- **Clear Selection**: clears any selection in effect for that variable only.
- **Invert Selection**: deselects any selected values, and selects all previously unselected values, for that variable only.

The context menu for continuous variables has the **Delete**, **Clear Selection**, and **Invert Selection** commands.

**Note:** You can select additional variables at any time in the Add Filter Columns list to use as filter columns. To remove a filter variable, click in the box that displays its values and press the Delete key on your keyboard, or right click and select **Delete** from the menu that appears. If the Add Filter Columns list is not open and you want to add more variables, click the large plus button () to open it.

For nominal or ordinal variables, the category labels show by default, However, you can right-click in any value and change the color of the categories as they display in the data filter control panel, or select the cell labelling information that shows for each level. Figure 3.63 illustrates changing the values in the age categories to be counts instead of age group level.
Adding Additional Groups of Variables to the Control Panel

You can form complex logical subsets by expanding the Data Filter control panel to include multiple groups of variables. If you press the Shift key when adding groups of variables, the selections you make in each group are selected with a logical OR. For example, the first control panel in Figure 3.65 shows the age and sex variables. To add age again as an OR variable,

- click the large plus (++) to reshow the Add Filter columns list
- highlight the age variable
- press the Shift key and click Add.

The age variable shows a second time in the control panel, with OR separating the two groups of variables. This example now selects of 12 year old males or 14 year old students of either sex.

The next sections describe control panel check box modes (Select, Show, and Include) and menu options on the Data Filter title bar.
Check Box Modes

The Data Filter control panel has three check boxes, Select, Show, and Include. When you first use the Data Filter, the Select box is checked by default. The data filter operates without any check boxes in effect, or you can use any combination of check box modes:

Select  The Select mode highlights the rows (observations) in the data table that correspond to the selection criteria you specify, as illustrated in Figure 3.66. The data selections are highlighted until you remove the checkmark from the Select checkbox.

Show  the Show mode shows the rows you identified using the data filter in plots and charts. All other rows have the hidden row state characteristic assigned to them. The hidden row state icon (mask) appears for those rows in the data table. All points are included in the computations, analyses, and in reports, but only points that are not hidden show in most plots and graphs.

Include  The Include mode Includes rows you identified using the data filter in statistical analysis. All other rows have the excluded row state assigned to them. The excluded row state icon appears next to the row number in the data table for these rows. Excluded rows are excluded from the computations, analyses, and reports.

Showing, hiding, including or excluding data are row state properties, and are discussed in detail in the “Properties & Characteristics of Data” chapter.

The options in the Data Filter window are active even if no check boxes are in effect. However, you must check at least one box to make your filter selections visible in the data table and in plots and charts.

Using Nominal or Ordinal Variables as Filter Columns

The example in Figure 3.66 reflects the Big Class.jmp data table from the Sample data library. When you select age, sex, and weight in the Data Filter window as filter variables and click Add, the window changes, as shown on the left in Figure 3.66. The values of the filter variable are discrete rectangles for nominal and ordinal variables, and are displayed as a range bar for continuous variable. To see the results in Figure 3.66:

1. With the Big Class,jmp data table open, choose Rows > Data Filter.
2. When the initial Data filter window appears, select age, sex, and weight in the Select Filter Column list. To select multiple variables, control-click (Windows and Linux) or command-click (Macintosh) age and sex and weight.
3. Click Add on the Data Filter window to see the variable values in the Data Filter window.
4. Click on the values in the Data Filter window to identify the rows you want the Data Filter to use. In this example, the Select box is checked, so the rows are selected in the data table. In Figure 3.66, 12 and 14 year old females are selected. To select contiguous values, Ctrl-click (Windows and Linux) or Cmd-click (Macintosh) the values you want to use.

Notice that you can select any values in any of the character variables you chose to use in the Data Filter (or any of the numeric values, as well).

- To make a contiguous selection of character values of a single variable, Shift-click the values.
To make a discontiguous selection of a single variable, Ctrl-click (Windows/Linux) or Cmd-click (Macintosh) each value you want.

To continue selecting contiguous values of the same variable or another variable, shift click values.

To continue selecting discontiguous values of another character variable, Ctrl-click (Windows/Linux) or Cmd-click (Macintosh) each value.

**Note:** Clicking in a continuous variable bar does not deselect the character values you have in effect. Selecting continuous values is covered in the next section.

**Figure 3.66** Select Columns as Data Filters

---

**Selecting Continuous Values as Filters**

The continuous variable, *weight*, shows with a slider that spans the range of weight values (Figure 3.66). There are several ways to identify filter values for a continuous variable.

- Drag across the slider bar. You can drag from either end of the slider bar. The selected *weight* values are shown above the slider bar.

- Click anywhere in the empty (unselected) part of the slider to set the filter range at that point.

- You can also edit the values of *weight* in the text above the slider bar. Click in the value area to create a text box and enter the value you want, as shown to the right.

By default, the range of values includes the endpoints (55 ≤ height ≤ 70). Optionally, you can change the sign of the inclusion statement above the bar to exclude either or both of the endpoints. To do this, shift click on either sign in the inclusion statement, as shown here. Note that the inclusion statement now reads 55 ≤ height < 70, (excluding the 70 end-point).
The selection of a numeric range is persistent in that you can click anywhere else (a character value or another number bar) and the numeric selection is not affected. You must click within a numeric bar to change its selection.

**Changing the Data Table After Making Data Filter Selections**

If you have identified a subset with the Data Filter and subsequently alter row states in the data table or select points in graph or plot, the selections in the Data Filter might not reflect the row state status of the data table. The data table and the Data Filter are then ‘out of sync.’ The Data Filter responds with a warning message and has an additional button as shown in Figure 3.67. The message warns you that “Your selection was changed in another window.” When you click the **Reset Selection** button, the data table selections change and again reflect the selections in the Data Filter; the button no longer appears on the Data Filter panel.

**Figure 3.67 Data Filter and Data Table Selections Are Different**

**Data Filter Menu Commands**

The red triangle menu on the Data Filter title bar has special purpose commands for the Data Filter, as shown to the right.

**Animation**

The animation feature given by the Data Filter causes a sequential highlighting of the values of a single variable. For example, if you have the Data Filter shown in Figure 3.68, then you can cause animation of the values of *age*, *sex*, or *height* to occur. The individual values highlight in the data table, but patterns are more interesting if you first create a plot and then invoke the animation of a variable using the Data Filter to see how it behaves on the plot.
To use the animation feature, select **Animation** from the Data Filter menu to display the Animation control panel. Then click the first button on the Animation Control Panel to start the animation. When you start the animation feature, the values of the first variable in the Data Filter are alternately highlighted. The highlighted frame around the variable tells you which variable is selected for animation. To animate a different variable, click in the variable box you want. The animation cycles through the values of either character or numeric variables.

The Animation Control panel (Figure 3.68) has these controls:

- The middle button ( ) starts and stops the animation. After you start the animation cycles, the button changes to a stop button ( ). By default the animation begins with first value of the topmost variable.
- The backward arrow ( ) moves the animation backward one cycle. Click more than once to go backward more than one cycle. Then click the start button.
- The forward arrow ( ) moves the animation forward one cycle. Click more than once to go forward more than one cycle. Then click the start button.
- The square button ( ) hides the Animation Control section on the Data Filter Window. Select **Animate** from the menu on the Data Filter title bar again to see the Animation Control.

The Animate mode drop-down menu has these options.

- **Forward** highlight values forward from first to last.
- **Backward** highlight values from last to first.
- **Bounce** highlight forward and then backward repeatedly.

To adjust the speed of the animation, click in speed bar to the left (slower) or right (faster).

**Make Subset**

The **Make Subset** command performs similarly to **Tables > Subset**, but does not offer a dialog with subsetting options. When you choose **Make Subset**, JMP creates a new table with the
selected columns in the active data table and the rows identified by the Data Filter. This is true even if you have manually selected additional rows or columns in the data table.

**Script**

The **Script** command performs the same as in other platforms. You can save the script, called **Data Filter**, to the data table, to a script window, to a journal, or copy it to the clipboard. The script opens the Data Filter window and lists all the variables you specified. This is particularly valuable for saving specifications of a complex subset of data. When you run the script, the Data Filter appears with the variables you selected with the selections you made.

**Save Where Clause**

Once you have identified the filter variable values to use, that information can be expressed as a JMP **Where** clause. The **Where** clause is used in JSL (JMP Scripting Language) programs to identify specific rows of data for processing or analysis. The Data Filter builds a **Where** clause based on the value selections you make. Figure 3.69 shows the options available in the Data Filter for saving a **Where** clause and the **Where** clause that describes the values shown.

- **Clipboard** creates a **Where** clause from the filter criteria and puts it on the clipboard.
- **Row State Column** creates a row state column in the data table that has a formula equivalent to the filter criteria.
- **Data Table** creates a **Where** clause from the filter criteria and saves it as a JSL command with the current data table in a table property called **Filter**.
- **Script Window** creates a **Where** clause from the filter criteria and appends it to the current script text window, or creates a new script if one doesn’t already exist.
- **Journal** creates the **Where** clause from the filter criteria and appends it to the current journal, or creates a new journal if one doesn’t already exist.

**Figure 3.69** Save Where Clause
How To Save Tables, Reports & Sessions

Different Saving Methods

There are several different ways to save your analyses in JMP. The way you choose should depend on if and how you want to interact with your analyses in the future.

This chapter describes the ways you can save data tables and reports in JMP.
Contents

Saving Data Tables ................................................................. 107
  Saving .jmp Files for use in JMP 5.1.2 or Earlier .......................... 107
  Saving as a Text File .......................................................... 108
  Saving as a SAS Transport File ............................................. 109
  Saving as a SAS Dataset (Windows Only) .................................. 110
  Saving as a Microsoft Excel File (Windows and Macintosh Only) ...... 110
  Saving Data Tables to a Database ........................................... 111
Saving Reports ........................................................................... 112
  Saving Using the Journal Command .......................................... 113
  Saving Using the Layout Command .......................................... 116
  Saving Parts of a Report in a Graphic Format ............................ 119
Pasting Reports into Another Program ........................................ 120
Saving JMP Sessions ................................................................... 120
  Saving Sessions Upon Exiting .................................................. 120
  Saving Sessions Manually ...................................................... 121
Working with JMP Projects (Windows Only) .................................. 122
  Creating a JMP Project .......................................................... 122
  Saving and Closing a JMP Project ............................................ 123
  Adding Items to a JMP Project ................................................ 124
  Customizing the Project ........................................................ 125
Saving a Log Window .................................................................. 126
Specifying Where to Save Files (Windows Only) ............................. 126
## Saving Data Tables

JMP saves data tables in the formats listed below.

To save data tables:

- On Windows and Linux, select **File > Save As** to save in multiple formats.
- On the Macintosh, select **File > Save As** to save as a JMP file (.jmp) and **File > Export** to save in Text (.dat), Microsoft Excel (.xls), and SAS Transport (.xpt) formats.

In addition to these file types, JMP can save files for types that have a corresponding ODBC driver. See “Saving Data Tables to a Database,” p. 111, for details.

### Table 4.1 File Types and Extensions

<table>
<thead>
<tr>
<th>File Type(s)</th>
<th>Extension</th>
<th>OS Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>JMP Data Table</td>
<td>.jmp</td>
<td>All</td>
</tr>
<tr>
<td>SAS Transport File</td>
<td>.xpt</td>
<td>All</td>
</tr>
<tr>
<td>Excel File</td>
<td>.xls</td>
<td>Windows and Macintosh</td>
</tr>
<tr>
<td>Text File</td>
<td>.txt</td>
<td>Windows and Linux</td>
</tr>
<tr>
<td>SAS Version 7 Dataset</td>
<td>.sas7bdat</td>
<td>Windows</td>
</tr>
<tr>
<td>MS Access Database, CBA_EH_DB, CBA_TL_DB</td>
<td>.mdb</td>
<td>Windows</td>
</tr>
<tr>
<td>dBASE File</td>
<td>.dbf, .ndx, .mdx</td>
<td>Windows</td>
</tr>
<tr>
<td>Text File</td>
<td>.dat</td>
<td>Macintosh</td>
</tr>
<tr>
<td>JMP Report</td>
<td>.jrp</td>
<td>Linux</td>
</tr>
<tr>
<td>JMP Journal</td>
<td>.jrl</td>
<td>Linux</td>
</tr>
<tr>
<td>OpenOffice Spreadsheet</td>
<td>.sxc</td>
<td>Linux</td>
</tr>
</tbody>
</table>

The maximum length of the data table’s name depends on your computer’s operating system.

## Saving .jmp Files for use in JMP 5.1.2 or Earlier

JMP 7 uses the Unicode character set, which supports special characters such as é and ½. You can save data tables (.jmp) from JMP so that they can be opened in older applications that do not support Unicode (such as JMP 5.1.2 and earlier). This works if all of the data table’s character data is convertible to a legacy character set that the application can read.

There are two ways to do this

- One way is to use options in the Save As dialog. In Windows, place a check in the **Use JMP V5 Format (No Unicode)** checkbox that appears when you select **File > Save As**. For Macintosh, the checkbox is **JMP 5 Compatible (without Unicode text)**. For Linux, the checkbox is **Save Files in JMP v5.x Format**. The file is then saved without Unicode text.
- Another way to save tables so they can be opened by earlier versions of JMP is to disable the Unicode feature in JMP 7 using preferences:
  1. Select **File > Preferences** (Windows/Linux) or **JMP > Preferences** (Macintosh).
  2. Click the **General** category.
3. Uncheck the box beside *Save Text Files as Unicode*. Your text files will now be saved as plain (legacy) text.

**Saving as a Text File**

JMP can convert data from a JMP data table to standard text format with rows and columns.

To save a data table as a text file, follow the steps in the table below based on the operating system you are using and how you want to save the file.

**Table 4.2 Saving a Data Table as a Text File**

<table>
<thead>
<tr>
<th>Saving as a Text File</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Windows</strong></td>
</tr>
<tr>
<td>1 Select File &gt; Save As.</td>
</tr>
<tr>
<td>2 Type a name for the file in the File name box.</td>
</tr>
<tr>
<td>3 Select Text Export Files (*.TXT) from the Save as type drop-down menu.</td>
</tr>
<tr>
<td>4 Click the Options button and specify end-of-line and end-of-field characters and detail the exportation of column names. If you want to save the file with no delimiters, select None in the End of Field box. See Figure 4.1 for details.</td>
</tr>
<tr>
<td>5 Click OK.</td>
</tr>
<tr>
<td>6 Click Save.</td>
</tr>
<tr>
<td><strong>Macintosh</strong></td>
</tr>
<tr>
<td>1 Select File &gt; Export.</td>
</tr>
<tr>
<td>2 From the window that appears, select Text and click Next.</td>
</tr>
<tr>
<td>3 Type a name for the file in the Save As box.</td>
</tr>
<tr>
<td>4 Click Export.</td>
</tr>
<tr>
<td><strong>Linux</strong></td>
</tr>
<tr>
<td>1 Select File &gt; Save As.</td>
</tr>
<tr>
<td>2 From the Save as type field, select *.txt (Delimited Text).</td>
</tr>
<tr>
<td>3 Type a name for the file in the File Name box.</td>
</tr>
<tr>
<td>4 Click Next.</td>
</tr>
<tr>
<td>5 Specify end-of-line and end-of-field characters and detail the exportation of column names. See Figure 4.1 for details.</td>
</tr>
<tr>
<td>6 Click Finish.</td>
</tr>
</tbody>
</table>
**Saving as a SAS Transport File**

You can save a JMP data table in SAS transport file format or append a data table to an existing SAS Transport document.

**Using Windows and Linux**

1. Select File > Save As.
2. Type a name for your file in the **File Name** box. Note that the maximum length of a data table name depends on the operating system you are using.
3. Select the .xpt file extension (SAS Transport Files) from the **Save as type** drop-down menu.

To append the data table to an existing SAS transport library, click the box next to **Append To**, and highlight the file to which you want to append.

4. Click **Save**.

---

**Note:** If double-quotes are encountered when importing text data, the delimiter rules change and JMP looks for an end double-quote. Other text delimiters, including spaces embedded within the quotes, are ignored and treated as part of the text string.
Using Macintosh
1. Select File > Export.
2. To create a new SAS transport file, select SAS Transport.
3. Click Next.
4. Type a name for the file in the Save As box. Note that the maximum length of a data table name depends on the operating system you are using.
5. Click Export.
6. To append the data table to an existing SAS transport library, select SAS Transport and check the box beside Append.
7. Click Next.
8. Highlight the file to which you want to append.
9. Click Append.

Saving as a SAS Dataset (Windows Only)
On Windows, JMP can save data tables as SAS version 6 and higher datasets. It writes columns as SAS variables and writes rows as SAS observations. It saves them in a format that SAS recognizes.

To save a data table as a dataset:
1. Select File > Save As.
2. Type a name for your file in the File Name box. Note that the maximum length of a data table name depends on the operating system you are using.
3. Select SAS V7 Dataset from the Save as type drop-down menu.
4. (Optional) If you want to save the file using SAS version 6 format (.sd2), click the box next to Use SAS V6 Format (.sd2). If you’re using SAS version 7 or higher, don’t click this.
5. Click Save.

Note: When you are exporting data to a SAS file, JMP date columns become SAS date values with the appropriate SAS format.

Saving as a Microsoft Excel File (Windows and Macintosh Only)
You can save a JMP data table in Microsoft Excel workbook format.

Using Windows
1. Select File > Save As.
2. Type a name for your file in the File Name box. Note that the maximum length of a data table name depends on the operating system you are using.
3. Select the .xls file extension (Excel Files) from the Save as type drop-down menu.

Using Macintosh
1. Select File > Export.
2 Select Excel.
3 Click Next.
4 Type a name for the file in the Save As box. Note that the maximum length of a data table name depends on the operating system you are using.
5 Click Export.

Saving Data Tables to a Database

You can save a data table to any database on your system that has a compliant ODBC (Open Database Connectivity) driver:
1 Select File > Database > Save Table. Figure 4.2 shows the window initially displayed.

Figure 4.2 The Database Save Table Window

2 In the Connections box, highlight the name of the database to which you want to save the file. The Connections box contains a list of databases to which your system is connected (Figure 4.3). If you are not connected to the needed database, create it by using another application, or:
   a. Click Connect.
   b. Select the data source you want and click OK. Or, to create a new source, click the New button (Windows and Linux) or Add button (Macintosh). Depending on which data source you select (and which database drivers you have installed on your computer), you may be presented with a variety of windows. Use them to create the database source.
   c. Select the database to which you want to save the file.
3 Click the drop-down menu beside JMP data table to be saved, as shown in Figure 4.3, and select which open JMP data table you want to save to the database.
4 In the box beside **Save to database table**, type the name you want the table to have when you save it in the database.

5 Click **Save Table**.

---

**Saving Reports**

JMP saves reports in the formats listed in the table below.

To save reports:

- On Windows and Linux, select **File > Save As** to save in multiple formats.
- On the Macintosh, select **File > Save As** to save as a JMP report (.jrp) and **File > Export** to save in Text (.txt), HTML (.html), and Rich Text (.rtf) formats.

**Table 4.3 Report File Types and Extensions**

<table>
<thead>
<tr>
<th>File Type</th>
<th>Extension</th>
<th>Description</th>
<th>OS Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>JMP Report</td>
<td>.jrp</td>
<td>Analysis report originally created in JMP. It can be reopened for continued analysis.</td>
<td>All</td>
</tr>
<tr>
<td>Hypertext Markup</td>
<td>.htm, .html</td>
<td>World Wide Web format; marked up text that refers to separate picture files.</td>
<td>All</td>
</tr>
<tr>
<td>Language</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rich Text Format</td>
<td>.rtf</td>
<td>Word processing format; mixture of pictures, text, and tables.</td>
<td>All</td>
</tr>
<tr>
<td>JMP Journal</td>
<td>.jrn</td>
<td>Analysis report duplicated in a separate window titled Journal. You can edit it or append other reports to it. Note that on Macintosh and Linux, select <strong>Edit &gt; Journal</strong>, then <strong>File &gt; Save</strong>. On Windows, choose <strong>File &gt; Save</strong> and choose the journal format.</td>
<td>All</td>
</tr>
<tr>
<td>Text Format</td>
<td>.txt</td>
<td>Plain text format; no pictures.</td>
<td>Windows and Macintosh</td>
</tr>
<tr>
<td>Portable Network</td>
<td>.png</td>
<td>Compressed bitmap pictures; successor to GIF.</td>
<td>Windows</td>
</tr>
<tr>
<td>Graphics</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Saving Using the Journal Command

You can save a report for future editing by journaling a report window. The window is duplicated in a separate window titled Journal, and you can edit it or append other reports to it.

Using Windows or Linux

To create a journal and save it:

1. Select **Edit > Journal**. The report window is duplicated in a separate window titled Journal.

Table 4.3 Report File Types and Extensions

<table>
<thead>
<tr>
<th>File Type</th>
<th>Extension</th>
<th>Description</th>
<th>OS Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>Joint Photographs Expert Group</td>
<td>.jpg</td>
<td>Compressed bitmap pictures; standard for photographs.</td>
<td>Windows</td>
</tr>
<tr>
<td>Scalable Vector Graphic</td>
<td>.svg</td>
<td>Pictures stored as text; best used for two-dimensional graphics.</td>
<td>Windows</td>
</tr>
<tr>
<td>Windows Metafile</td>
<td>.wmf</td>
<td>Pictures stored as commands; resolution independent.</td>
<td>Windows</td>
</tr>
<tr>
<td>Plain Text</td>
<td>.txt</td>
<td>Plain text format; no pictures.</td>
<td>Windows</td>
</tr>
<tr>
<td>Microsoft Word</td>
<td>.doc</td>
<td>Word processing format; mixture of pictures, text, and tables.</td>
<td>Windows (You must have Microsoft Word 2000 or later installed.)</td>
</tr>
</tbody>
</table>

**Note:** When saving as .html or .rtf in Windows and Linux, there are options at the bottom of the window (Windows) and after clicking the Next button (Linux) that let you select a graphics file format. Select the format you want JMP to save graphics in within the .html or .rtf file.
2. Select **File > Save As**.

3. Save it in .jrn format, as shown in Figure 4.4. You can also add elements to the journal. See “Appending Reports to a Journal,” p. 115, and “Customizing JMP Journals,” p. 116, for details.
Chapter 4

How To Save Tables, Reports & Sessions

Saving Reports

Figure 4.4  Save the JMP Journal As One of Many File Types

Alternately, you can use the File > Save As command on Windows to save a report as a journal without creating a separate Journal window.

Using Macintosh

To export a journal to Text (.txt), HTML (.html), and Rich Text (.rtf) formats:
1. Select File > Export.
2. From the window that appears, select the appropriate radio button (Text, HTML, or Rich Text).
3. Click Next.
4. Type a name for the file in the Save As box.
5. Click Export.

Appending Reports to a Journal

To append other reports to a report you journaled, select Edit > Journal again. If an area of an analysis window is selected, Edit > Journal saves only the selected area instead of the entire window. See “Customizing JMP Journals,” p. 116, for details.

When manipulating the report, remember that:

- The journal window is as functional as the report window: you can click icons, click and drag, and right-click to access menus.
- When a report is journaled, the journaled copy is no longer connected to the data table.

To insert a page break for printing purposes, right-click the disclosure button ( on Windows/Linux and on the Macintosh) in the journal window and select Edit > Page Break.
Note: If you create a journal file for one report (or data table) then open another report and journal it, the second report will be added to the end of the first report in the journal. To create separate journals for separate reports, save and close the first journal before creating the second. Or, place separate reports in separate layout windows by using the Layout command, as described in “Saving Using the Layout Command,” p. 116.

To save only a selected area of a report or data table to a journal:

1. Click the selection tool ( ).
2. Click and drag to select items in a report or data table, or Shift-click to select discontinuous items.
3. Select Edit > Journal. Or, if you already have a journal window open, click and drag the selected item from the report into the journal window.
4. Select File > Save As.

Customizing JMP Journals

The reports in the journal window look like the live analysis, but they are disconnected from the data, and analysis commands are no longer available. However, you can still customize the appearance of the journal just as you would do with a live analysis. When a JMP journal is open, you can:

- Print the contents of the journal window by selecting File > Print.
- Add notes to the end of the journal by double-clicking the open area at the bottom.
- Add file references, hyperlinks, and more. See “Importing Data,” p. 13, for details.
- Click the disclosure buttons (  on Windows/Linux and  on the Macintosh) to open and close report outline levels.
- Resize plots and graphs (see “Resizing Plots and Graphs,” p. 194).
- Select and move any element of the report by copying and pasting or dragging and dropping.
- Right-click (Ctrl-click on the Macintosh) plots and graphs and assign markers, change marker size, change background color, and more.
- Tailor plot axes with the Axis Specification window (see “Customizing Axes and Axis Labels,” p. 199) or by dragging them.
- Select and delete any report element.
- Use the annotate tool ( ) and other draw tools (see “Adding Elements to a Report,” p. 210).
- Copy or drag individual graphs and text reports from a JMP analysis window and paste or drop them in a journal window.
- Copy or drag text and pictures from other applications and paste or drop them in a graph or at the end of a journal window (see “Adding Graphics (Windows and Macintosh Only),” p. 215).
- Rerun an analysis from the journal window by clicking the red triangle icon and selecting Rerun in new window.

Saving Using the Layout Command

You can edit or manipulate the report before you save, allowing you to combine several reports into one or rearrange the report elements. You do this by selecting Edit > Layout. Using this command is differ-
ent from using the **Edit > Journal** command because the Layout command provides additional options that let you ungroup parts of a report and restructure it to best fit your needs.

**To create a layout:**

1. Select **Edit > Layout**. The report window is duplicated in a separate window titled Layout.

   ![Report window](image1)
   ![Layout window](image2)

2. The **Layout** menu now becomes visible. It is located between the **Edit** menu and the **Tables** menu (between the **View** menu and **Tables** menu on Linux) in the main menu bar, as shown in Figure 4.5. Items in the Layout menu are only available when you have selected an item using the arrow tool. See “The Layout Menu,” p. 429, for details.
3 Click inside the layout window. The entire report becomes highlighted.

4 Select Layout > Ungroup, or right-click (Ctrl-click on the Macintosh) inside the report and select Ungroup. This performs the first stage of ungrouping report elements, which ungroups (or disconnects) the topmost title bar from its reports and subreports. Each time you ungroup a report outline level title from its reports, the disclosure button (on Windows/Linux and on the Macintosh) for that level disappears and you can no longer close it. However, you can do many of the surface operations available, use the context menu in plots, tailor axes, rerun the analysis in a new window, edit scripts, etc.

5 Select Layout > Ungroup again to ungroup the next level of the report outline. Note that only selected items are ungrouped.

6 Continue to select specific report elements (or all elements) and ungroup them until each title and each piece of a report or plot is an object.

Note: You can ungroup a report from its title bar and ungroup all its major pieces, but you cannot ungroup a column in a report table from its column header.

7 Click an object to select it and move it anywhere in the layout window. The layout window has as many pages as you want, outlined with gray boundary lines.

8 Select File > Save As. JMP saves the file as a journal file (.jrn).

Use the table below to take further actions in a layout window.

Table 4.4 Working in a Layout Window

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit a title bar</td>
<td>Double-click the title bar or report table column header.</td>
</tr>
<tr>
<td>Quickly ungroup a layout to its</td>
<td>Repeatedly press Ctrl-U (Command-U on the Macintosh).</td>
</tr>
<tr>
<td>smallest objects</td>
<td></td>
</tr>
<tr>
<td>Rerun the report in a new window</td>
<td>Click the red triangle icon on the title bar and select Rerun in new window from the menu.</td>
</tr>
<tr>
<td>Edit a script</td>
<td>Click the red triangle icon on the title bar and select Edit Script from the menu.</td>
</tr>
<tr>
<td>Access Layout menu items (on the</td>
<td>Select the arrow cursor.</td>
</tr>
<tr>
<td>main menu bar)</td>
<td></td>
</tr>
<tr>
<td>Insert a page break</td>
<td>Right-click a disclosure button ( on Windows/Linux and on the Macintosh) on the title bar and select Display Box &gt; Page Break.</td>
</tr>
</tbody>
</table>
4 Saving Files

Chapter 4 How To Save Tables, Reports & Sessions

Saving Reports

The example in Figure 4.6 shows results extracted, combined, and organized in a compact form from a bivariate analysis (scatterplot and polynomial fit), a distribution analysis (histogram and frequency count), and a one-way analysis (means and t-test). The result gives a neat-looking summary of oxygen uptake as a function of run time in an exercise experiment. This was done by forming a layout window for one analysis, then dragging the other desired analysis elements into the layout window, arranging the desired pieces, and deleting unwanted elements.

Figure 4.6 Multiple Analysis Results in a Layout Window

Table 4.4 Working in a Layout Window

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select and deselect items</td>
<td>Right-click a disclosure button ( on Windows/Linux and ▲ ▼ on the Macintosh) on the title bar and select Display Box &gt; Select or Display Box &gt; Deselect.</td>
</tr>
</tbody>
</table>

Saving Parts of a Report in a Graphic Format

You can save part of an analysis report window as a graphic. Although you will not be able to manipulate or customize the report before saving it, you can quickly save highlighted selections. On Windows, you can save the selection in .png, .jpg, .wmf, and .svg formats. On the Macintosh, you can save the selection in .png format.

To save a selection:
1. Click the selection tool ( ).
2. Highlight the area you want to save.
3. Select Edit > Save Selection As (Windows/Linux) or press the Command key and select File > Export (Macintosh).

Select the graphics file format to which you want to save the selection.

Note: Right-click the selection and choose Copy, then paste the selection into another part of JMP or another software program (see “Pasting Reports into Another Program,” p. 120).
Pasting Reports into Another Program

When you need JMP reports or data tables for use in another program, you can save the reports or tables by copying and pasting or dragging and dropping parts of it into another program, such as Microsoft Word or PowerPoint. Then save the document in that application. Note that on Linux, you can copy and paste or drag and drop text but not graphics.

1. Click the selection tool ( ).
2. Click and drag (or Shift-click) to select items in a report window or data table. Clicking near the edge of the report window selects the entire report.
3. Click the selected items and drag them from JMP to the other program. Or, copy the selected items in JMP and paste them into the other program. When you paste an element into another application, the format used depends on the application into which you paste. If the application has a Paste Special command and you utilize it, you can select a format to use, such as text (.rtf), unformatted text (.txt), picture or Windows metafile (.wmf), bitmap (.bmp), or enhanced picture (.emf).

**Note:** To copy all text (no graphs) from the active report window as unformatted text, select **Edit > Copy As Text**. On the Macintosh, press the Shift key and select **Edit > Copy As Text**. To copy only the graph (no text), right-click the graph and select **Edit > Copy Picture**.

Saving JMP Sessions

Each time you use JMP, it is called a session. A saved session is a JSL script that will re-open documents and re-run analyses to restore JMP to the state it was in when the saved session script was created. A saved session can help get you back to a previous state without having to manually re-open files and re-run analyses.

If you are an advanced user, it is important to understand what session information is preserved in a saved session. Any documents (such as data tables, scripts, and journals) that have been saved will be re-opened, and any windows that support script saving will be re-run (equivalent to clicking the red triangle in a report and selecting **Script > Redo Analysis**). Side effects of running scripts, such as global variable values or custom windows, will not be saved, and the state of highly interactive analyses will not be saved.

Saving Sessions Upon Exiting

The most common use of saved sessions is to save the state when JMP exits so it can be restored when JMP restarts. By default, JMP asks if you would like to save the state of your session each time you exit the program (Figure 4.7). If saved files are open when you exit, when you return to JMP it will reopen all saved documents you left open and rerun any analyses you left open. This allows you to quit JMP, then return to it later without having to open the files with which you were previously working.
Figure 4.7  Saving Session Upon Exiting

To always save the session upon exiting, or to never save the session upon exiting, check the box beside **Don’t ask me again about saving the session** and click **Yes** or **No**. You can also later change this option in JMP’s preferences:

1. Choose **File > Preferences**.
2. Select the **Reports** icon.
3. Next to the **Save the Session When Exiting** option, choose to always save the session, never save the session, or have JMP ask if you would like to save upon exiting.

**Saving Sessions Manually**

You can also save a session to a location of your choosing and continue working, so you can restore the saved state whenever you like. Manually saving sessions is useful when you want more control of session saving and restoring, especially when you want to maintain multiple independent session states, each with a different sets of files and analyses.

To manually save sessions, create a JSL script to re-open all currently open files and re-run all currently open analyses and graphs. This allows you to quit JMP, then return to it later without having to open the files with which you were previously working. It also allows you to create different JMP sessions without having to first exit JMP.

To create scripts of JMP sessions:

1. Select **File > Save Session Script**.
2. Type the name of your script into the dialog and click **Save**.

Another way of manually saving a session is by creating a journal of each session (see “**Saving Using the Journal Command**,” p. 113, and “**Importing Data**,” p. 13). A journal can be a notebook-style or project-style file. With it, you can collect references to files in a project, develop presentation launch pads, document projects, and store many scripts in one place.

Journals allow you to store data tables and reports from a session, and then open it and its contents on demand. You can also have more than one journaled session file open at the time.

To create a journal file that contains a JMP session:

1. Open the files you would like to include in the journal.
2. Select **File > New > Journal**. Or, to append your open files to an existing journal, open that journal.
3. Right-click in the empty journal and select **Add All Open Files**.
Working with JMP Projects (Windows Only)

A JMP Project is useful when you want to save multiple JMP file types (data tables, reports, scripts, or other JMP-supported formats) into a single file. This single JMP project file contains everything needed to re-open all the included files. This is its major difference from saved session scripts. The scripts save JMP’s state, while the projects save the state along with the files.

Creating a JMP Project

To create a JMP project, choose File > New > Project. The Project window appears on the left side of the JMP application window.
Saving and Closing a JMP Project

To save or close a JMP project, use the standard File menu or toolbar. In addition, you can use the Project menu, accessible by right-clicking the project name. (Figure 4.10).

When you save the project, links to the items in the project are saved rather than the items themselves. However, if the Archive all files and folders when project is saved command from the Project menu is checked, then a copy of each item is copied into the project archive. From this point on, if you open the project and modify an item, you are modifying the archived copy rather than the originals.
Adding Items to a JMP Project

You can add either saved or open files to a JMP project. If a file has not already been saved, you are be prompted to save it once you add it to the project.

Using the Project Menu

To add items using the Project menu, right-click on the Project name and select the desired command.

- **Add Folder** adds a new folder to the project.
- **Add Document** adds a JMP document to the project. After selecting this item, you are presented with the standard File Open dialog, which is used to select a document to add.
- **Add Database Query** opens the JMP database query Window, where you can create or open a query to a database. This query is then added to the project. See “Opening Data from a Database,” p. 25, “Retrieving Data Using SQL Statements,” p. 27, and “Using the WHERE Clause Editor,” p. 32 for detailed information on creating queries.
- **Add URL** opens the Internet Open dialog, where you can specify a URL to add to the project. See “Opening a File Using the Internet,” p. 34 for details on the Internet Open dialog.
- **Add Window** lets you add an open JMP document to the project. If the file has not already been saved, you are prompted to do so before it is added to the project.

Using Drag-And-Drop

Items can also be added to a project using drag and drop from the Window list, the File System list, or from Microsoft Outlook.
To use the Window list, open it by selecting View > Window List. The window list appears as shown in Figure 4.11.

**Figure 4.11** JMP Window List

Similarly, you can drag and drop documents and folders from the File System list into your project. First, select View > File System List if it is not showing. This gives you a view of connected storage systems. From this list, you can open files by double-clicking or drag the files into an open project.

**Tip:** In addition to files and folders, entire volumes can be added to JMP projects. In addition, emails can be directly dragged into an open JMP project.

**Customizing the Project**

JMP has several commands that let you organize and customize your project.

**Groups**

JMP projects support hierarchical groups. Groups are useful for organizing your project files. To add a new group, select New Group from the Project menu (shown in Figure 4.10).

**Notes**

JMP allows you to add descriptive notes about a project. Select the Edit Notes command from the Project menu to add or edit a project’s notes.
Saving a Log Window

Selecting View > Log displays a pane at the bottom of the JMP window that monitors JMP activities. You can use the log to locate errors in a script, correct JSL code, or retrieve requested information.

You may encounter instances where running a formula, matrix, or another operation writes information of interest to the log window. To save the contents of the log window:

1. Detach the log window from the bottom of the screen by right-clicking it and selecting Float Log Window.
2. Select File > Save As.

Specifying Where to Save Files (Windows Only)

You can specify a default location for saving JMP data tables, journals, and graphic selections. To specify where to save these files:

1. Select File > Preferences and click the File Locations icon. Figure 4.12 appears.

   ![Figure 4.12 Specifying Where to Save Files](image)

2. Highlight Save As directory for Data/Journals and click Browse.
3. Navigate into a directory where the file should be stored and click Select.
4. To have JMP use the specified directory every time you select File > Save or File > Save As, check the box beside Always go to this directory when Data/Journal Save As is displayed.
Beyond the basics of formatting data is customizing your rows and columns to suit your analysis. You can exclude, hide, label, color, mark, or lock rows or columns. Doing so customizes the appearance of points in scatterplots and graphs.
## Contents

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assigning Characteristics to Rows and Columns</td>
<td>129</td>
</tr>
<tr>
<td>Excluding Rows and Columns</td>
<td>129</td>
</tr>
<tr>
<td>Hiding Rows and Columns</td>
<td>131</td>
</tr>
<tr>
<td>Labeling Rows and Columns</td>
<td>132</td>
</tr>
<tr>
<td>Giving Rows a Color</td>
<td>134</td>
</tr>
<tr>
<td>Adding Markers to Rows</td>
<td>135</td>
</tr>
<tr>
<td>Assigning Colors or Markers to Rows According to Column Values</td>
<td>135</td>
</tr>
<tr>
<td>Deleting All Row Characteristics</td>
<td>137</td>
</tr>
<tr>
<td>Locking Columns in Place</td>
<td>137</td>
</tr>
<tr>
<td>Giving Columns a Preselected Analysis Role</td>
<td>138</td>
</tr>
<tr>
<td>Iconic Indicators</td>
<td>139</td>
</tr>
<tr>
<td>Assigning Properties to Columns</td>
<td>140</td>
</tr>
<tr>
<td>Giving Columns a Formula to Compute Values</td>
<td>141</td>
</tr>
<tr>
<td>Locking Columns</td>
<td>142</td>
</tr>
<tr>
<td>Adding Notes to Columns</td>
<td>142</td>
</tr>
<tr>
<td>Validating Column Data</td>
<td>143</td>
</tr>
<tr>
<td>Using Value Labels</td>
<td>146</td>
</tr>
<tr>
<td>Ordering Values in Columns</td>
<td>147</td>
</tr>
<tr>
<td>Assigning Value Color Ranges</td>
<td>149</td>
</tr>
<tr>
<td>Changing Columns’ Default Axis Settings</td>
<td>150</td>
</tr>
<tr>
<td>Defining Low and High Values (DOE Coding) for Columns</td>
<td>152</td>
</tr>
<tr>
<td>Setting Columns as Factors for Mixture Experiments</td>
<td>153</td>
</tr>
<tr>
<td>Specifying How Rows Appear in Analysis Reports</td>
<td>153</td>
</tr>
<tr>
<td>Entering Specification, Control, and Response Limits</td>
<td>154</td>
</tr>
<tr>
<td>Giving Columns a Design Role</td>
<td>156</td>
</tr>
<tr>
<td>Identifying Factor Changes</td>
<td>157</td>
</tr>
<tr>
<td>Assigning Sigma Values to Columns</td>
<td>158</td>
</tr>
<tr>
<td>Specifying Columns’ Measuring Units</td>
<td>159</td>
</tr>
<tr>
<td>Creating Your Own Column Property</td>
<td>160</td>
</tr>
<tr>
<td>Removing Properties</td>
<td>160</td>
</tr>
<tr>
<td>Standardizing Attributes and Properties Across Columns</td>
<td>161</td>
</tr>
<tr>
<td>Using Row State Columns</td>
<td>162</td>
</tr>
</tbody>
</table>
Assigning Characteristics to Rows and Columns

You can exclude, hide, label, color, or mark rows and columns. Doing so customizes the appearance of points in scatterplots and graphs. There are 16 markers and 65 colors from which you can select. You can also lock columns so they stay in place when you scroll.

The following sections show you how to assign properties and characteristics to rows and columns.

Excluding Rows and Columns

You can mark rows and columns so they will be excluded from analyses. When you mark rows or columns so they are excluded:

- Excluded data are excluded from calculations in text reports and graphs but are not hidden in plots. To hide excluded observations in plots, you must assign them the Hide/Unhide characteristic.
- A circle with a strikethrough (🚫) appears beside either the row number or the column name in the column panel, indicating that the row or column is excluded and will not be used in analyses.
- Data remain excluded until you select Exclude/Unexclude again.

To exclude data from analyses:

1. Highlight the row(s) or column(s) you want to exclude.
2. To exclude rows, select Exclude/Unexclude from one of the following places, as shown in Figure 5.1:
   - the Rows menu in the main menu
   - the red triangle icon in the rows panel
   - the red triangle icon in the lower left corner of the data grid
To exclude *columns*, select **Exclude/Unexclude** from one of the following places, as shown in Figure 5.2:

- the **Cols** menu in the main menu
- the red triangle icon in the columns panel
- the red triangle icon in the upper right corner of the data grid
Hiding Rows and Columns

When you mark rows or columns so they are hidden:

- You suppress (hide) rows and columns so they are included in analyses but do not appear in plots and graphs.
- To exclude hidden observations from analyses, you must also assign them the **Exclude/Unexclude** characteristic.
- A mask icon ( ) appears beside the hidden row number or the column name, indicating that the row or column is hidden.
- Data remain hidden until you select **Hide/Unhide** again.

To hide data:

1. Highlight the row(s) or column(s) you want to hide.
2. To hide rows, select **Hide/Unhide** from one of the following places, as shown in Figure 5.3:
   - the **Rows** menu in the main menu
   - the red triangle icon in the rows panel
   - the red triangle icon in the lower left corner of the data grid

**Figure 5.3** Different Ways to Access Row Characteristic Commands

To hide columns, select **Hide/Unhide** from one of the following places, as shown in Figure 5.4:

- the **Cols** menu in the main menu
- the red triangle icon in the columns panel
- the red triangle icon in the upper right corner of the data grid
Labeling Rows and Columns

When you position the arrow cursor over a point in a plot, the point’s label appears. By default, the label that appears is the row number. There are two ways you can customize the label:

- You can change the label so it displays values found in one or more columns instead of the row number.
- You can enable the label to appear always, not just when you position the cursor over points.

To change the label so it displays values found in one or more columns instead of the row number:

1. Highlight the column(s) whose values you want to appear as the label in plots.
2. Select **Label/Unlabel** from one of the following places, as shown in Figure 5.5:
   - the **Cols** menu in the main menu
   - the red triangle icon in the columns panel
   - the red triangle icon in the upper right corner of the data grid
A label, or yellow tag, icon ( ) beside the column name in the columns panel indicates that points on plots will be identified by the column value. If there are multiple labeled columns, their values appear on plots separated by a comma. Data remain labeled until you highlight the column and select **Label/Unlabel** again.

To enable the label to appear always, not just when you position the cursor over points:

1. Highlight the row(s) whose label you want to always appear in plots.
2. Select **Label/Unlabel** from one of the following places, as shown in Figure 5.6:
   - the **Rows** menu in the main menu
   - the red triangle icon in the rows panel
   - the red triangle icon in the lower left corner of the data grid
Giving Rows a Color

You can assign any colors to highlighted rows so the points in plots appear in the color you select. The active color assigned to a row appears next to the row number in the data grid.

1. Highlight the row(s) you want to give a color.
2. Select **Colors** from one of the following places, as shown in Figure 5.7:
   - the **Rows** menu in the main menu
   - the red triangle icon in the rows panel
   - the red triangle icon in the lower left corner of the data grid

**Figure 5.7** Different Ways to Access Row Characteristic Commands

3. Select a color from the options that appear, as shown in Figure 5.8.

**Figure 5.8** Available Colors
Adding Markers to Rows

You can assign a character from the JMP markers palette to replace the standard points in plots. These markers also appear next to row numbers in the data table.

1. Highlight the row(s) you want to give a new marker shape.
2. Select Markers from one of the following places, as shown in Figure 5.9:
   - the Rows menu in the main menu
   - the red triangle icon in the rows panel
   - the red triangle icon in the lower left corner of the data grid

Figure 5.9 Different Ways to Access Row Characteristic Commands

3. Select a marker shape from the options that appear, as shown in Figure 5.10.

Figure 5.10 Available Marker Shapes

Assigning Colors or Markers to Rows According to Column Values

You can assign a different color or marker to each row in your data table based on the values found in a particular column. For example, JMP will give all rows whose value in the column Sex is F a red square marker and M a green plus marker. These colors and markers will replace the default black dot in plots and will appear next to its row number in the data grid.

1. Select Color or Mark by Column from one of the following places, as shown in Figure 5.11:
– the **Rows** menu on the main menu bar
– the red triangle icon in the rows panel
– the red triangle icon in the lower left corner of the data grid

**Figure 5.11** Different Ways to Access Row Characteristic Commands

2. Highlight the column to which you would like to assign the color or marker, as shown in Figure 5.12.

**Figure 5.12** Color or Mark by Column

3. Select any of the following:

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assign a different color to each row in your data table based on the values found in the column you highlighted</td>
<td>Click the box beside <strong>Set Color by Value</strong>.</td>
</tr>
</tbody>
</table>
Assigning Characteristics to Rows and Columns

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assign a different marker to each row in your data table based on the values found in the column you highlighted</td>
<td>Click the box beside Set Marker by Value.</td>
</tr>
<tr>
<td>Include a legend with your new characteristics so you can easily identify which colors and markers correspond with which row</td>
<td>Click the box beside Make Window with Legend.</td>
</tr>
<tr>
<td>Assign colors in a chromatic sequential fashion based on the values in the highlighted column</td>
<td>Click the box beside Continuous Scale.</td>
</tr>
</tbody>
</table>

Deleting All Row Characteristics

To clear all row states in the data table, highlight the row(s) and select Rows > Clear Row States. All rows become included, visible, unlabeled, and show in plots as black dots. Selecting Rows > Clear Row States does not affect row states saved in row state columns, as described in “Using Row State Columns,” p. 162.

Locking Columns in Place

You can lock a column in place so when you scroll horizontally, the column remains visible. The name of a locked column is in italics in the columns panel to the left of the data grid.

To apply a scroll lock to a column:

1. Highlight the column(s) you want to lock in place. Note that hidden columns cannot be locked.
2. Select Cols > Scroll Lock/Unlock from one of the following places, as shown in Figure 5.13:
   - the Cols menu on the main menu bar
   - the red triangle icon in the columns panel
   - the red triangle icon in the upper right corner of the data grid
Giving Columns a Preselected Analysis Role

You can assign an analysis role, such as $x$, $y$, weight, or frequency, to a selected column and save the role with the data table. When you do this and then run an analysis, JMP uses the preselected role to automatically fill in the role boxes in dialogs so you do not have to specify these roles each time. For example, if you want a column named height to take the $x$ role in every analysis you conduct with a particular data table, you assign it the preselected role of $x$.

Note that when you selectFreq, the values in that column are what JMP uses as the frequency of the observation. If $n$ is the value of the Freq variable for a given row, then that row is used in computations $n$ times. If the $n$ is not an integer, then JMP truncates it. If it is less than 1 or is missing, then JMP does not use it to calculate any analyses.

When you selectWeight, the values in that column provide weights for each observation in the data table. The variable does not have to be an integer, but it is only included in analyses when its value is greater than zero.

To assign a preselected role to a column:

1. Highlight the column.
2. SelectCols > Preselect Role, as shown in Figure 5.14.
3 Select a role: **No Role, X, Y, Weight**, or **Freq** (Frequency).

After selecting the appropriate roles, icons in the columns panel, as shown in Figure 5.15, signify what roles the columns have been assigned. Click the icon to access a list of roles and select a different one.

**Figure 5.15 The Columns Panel**

**Iconic Indicators**

After assigning characteristics, icons appear on the data grid to indicate some of the rows’ or columns’ assigned characteristics. The icons appear to the right of each column name in the column panel, as shown in Figure 5.16, and to the left of the row number in the data table. You can click some icons on the right of each column name to reveal their contents.
Assigning Properties to Columns

In addition to the column characteristics described in “Assigning Characteristics to Rows and Columns,” p. 129, columns can contain special column properties, such as notes for documentation, formulas that calculate the column’s values, and restrictions on values.

After adding a property to a column, the properties icon (•) appears in the data table’s columns panel, indicating that the column contains a property. However, when formulas, range checks, and list checks are applied to a column, their own individual icons appear. If the column only contains the notes property or if there are no properties, the properties icon (•) will not appear (Figure 5.17).

The following sections describe properties you can add to columns.
Giving Columns a Formula to Compute Values

You can insert a formula into a column to compute the values for that column. Once you do this, the column becomes locked so its data values cannot be manually edited (this prevents invalidation of the formula).

To create a formula that will calculate the values for your column:

1. Double-click the column name in the data grid. The Column Info window appears.
2. Select **Formula** from the **Column Properties** drop-down menu, as shown in Figure 5.18.
3. Click the **Edit Formula** button.
4. Complete the formula (see “Creating a Formula,” p. 279, for details). The box beside **Lock**, as shown in Figure 5.18, becomes checked, indicating that you cannot edit the column’s values from the data table. (To edit values, you must first delete the formula.)
5. If you do not want JMP to evaluate the formula, click the box beside **Suppress Eval**. When formula evaluation is suppressed, part of the yellow plus icon (black on the Macintosh) beside the column name in the data grid is replaced with a yellow minus icon.
umn name in the column panel becomes grey (see “Iconic Indicators,” p. 139, for details).

6 If you do not want JMP to alert you of any errors in your formula, click the box beside Ignore Errors.

7 Click OK. The formula icon (++) now appears next to the column name in the data table’s column panel, indicating that the column contains a formula. Click the icon to edit the formula.

### Locking Columns

You can lock a column so none of its values can be edited. After you lock a column, the lock icon (🔒) appears next to the column name in the data table’s column panel.

Note that a column automatically becomes locked when you add a formula. However, the lock icon (🔒) will not appear beside that column’s name in the column panel. Instead, the formula icon (++) appears to indicate that the column contains a formula.

To lock a column:

1 Double-click the column name in the data grid. The Column Info window appears.
2 Click the box beside Lock, as shown in Figure 5.19

*Figure 5.19* Locking a Column

3 Click OK.

### Adding Notes to Columns

Just as you can add notes to a data table in the form of a table variable, you can add notes to individual columns in the form of a column property. For example, you may want to document or keep notes for one or more columns in a data table, such as a description of the source of the data.

To add notes to a column:

1 Double-click the column name in the data grid. The Column Info window appears.
2 Select Notes from the Column Properties drop-down menu.
3 Type into the text box, as shown in Figure 5.20
Validating Column Data

You can set up a column so that it only accepts certain values. These values can be individual numbers (list checking), or they can be all numbers that fall within a range (range checking). The following sections describe the two types of column validation.

List Checking

You can set up a column so it can only contain certain individual values that you specify. For example, you can set up a column so it can only contain the numbers 2, 4, or 6. When you do this, the cursor changes to \( \text{\textbullet} \) when positioned over the column. If you try to enter a value not included on the validation list, a warning message appears. If you right-click a cell (Ctrl-click on the Macintosh), a menu of acceptable values shows. You can then select the cell value from the menu instead of typing it into the cell.

List checking is also useful when you would like your graphs or plots to order data in a certain way. For example, histogram bars are ordered alphabetically by default. To present them in a different order, create a list check where the values you enter are in the new order. They are then displayed in an output report in that order instead of the default order. (Note that list checking does not apply to bar charts.)

After you lock a column, the \( \text{\textbullet} \) icon appears next to the column name in the data table's column panel.

To set up list checking:
1. Highlight the column to which you want to apply the validation.
2. Access the list check information by taking one of the following actions:
   - Double-click the column name in the data grid. The Column Info window appears. Select **List Check** from the **Column Properties** drop-down menu, as shown in Figure 5.21.
4. Click **OK**.
- Right-click (Ctrl-click on the Macintosh) the column name and select Validation > List Check. The window in Figure 5.22 appears.

- Select Cols > Validation > List Check. The window in Figure 5.22 appears.

**Figure 5.21** Select List Check as a New Property

![List Check Window](image)

**Figure 5.22** List Check Window

3 The list in the window contains values that JMP will accept. Use the table below to change the values:

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove value(s) from the list</td>
<td>Highlight them and click the <strong>Remove</strong> button.</td>
</tr>
<tr>
<td>Add values to the list</td>
<td>Type the values into the empty text box and click <strong>Add</strong>.</td>
</tr>
</tbody>
</table>
Assigning Properties to Columns

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move the highlighted number to another position in the list</td>
<td>Click the <strong>Move Up</strong> and <strong>Move Down</strong> buttons. Remember that the order in which values appear in this list will be the order in which they appear in analysis reports.</td>
</tr>
</tbody>
</table>

4. Click **OK**. The ícone now appears next to the column name in the data table's column panel, indicating that the column contains a list check. Click the icon to make changes to the list check.

**Range Checking**

You can set up a column so that it can only contain values within a range of numbers. When you do this, the cursor changes to a checkmark (✓) when positioned over the column. If you try to enter a value outside the validation range, a window prompts you to change the cell value.

To set up range checking:

1. Highlight the column to which you want to apply the validation.
2. Access the range check information by taking one of the following actions:
   - Double-click the column name in the data grid. The Column Info window appears. Select **Range Check** from the **Column Properties** drop-down menu, as shown in Figure 5.23.
   - Right-click (Ctrl-click on the Macintosh) the column name and select **Validation > Range Check**. The window in Figure 5.24 appears.
   - Select **Cols > Validation > Range Check**. The window in Figure 5.24 appears.

**Figure 5.23** Select Range Check as a Column Property
Assigning Properties to Columns

3. Type the lowest value you want the column to accept into the box beside $a$.
4. Type the highest value you want the column to accept into the box beside $b$.
5. Select which formula to use to set up the range. Remember that $x$ is the value entered into the column, $a$ is the beginning of the range, and $b$ is the end of the range. For a single-sided range check, leave either $a$ or $b$ empty.
6. Click OK. A checkmark (✓) now appears next to the column name in the data table’s column panel, indicating that the column contains a range check. Click the icon to make changes to the range check.

Turning List/Range Checking Off

To turn off list or range checking:
1. Right-click (Ctrl-click on the Macintosh) the column name.
2. Select Validation > No Checking.

Using Value Labels

Value labels allow you to display a label instead of a value in each instance that the value appears. When you assign value labels, the labels appear in the data table instead of the original values, but the original values are not lost. They can be displayed by double-clicking the label.

Also note that:
- When your data table contains value labels, using the Search commands will search for actual values, but will not search for labels.
- When your data table contains value labels, the row editor will display the label, and when the cell is highlighted for editing, it will show the actual value.
- If you copy and paste a cell with a value label, the actual value is pasted.

To set up value labels:
1. In the data table, locate the column to which you want to apply the value label and double-click the area above the column name. The Column Info window appears.
2. Select Value Labels from the Column Properties drop-down menu, as shown in Figure 5.24.
Assigning Properties to Columns

3 In the **Value** text box, type the value you want to give a label.
4 In the **Label** text box, type what you want to appear as the label.
5 Click **Add**.
6 To create more value labels, repeat the above steps.
7 Click **OK**. The properties icon (✱) now appears next to the column name in the data table's column panel, indicating the column contains a property.

To turn value labels off without deleting what you have set up, uncheck the box beside **Use Value Labels**.

To edit a value label that already exists:
1 In the data table, locate the column to which you want to apply the value label and double-click the area above the column name. The Column Info window appears.
2 Highlight **Value Labels** in the **Current Properties** box.
3 Highlight the value label you want to edit.
4 To edit its value, enter a new value into the **Value** box and click **Change**.
   To edit its label, enter a new label into the **Label** box and click **Change**. The new value and/or label appears in the place of the highlighted one.
5 When finished, click **OK**.

**Note:** In a formula, when you reference a column using value labels, hover your mouse over the value label to see the actual data value.

Ordering Values in Columns

Categorical values in a JMP report might not appear in the order you prefer. For example, instead of showing ages from high to low (to the left in Figure 5.25), you might want to list ages from low to high (to the right in Figure 5.25). To do this, use the Value Ordering column property.
To assign the column the Value Ordering property:

1. Double-click the column name in the data grid. The Column Info window appears.
2. Select Value Ordering from the Column Properties drop-down menu. Value ordering information appears on the right, as shown in Figure 5.26.

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove value(s) from the list</td>
<td>Highlight them and click the Remove button.</td>
</tr>
<tr>
<td>Add values to the list</td>
<td>Type the values into the empty text box and click Add.</td>
</tr>
</tbody>
</table>
Assigning Properties to Columns

1. Click OK. The properties icon ( *) now appears next to the column name in the data table's column panel, indicating the column contains a property.

**Note:** If you use both the Value Ordering and Row Order Levels properties, the Value Ordering property overrides the Row Order Levels.

4. If your values include any of the following, they will automatically appear in the appropriate order in reports. You do not need to assign their columns the Value Ordering property:
   - January, February, March, April, May, June, July, August, September, October, November, December
   - Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec
   - Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday
   - Very Low, Low, Medium Low, Medium, Medium High, High, Very High
   - Strongly Disagree, Disagree, Neutral, Indifferent, Agree, Strongly Agree
   - Failing, Unacceptable, Very Poor, Poor, Bad, Acceptable, Average, Good, Better, Very Good, Excellent, Best

**Assigning Value Color Ranges**

In mosaic plots, nominal and ordinal values appear color-coded. In other plots with a legend displayed, the values are color-coded. You can assign the values of a nominal or ordinal column a certain color or range of color gradients. Once you do that, the column's values appear with an assigned color in all applicable graphs.

To assign a column color values:

1. Highlight a nominal or ordinal column in the data table.
2. Select **Cols > Column Info**. The Column Info window appears.
3. Select **Value Colors** from the **Column Properties** drop-down menu. Value color information appears on the right, as shown in Figure 5.27.
4 To change a color, right-click a color circle on the right and select a color.

5 Use the Macros button to do the following:

– **Gradient between ends**  Sets the colors of the top and bottom values so JMP can apply a color gradient across the entire range of values. Use this command to make all the colors in between for the other levels.

– **Gradient between selected points**  Sets the colors of the top and bottom values so JMP can apply a color gradient to a range of values you have highlighted in the Value Colors list.

6 Click **OK**. The properties icon (anism) now appears next to the column name in the data table’s column panel, indicating the column contains a property.

### Changing Columns’ Default Axis Settings

You can specify default axis settings for a column so whenever the column is used in analysis, JMP automatically uses the specified settings. These settings include the minimum and maximum values, number of increments, number of tick marks, etc.

To specify default axis settings:

1 Double-click the column name in the data grid. The Column Info window appears.

2 Select **Axis** from the **Column Properties** drop-down menu. Axis information appears on the right, as shown in Figure 5.28.
3 Use the table below to specify axis properties:

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the scale type (linear or log)</td>
<td>Click the drop-down menu beside Scale Type and select either linear or log.</td>
</tr>
<tr>
<td>Set minimum and maximum values you want the graph to display.</td>
<td>Type values in the box beside Min and Max.</td>
</tr>
<tr>
<td>Specify the number of increments on the graph</td>
<td>Type the number in the box beside Inc.</td>
</tr>
<tr>
<td>Specify the number of minor tick marks on the graph</td>
<td>Type the number in the box beside Minor Ticks. Then, click the boxes beside Show Minor Ticks.</td>
</tr>
<tr>
<td>View major tick marks, major gridlines, minor gridlines, and labels</td>
<td>Click the boxes beside Show Major Ticks, Show Minor Ticks, Show Major Grid, Show Minor Grid, and Show Labels.</td>
</tr>
<tr>
<td>Display the labels on the x-axis vertically instead of horizontally</td>
<td>Click the box beside Rotated Labels.</td>
</tr>
<tr>
<td>Add up to four reference lines to the graphs</td>
<td>In the boxes under Ref Lines, type a value for each, and up to four lines will appear on your graphs at the indicated positions.</td>
</tr>
</tbody>
</table>

4 Click OK. The properties icon (*) now appears next to the column name in the data table’s column panel, indicating the column contains a property.
An alternate way to set the default axis properties for a column is to:

1. Create the graph.
2. Change the axis to your preferred specifications (see “Customizing Axes and Axis Labels,” p. 199).
3. Right-click the axis and select Save to Column Property. The properties icon (☆) now appears next to the column name in the data table’s column panel, indicating the column contains a property.

**Defining Low and High Values (DOE Coding) for Columns**

When you fit a column in a model, the low and high values of the column are transformed to –1 and 1, which makes tests and parameter estimates more meaningful. This is referred to as coding and can be used for any continuous variable. It is the default for continuous factors generated by the DOE commands in JMP. Note that if a column has one or more limits missing, JMP substitutes the data’s minimum and maximum for the high and low values.

To specify which values you want to use as the low and high values in a column:

1. Double-click the column name in the data grid. The Column Info window appears.
2. Select Coding from the Column Properties drop-down menu. Coding information appears on the right, as shown in Figure 5.29.

**Figure 5.29** Coding Window

3. Type the values you want to use as low and high values into the text boxes.
4. Click OK. The properties icon (☆) now appears next to the column name in the data table’s column panel, indicating the column contains a property.
Setting Columns as Factors for Mixture Experiments

You might have a column in a data table that is one of several factors that form 100% of a mixture. You can set up the column so JMP uses it to automatically generate a no-intercept model (using the Fit Model command) when you analyze the data.

Note that after setting columns as factors for mixture experiments, the properties icon (★) appears next to the column name in the data table’s column panel, indicating the column contains a property.

To set this up:
1. Double-click the column name in the data grid. The Column Info window appears.
2. Select Mixture from the Column Properties drop-down menu. Mixture information appears on the right, as shown in Figure 5.30.

Figure 5.30 Mixture Information

3. Enter the upper and lower limits as well as the sum of terms.
4. Check the boxes beside L and U PseudoComponent Coding, if desired. Using the example in Figure 5.30, where the mixture sum value is 1, the terms are coded as:

   \[ X_iL = (X_i - L_i)/(1 - L) \] 
   \[ X_iU = (U_i - X_i)/(U - 1) \]

   where \( L_i \) and \( U_i \) are the lower and upper bounds, \( L \) is the sum of \( L_i \), and \( U \) is the sum of \( U_i \). If you check both in this example, the Fit Model platform uses the L coding if \( (1 - L) < (U - 1) \), and the U coding otherwise.

In the Fit Model report, the main effects are labeled with the coding transformation. Crossed effects are not labeled, but coding values are used. All the features of fitting, such as the profilers and saved formulas, respect the pseudocomponent coding but present the un-coded values in the tables and plots.

5. Click OK. The properties icon (★) now appears next to the column name in the data table’s column panel, indicating the column contains a property.

Specifying How Rows Appear in Analysis Reports

By default, the row data in an analysis report is ordered by the data’s values. However, if you would like to view row data in an analysis report in the order it appears in the data table column, you can change the default setting.

To specify how rows appear:
1. Double-click the column name in the data grid. The Column Info window appears.
2. Select Row Order Levels from the Column Properties drop-down menu, as shown in Figure 5.31. A Row Order Levels checkbox appears on the right.

**Figure 5.31** Specifying Row Order Levels

3. Make sure there is a check in the box beside Row Order Levels.
4. Click OK. The properties icon (●) now appears next to the column name in the data table’s column panel, indicating the column contains a property.
5. Remember that what you have done in the above steps only applies to the selected column. To apply it to other columns, repeat the above steps for each column or use the Standardize Attributes command, which is explained in “Standardizing Attributes and Properties Across Columns,” p. 161.

**Tip:** If you would like your rows to appear in the analysis reports in another order (besides according to their values or their occurrence in the data table columns) use the value ordering property. See “Ordering Values in Columns,” p. 147, for details. The Value Ordering property overrides the Row Order Levels property when both are evoked.

## Entering Specification, Control, and Response Limits

You can save specification, control, and response limits in a column. If you do this, you can run a capability analysis, control chart analysis, or analyses displaying the prediction and contour profilers without having to re-specify roles and limits each time. Saving these limits in a column facilitates consistency from use to use. For example, if you run an analysis that employs these limits, then come back later and change the data, you can run a new analysis on the new data using the same limits.

To enter specification, control, and response limits:

1. Double-click the column name in the data grid. The Column Info window appears.
2. Select one of the following from the Column Properties drop-down menu, as shown in Figure 5.32.
Properties & Characteristics of Data
Assigning Properties to Columns

Chapter 5

Properties & Characteristics of Data

Assigning Properties to Columns

Figure 5.32 The New Property List

- **Spec Limits**  Lets you enter a lower spec limit, upper spec limit, and target value for a numeric column. When you assign a column these values, JMP automatically uses them when you run a capability analysis (this type of analysis is run after you have selected Analyze > Distribution), as shown in Figure 5.33.

Figure 5.33 Capability Analysis Using Spec Limits Found Within a Column

If you have given a column spec limits, JMP will use them to create a capability analysis when it is selected from a distribution output report

- **Control Limits**  Lets you select a control chart type and then enter the values you want to use for average (Avg), lower control limit (LCL), and upper control limit (UCL) for each chart. These values will be saved with the column and automatically used when you run an analysis using Graph > Control Chart.

- **Response Limits**  Lets you define response column values for use in analyses such as those displaying the prediction and contour profilers or DOE. You can specify values for the lower, middle, and upper limits, and desirability values, as shown in Figure 5.34. You can also select Maximize, Match Target, Minimize, or None, which are possible goals for a DOE response vari-
able. If you have two responses, you can enter an importance value, which lets JMP know how to weigh one response's importance against another's.

Figure 5.34 Defining Response Column Values

3 Click OK. The properties icon (★) now appears next to the column name in the data table's column panel, indicating the column contains a property.

Giving Columns a Design Role

You can tell JMP how to use a factor column in a model to design an experiment. You can tell JMP to use it as a continuous, categorical, blocking, covariate, mixture, constant, signal, or noise factor.

To give a column a design role:

1 Double-click the column name in the data grid. The Column Info window appears.
2 Select Design Role from the Column Properties drop-down menu, as shown in Figure 5.35. Design role information appears on the right.
3 Click the Design Role drop-down menu and select how you want JMP to use the factor column: Continuous, Categorical, Blocking, Covariate, Mixture, Constant, Signal, Noise, Uncontrolled, or Random Block.

4 Click OK. The properties icon (*) now appears next to the column name in the data table's column panel, indicating the column contains a property.

Identifying Factor Changes

To create a split plot design using JMP’s DOE (Design of Experiments) commands, you must identify a factor as “hard,” meaning that the factor would be difficult to change. Identifying a factor as “hard” can be done in the DOE design panel (see JMP Design of Experiments for details) each time you design an experiment. However, if you want to create a split plot design every time you use a certain factor, save yourself steps by setting up that factor to be “hard” in all experiments:

1 Double-click the column name in the data grid. The Column Info window appears.

2 Select Factor Changes from the Column Properties drop-down menu, as shown in Figure 5.36. Factor changes information appears on the right.
3 Click the Factor Changes drop-down menu and select how you want JMP to use the factor column: Easy or Hard.
4 Click OK. The properties icon ( ) now appears next to the column name in the data table’s column panel, indicating the column contains a property.

Assigning Sigma Values to Columns

You can enter a known Sigma to be saved with the column to be used by applications, such as control charts, that require a Sigma value to complete computations. If no value is supplied, Sigma is calculated from the sample.

To assign a value to Sigma:
1 Double-click the column name in the data grid. The Column Info window appears.
2 Select Sigma from the Column Properties drop-down menu.
3 Type the value to be used for Sigma into the text box shown in Figure 5.37.
Assigning Properties to Columns

Figure 5.37 Sigma Window

4 Click **OK**. The properties icon (球星) now appears next to the column name in the data table's column panel, indicating the column contains a property.

Specifying Columns’ Measuring Units

JMP allows you to specify, within a column, the measurement units that were used to collect the data. For example, you might want a column to indicate that age values are measured in months or that a monetary value is in thousands of dollars.

To add this information to a column:

1 Double-click the column name in the data grid. The Column Info window appears.
2 Select **Units** from the **Column Properties** drop-down menu.
3 Type the measurement you wish to use in the text box shown in Figure 5.38.

Figure 5.38 Units Window
4 Click OK. The properties icon (†) now appears next to the column name in the data table’s column panel, indicating the column contains a property.

Creating Your Own Column Property

You can create your own column property and assign any name you want to it. This property is then available for JSL programming.

1 Double-click the column name in the data grid. The Column Info window appears.
2 Select Other from the Column Properties drop-down menu.
3 Type a name for the new property.
4 Enter a value for the property.

Removing Properties

Column properties can be added or deleted at any time. To delete a property:

1 Double-click the column name in the data grid. The Column Info window appears.
2 Select the property in the Current Properties drop-down menu and click Remove, as shown in Figure 5.39.

Figure 5.39 Removing Properties
Standardizing Attributes and Properties Across Columns

When a column contains attributes (data types, modeling types, numeric formats, etc.) or properties (formulas, notes, list and range checks, etc.) that you want other columns to have, you can use the existing column to standardize the attributes and properties across columns. This includes both adding and deleting attributes and properties.

Adding Attributes and Properties

To apply an existing column’s attributes and properties to multiple columns:

1. Select the column containing the desired attributes or properties.
2. Select Cols > Standardize Attributes. The window in Figure 5.40 appears.
3. Click the Attributes button (Figure 5.40), and select items to be duplicated across columns.

Figure 5.40 Standardizing Attributes Across Columns

4. To change the values of any of the attributes, use the drop-down menus and text boxes in the attributes information area.

5. Click the Column Properties button in the Standardize Properties area and set up the properties you want the other columns to possess, as shown in Figure 5.41.
6 Click out of the Standardize Columns Attributes window and into the data table.
7 Highlight the columns in the data table to which you want to apply the attributes and properties.
8 Click back into the Standardize Columns Attributes window and click **Apply**. The attributes and properties apply to all the selected columns in the data table. You can view your results.
9 Click **OK**.

**Tip:** If the columns to which you want to apply changes are located to the right of the column containing the attributes or properties, highlight both columns and skip steps 6 and 7 above. JMP uses the left-most column as the one with the desired attributes and applies it to the other highlighted columns.

---

**Deleting Properties**

To delete the same properties across multiple columns:

1 Select the column containing the attributes or properties you want to delete.
2 Select **Cols > Standardize Attributes**.
3 Click the **Column Properties** button in the Delete Properties area and select the properties you want to delete.
4 Click **OK**.

---

**Using Row State Columns**

You can create a column that only contains row state information, which stores information about whether the rows are excluded, hidden, labeled, colored, or marked (see “Assigning Characteristics to Rows and Columns,” p. 129, for details). This column has its own data type and it does not have a modeling type because its values are not used in analyses.
Using row state columns is a two-step process. The first step is to set up the column. Then, add values to the column just as you would if it contained numeric or character data. The sections below describe how to complete these steps.

**Step 1: Set Up Row State Columns**

1. Create a new column by either double-clicking the top of an empty column, or by selecting **Cols > New Column**.
2. If you double-clicked to create a new column, double-click the column name again.
3. In the window that appears, click the **Data Type** menu and select **Row State**, as shown in Figure 5.42.

**Figure 5.42 Select Row State for the Column's Data Type**

4. Click **OK**.

5. Add or copy values to the column by following the steps in “**Step 2: Add Values to Row State Columns**,” p. 163.

**Step 2: Add Values to Row State Columns**

After setting up the row column, populate its cells with either new information or with pre-existing row state information. There are two ways to do this: by either creating row state characteristics for the row state column or by copying existing row state information into the column. The sections below describe these two ways.

To create row state characteristics for the row state column:

1. Right-click (Ctrl-click on the Macintosh) the row state column name.
2. Select **Row States Cells**. The submenu appears.
3. Select a characteristic to apply to all rows in the column.
To populate a row state column by copying existing row state information into the column:

1. To populate only certain rows in the row state column, highlight those row(s). To populate on all rows in the column, highlight the row state column.

2. Click the star icon (⭐) beside the column name located in the column panel (to the left of the data grid). The drop-down menu shown in Figure 5.44 appears.

3. Select one of the following:
   - **Copy from Row States**  Copies the characteristics from the row number area to the row state column, replacing existing row state values in the column.
   - **Add from Row States**  Adds the characteristics from the row number area to the row state column, preserving existing row state values in the column.
   - **Copy to Row States**  Copies the characteristics from the row state column to the row number area, replacing existing active row states.
   - **Add to Row States**  Adds the characteristics from the row state column to the row number area, preserving existing active row states.
Permanently Highlighting Cells

You can save a highlight in a row state column just like you save other row state characteristics (hide, exclude, color, etc.). This places a “permanent” highlight on a cell. To do this:

1. Right-click a cell and select **Row States Cells > Select/Deselect**.
2. Repeat this for as many cells as you would like to highlight.
3. To remove the highlight, right-click (Windows) or Ctrl-click (Macintosh) on the cell and select **Row States Cells > Select/Deselect**.
All analyses produce report windows, such as the one shown below.

Reports contain both text reports and graphs. They are designed to be convenient in several ways:

- Individual plots can be resized and text reports can be opened and closed to optimize screen space (see “Resizing Plots and Graphs,” p. 194, and “Showing and Hiding Parts of a Report,” p. 171).
- Plots and text reports can be printed (see “Printing Reports,” p. 175).
- Context-sensitive help is accessible through the question mark tool. After selecting it, you can click anywhere in a report (see “Learning About JMP,” p. 3).
- All or part of a report can be copied to other applications, such as Microsoft Word (see “Pasting Reports into Another Program,” p. 175, and “Pasting Reports into Another Program,” p. 120).

This chapter describes features common to all reports in JMP.
## Contents

**Editing Reports** .......................................................... 169
  - Accessing General Report Formatting Options .......................... 169
  - Showing and Hiding Parts of a Report .................................. 171
  - Renaming a Report ....................................................... 172
  - Increasing Font Sizes .................................................... 173
  - Saving Results as Column Values ..................................... 173
  - Editing Data Table Rows from a Report ................................ 173
  - Understanding the $p$-value Indicator ................................ 174

**Printing Reports** .......................................................... 175
**Pasting Reports into Another Program** .................................. 175
**Adding Options and Working with Analyses** ............................. 176
**Saving Your Steps as a Script** .......................................... 177
**Formatting Report Tables** ................................................ 179
  - Reordering Rows (Sorting) ............................................... 179
  - Showing and Hiding Columns .......................................... 180
  - Adding Outlines and Borders ......................................... 180
  - Changing Numeric Formats and Field Widths ........................ 181
  - Changing Table Names and Column Headings ........................ 182
  - Turning a Report Table Into a Data Table ........................... 182
  - Turning a Report Table Into a Matrix ............................... 183

**Selecting Points in Plots** ............................................... 184
**Using Markers** ............................................................. 186
  - Changing Marker Shape ................................................. 186
  - Changing Marker Colors ............................................... 186
  - Changing Marker Size .................................................. 187
  - Changing the Marker Drawing Mode and Transparency .............. 188
  - Adding Outlines Around Markers ..................................... 188
  - Specifying Marker Transparency ..................................... 189
  - Excluding and Hiding Markers ........................................ 190
  - Adding Labels to Markers .............................................. 190
  - Changing Marker Shape or Colors Based On Values ................. 192
  - Removing the Legend .................................................... 193

**Altering Plot and Chart Appearances** .................................. 194
**Adding Elements to a Report** ......................................... 210
Editing Reports

JMP reports are displayed in standard windows with scroll bars and options to resize. They also have other special buttons and menus like those illustrated in Figure 6.1 and those discussed in the following sections.

Figure 6.1 Basics of the Report Window

Note that there are many functions you can use with the hand tool (also known as the grabber tool: ⏇️) in a report. Here are some examples of the way the hand behaves in graphs and plots:

- Use the hand tool to change the displayed range of axis values:
  - On a y-axis, dragging ⏴️ or ⏳️ scales the y-axis; dragging ⏳️ scrolls the y-axis.
  - On an x-axis, dragging ⏴️ scrolls the x-axis; dragging ⏳️ or ⏳️ scales the x-axis.

- On histograms, use the hand tool to change the number of bars or to shift the boundaries of the bars.

- On spinning and surface plots, click and drag the hand tool to spin the plot. To adjust the speed of the spin, increase the speed at which you drag the hand tool. Or, press Shift-Alt (Ctrl-Alt on Linux) and click and drag the circle that appears (a large circle will spin the plot slower).

- In all report tables, use the hand tool to click and drag columns for rearranging.

Accessing General Report Formatting Options

Right-click (Ctrl-click on the Macintosh) a disclosure button (⬆️⬇️ on Windows/Linux and ⬆️⬇️ on the Macintosh) to show a menu that lets you rearrange the report and gives you control over report outline levels. For example, see the menu in Figure 6.2.
The resulting menu has the following report formatting options:

- **Close** Closes (hides) that section of the report. This can also be accomplished by clicking the disclosure button (◨ down on Windows/Linux and ◄ down on the Macintosh).

- **Horizontal** (if available) Horizontally aligns the next lower outline levels. By default, most reports are arranged with the outline levels showing vertically with indented outline levels.

- **Open All Below** Opens all outline levels beneath the level where this command is selected, including that level.

- **Close All Below** Closes all outline levels beneath the level where this command is selected, including that level.

- **Open All Like This** Opens all of the same type of reports as the one that is present in the analysis window. If you analyze several variables at a time, or select multiple options on a single analysis, you often have many of the same type report tables and want to open or close them all at once.

- **Close All Like This** Closes all of the same type of reports as the one that is present in the analysis window.

- **Close Where No Outlines** Closes all parts of the report that do not have sublevels. This command is usually used at the top level of the report outline. It is a quick way to see a nesting structure overview of a report.

- **Append Item** Displays a submenu, which lists ways you can add structural items to the report. Items include text, outline title bars, references to other JMP files and windows, a list of all open JMP files, and URLs.

- **Edit** Displays the submenu shown in Figure 6.2, which affect all reports at the outline level where they are used:
  - **Select** Highlights all reports for that outline level.
  - **Deselect** Deselects all selected reports for that outline level.
  - **Journal** Duplicates the report in a separate window titled Journal so you can edit it or append other reports to it (see “Saving Using the Journal Command,” p. 113, for details).
  - **Copy Picture** Copies the report to the clipboard. You can then open another application and paste it.
  - **Page Break** Inserts a page break for printing purposes.
An alternative way to access these options is to Alt-right-click (Ctrl-Option-click on the Macintosh and Ctrl-Alt-right-click on Linux) the disclosure button ( Disclosure Button on Windows/Linux and Disclosure Button on the Macintosh). This displays a window, as shown in Figure 6.3, with checkboxes for commands and options so you can select multiple actions at the same time. You can also do the same for the menu under a red triangle icon.

Figure 6.3 Menu Items in a Window

### Showing and Hiding Parts of a Report

JMP reports are organized in a hierarchical outline. On a Windows or Linux operating system, each level of the outline has a blue diamond-shaped disclosure button ( Disclosure Button). On the Macintosh, each level of the outline has a grey arrow-shaped disclosure button ( Disclosure Button).

To use the disclosure button, click the disclosure button to open and close that section of the report. In Figure 6.4, the report on the left has the Whole Model Test open, while the report on the right has it closed.
Figure 6.4  Reports With a Section Open (Left) and Closed (Right)

Renaming a Report

To change the title, or name, that appears on the top of a report:

1. Double-click the report title. The cursor becomes a flashing text insertion bar.
2. Edit its title.

Double-click the title  

Once the text is highlighted, begin to edit
Increasing Font Sizes

On Windows and Linux, quickly change the font size JMP uses in reports and data tables by selecting **Window > Font Sizes**. Then choose from one of the submenu items:

- **Increase Font Size**: Increases the font size. Select again to increase the font size again.
- **Decrease Font Size**: Decreases the font size. Select again to decrease the font size again.

Saving Results as Column Values

Some reports give you the option of saving parts of the results as a new column in the corresponding data table. To add this new column:

1. After running an analysis and obtaining a report, click the red triangle icon to the left of the report title.
2. From the drop-down menu that appears, select a **Save** option, if available.

Editing Data Table Rows from a Report

To browse or edit values one row at a time from the report graph:

1. Highlight a point in the report.
2. Right-click (Ctrl-click on the Macintosh) anywhere in a graph.
3. Select **Row Editor**.
4. When the row editor appears, it displays information about the first selected row.
5. Edit the data.
6. Click the arrow buttons to browse through selected rows or the entire data set. Figure 6.5 shows the function of each button.
7 Click the red triangle icon in the row editor to access the following options:

**Next Selected**  Provides the same functionality as the button. It displays information for the selected row that is located after the current one.

**Prev (Previous) Selected**  Provides the same functionality as the button. It displays information for the selected row that is located before the current one.

**Next**  Provides the same functionality as the button. It displays information for the row that is located after the current one, regardless of whether the row is selected.

**Prev (Previous)**  Provides the same functionality as the button. It displays information for the row that is located before the current one, regardless of whether the row is selected.

**Save**  Saves the data table and any changes you have made to it via the row editor.

**New Row**  Creates a new row in the data table.

**Find**  Provides the same functionality as the button. It displays the same window as if you had selected Rows > Row Selection > Select Where. Click the option under Currently Selected Rows you wish to use, then highlight the column whose rows you wish to select. Type the value for which you want JMP to search. See “Selecting Cells with Specific Values,” p. 91, for details.

**Blink**  Provides the same functionality as the button. It causes the current row’s highlight to flash.

**Note:** Text in a locked column or a locked data table cannot be edited. See “Locking Columns,” p. 142, for details on unlocking a column. See “Locking Tables,” p. 82, for details on unlocking a data table.

You can also access the row editor from a data table. See “Using the Row Editor,” p. 80, for details.

**Understanding the p-value Indicator**

*p*-values that are less than 0.05 are statistically significant. In output reports, JMP indicates the significance of these values by placing an asterisk beside them.
Printing Reports

To print the report in the active window, select **File > Print**. This command displays the standard window for printing. The appearance of the window depends on your operating system and printer driver.

- If you are using a Windows operating system and would like to view the active window in the form it will print before you print it, select **File > Print Preview**. If there is no open window, this command is not available.
- To set printed page characteristics before printing, select **File > Print Setup** (Windows) or **File > Page Setup** (Macintosh) to display the standard window for setting these characteristics. The form of the window depends on your operating system and current printer driver.

To insert a page break for printing purposes:

1. Right-click the disclosure button (ıld on Windows/Linux and ıld on the Macintosh) in the report window.
2. Select **Edit > Page Break**.

Pasting Reports into Another Program

When you need JMP reports or data tables for use in another program, you can save the reports or tables by copying and pasting or dragging and dropping parts of it into another program, such as Microsoft Word or PowerPoint. Then save the document in that application. Note that on Linux, you can copy and paste or drag and drop text but not graphics.

1. Click the selection tool (arrivée).
2. Click and drag (or Shift-click) to select items in a report window or data table. Clicking near the edge of the report window selects the entire report.
3. Click the selected items and drag them from JMP to the other program. Or, copy the selected items in JMP and paste them into the other program. When you paste an element into another application, the format used depends on the application into which you paste. If the application has a
Paste Special command and you utilize it, you can select a format to use, such as text (.rtf), unformatted text (.txt), picture or Windows metafile (.wmf), bitmap (.bmp), or enhanced picture (.emf).

**Note:** To copy all text (no graphs) from the active report window as unformatted text, select Edit > Copy As Text. On the Macintosh, press the Shift key and select Edit > Copy As Text. To copy only the graph (no text), right-click the graph and select Edit > Copy Picture.

---

## Adding Options and Working with Analyses

### How to Access Analysis Options

Click the red triangle icon in a report to display a list of options that apply for that particular report, as shown in **Figure 6.6**.

**Figure 6.6** The Red Triangle Icon

Click to access analysis options for that particular report:

- Display Options
- Histogram Options
- Normal Quantile Plot
- Outlier Box Plot
- Quantile Box Plot
- Stem and Leaf
- CDF Plot
- Test Mean
- Test Std Dev
- Confidence Interval
- Prediction Interval
- Tolerance Interval
- Capability Analysis
- Fit Distribution
- Save

In addition to clicking the red triangle icon, you can also:

- Alt-click (Option-click on the Macintosh and Ctrl-Alt-click on Linux) the red triangle icon, and a panel of all commands and options appears with checkboxes so that you can select multiple actions at the same time.

- Ctrl-click (Command-click on the Macintosh and Ctrl-Alt-right-click on Linux) the red triangle icon to broadcast the command you select to all similar reports in the analysis window. For example, if you Ctrl-click the icon in a oneway analysis and select Means/Anova/ t Test, an analysis of variance is performed for all oneway analyses in the active report window.

Chapters in the *JMP Statistics and Graphics Guide* describe the menus for each statistics and graphics platform.
Rerunning An Analysis

You can redo an analysis and get its report without having to return to the main menu. For example, if you run a bivariate fit, then alter a value or two in the data table, you could go back to the original report and rerun the analysis from there.

To redo an analysis from the report window:

1. Click the red triangle icon in the report title.
2. Select Script > Redo Analysis.

Figure 6.7  Rerunning an Analysis

Saving Your Steps as a Script

After completing an analysis and receiving a report, you might want to save the process you used to arrive at the report as a JSL script. You can save the script inside the data table, inside the report, or in a separate script window. To do this, click the red triangle icon in the report title and select Script. Then select the Save Script option you prefer:
Output Reports
Chapter 6
Saving Your Steps as a Script

Figure 6.8 The Script Menu

Copy Script  Copies the steps taken to arrive at the current report to the clipboard as JSL. You can paste the script into a text editor.

Save Script to Data Table  Saves the steps taken to arrive at the current report as a JSL script in the data table. The script appears in the tables panel of the data table. For details, see “The Table Panel,” p. 50 and “Creating Scripts,” p. 86.

Save Script to Journal  Saves the steps taken to arrive at the current report as a JSL script in a journal (see “Saving Using the Journal Command,” p. 113, for details about journaling). From the journal, click the script to run it.

Figure 6.9 The Script Is Added to a Journal

Save Script to Script Window  Saves the steps taken to arrive at the current report as a JSL script in a script window, as shown in Figure 6.10.

Figure 6.10 The Script Is Added to a Script Window

Save Script to Report  Saves the steps taken to arrive at the current report as a JSL script within the report itself, as shown in Figure 6.11.
Figure 6.11 The Script Is Added to the Report

Save Script for All Objects  Saves the steps taken to arrive at the current report—including all by variable assignments—as a JSL script in a script window.

Data Table Window  Displays the associated data table as the front-most window.

Non-English versions of JMP can save scripts in either English or your local language. See “Saving Scripts in Different Languages,” p. 325.

Formatting Report Tables

There are many ways you can format your report to meet your needs. The sections below detail how to make changes to the textual portions of your reports.

Reordering Rows (Sorting)

To sort, or rearrange, the rows found in a report table:

1. Right-click (Ctrl-click on the Macintosh) anywhere in a report table.
2. Select Sort by Column.
3. From the window that appears, highlight one or more columns as sort variables. Figure 6.12 shows the sequence of sorting a report table.
Figure 6.12 Sorting a Report Table

4 (Optional) To display the sorted column in ascending order (instead of the default, which is descending order), click the box beside Ascending.

Showing and Hiding Columns

Report tables often have many columns. You can specify which columns you want to view. The table in Figure 6.13 is a Frequencies table showing only the level, count, and probability. The standard error probability and cumulative probability values are hidden. To show or hide columns:

1 Right-click (Ctrl-click on the Macintosh) anywhere in a report table.
2 Select Columns.
3 Select a column to show or hide. Columns with checks beside their names will appear in the table (Figure 6.13).

Figure 6.13 Showing and Hiding Columns

Note: Columns whose names begin with a tilde (~), such as ~Bias, are not applicable to the analysis you ran and will not appear in the table, even if you place checks next to their names.

Adding Outlines and Borders

By default, a report table has no outlines to separate rows and columns. You can tailor the appearance and content of the tables. To add outlines and borders:

1 Right-click (Ctrl-click on the Macintosh) anywhere in a report table.
2. Select **Table Style**.

3. Select one of the options to enhance the appearance of the table (Figure 6.14).

**Figure 6.14** Table Style Menu and Beveled Table (on Windows)

<table>
<thead>
<tr>
<th>Table Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plain</td>
<td>Contains no divider lines or borders.</td>
</tr>
<tr>
<td>Bordered</td>
<td>Contains a border around the table and divider lines between columns.</td>
</tr>
<tr>
<td>Embossed</td>
<td>On Windows and Linux, adds a three-dimensional effect to the border and divider lines. On the Macintosh, changes the border from black to grey.</td>
</tr>
<tr>
<td>Beveled</td>
<td>On Windows, adds a three-dimensional effect and causes the corners of borders to be rounded instead of square. On the Macintosh and Linux, shades the table background grey.</td>
</tr>
</tbody>
</table>

### Changing Numeric Formats and Field Widths

By default, JMP picks what it considers the best format for numbers both in reports and in the data table. For long decimals, this format is as wide as will fit in the column. It also truncates trailing zeros.

To change this in a report table:

1. Double-click anywhere in a report’s numeric column, as shown in Figure 6.15. The Column Numeric Format window appears.

**Figure 6.15** Change the Table’s Format

2. Select a format from the **Format** drop-down menu, as shown in Figure 6.16.
If you select **Fixed Dec**, **Date**, **Time**, or **Duration**, other fields appear. Type in the number of decimals, select the date format, or select the time format from the next box.

4. In the **Field Width** box, type the number of characters you want the column in the report to accommodate. Be sure to type a number that is the largest number of digits you think a value in the column could have.

5. Click **OK**, and the column in the analysis table formats accordingly.

**Changing Table Names and Column Headings**

You can change the name of a report table and a column heading:

1. Double-click the table’s name or heading. It is highlighted, as shown in Figure 6.17.

2. Click it again. The cursor becomes a flashing text insertion bar.

3. Edit its contents.

**Turning a Report Table Into a Data Table**

You can create a JMP data table from a report table. The data table in Figure 6.18 is the JMP data table created from the Frequencies table in an output report. To turn a report table into a data table:

1. Right-click (Ctrl-click on the Macintosh) anywhere in a report table.

2. Select **Make into Data Table** to create a data table from the report table.

Select **Make Combined Table** to search the report for other tables like the one you clicked and combine them into a single data table.
Turning a Report Table Into a Matrix

You can create a JMP matrix from an report table. For example, when working with JMP Scripting Language (JSL), you might want to access a report’s table that has been stored into a JSL variable. Or, you might want to store a report table’s values into a table property as either a table property or as a JSL assignment, which is stored within the data table and is accessible via a script or the formula editor.

To store a table in matrix form into a global variable, into a table property, or into a table property as an assignment:

1. Right-click (Ctrl-click on the Macintosh) anywhere in a report table.
2. Select Make into Matrix, as shown in Figure 6.19.

Figure 6.19 Select Make Into Matrix

3. In the window that appears, tell JMP how you want to store the table, as shown in Figure 6.20.

Figure 6.20 Select into global variable

4. (Optional) Rename the variable or property by typing a new name into the box beside Name.
Selecting Points in Plots

To select a point in a plot, click the point with the arrow cursor. This selects the point as well as the corresponding row in the current data table. To keep all points selected, press the Shift key while you click new points. A point’s label appears when you place the cursor over the point with or without clicking.

Selecting Rows and Columns in Plots, Charts, and Graphs

All graphs and plots that represent the same data table are linked to each other and to the corresponding data table. When you click points in plots or bars of a graph, the corresponding rows highlight in the data table. The example in Figure 6.21 shows a histogram with the SPEEDYTYPE bar highlighted, and the corresponding rows highlighted in the table. You can also extend the selection of bars in a histogram by pressing Shift and then clicking them.

Figure 6.21 Highlighting Rows In a Histogram

Selecting a Rectangular Area of Points

You can select all points that fall in a rectangular area using the arrow cursor. Click and drag the arrow to highlight points. Alternatively, you can use the brush tool. As you move the brush over the graph, points that fall within the rectangle are selected. Any points marked in the data table as hidden (see “Hiding Rows and Columns,” p. 131) are not selected.

To select points using the brush tool:

1. Click the brush tool ( ) in the toolbar.
2. Click and hold the cursor (now brush-shaped) in a plot. A rectangle appears.
3. Move the rectangle over points. As it passes over them, they appear larger and are highlighted both in the plot and in the active data table.

Note: To keep all points selected as you move the brush-shaped cursor over points, press the Shift key before you click in the plot.
4 Release, and the points within the rectangle remain selected.

Optional ways of using the brush tool include:

- To change the size of the selection rectangle, press the Alt key (Option key on the Macintosh and Alt-Shift on Linux) before you click in the plot. This shape acts like a slicing tool that can traverse and highlight slices of points across either axis.
- If you press the Ctrl key (Command key on the Macintosh) and drag the brush tool, the selection status of points within the rectangle continuously inverts. This causes selected points and row numbers in the data table to flash.
- If you Ctrl-Alt-drag (Command-Option-drag on the Macintosh) with the brush tool and then release (push the rectangle), the rectangle bounces in the frame. The speed and direction you push (or drag) the cursor determines the speed and direction of the bouncing rectangle. Click the report to stop the rectangle.

Selecting an Irregular-Shaped Area of Points

You can use the lasso tool to select points that fall in an irregular-shaped area. Any points marked in the data table as hidden (see “Hiding Rows and Columns,” p. 131) are not selected.

To select points within an irregular-shaped area:
1 Click the lasso tool ( ) in the toolbar.
2 Click and hold the cursor (now lasso-shaped) in a plot.

Note: To keep all points selected as you drag the lasso around several sets of points, press the Shift key before you click in the plot.

3 Drag the lasso around any set of points.

4 Release, and JMP automatically closes the lasso and highlights the points within the enclosed area.
Using Markers

Markers are points on a graph that represent data. Once they are changed from their default setting, they also appear next to rows in the data table. The following sections show you how to change marker shape, size, color, etc.

Changing Marker Shape

You can assign a character from the JMP markers palette to replace the standard points in scatterplots and spinning plots. These markers also appear next to row numbers in the data table.

1. Highlight the marker(s) whose shape you would like to change.
2. Right-click (Ctrl-click on the Macintosh) anywhere in the graph. In a histogram, right-click the box plot area on the right.
3. Select Row Markers. The menu in Figure 6.22 appears.

![Figure 6.22 Row Markers](image)

4. Select a marker shape from the options that appear.

Changing Marker Colors

You can assign any color to highlighted rows. When you do this, the points in scatterplots and spinning plots appear in the color you select from the Colors palette. The active color assigned to a row appears next to the row number in the data grid.

To change the color of markers (points) on a graph:

1. Highlight the marker(s) whose shape you would like to change.
2. Right-click (Ctrl-click on the Macintosh) anywhere in a graph. In a histogram, right-click the box plot area on the right.
3. Select **Row Colors**. The **Colors** palette appears.
4. Select one of the colors.

### Changing Marker Size

To increase or decrease the size of markers (points) on a graph:

1. Right-click (Ctrl-click on the Macintosh) anywhere in a graph. Ctrl-right-click (Command-Ctrl-click on the Macintosh) to broadcast the command and apply it to all plots of the same type located in the same window. In a histogram, right-click the box plot area on the right.
2. Select **Marker Size**. The menu in Figure 6.23 appears.

![Figure 6.23 Select a Marker Size](image)

3. Select one of the marker sizes listed. **Preferred Size** is the size that JMP estimates to be the best size for the graph.
Changing the Marker Drawing Mode and Transparency

When working with a large number of markers on a graph, the markers may appear crowded. If this is the case, you may need to alter the transparency to gain a better view. Altering the transparency may also affect the marker drawing mode, which is the mode JMP uses when it refreshes a report window. As it draws markers on a plot, it uses one of two speeds: normal or fast.

To change the marker drawing speed:

1. Right-click (Ctrl-click on the Macintosh) anywhere in a graph. In a histogram, right-click the box plot area on the right.
2. Select Marker Drawing Mode. The menu in Figure 6.24 appears.

![Figure 6.24 Select a Marker Drawing Mode](image)

3. Select either Normal or Fast.
   - **Normal**: If JMP is in normal drawing mode and the number of markers in a graph are more than the specified threshold number, JMP automatically switches to fast mode. See “Marker Drawing Speed Threshold,” p. 331, for details about setting the marker threshold.
   - **Fast**: Graphs displaying a large number of markers will appear faster if you set the marker drawing speed to Fast. Note that when the drawing speed is set to Fast, marker size reverts to Preferred Size and marker transparency settings revert to the default opaqueness.

   **Note**: Information about the Outlined selection in the Marker Drawing Mode menu appears in the section “Adding Outlines Around Markers,” p. 188.

Adding Outlines Around Markers

You can add a black outline, or frame, to markers in a plot. Outlined markers are available at the medium, larger, XL, XXL, and XXXL marker size (see “Changing Marker Size,” p. 187, for details). To add outlines:

1. Right-click a plot or graph.
2. Select Marker Drawing Mode, as shown in Figure 6.24.
3 Select **Outlined**.

To make the most of an outline, it is best if your marker is a color other than black. To change marker colors:

1. Highlight the markers whose color you wish to change.
2. Right-click (Ctrl-click on the Macintosh) anywhere in the graph.
3. Select **Row Colors**.
4. Select a marker color from the options that appear. The outline appears on highlighted points and rows.

### Specifying Marker Transparency

You can change the transparency of markers (points) on a graph, which, for example, allows you to control the visibility of overlapping points.

Note that marker transparency settings revert to the default opaqueness and marker size reverts to **Preferred Size** when the drawing speed is set to **Fast**.

To adjust markers’ transparency:

1. Right-click anywhere in a graph. In a histogram, right-click the box plot area on the right.

2. Select **Transparency**. The window shown in Figure 6.25 appears.

**Figure 6.25** Transparency Window

3. Type the level of transparency you want the markers (points) to have on the graph. A value of 1 indicates total opaqueness, while 0 indicates invisibility. Values between 1 and 0 are semi-transparent.
4. Click **OK**.
Excluding and Hiding Markers

Using the Exclude/Unexclude command, you can exclude highlighted rows from statistical analyses. Data remain excluded until you select Rows > Exclude/Unexclude for those highlighted rows.

Warning: Excluded data are not automatically hidden in plots even though they are excluded from calculations in text reports and graphs.

Using the Hide/Unhide command, you can suppress (hide) the appearance of highlighted points in scatterplots. For example, you can exclude points from analysis and then hide those same points in scatterplots. The data remain hidden until you select Rows > Hide/Unhide for highlighted hidden rows.

Warning: Hidden points are not automatically excluded from statistical computations that affect text reports and graphs, even though they are not displayed in the plots. To exclude hidden observations from analyses, you must highlight them and select Rows > Exclude/Unexclude characteristic.

To exclude or hide markers (points) from analyses:

1. Highlight the marker(s) you would like to exclude or hide.
2. Right-click (Ctrl-click on the Macintosh) anywhere in a graph.
3. Select Row Exclude or Row Hide.

Adding Labels to Markers

When you position the arrow cursor over a point in a plot, the point’s label appears. By default, the label is the row number. There are two ways you can customize the label:

- You can change the label so it displays values found in one or more columns instead of the row number.
- You can enable the label to appear always, not just when you position the cursor over points.

To change the label so it displays values found in one or more columns instead of the row number:

1. In the data table, highlight the column(s) whose values you want to appear as the label in plots.
2. Select Label/Unlabel from one of the following places, as shown in Figure 6.26:
   - the Cols menu in the main menu
   - the red triangle icon in the columns panel
- the red triangle icon in the upper right corner of the data grid

**Figure 6.26** Different Ways to Access Column Characteristic Commands

A label, or yellow tag, icon ( ) beside the column name in the columns panel indicates that points on plots will be identified by the column value. If there are multiple labeled columns, their values appear on plots separated by a comma. Data remain labeled until you highlight the column and select **Label/Unlabel** again.

To enable the label to appear always, not just when you position the cursor over points:

1. Highlight the point(s) whose label you want to always appear in plots.
2. Right-click (Ctrl-click on the Macintosh) anywhere in a graph. In a histogram, right-click the box plot area on the right.
3. Select **Row Label**, as shown in Figure 6.27.

**Figure 6.27** Select Row Label

A label, or yellow tag, icon ( ) beside the row number in the data table indicates that points on plots corresponding to the row will appear with a label.
Changing Marker Shape or Colors Based On Values

In some plots, you can change marker shapes and/or colors based on the values of points by adding a row legend. It is called a row legend because JMP automatically inserts a legend using row color or row marker settings (Figure 6.30). When you assign markers or colors in this way, it assigns the characteristic(s) to all points in a graph, regardless of what points you have selected, and all previous marker and color settings are overwritten.

To add shapes or colors based on marker values:
1 Right-click (Ctrl-click on the Macintosh) anywhere in a graph. In a histogram, right-click the box plot area on the right.
2 Select Row Legend, as shown in Figure 6.28.

Figure 6.28 Select Row Legend

3 In the window that appears (Figure 6.29), highlight the column whose values you want to color and/or mark.

Figure 6.29 Adding a Row Legend

4 Refine your row legend using the following options:
– Click **Set Color by Value** to have the values in the highlighted column determine the row/legend color.

– Click **Set Marker by Value** to have the values in the highlighted column determine the row marker used in the graph.

– Click **Make Window with Legend** to include a legend in the report window that tells you what color and/or shape corresponds to which value. This is available only for ordinal and nominal columns. If you would like a legend for a continuous column, select **Continuous Scale**, as described below.

– Click **Keep current colors or markers if already consistent** to include a legend that honors any previously-specified color ranges, such as if you have set up a column’s color range by clicking the column name and selecting **Column Info > Column Properties > Value Colors**. For details, see “Assigning Value Color Ranges,” p. 149

– Click **Continuous Scale** to assign colors on a spectrum that corresponds to the ascending or descending order of the values. Use this option when the highlighted column contains continuous values. JMP assigns colors in the order of pink, red, yellow, yellow-green, light blue, and blue to the numbers in the order of largest to smallest. Pink and red are the high values while light blue and blue are the low values.

Note that colors or markers may be reused if there are more values than available colors or markers.

**Removing the Legend**

After you make the legend, right-click it to change the colors and the markers or to remove the legend. To remove colors and/or markers, highlight the row(s) in the data table and select **Rows > Clear Row States** (Figure 6.30).

**Figure 6.30** Right-Click the Legend to Remove Legend
Altering Plot and Chart Appearances

There are many ways you can format your report to meet your needs. The sections below detail how to make changes to the graphical portions of your output reports.

Resizing Plots and Graphs

There are two main ways to resize plots and graphs: using the click and drag method, and resizing it according to pixel size.

Using Click and Drag

To resize a plot or graph using the click and drag method:

1. Place the cursor on the right edge, bottom edge, or lower-right corner of the plot frame. The cursor changes to a small double-arrow pointer, as shown in Figure 6.31.

![Figure 6.31 Resizing a Plot or Graph](image)

2. Click and drag to change the size of the plot. When you resize, the height and width of all plots in that frame adjust independently of other frames in the same report window. Use the table below to adjust the plot how you want it:

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust the plot frame but preserve the proportions (aspect ratio)</td>
<td>Press the Shift key and click and drag the corner of the frame.</td>
</tr>
<tr>
<td>Adjust a plot in 8-pixel increments</td>
<td>Press the Alt key (Option key on the Macintosh) and click and drag the corner of the frame.</td>
</tr>
<tr>
<td>Adjust all plots of the same type simultaneously</td>
<td>Press the Ctrl key (Command key on the Macintosh) and click and drag the corner of one of the plots. For example, if you do this for one scatterplot, all scatterplots in the window resize together and the mosaic plots are unchanged.</td>
</tr>
</tbody>
</table>

Specifying Pixel Size

To resize a plot or graph to a specific pixel size:

1. Right-click (Ctrl-click on the Macintosh) the plot or graph.
2. Select **Size/Scale**. To enter the number of pixels for the frame’s height and width, select **Frame Size**. Select **Size to Isometric** when the \( x \)- and \( y \)-axes are measured in the same units and you want distances on the graph to be represented accurately regardless of direction.
3 Enter the desired measurements in pixel amounts, as shown in Figure 6.33.

Figure 6.33 Specify the Desired Size

Zooming In and Out

The magnifier ( ) lets you automatically zoom in on any area of a plot. When you click the magnifier, the point or area where you click becomes the center of a new view of the data. The scale of the new view enlarges, giving you a closer look at interesting points or patterns. You can:

- Click and drag the magnifier to focus in on a particular region of the plot.
- On a ternary plot, drag the magnifier to zoom the triangular axes.
- Zoom repeatedly to look closer at the data.
- Ctrl-click once to return to your previous state before the last zoom.
- Double-click or Alt-click the magnifier to restore the original plot.

The example in Figure 6.34 dramatically illustrates the magnifier using Pollen.jmp. To follow this example, open Pollen.jmp from the Sample Data folder that was installed when you installed JMP.

In this example, the data were devised with a hidden pattern (message) buried in over 3,800 points. Selecting Analysis > Fit Y by X displays the whole table as the dense cloud shown to the left in
Figure 6.34. Clicking the magnifier twice produces the plot in the middle, and clicking twice more reveals the surprise message shown in the plot on the right.

**Figure 6.34** Example of Zooming with the Magnifier Tool

### Changing Line Widths

After fitting a line to a graph, or producing a graph with a line already present, you can adjust the width of the line:

1. Right-click (Ctrl-click on the Macintosh) anywhere in a graph.

2. Select **Line Width Scale**.

3. Select to increase the current line width one to three times its default width. Or, select **Other** and specify a larger or smaller number. Select **Scale with Font** to increase the line size as you increase JMP’s display font size using **Window > Font Sizes** (Windows and Linux) and **View > Make Text Bigger/Smaller** (Macintosh).

### Changing the Background or Histogram Bar Color

To change the background color of any graph:

1. Right-click (Ctrl-click on the Macintosh) anywhere in a graph. In a histogram, right-click the box plot area on the right.
2 Select **Background Color**.

3 On the Macintosh, click a color on the circle to select a pre-set color, and use the slider on the right of the circle to increase or decrease the intensity of the color.

On Windows and Linux, click a color square from the *Basic colors* area to select a pre-set color, or create a custom color by following these steps:

   a. Click a color band from the large color area on the right of the window. Or, if you know the values of the color you would like to use, type the **Red**, **Green**, and **Blue** values.

   b. Use the slider on the right of the large color area to increase or decrease the intensity of the color. If you know the intensity of the colors you would like to use, type the **Hue**, **Sat.** (Saturation), **Lum.** (Luminance).

   c. Click **Add to Custom Colors** (Figure 6.35). The color is added to an empty square in the *Custom colors* area.

*Figure 6.35 Background Color Options (Windows)*

To change the color of the bars in a histogram:

1 Right-click (Ctrl-click on the Macintosh) anywhere in a histogram and select **Histogram Color**.
2. Click a color square from the color area.

**Displaying Axis Coordinates**

You can measure points and distances in graphs, or easily find the exact value, or coordinates, of points and distances on plots and graphs. To do this, click the crosshairs tool ( ), then click and hold anywhere on a graph. The coordinate values appear where the crosshairs intersect the vertical and horizontal axis as you drag the crosshairs within a plot.

On a fitted line or curve, the crosshairs identify the response value for any predicted value. On a ternary plot, this tool displays triangular crosshair lines.

**Scrolling and Scaling Axes**

The hand tool (also known as the grabber tool) ( ) provides a way to change the axes and view of a plot:

- On a y-axis, dragging or scales the y-axis; dragging scrolls the y-axis.
- On an x-axis, dragging scrolls the x-axis; dragging or scales the x-axis.
Customizing Axes and Axis Labels

Double-click a numeric axis to customize it using the Axis Specification window. Or, right-click the axis area and select **Axis Settings** to access the window.

Customization features in the window depend on the data type of the axis and the specific platform JMP uses to create the plot or chart. Figure 6.36 shows a typical Axis Specification window for numeric axes.

**Figure 6.36** The Axis Specification Window for a Numeric Axis

The following sections describe how to use the axis specification window and what tasks you can accomplish with it.

**Changing the Axis Scale Type**

When viewing a graph with a numeric axis, you can change the axis scale:


2. Select a scale type: either linear or log.

To set a default scale type for a variable, which avoids making this change every time you run an analysis, see “**Changing Columns’ Default Axis Settings**,” p. 150.
Changing the Numeric Format of an Axis

For plots and charts that contain a numeric axis area, you can change the format of the axis. To change the numeric format while viewing a graph:

2. In the box beside **Format**, use the drop-down menu to select an option. See “**Numeric Format Options**,” p. 61, for details.

3. If you selected:
   - **Date** or **Time** from the **Format** drop-down menu in the previous step, use the drop-down menu to the right of the selection you just made to select date increments for tick marks. See “**Numeric Format Options**,” p. 61, for descriptions of options. You will also need to specify the format of the increments, as described in “**Changing the Axis Increments**,” p. 201.
   - **Fixed Dec** from the **Format** drop-down menu in the previous step, a text box appears beside the **Format** box. Type the number of decimal places you want JMP to display.

**Note:** When you change the numeric format of an axis, you do not change the numeric format of the way the values appear in the corresponding data table. To change the way a date or time appears in a data table, see “**Choosing Numeric Formats**,” p. 60.

Selecting a date interval from the date increment drop-down menu divides the JMP date (number of seconds) into the appropriate units to give the plot scale you want for your data. The date axis must be a column with a JMP date value and appear in the Axis Specification window in the date format found in the Column Info window. However, you can use the Axis Specification window to format the date any way you want it to be displayed in the plot.

Establishing the Minimum and Maximum Axis Values

For plots and charts that contain a numeric axis area, you can change the minimum (**Min**) and maximum (**Max**) values you want the graph to display.
To change the minimum and maximum axis values while viewing a graph:

1. Double-click a numeric axis. Or, right-click a numeric axis and select **Axis Settings**. The axis specification window appears.
2. Type in a value for the minimum (Min) and maximum (Max) values you want the graph to display.

You can restore the default minimum and maximum axis settings of a numeric axis by right-clicking a numeric axis and selecting **Revert Axis**.

To set a default minimum and maximum axis value for a variable, which avoids making this change every time you run an analysis, see “Changing Columns’ Default Axis Settings,” p. 150.

The example on the right in Figure 6.37 is an enlargement of the point cluster that shows between -200 and 500 in the plot to the left. The enlarged plot is obtained by reassigning the maximum and minimum axis values and changing the number of minor tick marks (see “Adding Minor Tick Marks,” p. 205, for details).

**Figure 6.37** Rescale Axis to Enlarge a Plot Section

### Changing the Axis Increments

While viewing a graph, you can change the axis increments:

1. Double-click a numeric axis. Or, right-click a numeric axis and select **Axis Settings**. The Axis Specification window appears.
2. In the text box beside **Increment**, type the number of increments you want displayed.
3. If the format of the axis is **Date** or **Time** (as shown in the **Format** drop-down menu), there will be another drop-down menu that appears beside **Increment** (see Figure 6.38). From that box, select which format you want the increments to take.
To set a default axis increment for a variable, which avoids making this change every time you run an analysis, see “Changing Columns’ Default Axis Settings,” p. 150.

**Adding and Removing Axis Labels**

You can add or remove labels in a numeric axis. To add an axis label:

1. Right-click a numeric axis and select Add Axis Label.
2. Type a name for the axis label. The axis area enlarges to hold the number of label lines you enter.

This command can be used multiple times to add multiple labels. To edit the label after it has been added to the axis, click it and it will turn into an edit box.

To remove an axis label, right-click a numeric axis and select Remove Axis Label. The last label added is removed.

**Changing Axis Label Font**

You can modify the axis label font on any axis type. When you modify it, your change only applies to the active graph. To set the default axis label font, see “Customizing Fonts and Languages,” p. 333.

To change the current font type and size:

1. Right-click an axis label.
2. Select **Font**.
3. Make your selections in the window.

To change the font color:
1. Right-click an axis label.
2. Select **Font Color**.
3. Select a color for the text from the color palette provided.

**Rotating Axis Labels**

You can modify the axis label on any axis type. To rotate an axis label:
1. Right-click an axis label.
2. Select **Rotate Text**.
3. Select which direction to rotate the text: **Horizontal**, **Left**, or **Right**.

To set a default axis label position for a variable, which avoids making this change every time you run an analysis, see “Changing Columns’ Default Axis Settings,” p. 150.

**Copying and Pasting Graph Contents**

After customizing a graph by adding elements such as a fitted line, you can copy and paste the contents from one graph to another compatible graph:
1. Right-click the graph you have customized.
2. Select **Edit > Copy Frame Contents**.
3. Right-click the graph to which you would like to copy the settings.
4 Select **Edit > Paste Frame Contents.**

### Copying and Pasting Axis Settings

After customizing an axis (as described in “Customizing Axes and Axis Labels,” p. 199), you can copy and paste your new settings to another axis:

1. Right-click the axis you have customized.
2. Select **Edit > Copy Axis Settings.**
3. Right-click the axis to which you would like to copy the settings.
4. Select **Edit > Paste Axis Settings.**

### Changing the Values’ Order

Data in a JMP report might not appear in the order you prefer. To give data a specific order so it appears that way in a report, assign the column the Value Ordering property before running the analysis, as described in “Ordering Values in Columns,” p. 147.

If your values include any of the following, they will automatically appear in the appropriate order in reports:

- January, February, March, April, May, June, July, August, September, October, November, December
- Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec
- Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday
- Very Low, Low, Medium Low, Medium, Medium High, High, Very High
- Strongly Disagree, Disagree, Neutral, Indifferent, Agree, Strongly Agree
- Failing, Unacceptable, Very Poor, Poor, Bad, Acceptable, Average, Good, Better, Very Good, Excellent, Best

### Customizing Tick Marks and Tick Mark Labels

On a numeric axis, you can add and remove tick marks, add and remove gridlines, and add minor tick marks. You can also change the font type, size, and style (bold or italic), the color of the text, rotate the axis labels, or add an outline box to nominal or ordinal axes’ tick mark labels. The following sections describe how to customize them.
Adding Tick Marks and Gridlines

For plots and charts that contain a numeric axis area, you can show or hide tick marks and gridlines. To do this, double-click a numeric axis. Or, right-click a numeric axis and select **Axis Settings**. The Axis Specification window appears, as shown in Figure 6.39. Use the table below to show or hide tick marks and gridlines.

Figure 6.39 Show or Hide Tick Marks and Gridlines

![Figure 6.39](image)

Table 6.1 Showing Tick Marks and Gridlines

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show major tick marks</td>
<td>Click the box to the right of <strong>Major</strong> and underneath <strong>Tickmark</strong>.</td>
</tr>
<tr>
<td>Show minor tick marks</td>
<td>Click the box to the right of <strong>Minor</strong> and underneath <strong>Tickmark</strong>.</td>
</tr>
<tr>
<td>Show gridlines for minor tick mark increments</td>
<td>Click the box to the right of <strong>Minor</strong> and underneath <strong>Gridline</strong>.</td>
</tr>
<tr>
<td>Show gridlines for major tick mark increments</td>
<td>Click the box to the right of <strong>Major</strong> and underneath <strong>Gridline</strong>.</td>
</tr>
</tbody>
</table>

To set default tickmarks for a variable, which avoids making this change every time you run an analysis, see “Changing Columns’ Default Axis Settings,” p. 150.

Adding Minor Tick Marks

To add tick marks to a numeric axis, or to change the number of minor tick marks that appear on a numeric axis:

1. Double-click the tick mark. Or right-click it and select **Axis Settings**. The Axis Specification window appears.
2. In the box beside **# Minor Ticks**, type the number of minor tick marks you want to appear between major tick marks. See Figure 6.40.
3 Click the box to the right of **Minor** and below **Tickmark** to indicate that you want the tick marks to appear on the axis. See Figure 6.40.

**Figure 6.40** Changing the Number of Minor Tick Marks

To set default minor tick marks for a variable, which avoids making this change every time you run an analysis, see “Changing Columns’ Default Axis Settings,” p. 150.

**Adjusting the Field Width of Labels**

On plots and charts that contain a numeric axis area, you can adjust the width of the tick mark labels so that they show large values with many decimal places or only a small amount of space/truncated values. If the field width is set too small, your tick mark labels will appear as an ellipsis (three periods).

To change the field width while viewing a graph:

1 Double-click a numeric axis. Or, right-click and select **Axis Settings**. The Axis Specification window appears.

2 In the **Field Width** text box, type the number of characters needed to accommodate the largest number of digits or characters you think the new column could have. The maximum field width is 40 for numeric values. There is no limit for character values.

Note that in increasing/decreasing the field width of tick mark labels, you do not change the field width for the cells that contain the values in the corresponding data table. To change the field width of cells in a data table, see the section “Choosing Numeric Formats,” p. 60.

**Changing Tick Mark Label Font Types and Sizes**

You can modify a numeric axis tick label’s font type, size, and style (bold and italic). To change font type and size:

1 Double-click the tick label. Or, right-click it and select **Axis Settings**. The Axis Specification window appears.

2 Select **Font**, and make your selections.
Note: To make global changes to all types of axes’ font types and sizes, select File > Preferences (JMP > Preferences on the Macintosh). Click the Fonts tab, then click Axis.

Rotating Tick Mark Labels
To rotate tick mark labels vertically or horizontally:
1. Double-click the tick label. Or, right-click it and select Axis Settings. The Axis Specification window appears. On a nominal axis, right click the tick label and select Rotated Tick Labels.
Figure 6.41 Rotating Tick Labels on a Nominal or Ordinal Axis

2 Select Rotated Tick Labels, as shown in Figure 6.41
To rotate them back, complete the steps again.

Extending Divider Lines and Frames
Extending the vertical divider line(s) between tick labels is useful when there are many levels of a nominal or ordinal variable.
To extend the divider line to the x-axis labels:
1 Right-click a nominal or ordinal axis.
2 Select Divider Lines to add the lines, or Lower Frame to add a frame around the axis area.
Adding Reference Lines

To add reference lines to graphs:

1. Double-click a numeric axis. Or, right-click a numeric axis and select **Axis Settings**. The Axis Specification window appears.

2. In the text box to the left of the **Add Ref Line** button, type the value to which you want the reference line to correspond. This will be the position on the graph at which the line will be placed, as shown in Figure 6.42.

3. Further customize the reference line by choosing either of these options:

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Give the line a color</td>
<td>Click the color bar drop-down menu and select a color, as shown in Figure 6.42.</td>
</tr>
<tr>
<td>Use a stippled line</td>
<td>Click the line drop-down menu and select one of the line types, as shown in Figure 6.42.</td>
</tr>
</tbody>
</table>

4. Click the **Add Ref Line** button. The value will move into the box to the right of the **Add Ref Line** button, indicating that it will be placed on the graph.

5. To add more lines, repeat the above steps.
Figure 6.42 Adding a Reference Line

To set a default reference line for a variable, which avoids making this change every time you run an analysis, see “Changing Columns’ Default Axis Settings,” p. 150.

Adding Elements to a Report

You can add text notes, lines, polygons, ovals, and rectangles to a report using graphics tools found in the toolbar.

Adding an Annotative Note

You can add editable text notes to a JMP report using the annotate tool ( ). To add an annotation:

1. Select the annotate tool ( ) from the Tools menu or toolbar.
2. Click the location in the window where you want to add the annotation. Or, click-and-drag to size
the annotation note. A white editable text box is displayed.

3 Enter text.
4 Click outside the annotation. The annotation turns yellow.
5 Right-click the annotation to access the following options:

**Background Color**  Provides you with a color palette, from which you can select the background color for the annotation.

**Text Color**  Provides you with a color palette, from which you can select the color for the annotation's text. The color of the font also defines the color of the annotation outline. If you select the same color for both the background and the font, the font does not show except for black and white. A black font on a black background changes to white, and a white font on a white background appears black.

**Font**  Lets you change the current font type, style, and size. To change the default font, see “Customizing Fonts and Languages,” p. 333.

**Tag line**  Attaches a line to the annotation that points to a place in the text, as shown below. To move the line with the annotation to a new position, press the Ctrl key (Command key on the Macintosh) and drag the annotation.

**Filled**  Removes the background color from the annotation so it looks transparent. A transparent note is handy for putting titles and footnotes on a graph.

**Reanchor**  Reanchors the annotation.

**Delete**  Deletes the entire annotation.
**Note:** When adding multiple annotations, press the Shift key when selecting the annotation tool for the first time. This causes subsequent clicks to add an annotation, and you will not have to select the annotate tool from the toolbar before the addition of each annotation.

Once you’ve added an annotation, you can do the following:

**Table 6.2 Using Annotations**

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add to or edit an annotation</td>
<td>Click inside the text box.</td>
</tr>
<tr>
<td>Move an annotation</td>
<td>Click inside the annotation box and drag it. When an annotation is moved, it becomes selected, as indicated by a double blue line with handles around the perimeter.</td>
</tr>
<tr>
<td>Resize an annotation</td>
<td>Place the cursor on the handle of a selected note (showing in the middle of the edges and in the corners) and it appears as a single crossed arrow; drag to resize the annotation.</td>
</tr>
<tr>
<td>Delete an annotation</td>
<td>Highlight the annotation by clicking the handle of a note. Then press the Delete (or Backspace) key.</td>
</tr>
</tbody>
</table>

**Adding Shapes**

You can add editable lines, polygons, and simple shapes (ovals or rectangles) to a JMP report using the drawing tools (⃦ ⃦ ⃦). The following sections describe how each of these tools can be used.

**Note:** Each graphics tool remembers the most recent options chosen. This is useful if you need many annotations or other graphics with the same characteristics. For example, suppose you want many thick green lines with an arrow on one end. Create a line the way you want it, set the options, and subsequent lines appear with those options in effect. The options persist until you change them.

**Adding a Line**

To add a line to a report window:

1. Click the line tool (⃦) in the tool palette.
2. Click and drag where you want to insert the line. The line appears selected, showing handles on both ends, such as is shown in Figure 6.43.
3. Click and drag the line to move it.
4. Click a handle and drag to rotate the line.
5. Right-click (Ctrl-click on the Macintosh) a line for a menu of options to tailor the appearance of the line, as shown in Figure 6.43.
Adding Elements to a Report

Adding a Polygon or Spline

To add a polygon (also known as a spline) to a report window:

1. Click the polygon tool ( ) in the tool palette.
2. Click to create the beginning point for the first side of a polygon.
3. Click again at the location where you want to complete the first side and begin an adjacent side. A square selection box with handles appears around the polygon area.
4. Click a third time to complete the second side.
5. Continue this process until the polygon is the way you want it. Each time a side is complete, the selection box adjusts to encompass the polygon sides.
6. Double-click to release the polygon tool.

Once you've added a polygon, you can do the following:

Table 6.3 Working with Polygons

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select or deselect the polygon</td>
<td>Click the edge of a completed polygon.</td>
</tr>
<tr>
<td>Resize the polygon</td>
<td>Select it and drag one of the selection box's handles.</td>
</tr>
<tr>
<td>Move the polygon</td>
<td>Click between the box's handles and drag the selection box.</td>
</tr>
<tr>
<td>Change the number of sides of</td>
<td>Click and drag the sides to form the new shape.</td>
</tr>
<tr>
<td>the polygon</td>
<td></td>
</tr>
</tbody>
</table>

Select the polygon, then right-click (Ctrl-click on the Macintosh) it for a menu of options to tailor its appearance, as shown in Figure 6.44.
Figure 6.44  Right-Click a Polygon to Tailor Its Appearance.

**Filled**  Alternately fills or empties the area of the shape.

**Raised**  Displays thick shaded lines around the shape. If the shape is also filled, the lower edge of the figure appears raised, giving it a three-dimensional look.

**Smooth**  Smooths the vertices of a polygon to produce a Bezier curve. The smoothed figure is reshaped and resized the same way as the polygon, and can be filled and raised.

**Closed**  Alternately opens or closes the last segment of a polygon.

**Color**  Displays the JMP color palette to change the color of the shape’s sides, and its fill color when the Filled option is in effect.

**Reanchor**  Reanchors the shape.

**Delete**  Removes the shape from the report. You can also remove the shape by selecting it and then pressing the Delete (or Backspace) key.

### Adding an Oval or Rectangle

To add an oval or rectangle to a report window:

1. Click the simple shape tool ( ) in the tool palette.
2. Click and drag where you want to insert the shape. An oval appears with a selection box around it.
3. (optional) Right-click (Ctrl-click on the Macintosh) the edge of the oval and select **Shape** to turn the oval into a rectangle.

Once you've added the shape, you can do the following:

- Select the shape and drag one of the selection box handles to reshape or resize.
- Click and drag an edge of the selection box (located between the handles) to move it.
- Select the shape, then right-click (Ctrl-click on the Macintosh) it for a menu of options to tailor its appearance, as shown in Figure 6.45.
Adding Elements to a Report

Figure 6.45 Right-Click an Oval or Rectangle to Tailor Its Appearance.

**Filled** Alternately fills or empties the area of the shape.

**Raised** Displays thick shaded lines around the shape. If the shape is also filled, the lower edge of the figure appears raised, giving it a three-dimensional look.

**Shape** Displays a submenu whose options transform the shape into either an oval or a rectangle when selected.

**Color** Displays the JMP color palette to change the color of the shape's sides and its fill color when the **Filled** option is in effect.

**Reanchor** Reanchors the shape

**Delete** Removes the shape from the report. You can also remove the shape by selecting it and then pressing the Delete (or Backspace) key.

**Adding Graphics (Windows and Macintosh Only)**

To enhance your graphs with logos, pictures, or any other type of graphic, you can paste it into a report in .bmp, .jpeg, or .png format. You can also drag and drop graphics into reports.

To add graphics:
1. Open the graphic file and select the graphic. Copy it to the computer’s clipboard.
2. Right-click inside a graph.
3. Select **Paste**. The graphic is inserted at the point in the graph that you right-clicked.

You can also add the graphic to the end of a report window by copying the graphic into computer memory, making sure the report is the active window and selecting **Edit > Paste**.

**Adding and Editing Graphics Scripts**

Once you have a report, you can add a script that inserts graphical elements to the report.

To add a graphics script to a report, right-click the graph and select **Customize**.

**Options**

The options in the customize menu follow (see Figure 6.48).

**Line Color** changes the color of the line. Click to choose from any color in the dialog. Right-click for a selection of 65 colors in the color menu. See “Changing Color Schemes,” p. 332.
**Line Style**  changes the style of the line. Click to choose from a selection of five different styles (see Figure 6.46).

**Line Width**  changes the width of the line. Click in the box and type the desired line width.

**Marker**  changes the marker shape or size. Left-click to change the shape. Right-click to change the size. For more information on markers, refer to “Using Markers,” p. 186.

**Line of Fit Marker**  changes the markers specific to the line points. These markers relate only to the Line of Fit properties. Left-click to change the shape. Right-click to change the size.

**Text Color**  changes the color of the text.

**Font**  changes the font, style, and size of the text (see Figure 6.47).

**Text Style**  changes the style of the text. Center, left, or right justify the text. The last option is fill, which fills in the background of the text with the color specified.

**Fill Color**  changes the color of the Fit Confidence Region.

**Transparency**  changes the marker or label opacity. Type the level of transparency you want the markers (points) to have on the graph. The degrees of opacity ranges from 1 (opaque) to 0 (clear). See “Changing the Marker Drawing Mode and Transparency,” p. 188.

To apply transparency to an entire graph, see “Specifying Marker Transparency,” p. 189.

**Figure 6.46**  Line Style

![Line Style Example](image)

**Figure 6.47**  Font Menu

![Font Menu Example](image)

Figure 6.48 shows all the options available for customization.
Applying a Script to a Graph

To apply a script to the graph, follow these steps. In this example, a sine wave is applied to the graph.

1. Click the plus (+) button (see Figure 6.49). This opens up the script window.

2. In the Customize Graph dialog, double-click Script and type “My Sine Wave.”

3. Click the Samples drop-down menu and select Sine Wave.

4. Click OK or Apply.

The sine wave is now overlaid on top of the graph.

Customize Graph Menus

You have several menu options when you apply scripts to graphs.

- Click the Templates drop-down menu to get started (see Figure 6.50).
**Figure 6.50** Templates

- Click the Samples drop-down menu for a list of samples.

**Figure 6.51** Samples

- To delete a script, follow these steps.
  a. Click the script that you want to delete in the left panel. The script that you click on is highlighted, as shown in Figure 6.52.

**Figure 6.52** Scripts

  b. Click the minus (-) button.

**Note:** Only custom scripts can be deleted or moved (such as My Sine Wave). You cannot delete or move any built-in scripts (such as Line of Fit).

- To draw a script on top of or underneath another script, move the script in the drawing order. The drawing order is the order in the list (see Figure 6.52). Follow these steps.
  a. Click the script that you want to move in the left panel. The script that you click on is highlighted.

  b. Click one of the arrows to move the script.
The arrows are used to move the selected script in the list. The order of the list corresponds to the layers in the graph.

**Script Submenu**

The customization menu applies to all script submenus in JMP. See “Saving Your Steps as a Script,” p. 177.

**Copying**

To copy line graph content from one graph to another, see “Copying and Pasting Graph Contents,” p. 203.

**Copying Customizations**

To copy a sine wave, follow these steps.

1. Right-click in the graph that you want to customize and select **Customize**.
2. Click the plus (+) button.
   
   This opens up the script window.

3. In the Customize Graph dialog, double-click **Script** and type “My Sine Wave.”
4. Click the Samples drop-down menu and select **Sine Wave**.
5. Click **OK**.

   The sine wave is now overlaid on top of the customized graph.

6. Right-click in the customized graph and select **Edit > Copy Customizations**.
7. Right-click in the graph to which you would like to copy the settings and select **Edit > Paste Customizations**.

   The customized sine wave is now copied onto the graph.

**Note:** The copy customizations feature only copies what you added (such as My Sine Wave). It does not copy all contents in the graph.
You can perform a wide variety of data management tasks on JMP data:

- Create a new data table from a subset of rows and columns from another data table
- Sort by any number of columns
- Stack multiple columns into a single column
- Split a column into two columns
- Transpose rows and columns
- Concatenate multiple tables end to end
- Join two tables side by side
- Update columns in a table with values from another table
Creating a Subset Table

You can produce a new data table that is a subset of all rows and columns, only highlighted rows and columns, or randomly-selected rows from the active data table.

To create a subset:

1. Select Tables > Subset. The window in Figure 7.1 appears.

Figure 7.1 The Subset Window

2. Select a row option from the list:
   - **All Rows**  Creates a subset table that contains all rows from the active table.
   - **Selected Rows**  Creates a subset table that contains only the selected rows from the active table.
   - **Random - sampling rate**  Creates a subset table whose data is a random proportion of the active data table. Enter the proportion of the sample you want in the text box. For example, if you want a random 50% of the data to be included in the new table, enter 0.5 in the text box.
   - **Random - sample size**  Creates a subset table whose data is a random sample of the active data table. Enter the size of the sample you want in the text box. For example, if you want 16 random rows to be included in the new table, enter 16 into the text box.

3. Select a column option from the list:
   - **All columns**  Creates a subset table that contains all columns from the active table.
   - **Selected columns**  Creates a subset table that contains only the columns from the active table.

4. Use the following table to further customize your subset table:

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output table name</td>
<td>To give a name to the subset table, type a name in the box beside <strong>Output table name</strong>.</td>
</tr>
</tbody>
</table>
Creating a Subset Table from a Report

Using a Histogram

After you produce output that contains a histogram (by selecting Analyze > Distribution), you can use the histogram to create a new data table containing the data in the histogram's highlighted bars.

To create a subset, double-click a highlighted bar. Or, right-click (Ctrl-click on the Macintosh) anywhere in the histogram and select Subset from the menu. The subset table appears, as shown in Figure 7.2.

Using a Pareto Plot

After you produce output that contains a Pareto Plot (by selecting Graph > Pareto Plot), you can use the Pareto Plot to create a new data table containing the data in the Pareto Plot's highlighted bars. To create a subset, double-click a highlighted bar.
You can sort a JMP data table by columns in either ascending or descending order. By default, columns sort in ascending order. You can either create a new table that contains the sorted values, or you can replace the original table with the sorted table.

If columns contain value labels (see “Using Value Labels,” p. 146), sorting is based on the actual data values, not the value labels. However, the value labels are displayed in the sorted data table.

To sort:
1. Select Tables > Sort. The window in Figure 7.3 appears.

Figure 7.3  The Sort Window

2. Highlight the names of the columns by which you would like to sort.
3. Click the By button to add them to the sort list. The columns you add to the list establish the order...
of precedence for sorting. The first column in the list is the major sort field. Each variable thereafter is sorted within the previous variable in the sort list.

4 Use the following table to further customize the sort:

<table>
<thead>
<tr>
<th>Option in JMP</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ascending/descending buttons (▲ ▼)</td>
<td>To change the order that the values of the grouping variables will be listed (ascending or descending order), select a variable in the grouping variable list and click the appropriate ascending/descending buttons (▲ ▼). The icon beside the variable changes to indicate the sorting order.</td>
</tr>
<tr>
<td>Replace Table</td>
<td>To replace the original data table with the sorted table instead of creating a new table with the sorted values, click the box beside Replace Table. This option is not available if there are any open report windows generated from the original table.</td>
</tr>
<tr>
<td>Output table name</td>
<td>To give a name to the subset table, type a name in the box beside Output table name.</td>
</tr>
</tbody>
</table>

5 Type a name for the new sorted table in the box beside Output Table.

6 Click Sort.

Follow along with this next example by opening Popcorn.jmp from the Sample Data folder that was installed when you installed JMP. Figure 7.4 shows Popcorn.jmp in its original form (top table) and sorted by popcorn and yield (within popcorn) (bottom table).

Figure 7.4 Sort in Ascending or Descending Order
Stacking Columns

You can rearrange your data table by stacking two or more columns into a single new column, preserving the values from the other columns. Or, you can stack a set of columns into multiple groups. The various ways you can stack columns are explained in the table in step 3 below.

To stack columns:

1. Select **Tables > Stack**. The window shown in Figure 7.5 appears.

Figure 7.5 Stack Window

2. Highlight the names of the columns you want to stack and click **Stack Columns**.

3. Use the following table to further customize the stacking.

<table>
<thead>
<tr>
<th>Option in JMP</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Multiple series stack</strong></td>
<td>To stack selected columns into two or more columns, check the box beside <strong>Multiple series stack</strong>. Specify the number of columns into which you want the selected columns to be stacked by entering the number into the <strong>Number of Series</strong> box. This box appears when you check the box beside <strong>Multiple series stack</strong>. For details, see “<strong>Example of Stacking Into More Than One Column (Using the Multiple Series Stack Option)</strong>,” p. 229</td>
</tr>
<tr>
<td><strong>Stack by Row</strong></td>
<td>Leaving <strong>Stack by Row</strong> unchecked stacks one column underneath another. Checking it stacks columns by rows.</td>
</tr>
<tr>
<td><strong>Eliminate missing rows</strong></td>
<td>To eliminate missing data from the new table, check the box beside <strong>Eliminate missing rows</strong>. If <strong>Stack by Rows</strong> is checked also, only rows with all data missing are eliminated.</td>
</tr>
</tbody>
</table>
### Option in JMP | Description
---|---
Drop non-stacked columns | To have only the stacked columns appear in the new table, check the box beside Drop non-stacked columns. When not checked, the new table contains all columns from the original table plus the newly stacked columns.
Output table name | To name the new table, type a name in the box beside Output table name.
Stacked Data Column | To assign a name to the column that will contain the “stacked” columns’ data, enter a name in the Stacked Data Column box. If you do not enter a name for the new stacked column, its name is Data by default. Leave the box empty if you do not want this column to appear in the new table.
Source Label Column | To assign a name to the column that will contain the original table’s column names, enter the name in the Source Label Column box. The default name is Label. Leave the box empty if you do not want this column to appear in the new table.
Copy formula | To include formulas from the original table in the output columns, click the box beside Copy formula. This option is not present when there are no formulas in the data table.
Suppress formula evaluation | To prevent JMP from evaluating columns’ formulas when the new table is created, check the box beside Suppress formula evaluation. This option is not present when there are no formulas in the data table.

### Example of Stacking into One Column

The data table on the left in Figure 7.6 shows the sample JMP data table called popcorn trials.jmp, with two columns listing popcorn yield from two popping trials conducted under various conditions. A researcher wants the data table to display only one column containing the yields from the trials. He would want the two columns called yield1 and yield2 to be stacked into a single column (by default, this new single column would be called Data).

By selecting Tables > Stack and completing the window shown in the middle in Figure 7.6, the researcher would create the new table found on the bottom in Figure 7.6. The column named Label is the Source Label Column that identifies the source of the data. Its values are the column names in the original table from which the stacked values originated.
Chapter 7  
Reshaping Data

Figure 7.6 Stack Window and Stacked Columns Example

Original table

<table>
<thead>
<tr>
<th></th>
<th>4</th>
<th>5</th>
<th>6</th>
<th>7</th>
<th>8</th>
</tr>
</thead>
<tbody>
<tr>
<td>color</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>item</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>batch</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>yield1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>yield2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

New table

<table>
<thead>
<tr>
<th></th>
<th>4</th>
<th>5</th>
<th>6</th>
<th>7</th>
<th>8</th>
</tr>
</thead>
<tbody>
<tr>
<td>color</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>item</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>batch</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>label</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Data</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Example of Stacking Into More Than One Column (Using the Multiple Series Stack Option)

Suppose a researcher has the data table found at the top of Figure 7.7. If her goal is to have A1, A2, A3, and A4 in one column, B1, B2, B3, and B4 in a second column, and C1, C2, C3, and C4 in a third column, she selects **Tables > Stack** then uses the **Multiple series stack** option in the Stack window. She specifies 3 as the number of series because she wants the output table to contain three stacked columns. She also adds columns in an order that reflects the way she wants the columns in the series grouped.
Splitting Columns

You can create a new data table from the active table by splitting one column into several new columns. This column is split according to the values found in another column, referred to as the **Split By** column. You can also split columns according to the values of one or more grouping variables.

To split columns:

1. Select **Tables > Split**. The window in Figure 7.8 appears.
Figure 7.8 Split Window

2 Highlight the names of the column(s) you want to split and click **Split Columns**.

3 Highlight a column whose values you want to use as the new column names and click **Split By**. The column name appears in the **Split By** box.

4 Use the following table to further customize the split:

<table>
<thead>
<tr>
<th>Option in JMP</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Group</strong></td>
<td>To use a grouping variable, highlight one or more columns whose values can uniquely identify each row in the new table and click <strong>Group</strong>. These will be your grouping variables. Each group results in a row in the output table.</td>
</tr>
<tr>
<td><strong>Output table name</strong></td>
<td>To assign a name to the new table, enter the name in the box beside <strong>Output table name</strong>.</td>
</tr>
<tr>
<td><strong>Copy formula</strong></td>
<td>To include formulas from the original table in the output columns, click the box beside <strong>Copy formula</strong>. This option is not present when there are no formulas in the data table.</td>
</tr>
<tr>
<td><strong>Suppress formula evaluation</strong></td>
<td>To prevent JMP from evaluating columns’ formulas when the new table is created, click the box beside <strong>Suppress formula evaluation</strong>. This option is not present when there are no formulas in the data table.</td>
</tr>
<tr>
<td><strong>Keep All</strong></td>
<td>To include all columns in the new table, click the <strong>Keep All</strong> option in the <strong>Remaining Columns</strong> area.</td>
</tr>
<tr>
<td><strong>Drop All</strong></td>
<td>To include only columns used in the split in the new table, click the <strong>Drop All</strong> option in the <strong>Remaining Columns</strong> area.</td>
</tr>
</tbody>
</table>
**Reshaping Data**

**Chapter 7**

**Transposing Rows and Columns**

5 Click **Split**.

**Example of Splitting Columns**

For example, suppose you want to rearrange the top table in Figure 7.9 to be like the table below it. Selecting **Tables > Split** displays the window in Figure 7.9. In this example, the Split window specifies that the values of **yield** form a new column for each of its values. **Trial** is the **Split Label Col** variable. Its values are used as the column names (yield1 and yield2) in the new table.

**Figure 7.9 Split Example**

<table>
<thead>
<tr>
<th>Option in JMP</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select</strong></td>
<td>To select which columns to keep in the new table, click the <strong>Select</strong> option in the <strong>Remaining Columns</strong> area. Then select which columns to keep in the new table.</td>
</tr>
</tbody>
</table>

**Transposing Rows and Columns**

You can create a new JMP table that is a transposed version of the active data table. The columns of the active table are the rows of the new table, and its rows are the new table’s columns.

When you transpose columns, you:
- select the columns to be transposed
- specify a “label” column, from which the new columns get their names (optional)
- specify “by” columns, which tells JMP to transpose data within groups (optional)
Columns you want to transpose must have the same data type. Also, if columns contain value labels (see "Using Value Labels," p. 146), transposing uses the actual data values, not the value labels.

To transpose rows and columns:

1. Open a data table that contains rows and columns you want to transpose.
2. Select Tables > Transpose. The window in Figure 7.10 appears. If columns that automatically appear in the Columns to be transposed box are not ones you want to transpose, highlight them and click Remove.

Figure 7.10 Transpose Window

3. Highlight the column name(s) you want to transpose in the Select Columns box on the left.
4. Click Transpose Columns.
5. To further customize your transpose:

<table>
<thead>
<tr>
<th>Option in JMP</th>
<th>Description</th>
</tr>
</thead>
</table>
| Label         | To use the data from a column in the original table as the column names in the new table:  
1. Highlight a column from the Select Columns box on the left.  
2. Click Label. The column name appears in the Label box.  
Note that only one column is created for each distinct value in the label column. Thus, if there are duplicate values in the label column, JMP creates only one column for the duplicated value using the value from the last duplicated row. |
| By            | To organize the transpose into groups based on the columns you put in the By box, highlight column name(s) in the Select Columns box whose values you want to see as a group, and click By. |
3 Click **Transpose**. The transposed data table appears. The new table will have an additional column called **Label** whose values are the column names of the original table.

The following rules apply to transposing:

<table>
<thead>
<tr>
<th><strong>Table 7.1</strong> Rules for Transposing</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>If</strong></td>
</tr>
<tr>
<td>The original table has columns but no rows</td>
</tr>
<tr>
<td>The original table has one column and it is assigned to <strong>Label</strong></td>
</tr>
<tr>
<td>The original table has multiple columns and contains a label column</td>
</tr>
<tr>
<td>There is no label column in the original table</td>
</tr>
</tbody>
</table>

### Examples of Transposing

The original table in Figure 7.11, which is the table on the top, has two rows and three continuous columns called **plastic**, **tin**, and **gold**. Selecting **Tables > Transpose** creates the transposed table on the bottom of the page. The transposed table has a row for each of the three columns in the example table and columns named **Row 1** and **Row 2** for the original table's rows. The additional column called **Labels** has the column names (**plastic**, **tin**, and **gold**) from the original table as values, 'plastic,' 'tin,' and 'gold.'
Figure 7.11 Simple Transpose

Original table

<table>
<thead>
<tr>
<th>Item</th>
<th>plastic</th>
<th>tin</th>
<th>gold</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>2</td>
<td>3</td>
</tr>
<tr>
<td>2</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
</tbody>
</table>

New table

<table>
<thead>
<tr>
<th>Item</th>
<th>plastic</th>
<th>tin</th>
<th>gold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>2</td>
<td>3</td>
</tr>
<tr>
<td>2</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The top table in Figure 7.12 has the same original table as is used in Figure 7.11, but it contains an additional column called item. Selecting **Tables > Transpose** and specifying that you want to use the column item as column labels in the new table creates the table shown on the bottom of the page. This new table uses values in the item column of the active table as column names in the transposed table.

Figure 7.12 Transpose with a Label

Original table

<table>
<thead>
<tr>
<th>Item</th>
<th>plastic</th>
<th>tin</th>
<th>gold</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>2</td>
<td>3</td>
</tr>
<tr>
<td>2</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
</tbody>
</table>

New table

<table>
<thead>
<tr>
<th>Item</th>
<th>plastic</th>
<th>tin</th>
<th>gold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>2</td>
<td>3</td>
</tr>
<tr>
<td>2</td>
<td>4</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 7.13 shows how to transpose groups of data without transposing across the entire data table. Selecting **Tables > Transpose** and specifying a **By** group creates the table shown on the bottom. This new table contains values that have been transposed in groups.
When you concatenate tables in JMP, you append them so one column in the new table is created for each column name in the original tables. If a column name is the same in the tables you want to concatenate, the column in the new table lists the values from all tables in the order of concatenation. If the two original tables have columns without the same name, those columns are included in the new table showing missing values.

To concatenate two data tables with the same column names:

1. Select **Tables > Concatenate**. The window in Figure 7.14 appears.

2. Highlight the name(s) of the table(s) you would like to add to the end of the active data table, and click **Add**.

3. (Optional) Click the box beside **Save and evaluate formulas** to request that JMP include all for-
mulas from the original data table (including those found in columns that are not part of the matching columns) and evaluate those formulas. If you don't click this option, no formulas are included in the new table.

4. (Optional) Click the box beside **Create source column** to add a column called Source Table to the new table. This column identifies the name of the source table in the corresponding rows.

5. Click **OK**.

**Example of Concatenating Tables with Same Column Names**

Suppose you want to concatenate two data tables with the same column names, as shown in Figure 7.15. After selecting **Tables > Concatenate**, the window in Figure 7.15 appears and lists all the open JMP data tables: Trial1 and Trial2. Note that these tables have the same column names. To concatenate, select them from the list on the left in the window and click **Add**. Then click **OK** to see the data tables combine into a new untitled table with all rows from the first data table followed by all rows from the second data table.

**Figure 7.15** Concatenate Tables with the Same Column Names

**Example of Concatenating Tables with Different Column Names**

Concatenated tables always have a column for every column name found in the original data tables. For example, in the tables shown to the left in Figure 7.16, the columns yield1 in Trial1.jmp and yield2 in Trial2.jmp contain similar information (the column names have been changed to illustrate concatenating tables with different names). However, the new concatenated table shown to the right has columns for both variables. These columns have missing values for rows from the table in which the column did
not exist. The column called trial occurs in both tables and concatenates to form a single column in the new table.

**Figure 7.16** Concatenate Tables With Different Column Names

You can concatenate as many tables as you want. The number of rows in the new table is the sum of the number of rows in all the tables.

---

### Joining Tables

You can combine two data tables into one new table by selecting **Tables > Join**. Tables can be joined in three different ways:

- By combining them according to row number (see “How to Join Tables,” p. 238, and “Example 1: Join by Row Number,” p. 241)
- In a Cartesian fashion, where you form a new table consisting of all possible combinations of the rows from two original tables (see “How to Join Tables,” p. 238, and “Example 2: A Cartesian Join,” p. 244)
- By matching the values in one or more columns that exist in both data tables (see “How to Join Tables,” p. 238, and “Example 3: Join by Matching Columns,” p. 246)

---

### How to Join Tables

To join two data tables into a new one:

1. Select **Tables > Join**. In the window that appears, the names of all open tables appear below **Join...with**, as shown in Figure 7.17.
2. In the **Join...with** box, highlight the table to join with the active table.

3. Select how to join the tables from the **Matching Specification** area:

   - **By Row Number**  Joins the two tables side by side.

   - **Cartesian Join**  Joins two tables using a Cartesian fashion, where it forms a new table consisting of all possible combinations of the rows from two original tables. JMP crosses the data in the first table with the data in the second to display all combinations of the values in each set.

   - **By Matching Columns**  When you select this option, the window expands, prompting you to select columns whose values and data types must match in both tables for rows to be joined. You should:

     a. Highlight a column name from each list in the **Source Columns** area. The first highlighted column in the top list pairs with the first highlighted column in the bottom list, the second columns are paired, and so on. Rows join only if values and data types match for all the column pairs.

     b. Click **Match**. The selected pair of columns are displayed in the **Match columns** box. Matching columns do not have to have the same names and do not have to be in the same relative column position in both tables.

     c. (Optional) To only include the first match found, check the boxes associated with **Drop multiples** in both tables. Only the first match found is written to the new table. If you specify this option for one table, the first match value is joined with all matches in the other table. If you do not check the boxes associated with **Drop multiples** in either table, a Cartesian join is performed within each group of matching column values.
d. (Optional) To include all rows from the data table, even when there is no matching value, check the boxes associated with **Include non-matches**. You can specify this option for either or both data tables being joined.

4 Type the name of the new table in the text box beside **Output table name**.

5 Consult the following table to further specify how to combine the data tables:

<table>
<thead>
<tr>
<th>Option in JMP</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select Columns for joined table</strong></td>
<td>Select the <strong>Select Columns for joined table</strong> option if you want to select a subset of columns from either table for inclusion in the output table. Follow these steps:</td>
</tr>
<tr>
<td></td>
<td>1 In the <strong>Source Columns</strong> area, highlight the columns from each table that you want to include in the new table.</td>
</tr>
<tr>
<td></td>
<td>2 Click <strong>Select</strong> in the <strong>Output Columns</strong> area.</td>
</tr>
<tr>
<td><strong>Update first table with data from second table</strong></td>
<td>When <strong>Update first table with data from second table</strong> is checked, column data from the second table are used to change the data of the same name columns in the original table. Notes:</td>
</tr>
<tr>
<td></td>
<td>• JMP will not replace data with missing values.</td>
</tr>
<tr>
<td></td>
<td>• The output table uses the same columns as the original table. Thus, when you use <strong>Update first table with data from second table</strong>, <strong>Select Columns for joined table</strong> is not applicable.</td>
</tr>
<tr>
<td></td>
<td>• The <strong>Update first table with data from second table</strong> option is only available when joining by row number or by matching columns.</td>
</tr>
<tr>
<td><strong>Merge same name columns</strong></td>
<td>Click the box beside <strong>Merge same name columns</strong> if you want the data from the second table to replace the data of the same name columns in the original table, regardless of if they are missing.</td>
</tr>
<tr>
<td></td>
<td>If you join by matching columns, the new table will contain a column named <strong>Match Flag</strong>:</td>
</tr>
<tr>
<td></td>
<td>• If a one (1) appears in this column, the data originated from the first (active) table.</td>
</tr>
<tr>
<td></td>
<td>• If a two (2) appears in this column, the data originated from the second table.</td>
</tr>
<tr>
<td></td>
<td>• If a three (3) appears in this column, the data was found in both the first and second tables.</td>
</tr>
<tr>
<td><strong>Copy formula</strong></td>
<td>To include formulas from the original table in the output columns, click the box beside <strong>Copy formula</strong>.</td>
</tr>
</tbody>
</table>
Examples of Joining Tables

The following sections give examples of how to use the Join command.

Example 1: Join by Row Number

Joining tables by row number joins the two tables side by side, and the new table has all columns from both tables (unless you specify to only include certain columns).

Joining Tables with an Unequal Number of Rows

If two tables you want to join have an unequal number of rows, the new table will have values for rows found in both tables. For example, as Figure 7.18 shows, if one table with two rows (the table on the left) is joined with a table with four rows (the table in the center), then the new table (the table on the right) contains four rows.

Figure 7.18 Joining Tables by Row Number

Joining Columns with the Same Name

If the two tables have column names that are the same, the names of these columns in the new table appear as “column name of table name.” For example, if you joined tables named Animal Data.jmp and Reptile Data.jmp, and both tables contained a column named gender, the new table contains columns named gender of Animal Data and gender of Reptile Data, as shown in Figure 7.19.
As a similar example, suppose you want to combine the eight rows from each data table shown in Figure 7.20 into a single table. You want to combine them so the new table contains all columns from both tables. Follow along with this next example by opening Trial1.jmp and Trial2.jmp from the Sample Data folder that was installed when you installed JMP.

Figure 7.20  The Trial1.jmp and Trial2.jmp Data Tables

1  Select Tables > Join, and the window in Figure 7.21 appears.
Figure 7.21 Join Window

![Join Window](image)

2 Highlight Trial2 in the **Join...With** box.
3 Then click **OK** and the result is the data table in Figure 7.22.

**Figure 7.22** The Joined Table

![Joined Table](image)

Note that if a column name is the same in the two original tables, the output column name is qualified by the source table name. For example, the column names in the new table are “*variable name of table name*."

**Joining Only Specified Columns**

As a second example using the same data tables as the previous example, suppose you don’t want all columns from the original data tables to be in the joined table. You only want popcorn and yield from Trial1 list and yield from the Trial2 to be in the joined table.

1 Select **Tables > Join**.
2 Select Trial2 in the **Join...With** box.
3 Click **Select columns for joined table** in the **Output Columns** area to specify the subset of columns you want.
4 Select all the columns you want from both tables in the **Source Columns** list and click **Select**. In
this example, select popcorn and yield from Trial1 list and yield from the Trial2 list. The box in the **Output Columns** area lists the columns you want in the new table. The tables Trial1 and Trial2 (Figure 7.23) have identical data in the popcorn column, so only one of them is needed in the joined table.

5 Click OK.

The new table has only the selected columns, as shown in Figure 7.23.

**Figure 7.23** Joining Only Specified Columns

---

### Example 2: A Cartesian Join

When doing a Cartesian join, JMP joins two tables in a Cartesian fashion, where it forms a new table consisting of all possible combinations of the rows from two original tables. This creates cases in the output table so there will be one case for each combination of column values. For example, as Figure 7.24 shows, JMP crosses the data in table **a** with the data in table **b** to display all combinations of the values in each set (the table named *Cartesian join*).
For another example, suppose you want to construct a JMP table that has a row for each combination of
levels of experimental conditions in the popcorn example.

You can begin with the three small tables shown at the top in Figure 7.25: oil amount.jmp, batch.jmp,
and popcorn.jmp. Each table has two rows and one column. The values are the experimental categories
for popcorn yield trials.

In this example, you must use the Tables > Join command twice. The first join combines oil
amount.jmp with batch.jmp using the Cartesian option. The join produces the lower-left table in
Figure 7.25, which has all columns from the two original tables. Each value in oil amount.jmp pairs
with each value in batch.jmp, giving a new table with four rows.

The second join combines the new table (Cartesian oil amount + batch) with popcorn.jmp and pro-
duces the lower-right table (all tables joined) in Figure 7.25. This final data table has a row for each
experiment condition and is ready for recording results of the corn popping trials. Keep in mind that
the number of rows produced by a Cartesian join is the product of the number of rows in the original
tables.

Figure 7.25 Examples of a Cartesian Join
Example 3: Join by Matching Columns

When join by matching columns, JMP finds specified column(s) values that exist in both tables and combines all values associated with that value into a new data table. Note that to join by matching columns, the columns must have the same data type (numeric, character, or row state).

Joining Tables with the Same Rows in Different Order

Suppose you have one data table containing students’ names, ages, and sexes. You have another data table containing their names, height, and weight. Instead of working with two separate tables, you would like to combine the tables into one, as shown in Figure 7.26. Then, you will be prepared to run any appropriate analyses.

You realize that the students’ names are not in the same order in both tables; for example, Alice is on row 7 in the first table and row 9 in the second table.

Figure 7.26 shows the two original tables and new table you would like to create.

To join the tables so that the new table contains Alice’s (as well as every other students’) name, age, sex, height, and weight:

1. Select Tables > Join and select Student2 in the Join...With box.
Because both tables have one column (name) that contains the same values, you need to tell JMP that they are “matches.” When you do this, JMP examines each of the values in the name column of the first table to see if there was a corresponding value in the second table’s name column. For example, it detects that Alice is located in both tables. It creates a name column in the new table with Alice as a value. It then takes the age and sex of Alice from table one and puts it in the new table. Then it takes the height and weight of Alice and puts them in the new table.

2. Select By Matching Columns in the Matching Specification area.

3. Highlight name from Students1’s list and name from Student2’s list and click Match. The completed window should look like that in Figure 7.27.

4. You want the new table to contain only one row for each name, so check the Drop multiples boxes for both tables. Then, click OK.

**Figure 7.27 Matching Columns**

Joining Tables with Different Numbers of Rows and Different Column Names

You can follow along with this example by opening the Trial1.jmp and Little.jmp tables that are in the Sample Data folder that was installed when you installed JMP.

Suppose Sarah and Joe are running a popcorn experiment. They are popping different types of popcorn (gourmet and plain) in different amounts of oil. They are recording the amount (yield) of popcorn that is produced.

Sarah gave you the first trial data in a file named Trial1.jmp. Joe gave you the second trial data in a file named Little.jmp. Figure 7.28 shows the two tables.
Before examining the collected data, you realize it would be convenient to join Sarah and Joe's tables into a single table, such as the one in Figure 7.29.

To join Sarah and Joe's tables:

1. Select Tables > Join.
2. Identify Little as the table to which you want to join Trial 1.
4. Highlight popcorn, oil amt, and batch from Trial 1’s list.
5. Highlight popcorn, oil, and batch from Little’s list.
6. Click Match.

As you can see from Figure 7.28, Sarah completed her experiment, but Joe only partially completed his experiment. Therefore, the tables you received from Sarah and Joe have different numbers of rows:
Trial1.jmp has values for eight experimental conditions, and Little.jmp has values for only four of those conditions.

You want the new table to contain all the rows that are found in Trial1.jmp, even if that row in the Little.jmp table contains a missing value.

7 Check the **Include Non Matches** boxes for both tables.

In the new table, you only want one column for popcorn, one column for oil, and one column for batch. But, you want two columns for yield—yield from Trial 1 and yield from Little.

8 Check the box beside **Select columns for joined table**.

9 Highlight popcorn, oil amt, batch, and yield from Trial 1’s list and click **Select**.

10 Highlight yield from Little’s list and click **Select**.

11 Ensure that the completed window matches Figure 7.30 and click **OK**.

**Figure 7.30** Join by Matching Columns Window

JMP creates the table shown in Figure 7.31. The new table is now sorted by the matching columns, as shown in Figure 7.31. Note that the yield column from Little.jmp (Yield of Little) has missing values whenever there were no matching values in Trial1.
Updating a Table

If you have two data tables and would like to update one table with data from a second table, select **Tables > Update**.

Before updating a table, make sure the name of the column containing the values you want to replace is the same as the name of the column containing the data you want to replace it with.

To replace values in the active table with those found in another open table:

1. Click the table you want to update (this is the table whose values will be replaced) to make it the active table.
2. Select **Tables > Update**. In the window that appears, the name of the active table is shown above the list, as shown in Figure 7.32.

**Figure 7.32** Updating a Table

3. Highlight the table that contains the data you want to transfer.

4. If your two tables have one or more columns whose values uniquely describe each row, JMP will use those columns as the match column values. That is, JMP updates the rows whose match column values coincide. JMP uses these columns to preserve the sorted order of the data. If your tables do not have matching column values, you can incorporate the updated values according to their row order by continuing to step 5. However, to proceed with tables containing matching column values:
a. Check **Match columns**. Figure 7.33 appears.

**Figure 7.33** This Window Appears When You Click Match Columns

![Update Window](image)

b. Highlight two column names (in the respective tables) that you want to match.

c. Click **Match**. Repeat to match more columns.

**Note:** The column name(s) that you did not “match” and that are different between the two tables will be added to the end of the first table as separate column(s).

5 If you do not want JMP to replace the values in the first table with any missing values found in the second table, click the box beside **Ignore missing**. The first table will retain its original values if they correspond to missing values in the second table.

6 Click **OK**.

### Example of Updating a Table

Suppose a researcher is in possession of a data table named **Big Class.jmp** when she receives a second table named **NewHeights.jmp** (Figure 7.34), which contains more recent measurements of the students’ height.

The researcher wants to avoid scrolling through **Big Class.jmp** to find the students whose height has changed. She also wants to avoid copying and pasting or typing in the new values. She wants to quickly update **Big Class.jmp** with the more recent height values, which are found in **NewHeights.jmp**.
She opens both tables and selects **Tables > Update**. She selects **NewHeights.jmp** (Figure 7.35). She then clicks **Match Columns** and, in the window that appears, selects **name** in the column list for both tables and clicks **Match**. This tells JMP to use **name** as the match column value because it is the column whose values uniquely describe each row.

**Figure 7.35** Updating BigClass.jmp with NewHeights.jmp

The resulting updated table is shown in Figure 7.36.
Figure 7.36  The Updated Table

<table>
<thead>
<tr>
<th></th>
<th>name</th>
<th>age</th>
<th>sex</th>
<th>height</th>
<th>weight</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>KATE</td>
<td>12</td>
<td>F</td>
<td>62</td>
<td>90</td>
</tr>
<tr>
<td>2</td>
<td>LOUISE</td>
<td>12</td>
<td>F</td>
<td>61</td>
<td>123</td>
</tr>
<tr>
<td>3</td>
<td>JANE</td>
<td>12</td>
<td>F</td>
<td>67</td>
<td>74</td>
</tr>
<tr>
<td>4</td>
<td>JACLYN</td>
<td>12</td>
<td>F</td>
<td>61</td>
<td>145</td>
</tr>
<tr>
<td>5</td>
<td>LILLIE</td>
<td>12</td>
<td>F</td>
<td>57</td>
<td>84</td>
</tr>
<tr>
<td>6</td>
<td>TIM</td>
<td>12</td>
<td>M</td>
<td>59</td>
<td>84</td>
</tr>
<tr>
<td>7</td>
<td>JAMES</td>
<td>12</td>
<td>M</td>
<td>70</td>
<td>123</td>
</tr>
<tr>
<td>8</td>
<td>ROBERT</td>
<td>12</td>
<td>M</td>
<td>64</td>
<td>79</td>
</tr>
<tr>
<td>9</td>
<td>BARBARA</td>
<td>13</td>
<td>F</td>
<td>68</td>
<td>112</td>
</tr>
<tr>
<td>10</td>
<td>ALICE</td>
<td>13</td>
<td>F</td>
<td>63</td>
<td>107</td>
</tr>
<tr>
<td>11</td>
<td>SUSAN</td>
<td>13</td>
<td>F</td>
<td>62</td>
<td>67</td>
</tr>
<tr>
<td>12</td>
<td>JOHN</td>
<td>13</td>
<td>M</td>
<td>63</td>
<td>98</td>
</tr>
</tbody>
</table>
You can perform a wide variety of data management tasks on JMP data:

- Create a table that contains columns of summary statistics
- Tabulate data so it is displayed in a tabular format
# Contents

**Summarizing Columns** ................................................................. 257
- Creating a Summary Table ......................................................... 258
- Adding a Statistics Column to an Existing Summary Table ............ 259
- Explanation of Statistics .......................................................... 260
- Example of Adding a Statistics Column ........................................ 261

**Tabulating Data** ............................................................................ 262
- How to Create a Table in Tabulate ............................................... 263
- Elements of a Table in Tabulate ................................................... 264
- Clicking and Dragging Items ......................................................... 267
- Inserting a Grouping Column ....................................................... 268
- Inserting an Analysis Column ...................................................... 268
- Using the Dialog ........................................................................... 268
- Editing Tables in Tabulate ......................................................... 269
- Additional Tabulate Options ....................................................... 271
- Example of Tabulating Data ......................................................... 272
Summarizing Columns

The **Tables > Summary** command calculates various summary statistics, including the mean and median, standard deviation, minimum and maximum value, range, percentage of total, sum variance, standard error, coefficient of variation, and user-specified quantiles.

In a summary table:

- A single row exists for each level of a grouping variable you specify. If no grouping variable is specified, a single row exists for the full data table.
- When there are several grouping variables, the table contains rows for each combination of levels of all the grouping variables.
- In addition to one column for each grouping variable, the table contains frequency counts in a column named **N Rows** with counts for each grouping level.
- The summary table is linked to its source table; when you select rows in the summary table, the corresponding rows are highlighted in its source table.
- If the source table’s column(s) contain value labels, the value labels are displayed in the new table.
- A summary table is not saved when you close it unless you select **File > Save As** to give it a name and location.

**Figure 8.1** Example of Creating a Summary Table with One Grouping Variable
Creating a Summary Table

To create a summary table:

1. Open a data table.
2. Select **Tables > Summary**. The window in Figure 8.2 appears.

Figure 8.2 The Summary Window

3. To add columns that display summary statistics (such as mean, standard deviation, median, etc.) for any numeric column in the source table:
   a. In the Summary window, highlight the column you want to use in calculating the statistics.
   b. Click the **Statistics** button.
   c. Select one of the standard univariate descriptive statistics from the **Statistics** drop-down menu.
      The statistics are described in “Explanation of Statistics,” p. 260. The example in Figure 8.7 shows how to generate the mean of Profits/Emp for each level of the grouping variable.

4. If you want the statistics summarized by group, highlight the column(s) you want to be your grouping variables and click **Group** to move the variable into the grouping variables list. See “Example of Adding a Statistics Column,” p. 261, for an example.
   a. Repeat this step for as many grouping variables as you want.
   b. To change the order that the values of the grouping variables will be listed (ascending or descending order), select a variable in the grouping variable list and click the ascending/descending buttons ( ). The icon beside the variable changes to indicate the sorting order.
   c. To add marginal statistics (for the grouping variables) to the output columns, click the box beside **Include marginal statistics**. In addition to adding marginal statistics for each grouping variable, JMP adds a row at the end of the table that shows the summary statistics for the whole table.

Figure 8.3 shows the summary table for grouping variables Type and Size Co with marginal statistics.
Figure 8.3 Summary Table with Marginal Statistics

<table>
<thead>
<tr>
<th>Companies By Type, Source</th>
<th>Type</th>
<th>Size Co</th>
<th>N Rows</th>
<th>Mean Profit (SM)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1</td>
<td>Computer big</td>
<td>4</td>
<td>1009.925</td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>Computer medium</td>
<td>2</td>
<td>-65.75</td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>Computer small</td>
<td>14</td>
<td>44.9557143</td>
</tr>
<tr>
<td></td>
<td>4</td>
<td>Computer</td>
<td>20</td>
<td>240.866</td>
</tr>
<tr>
<td></td>
<td>5</td>
<td>Pharmaceut big</td>
<td>5</td>
<td>894.42</td>
</tr>
<tr>
<td></td>
<td>6</td>
<td>Pharmaceut medium</td>
<td>5</td>
<td>638.98</td>
</tr>
<tr>
<td></td>
<td>7</td>
<td>Pharmaceut small</td>
<td>2</td>
<td>156.95</td>
</tr>
<tr>
<td></td>
<td>8</td>
<td>Pharmaceut</td>
<td>12</td>
<td>600.075</td>
</tr>
<tr>
<td></td>
<td></td>
<td>All rows</td>
<td>32</td>
<td>419.31875</td>
</tr>
</tbody>
</table>

5. To add specific quantile statistics, type the desired quantile value (%) for the first quantile (e.g., 25) in the box under For quantile statistics.

6. To change the format of the statistics column name, select from one of the formats in the statistics column name format drop-down menu. Figure 8.4 shows the available options. By default, the form is statistic(source column), where statistic is the selection made on the summary window, and source column is the column from the source table selected in the summary window.

Figure 8.4 Change the Way the Column Name Appears

7. Name the subset table by typing a name in the box beside Output table name.

8. To create a two-way table of summary statistics by adding a subgroup variable:
   a. Highlight the column(s) you want to be the nested variable(s). These will be your “subgroup variable(s).”
   b. Click SubGroup to move the variable(s) into the subgroup list.
   c. Highlight the column for which you want statistics summarized by subgroup.

9. Click OK.

Adding a Statistics Column to an Existing Summary Table

After you have created a summary table, you can add columns of descriptive summary statistics for any numeric column in the source table, as shown in Figure 8.5.

Figure 8.5 Example of a Summary Table with a Summary Statistics Column
To add a statistics column to a previously-created the summary table (as explained in “Creating a Summary Table,” p. 258), click the red triangle icon in the upper-left corner of the data grid, as shown in Figure 8.6, and select Add Statistics Column. This displays the Summary window.

Figure 8.6  Creating a Summary Statistics Column from Within a Data Table

**Explanation of Statistics**

You can add columns of descriptive summary statistics for any numeric column in the source table by clicking the Statistics button (Figure 8.7) and selecting one of the standard univariate descriptive statistics from the Statistics drop-down menu described below.

Figure 8.7  Adding Summary Statistics
The **Statistics** drop-down menu gives these summary statistics for numeric columns:

- **N**  
  Is the number of nonmissing values.

- **Mean**  
  Is the arithmetic mean of a column’s values. It is the sum of nonmissing values (and if defined, multiplied by the weight variable) divided by the **Sum Wgt**.

- **Std Dev**  
  Is the sample standard deviation, computed for the nonmissing values. It is the square root of the sample variance.

- **Min**  
  Is the smallest nonmissing value in a column.

- **Max**  
  Is the largest nonmissing value in a column.

- **Range**  
  Is the difference between **Max** and **Min**.

- **% of Total**  
  Is the percent of the total count for each group. Or, if you have so specified, the percent of nonmissing values of the column to the total count for each group.

- **N Missing**  
  Is the number of missing values.

- **Sum**  
  Is the sum of all values in a column.

- **Sum Wgt**  
  Is the sum of all weight values in a column (see “Giving Columns a Preselected Analysis Role,” p. 138). Or, if no column is assigned the weight role, **Sum Wgt** is the total number of nonmissing values.

- **Variance**  
  Is the sample variance, computed for the nonmissing values. It is the sum of squared deviations from the mean, divided by the number of nonmissing values minus one.

- **Std Err**  
  Is the standard error of the mean. It is the standard deviation divided by the square root of N. If a column is assigned the role of weight, then the denominator is the square root of the sum of the weights.

- **CV** (Coefficient of Variation)  
  Is the measure of dispersion, which is the standard deviation divided by the mean multiplied by one hundred.

- **Median**  
  Is the 50th percentile, which is the value where half the data are below and half are above or equal to the 50th quantile (median).

- **Quantiles**  
  Gives the value at which the specific percentage of the argument is less than or equal to. For example, 75% of the data is less than the 75th quantile. The summary window has an edit box for entering the quantile percentage you want.

### Example of Adding a Statistics Column

Suppose a researcher is working with **Companies.jmp**, which groups companies by **Type** and **Size**. Follow along with this next example by opening **Companies.jmp** from the Sample Data folder that was installed when you installed JMP.

Suppose the researcher wants to:

- Create a table that shows the average profit per employee for small, medium, and big computer companies and small, medium, and big pharmaceutical companies (i.e., a table that contains a row for each size company and a column for the mean profit per employee of each type of company).
- Create it so the cells hold the mean for the subgroup (defined by the intersection of the row and column).
The researcher first selects **Tables > Summary**, then selects **Size Co** as the grouping variable because he wants the values in that column to become rows in the new table. Then he highlights **profit/emp** and clicks the **Statistics** button and selects **Mean** from the drop-down menu to get the mean of **profit/emp**. Then he highlights **type** and clicks the **Subgroup** button to identify it as the subgroup variable. This tells JMP to create a column for the average profit per employee (Mean(profit/emp)) for each level (computer, pharmaseutical) of subgroup variable (**type**). The result is the summary table shown in Figure 8.8.

**Figure 8.8** Summary Statistics for a Subgroup

---

**Tabulating Data**

Use the **Tables > Tabulate** command for constructing tables of descriptive statistics. The tables are built from grouping columns, analysis columns, and statistics keywords. Through its interactive interface for defining and modifying tables, the Tabulate command provides a powerful and flexible way to present summary data in tabular form, as shown in Figure 8.9.

**Figure 8.9** Examples of Tables
Chapter 8

Summarizing Data

Tabulating Data

How to Create a Table in Tabulate

A report in Tabulate consists of one or more column tables concatenated side by side, and one or more row tables concatenated top to bottom. A report may have only a column table or a row table.

Creating a table using the interactive table is an iterative process:

1. Click and drag the items (column name from the column list or statistics from the keywords list) from the appropriate list. Refer to the description of the elements in the interactive table in “Elements of a Table in Tabulate,” p. 264.

   **Note:** If you prefer to use a dialog rather than the interactive table, see “Using the Dialog,” p. 268, for details.

2. Drop the items on the dimension (row table or column table) where you want to place the items’ label.

   See “Clicking and Dragging Items,” p. 267, and “Elements of a Table in Tabulate,” p. 264, for details.

3. After creating a table, add to it by repeating the above process. The table updates to reflect the latest addition. If there are already column headings or row labels, you decide where the addition goes relative to the existing items.
Elements of a Table in Tabulate

This section defines the terms used in tabulate.

Column Table and Row Table

In Tabulate, a table is defined by its column headings and row labels. They are henceforth referred to as the column table and row table.

Figure 8.10  Example of a Column Table and Row Table

Grouping Columns

Grouping columns are columns that you want to use to classify your data into categories of information. They can have character, integer, or even decimal values, but the number of unique values should be limited.

If there is more than one grouping column, Tabulate constructs distinct categories from the hierarchical nesting of the values of the columns.

For example, from the grouping columns Sex with values F and M, and the grouping column Marital Status with values Married and Single, Tabulate will construct four distinct categories, F and Married, F and Single, M and Married, M and Single.

You can specify grouping columns for column tables as well as row tables. Together they generate the categories that define each table cell.

Tabulate does not include observations with a missing value for one or more grouping columns.

Analysis Columns

Analysis columns are any numeric columns for which you want to compute statistics. They are usually continuous columns. Tabulate computes statistics on the analysis columns for each category formed from the grouping columns.

Note that all the analysis columns have to reside in the same dimension, either in the row table or in the column table.

Statistics

Tabulate supports a list of standard statistics. The list is displayed in the control panel. You can drag any keyword from that list to the table, just like you do with the columns.

The statistics associated with each cell are calculated on values of the analysis columns from all observations in that category as defined by the grouping columns.
Note also that all the requested statistics have to reside in the same dimension, either in the row table or in the column table.

Some of the keywords used in Tabulate are defined below. A comprehensive description is listed in “Explanation of Statistics,” p. 260.

- **N** is the default statistics when there is no analysis column.

- **Sum** is the default statistics for analysis columns when there is no other statistics for the table.

- **Quantiles** gives the value at which the specific percentage of the argument is less than or equal to. For example, 75% of the data is less than the 75th quantile. You may request different quantiles by clicking and dragging the Quantiles keyword into the table, then entering the quantile into the box that appears.

- **% of Total** computes the percentage of total of the whole population. The denominator used in the computation is the total of all the included observations, and the numerator is the total for the category. If there is no analysis column, the % of Total is the percentage of total of counts. If there is an analysis column, the % of Total is the percentage of the total of the sum of the analysis column. Thus, the denominator is the sum of the analysis column over all the included observations, and the numerator is the sum of the analysis column for that category.

  - Dropping one or more grouping columns from the table to the % of Total heading changes the denominator definition. For this, Tabulate will use the sum of these grouping columns for the denominator.

  - To get the percentage of the column total, drag all the grouping columns on the row table and drop them on the % of Total heading. Similarly, to get the percentage of the row total, drag all grouping columns on the column table and drop them on the % of Total heading.

- **All** is a special keyword for grouping columns. It is used when you want to aggregate summary information for categories of a grouping column. For example, suppose one of the grouping columns in a table is Sex with two categories, F and M. Adding the keyword All creates a third category called All, as shown in Figure 8.11. This category aggregates the statistics for both groups, F and M. This keyword is added to the table separate from the statistics keywords or from the columns.
Columns by Categories

Columns by Categories are a variant of the grouping columns. They are independent grouping columns sharing a common set of values. When a set of grouping columns is used collectively as Columns by Categories, a cross-tabulation of the column names and the categories gathered from these columns is generated. Each cell is defined by one of the columns and one of the categories. If Columns by Categories is defined on the Column table, then the corresponding categories are automatically used to define the row table.

For example, researchers collected employee survey data in the form of yes or no questions. The top table in Figure 8.12 tabulates the number of yes responses and the number of no responses to each question. It was made by adding all the columns (except the first one) as Columns by Categories.

The bottom table in Figure 8.12 further breaks down the tabulation by division (DivCode).
Figure 8.12 Tabulating by Adding Columns as Columns by Categories

<table>
<thead>
<tr>
<th></th>
<th>Yes</th>
<th>No</th>
<th>All</th>
</tr>
</thead>
<tbody>
<tr>
<td>It is safe to speak up at my company.</td>
<td>235</td>
<td>115</td>
<td>345</td>
</tr>
<tr>
<td>I am frustrated by frequent work priority changes.</td>
<td>75</td>
<td>21</td>
<td>96</td>
</tr>
<tr>
<td>I am frustrated by frequent organizational changes.</td>
<td>87</td>
<td>269</td>
<td>346</td>
</tr>
<tr>
<td>Work in my work group is well organized.</td>
<td>221</td>
<td>126</td>
<td>347</td>
</tr>
<tr>
<td>I have the resources to do my job efficiently.</td>
<td>221</td>
<td>122</td>
<td>343</td>
</tr>
<tr>
<td>My job responsibilities are clear.</td>
<td>253</td>
<td>67</td>
<td>320</td>
</tr>
<tr>
<td>My job is frequently dull.</td>
<td>38</td>
<td>303</td>
<td>341</td>
</tr>
<tr>
<td>Work groups are too territorial.</td>
<td>144</td>
<td>206</td>
<td>340</td>
</tr>
<tr>
<td>Morale at my company is generally high.</td>
<td>215</td>
<td>126</td>
<td>341</td>
</tr>
<tr>
<td>There is often excessive pressure in my job.</td>
<td>83</td>
<td>261</td>
<td>344</td>
</tr>
<tr>
<td>My manager provides clear expectations.</td>
<td>245</td>
<td>99</td>
<td>344</td>
</tr>
<tr>
<td>Creativity is encouraged at my company.</td>
<td>250</td>
<td>90</td>
<td>340</td>
</tr>
<tr>
<td>I feel well informed on company policies.</td>
<td>251</td>
<td>90</td>
<td>341</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DiCode</th>
<th>ABCD</th>
<th>BCDS</th>
<th>CAN</th>
<th>RDAS</th>
<th>RDAD</th>
<th>RDAU</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>It is safe to speak up at my company.</td>
<td>16</td>
<td>10</td>
<td>48</td>
<td>15</td>
<td>84</td>
<td>45</td>
</tr>
<tr>
<td>I am frustrated by frequent work priority changes.</td>
<td>1</td>
<td>27</td>
<td>17</td>
<td>44</td>
<td>23</td>
<td>93</td>
</tr>
<tr>
<td>I am frustrated by frequent organizational changes.</td>
<td>2</td>
<td>26</td>
<td>24</td>
<td>37</td>
<td>32</td>
<td>74</td>
</tr>
<tr>
<td>Work in my work group is well organized.</td>
<td>20</td>
<td>8</td>
<td>37</td>
<td>24</td>
<td>65</td>
<td>62</td>
</tr>
<tr>
<td>I have the resources to do my job efficiently.</td>
<td>22</td>
<td>6</td>
<td>36</td>
<td>25</td>
<td>56</td>
<td>66</td>
</tr>
<tr>
<td>My job responsibilities are clear.</td>
<td>24</td>
<td>4</td>
<td>43</td>
<td>19</td>
<td>71</td>
<td>30</td>
</tr>
<tr>
<td>My job is frequently dull.</td>
<td>1</td>
<td>27</td>
<td>6</td>
<td>56</td>
<td>19</td>
<td>83</td>
</tr>
<tr>
<td>Work groups are too territorial.</td>
<td>14</td>
<td>14</td>
<td>33</td>
<td>27</td>
<td>43</td>
<td>83</td>
</tr>
<tr>
<td>Morale at my company is generally high.</td>
<td>18</td>
<td>10</td>
<td>39</td>
<td>21</td>
<td>47</td>
<td>56</td>
</tr>
<tr>
<td>There is often excessive pressure in my job.</td>
<td>7</td>
<td>21</td>
<td>11</td>
<td>48</td>
<td>41</td>
<td>86</td>
</tr>
<tr>
<td>My manager provides clear expectations.</td>
<td>23</td>
<td>5</td>
<td>44</td>
<td>15</td>
<td>72</td>
<td>34</td>
</tr>
<tr>
<td>Creativity is encouraged at my company.</td>
<td>26</td>
<td>9</td>
<td>45</td>
<td>14</td>
<td>65</td>
<td>46</td>
</tr>
<tr>
<td>I feel well informed on company policies.</td>
<td>21</td>
<td>7</td>
<td>51</td>
<td>8</td>
<td>55</td>
<td>40</td>
</tr>
</tbody>
</table>

Clicking and Dragging Items

Each column heading has two zones: the upper and the lower. As you drag each column heading into a zone, the cursor transforms into a rectangle to indicate that you can drop the column heading at that position.

- Dropping in the upper zone places the new items above (before) the items on which the addition is dropped.
- Dropping in the lower zone places the addition below (after) the items on which the addition is dropped.

Each row label has two zones: the left and the right:

- Dropping in the left zone puts the new items to the left (before) of the items dropped on.
- Dropping in the right zone puts them to the right (after) of the items dropped on.

In a properly created table, all grouping columns are together, all analysis columns are together, and all statistics are together. Thus, JMP will not intersperse a statistics keyword within a list of analysis columns. Neither will it insert an analysis column within a list of grouping columns.

If the items’ role is obvious, such as keywords or character columns, when you drag and drop, JMP populates the table automatically with the given items. Otherwise, a popup menu lets you choose the role for the items. Roles included on the popup menu are:
• **Add Grouping Columns**  Choose *Add Grouping Columns* if you want to use the variables to categorize the data. For multiple grouping columns, Tabulate will create a hierarchical nesting of the variable.

• **Add Analysis Columns**  Choose *Add Analysis Columns* if you want to compute the statistics of these columns.

• **Columns by Categories**  Choose *Columns by Categories* if the columns are independent grouping columns (i.e., no hierarchical nesting) sharing a similar set of distinct data values, and you want a cross-tabulation of the column by the categories layout.

• **Grouping Columns for Separate Tables**  Choose *Grouping Columns for Separate Tables* if you have multiple independent grouping columns and you wish to generate separate tables for each grouping column.

**Inserting a Grouping Column**

To insert a grouping column, click and drag, then release a column name or statistics keyword into the table. Select *Add Grouping Columns* from the menu that appears, as shown in Figure 8.13. If adding it as a grouping column is the only logical choice, JMP automatically inserts it as a grouping column; the popup menu will not appear.

![Figure 8.13 Example of Adding a Grouping Column](image)

**Inserting an Analysis Column**

To insert an analysis column, click and drag, then release a column name or statistics keyword into the table. Select *Add Analysis Columns* from the menu that appears, as shown in Figure 8.13. If adding it as an analysis column is the only logical choice, JMP automatically inserts it as an analysis column; the popup menu will not appear.

**Using the Dialog**

If you prefer not to click and drag and build the table interactively, you can create a simple table using the dialog interface. After selecting *Tables > Tabulate*, select *Dialog* from the dropdown menu beside *Build table using*, as shown in Figure 8.14. The dialog is very similar to the Summary dialog (see “Summarizing Columns,” p. 257), and the resultant table is like the layout of the summary table. You can change the table generated by the dialog in the same way that you would with one generated through drag and drop.
Editing Tables in Tabulate

JMP provides several ways for you to edit the items you add to the table.

Changing Numeric Formats

The formats of each cell depend on the analysis column and the statistics. For counts, the default format has no decimal digits. For each cell defined by some statistics, JMP tries to determine a reasonable format using the format of the analysis column and the statistics requested. To override the default format:

1. Click the Change Format button at the bottom of the Tabulate window.
2. In the window that appears (Figure 8.15), enter the field width, a comma, and then the number of decimal places you want displayed in the table. If you would like JMP to determine the best format for you to use, type the word Best in the text box. JMP now considers the precision of each cell value and selects the best way to show it.
3. Click OK.
Deleting Items

After you add items, you can remove them by clicking the Undo button. You can also right-click the item in the table and select **Delete** from the menu that appears (Figure 8.16).

Removing Column Labels

Grouping columns display the column name atop the categories associated with that column. For some columns, the column name might seem redundant. Remove the column name from the column table by right-clicking the column name and selecting **Remove Column Label** (Figure 8.17). To re-insert the column label, right-click on one of its associated categories and select **Restore Column Label**.

---

**Figure 8.15 Changing Numeric Formats**

![Changing Numeric Formats](image1)

**Figure 8.16 Deleting Items**

![Deleting Items](image2)

**Figure 8.17 Right-click to Display the Menu**

![Right-click to Display the Menu](image3)
Editing Statistical Key Words and Labels

You may want to edit a statistical key word or a variable's label. For example, instead of Mean, you may want to use the word Average. To make edits, right-click the word you want to edit and select Change Item Label (Figure 8.17). In the box that appears, type the new label (Figure 8.18).

Figure 8.18 Editing Items

Note that if you change one statistics keyword to another statistics keyword, JMP assumes that you actually want to change the statistics, not just the label. It would be as if you have deleted the statistics from the table and added the latter.

Additional Tabulate Options

At the bottom of the Tabulate window, checkboxes allow you to control tool tips and shading:

- **Show Tool Tip** Displays tips that appear when you move the mouse over areas of the table.
- **Show Shading** Displays grey shading boxes in the table when there are multiple rows.

Other options are available by clicking the red triangle icon in the Tabulate window. They are shown in Figure 8.19.

Figure 8.19 The Test Build Panel

- **Show Table** Displays the summarized data in tabular form.
- **Show Chart** Displays the summarized data in bar charts that mirrors the table of summary statistics. The simple bar chart allows visual comparison of the relative magnitude of the summary statistics. By default, all columns of bars share the same scale. You can have each column of bars use the scale determined separately from the data in each displayed column, by un-checking the Uniform plot scale check box. The chart display also allows you to specify a uniform custom scale. The charts are either 0-based or centered on 0. If the data are all non-negative, or all non-positive, the charts will have its base line at 0. Otherwise, the charts are centered on 0.
Show Control Panel  Displays the control panel for further interaction.
Show Test Build Panel  Displays the control area that lets you create a “test build” using only some values from the original table. See “Using Large Amounts of Data (the Test Build Feature),” p. 272, for details.
Make Into Data Table  Makes a data table from the report. There will be one data table for each row table, since labels of different row tables may not be mapped to the same structure. See “Turning a Report Table Into a Data Table,” p. 182, for details.
Script  Displays options for saving scripts, redoing analyses, and viewing the data table. See “Saving Your Steps as a Script,” p. 177, for details.

Using Large Amounts of Data (the Test Build Feature)
If you have a very large data table, you might want to use a small subset of the data table to try out different table layouts to find one that best shows the summary information. In this case, JMP generates a random subset of the size as specified and uses that subset when it builds the table. To use the test build feature:

1. Click the red triangle icon in the Tabulate title bar.
2. Select Show Test Build Panel.
3. Enter the size of the sample you want in the box under Sample Size (>1) or Sample Rate (<1), as shown in Figure 8.20. The size of the sample can be either the proportion of the active table you enter or the number of rows from the active table.

Figure 8.20  The Test Build Panel

4. Click Resample.
5. To see the sampled data in a JMP data table, click the Test Data View button. When you dismiss the test build panel, Tabulate will use the full data table to regenerate the tables as designed.

Example of Tabulating Data
Follow along with this next example by opening Carpoll.jmp from the Sample Data folder that was installed when you installed JMP.

Creating a Table of Counts
Suppose you would like to view a table that contains counts for how many people in the survey own Japanese, European, and American cars. To create the table, select Tables > Tabulate. Then click and drag country into the left column of the table, as shown in Figure 8.21.
Now add further statistics and variables to the table. You would like to see a count of people who drive Japanese, European, and American cars broken down by the size of the car. To do this, click size and drag it beside country, as shown in Figure 8.22.
Creating a Table Showing Statistics

Now suppose you would like to see the average and standard deviation of the age of people who own each size car:

1. Click and drag `age`, placing it to the right of `size` in the table. Select **Add Analysis Columns** from the menu that appears.
2. Click and drag `Mean`, placing it over `Sum` in the table.
3. Click and drag `Std Dev`, placing it to the right of `age` in the table.

The results are shown in Figure 8.23.
Figure 8.23 Table that Includes the Mean and Standard Deviation of Age

Rearranging the Table Contents

Change the view of the data by clicking size and dragging it to the right of the table, as shown in Figure 8.24.

Figure 8.24 Moving size

Now click and drag age, placing it under Large in the table. Click and drag both Mean and Std Dev, placing them under Large in the table. The results are shown in Figure 8.25.
Figure 8.25 The Result of Moving Items

<table>
<thead>
<tr>
<th>country</th>
<th>Large</th>
<th>Medium</th>
<th>Small</th>
</tr>
</thead>
<tbody>
<tr>
<td>Japan</td>
<td>25.5</td>
<td>4.95</td>
<td>30.2</td>
</tr>
<tr>
<td>European</td>
<td>30.5</td>
<td>5.80</td>
<td>30.9</td>
</tr>
<tr>
<td>America</td>
<td>30.8</td>
<td>6.17</td>
<td>31.1</td>
</tr>
</tbody>
</table>

Now your table clearly presents the data. It is easy to see the mean and standard deviation of car owner age broken down by car size and country.
As described in “Giving Columns a Formula to Compute Values,” p. 141, you can create a column whose values are computed by a formula and store that formula as part of a column’s information. Formulas can be simple assignments of numeric, character, or row state constants, or they can contain complex evaluations based on conditional clauses. JMP’s formula editor provides you these capabilities, and it also allows you to examine or change the formula at any time.

The formula editor window operates like a pocket calculator with buttons, displays, and a list of functions.

Formulas are an integral part of a data table because:

- they are stored as part of a column’s information when you save the data table;
- you can examine or change them at any time by opening the formula editor;
- their values can be linked to, or dependent on, the values in other columns. Their values are automatically recomputed whenever you edit the values in the columns to which the formula is linked;
- their values are locked in the data table so they cannot be manually edited.

This chapter describes the formula editor and shows how to build formulas. For details on each function, see “Formula Functions Reference,” p. 431.
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating a Formula</td>
<td>279</td>
</tr>
<tr>
<td>Referencing Columns and Table Variables</td>
<td>279</td>
</tr>
<tr>
<td>Using Local Variables</td>
<td>280</td>
</tr>
<tr>
<td>Inserting Constants</td>
<td>282</td>
</tr>
<tr>
<td>Adding Operators</td>
<td>283</td>
</tr>
<tr>
<td>Using Functions</td>
<td>286</td>
</tr>
<tr>
<td>Referencing Rows</td>
<td>287</td>
</tr>
<tr>
<td>Adding Numeric Functions</td>
<td>288</td>
</tr>
<tr>
<td>Inserting Logarithmic or Trigonometric Functions</td>
<td>289</td>
</tr>
<tr>
<td>Adding Character Arguments and Returning Character Strings</td>
<td>290</td>
</tr>
<tr>
<td>Comparing Values</td>
<td>291</td>
</tr>
<tr>
<td>Using Conditional Clauses</td>
<td>292</td>
</tr>
<tr>
<td>Calculating Quantiles and Probabilities</td>
<td>293</td>
</tr>
<tr>
<td>Computing Statistical Functions</td>
<td>294</td>
</tr>
<tr>
<td>Generating Random Numbers</td>
<td>294</td>
</tr>
<tr>
<td>Using Dates and Times</td>
<td>295</td>
</tr>
<tr>
<td>Processing Row State Data</td>
<td>296</td>
</tr>
<tr>
<td>Using Assignment Functions</td>
<td>298</td>
</tr>
<tr>
<td>Ordering Expressions in Formulas</td>
<td>299</td>
</tr>
<tr>
<td>Using Formula Editor Options</td>
<td>300</td>
</tr>
<tr>
<td>Calculating Derivatives</td>
<td>300</td>
</tr>
<tr>
<td>Simplifying Complex Formulas</td>
<td>301</td>
</tr>
<tr>
<td>Evaluating Formulas</td>
<td>302</td>
</tr>
<tr>
<td>Ignoring Errors</td>
<td>303</td>
</tr>
<tr>
<td>Viewing a Formula's Values from the Formula Editor</td>
<td>303</td>
</tr>
<tr>
<td>Viewing a Formula in JSL</td>
<td>304</td>
</tr>
<tr>
<td>Editing Formulas</td>
<td>304</td>
</tr>
<tr>
<td>Customizing Formulas</td>
<td>307</td>
</tr>
<tr>
<td>Examples and Tutorials</td>
<td>310</td>
</tr>
<tr>
<td>Using Keyboard Shortcuts</td>
<td>315</td>
</tr>
<tr>
<td>Glossary of Terms</td>
<td>315</td>
</tr>
</tbody>
</table>
Creating a Formula

A formula is an expression stored in a column that performs operations in order to insert values into that column. Formulas can perform mathematical operations, such as addition and multiplication, or they can compare column values or join values by referring to other areas in the same data table. Formulas can consist of any legitimate JMP Scripting Language (JSL) commands. Once you insert a formula into a column, the column is locked: its values can only be edited by changing the formula.

There are three basic steps to building a formula:

1. Open the formula editor by right-clicking the column name to which you want to apply the formula and selecting Formula.

or

2. Double-click the column name to which you want to apply the formula, select Formula from the Column Properties drop-down menu, then click Edit Formula.

2. Select an empty formula element in the formula editing area by clicking it. (It is selected when there is a red outline around it.) All terms within the smallest nesting box relative to the place you clicked become selected. The subsequent actions apply to those combined elements.

3. Add expressions, functions, and/or terms from the formula work panel. They are applied to the highlighted red box. The following sections in this chapter provide detailed instructions on how to add constants, elements, operators, and functions.

Figure 9.1 How to Build a Formula

Step 1: Open the formula editor.

Step 2: Make sure there is a selected box in the formula editing area.

See “Using Basic Formula Editor Features,” p. 310, for an example of how to use the formula editor.

Referencing Columns and Table Variables

You can create a formula that refers to values found in other parts of the data table, such as other columns and table variables.
If you create a formula that refers to values found in other columns, the values in the column that contain the formula are dependent on the values in those other columns. Whenever a column that the formula refers to changes, the dependent column also changes. If you delete the referenced column, empty terms appear in the column containing the formula.

If you create a formula that refers to values found in table variables, those table variables must already exist in the data table. Table variables are character strings that are available to the entire table, and their names are displayed in the tables panel at the left of the data grid (see "Adding Table Variables," p. 83, for details).

To build a formula that references values found in columns or tables variables:

1. Open the formula editor by right-clicking a column name in the data grid and selecting Formula.
2. Select a box in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
3. Click the drop-down menu on the formula element browser and select either Table Columns or Table Variables, as shown in Figure 9.2. Then highlight an element from that category’s list. The element is added to the selected box in the formula editing area.

Figure 9.2 Formula Element Browser

See “Using Basic Formula Editor Features,” p. 310, for an example of referencing a column in a formula.

Note: In a formula, when you reference a column using value labels, hover your mouse over the value label to see the actual data value.

Using Local Variables

You can create and use temporary numeric variables in expressions. You can use ordinary local variables or you can use parameters, which are special types of local variables. Local variables exist only for the column in which they are defined. They appear in formulas as bold italic terms.
Local variables are most often used with Assignment functions (see “Using Assignment Functions,” p. 298, for details), which can assign expressions to local variables that are used in a complex equation. This technique can sometimes simplify building an equation and improve the efficiency of its evaluation.

To build a formula that references values found in local variables, follow the steps below.

**Step 1: Create the Local Variable**

1. Open the formula editor by right-clicking a column name in the data grid and selecting Formula.
2. Select a box in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
3. Click the drop-down menu on the formula element browser and select Local Variables from the formula element browser drop-down menu.
4. Click New Local Variable.
5. Type a name for the local variable. By default, local variables have the names $t0$, $t1$, and so on, and have missing values.
6. Assign a starting value, and click OK.
7. (Optional) To copy, edit or delete a local variable, right-click (Ctrl-click on the Macintosh) its name and select Copy, Edit, or Delete.

**Step 2: Insert a Local Variable Into a Formula**

1. Select a term in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
2. Click the local variable name in the Local Variables list. It appears in the formula as a bold italic term.

**Note:** Another way to create local variables is to use the button on the formula editor keypad, which automatically creates and displays local variables and places a semicolon after it. See “Adding Operators,” p. 283, for details.

See “Using Local Variables in a Formula,” p. 312, for an example of referencing local variables in a formula.

**Incorporating Parameters**

Parameters are special types of local variables. They can be used in formulas just as ordinary local variables can.

To view examples of parameters, perform these steps:

1. In the Sample Data folder that was installed when you installed JMP, open the Nonlinear Examples folder and then US Population.jmp.
2. Right-click the column name x-formula and select Formula.
3. Click the drop-down menu on the formula element browser and select Parameters.

Note that:

- After completing a nonlinear fit or after using the Reset button in the nonlinear control panel, the parameter’s value is the most recent value computed by the nonlinear platform.
• When a computing process changes the value of a parameter, the new value then appears in the parameter list.

• When you paste a formula with parameters into a column, the parameters are automatically created for that column unless it has existing parameters with the same names.

To build a formula that references values found in parameters:

**Step 1: Create the Parameter**

1. Open the formula editor by right-clicking a column name in the data grid and selecting Formula.
2. Make sure a term is selected (a red highlight is around it in the formula editing area) in the formula editing area.
3. Click the drop-down menu on the formula element browser and select Parameters.
4. Click New Parameter.
5. Type a name for the parameter. By default, parameters have the names b0, b1, and so on, and have missing values.
6. Assign a starting value, and click OK. It is important to enter this value when using a parameter in a model for the nonlinear platform. After completing a nonlinear fit, the parameter’s value is the most recent value computed by the nonlinear platform.
7. (Optional) To copy, edit or delete a parameter, right-click (Ctrl-click on the Macintosh) its name and select Copy, Edit, or Delete.

**Step 2: Insert a Parameter Into a Formula**

1. Select a term in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
2. Click the parameter name in the Parameters list. The parameter appears in the formula as bold type.

**Inserting Constants**

Formulas can be simple assignments of numeric, character, or row state constants, or they can contain complex evaluations based on conditional clauses. Constants include commonly-used numeric terms, such as e, pi, -1, 0, 1, and 2. There are two ways to add a constant value to a formula:

• Type them in manually using the keyboard
• Select them from the formula element browser, as shown in Figure 9.3.
To build a formula that contains constants:

1. Open the formula editor by right-clicking a column name in the data grid and selecting **Formula**.
2. Select a box in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
3. Either type in a number or click the drop-down menu at the top of the formula element browser and select **Constants**, as shown in Figure 9.3. Then click a value in the list that appears—0, 1, 2, -1, pi, e. The value appears in the outlined box.
4. Complete the remainder of the formula using the keypad and/or functions (see “Referencing Columns and Table Variables,” p. 279, “Adding Operators,” p. 283, and “Using Functions,” p. 286).

### Adding Operators

You can add operators to a formula by clicking the keypad (shown in Figure 9.4), which is a set of buttons used to help build formulas. It is composed of common operators, which are also referred to as functions.
To build a formula using operators found on the on-screen keypad:

1. Open the formula editor by right-clicking a column name in the data grid and selecting **Formula**.
2. Select a box in the formula editing area by clicking it. (It is selected when there is a red outline around it.) The operator will perform its action on the area that is highlighted.
3. Click the keypad button(s). See Figure 9.5 for an example of using the keypad.

**Figure 9.5** Example of Using the Keypad Operators

Click the minus key to add a subtraction operator

Use the table below to understand the on-screen keypad buttons.

**Table 9.1** Keypad Buttons in the Formula Editor

<table>
<thead>
<tr>
<th>Key</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Arithmetic buttons</td>
<td>Work as they normally do on a pocket calculator, providing addition, multipli-</td>
</tr>
<tr>
<td>-</td>
<td></td>
<td>cation, subtraction, and division operators.</td>
</tr>
</tbody>
</table>
Table 9.1 Keypad Buttons in the Formula Editor

<table>
<thead>
<tr>
<th>Key</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Insert" /></td>
<td>Insert</td>
<td>Inserts a new clause or function argument. First select the existing clause or argument you want the new element to follow, then click this button. The new clause appears and is selected. You can also insert a new clause or argument by typing a comma.</td>
</tr>
<tr>
<td><img src="image" alt="Delete" /></td>
<td>Delete</td>
<td>Deletes an element’s value, or deletes a clause. The delete button functions the same as the Delete key on the keyboard.</td>
</tr>
<tr>
<td><img src="image" alt="Exponent" /></td>
<td>Exponent</td>
<td>Raises a given value to a specified power. It has an exponent of two by default. The power is initially highlighted and can be changed to another value.</td>
</tr>
<tr>
<td><img src="image" alt="Root" /></td>
<td>Root</td>
<td>Calculates the specified root of the radicand. It has an implied index of two (a square root), which is not displayed. The index area is initially highlighted so you can enter a different index value.</td>
</tr>
<tr>
<td><img src="image" alt="Switch terms" /></td>
<td>Switch terms</td>
<td>Looks at the operator that is central to the selected expression and switches the expressions on either side of that operator.</td>
</tr>
<tr>
<td><img src="image" alt="Unary sign function" /></td>
<td>Unary sign function</td>
<td>Inverts the sign of the argument. Apply the unary sign function to variable expressions or use it to enter negative constants.</td>
</tr>
<tr>
<td><img src="image" alt="Local variable" /></td>
<td>Local variable</td>
<td>Creates and displays a local variable and assigns it the value of the selected expression. The local variable has the default name $t0$ in an expression and a semicolon after it. See “Using Local Variables,” p. 280, for details on creating and inserting local variables. See “Examples and Tutorials,” p. 310, for an example.</td>
</tr>
<tr>
<td><img src="image" alt="Delete expression (peel)" /></td>
<td>Delete expression (peel)</td>
<td>Deletes the selected expression and leaves a selected empty term in its place. Repeat this process to delete a formula term by term, in the precedence order of the formula, beginning with the first term you select, as shown in Figure 9.6. The on-screen delete expression key also lets you peel functions from their arguments. To do this, select a function and its arguments, then click this button. The function and all but its first argument are deleted. See “Deleting Functions,” p. 305, for details.</td>
</tr>
</tbody>
</table>

Figure 9.6 Repeated Clicks on the Delete Expression Key Produces This Sequence of Steps
Using Functions

You can add many types of functions to a formula. All of these functions are organized in the function browser, which groups collections of functions and features in lists organized both alphabetically (Functions (all)) and by topic (Functions (grouped)), as shown in Figure 9.7. Use the function browser to specify the type of calculation you want to perform on the elements in a formula.

Figure 9.7 The Function Browser

To create a formula that contains a function:

1. Open the formula editor by right-clicking a column name in the data grid and selecting Formula.
2. Select an expression in the formula editing area by clicking it. (It is selected when there is a red outline around it.) The function will perform its action on the area that is highlighted.
3. Click the drop-down menu in the function browser to view the groups of functions.
4. Select a group of functions to view. The functions that belong to that group are then displayed in the list below the drop-down menu. The function groups are briefly described in the following list. For a full description, see the following sections, starting with “Referencing Rows,” p. 287.

- **Functions (all)** Displays a list of all available functions in alphabetical order.
- **Functions (grouped)** Displays a list of all available functions grouped according to topic.
- **Row** Displays a list of functions that contains miscellaneous functions such as Lag, Dif, Subscript, Row, and NRow. See “Referencing Rows,” p. 287, for details.
- **Numeric** Displays a list of functions that are terms commonly used in formulas. See “Adding Numeric Functions,” p. 288, for details.
- **Transcendental** Displays a list of functions that are functions such as natural log, common log, exponential, root, factorial, combinatorial, beta, and gamma. See “Inserting Logarithmic or Trigonometric Functions,” p. 289, for details.
- **Trigonometric** Displays a list of functions that are the standard trigonometric functions: sine, cosine, tangent, inverse functions, and hyperbolic functions. See “Inserting Logarithmic or Trigonometric Functions,” p. 289, for details.
Character Displays a list of functions that operate on character arguments for trimming, finding the length of a string, changing numbers to characters or characters to numbers, etc. See “Adding Character Arguments and Returning Character Strings,” p. 290, for details.

Comparison Displays a list of functions that are the standard logical comparisons such as less than, less than or equal to, not equal to, etc. See “Comparing Values,” p. 291, for details.

Conditional Displays a list of functions that are programming-like functions, such as If, Match, and Select. See “Using Conditional Clauses,” p. 292, for details.

Probability Displays a list of functions that compute probabilities and quantiles for standard statistical distributions, such as normal, Student’s t, Chi-squared, and F-distributions. See “Calculating Quantiles and Probabilities,” p. 293, for details.

Statistical Displays a list of functions that calculate standard statistical quantities such as the mean or standard deviation. See “Computing Statistical Functions,” p. 294, for details.

Random Displays a list of functions that generate random numbers based on predefined distributions such as the uniform, normal, Cauchy, etc. There is also a function to randomize the order of table rows. See “Generating Random Numbers,” p. 294, for details.

Date Time Displays a list of functions that require arguments with the date data type, which is interpreted as the number of seconds since January 1, 1904. Date Time functions return values such as day, week, or month of the year. They can also compute dates and can find data intervals. See “Using Dates and Times,” p. 295, for details.

– Row State

Displays a list of functions that assign or detect row state status of color, marker, label, hidden, excluded, or selected. See “Processing Row State Data,” p. 296, for details.

Assignment Displays a list of functions that place the value on the right side of the assignment operator into the variable on the left side of the operator. See “Using Assignment Functions,” p. 298, for details.

5 Click any function in the Functions list to apply it to the selected item. When you click some items, you reveal a submenu from which you should make a selection.

Note: Most formulas give hints about appropriate arguments through grey words inserted in the boxes in the formula editing area. Formulas also show a small caret in the argument area if additional arguments can be added.

6 Continue to build the formula by highlighting terms and clicking items in the formula element browser, keypad, or function browser.

Referencing Rows

Adding a row function to a formula lets you reference specific rows or cells within specific rows. It lets you insert miscellaneous functions such as Lag, Dif, Subscript, Row, and NRow. To reference rows:

1 Open the formula editor by right-clicking a column name in the data grid and selecting Formula.

2 Select an expression in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
3 Click the drop-down menu on the function browser and select **Row**, as shown in Figure 9.8. The row functions now appear in the list below the drop-down menu.

**Figure 9.8 Select Row From the Function Browser List**

4 Select which function to insert in the formula. For descriptions of each function, see “**Row Functions**,” p. 433.

### Adding Numeric Functions

You can create a formula that contains arithmetic operators that are commonly used in formulas, such as absolute value, modulo, and floor. To add such numeric terms to a formula:

1 Open the formula editor by right-clicking a column name in the data grid and selecting **Formula**.
2 Select an expression in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
3 Click the drop-down menu on the function browser and select **Numeric**, as shown in Figure 9.9. The numeric functions now appear in the list below the drop-down menu.

**Figure 9.9 Select Numeric from the Function Browser List**
4 Select which function to insert in the formula. For descriptions of each function, see "Numeric Functions," p. 435.

Inserting Logarithmic or Trigonometric Functions

You can create a formula that supports transcendental functions, such as logarithmic functions for any base, functions for combinatorial calculations, the Beta function, and several gamma functions. To add transcendental functions:

1 Open the formula editor by right-clicking a column name in the data grid and selecting Formula.
2 Select an expression in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
3 Click the drop-down menu on the function browser and select Transcendental, as shown in Figure 9.10. The transcendental functions now appear in the list below the drop-down menu.

**Figure 9.10** Select Transcendental

![Transcendental Functions](image)

4 Select which function to insert in the formula. For descriptions of each function, see "Transcendental Functions," p. 435.

JMP also supports most trigonometric functions. To create a formula that employs trigonometric functions:

1 Open the formula editor by right-clicking a column name in the data grid and selecting Formula.
2 Select an expression in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
3 Click the drop-down menu on the function browser and select Trigonometric, as shown in Figure 9.11. The trigonometric functions now appear in the list below the drop-down menu.
Adding Character Arguments and Returning Character Strings

You can create a formula that accepts character arguments or returns character strings and converts the data type of a value from numeric to character, or character to numeric. When you create these formulas, note that:

- Character functions can result in either character or numeric data. If you calculate a data type different than the one specified, the data type of the computed column is automatically changed to match the result.
- When character functions result in character values greater than the allotted field width (as specified in the Column Info window, which is accessed by double-clicking a column name), the length of the character field is automatically increased to hold the computed result.
- Arguments that are literal character strings must be enclosed in quotation marks.

To build a formula that contains a character function or returns character strings:

1. Open the formula editor by right-clicking a column name in the data grid and selecting **Formula**.
2. Select an expression in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
3. Click the drop-down menu on the function browser and select **Character**, as shown in Figure 9.12. The character functions now appear in the list below the drop-down menu.
Chapter 9
The Formula Editor

Using Functions

Figure 9.12 Select Character from the Function Browser List

4 Select which function to insert in the formula. For descriptions of each function, see “Character Functions,” p. 438.

See “Using the Munger Function,” p. 313, for an example.

Comparing Values

You can create a formula that compare the values of two arguments. You do this by using the comparison function. Each comparison relationship evaluates as true or false based on numeric magnitudes or character rankings. A true relationship evaluates as 1, and false evaluates as 0.

Comparisons are useful when you include them in conditional expressions, but they can also stand alone as numeric expressions if neither term in comparison is missing.

A relational symbol’s arguments can be any two expressions. However, both arguments in a comparison function must be of the same data type. Also note that:

• JMP displays an error if you use a single “=” in a conditional where “==” is expected.
• The formula editor uses the International Utilities package when comparing character strings. This package contains different rankings for each international character set and takes diacritical marks into consideration.
• You should not use comparison operators to specifically compare to a missing value. Instead, use the Is Missing function to detect a missing value (see “Comparing Values,” p. 291).

To build a formula that contains a comparison function:

1 Open the formula editor by right-clicking a column name in the data grid and selecting Formula.
2 Select an expression in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
3 Click the drop-down menu on the function browser and select Comparison, as shown in Figure 9.13. The comparison functions now appear in the list below the drop-down menu.
Using Conditional Clauses

You can include conditional expressions (called *conditionals* for short) in your formulas. These expressions let you build a sequence of clauses paired with result expressions. Constructing a sequence of clauses is the way you conditionally assign values to cells in a calculated column. Conditionals follow these rules:

- When no clause is true, the formula editor evaluates the result expression that accompanies the else clause.
- All result expressions in a conditional expression must evaluate to the same data type.
- A missing term matches any data type.
- By definition, expressions that evaluate as zero are false.
- If an expression evaluates as missing, no clauses are executed and missing is returned. All other numeric expressions are true.

To build a formula that contains conditional clauses:

1. Open the formula editor by right-clicking a column name in the data grid and selecting **Formula**.
2. Select an expression in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
3. Click the drop-down menu on the function browser and select **Conditional**, as shown in Figure 9.14. The conditional functions now appear in the list below the drop-down menu.
4 Select which function to insert in the formula. For descriptions of each function, see “Conditional Functions,” p. 445.

See “Using the Match Conditional Function,” p. 314, for an example.

Calculating Quantiles and Probabilities

You can create a formula that calculates quantiles for various standard statistical distributions and quantiles. To calculate quantiles and probabilities:

1 Open the formula editor by right-clicking a column name in the data grid and selecting Formula.
2 Select an expression in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
3 Click the drop-down menu on the function browser and select Probability, as shown in Figure 9.15. The probability functions appear in the list below the drop-down menu.

Figure 9.15 Select Probability

4 Select which function to insert in the formula. For descriptions of each function, see “Probability”
Computing Statistical Functions

There are two kinds of Statistical functions you can use in a formula:

- The functions with names that have the prefix Col. These functions compute statistics for a column of numbers or expressions involving columns.
- The Mean, Std Dev, Number, Sum, Quantile, Maximum, Minimum, and N Missing functions. These functions evaluate across columns or arguments. The statistic is computed for each row across the series of arguments. You can use the insert key ( ) on the on-screen keypad, or type a comma to add arguments to the functions that accept multiple arguments. When there are multiple contiguous arguments, select the function and the first argument, then Shift-click the last argument in the group. These functions then automatically show with the complete list.

To create a formula containing a statistical function:

1. Open the formula editor by right-clicking a column name in the data grid and selecting Formula.
2. Select an expression in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
3. Click the drop-down menu on the function browser and select Statistical, as shown in Figure 9.16. The statistical functions now appear in the list below the drop-down menu.

Figure 9.16 Select Statistical from the Function Browser List

4. Select which function to insert in the formula. For descriptions of each function, see “Statistical Functions,” p. 457.

Generating Random Numbers

You can create formulas that generate real numbers by effectively “rolling the dice” within the constraints of a specified distribution. Each time you click Apply in the formula editor window, these functions produce a new set of random numbers.
Note: Random numbers are generated using the Mersenne-Twister technique. This technique has a period length of $2^{19937} - 1$ (as opposed to $2^{31} - 1$ for the generator used in JMP 4.03 and earlier). Details on the generators is found in Matsumoto and Nishimura (1998). The new generators are verified to pass all the DIEHARD tests as documented in Marshalled (1996).

To create a formula containing a random number:
1. Open the formula editor by right-clicking a column name in the data grid and selectingFormula.
2. Select an expression in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
3. Click the drop-down menu on the function browser and select Random, as shown in Figure 9.17. The random functions now appear in the list below the drop-down menu.

**Figure 9.17** Select Random from the Function Browser List

4. Select which function to insert in the formula. For descriptions of each function, see “Random Functions,” p. 461.

Using Dates and Times

JMP stores dates and times in numeric columns using the Macintosh standard of the number of seconds since Jan 1, 1904. When a column has date values, you can assign a date format to that column by double-clicking a column name and selecting Date or Time from the Format menu. See “Numeric Format Options,” p. 61, for details.

To use dates and times in a formula:
1. Open the formula editor by right-clicking a column name in the data grid and selectingFormula.
2. Select an expression in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
3. Click the drop-down menu on the function browser and select Date Time, as shown in Figure 9.18. The date and time functions now appear in the list below the drop-down menu.
Figure 9.18 Select Date Time from the Function Browser List

4 Select which function to insert in the formula. For descriptions of each function, see “Date Time Functions,” p. 464.

Processing Row State Data

There are six characteristics that rows in a data table can have: selected, hidden, excluded, labeled, colored, and marked. If you give rows one or more of these characteristics (see “Assigning Characteristics to Rows and Columns,” p. 129, for details) and then create row state data table columns (see “Using Row State Columns,” p. 162, for details), you can then create a formula that computes and saves row state conditions. This formula processes row state data just as it would process character and numeric data.

Note: A row can be assigned any combination of row states; a row state column can have multiple row states as a value.

Use the table below to understand the type of argument each Row State function requires and what each returns.

Table 9.2 Row State Functions

<table>
<thead>
<tr>
<th>Function Name</th>
<th>Argument Type Required</th>
<th>What the Function Returns (Your Column Data Type Should Be This Type)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Row State</td>
<td>none</td>
<td>row state of current row</td>
</tr>
<tr>
<td>As Row State</td>
<td>numeric</td>
<td>all row states of current row</td>
</tr>
<tr>
<td>Combine States</td>
<td>multiple row state arguments</td>
<td>multiple row state assignments</td>
</tr>
<tr>
<td>Excluded State</td>
<td>positive integer or zero</td>
<td>row state-excluded or not excluded</td>
</tr>
<tr>
<td>Hidden State</td>
<td>positive integer or zero</td>
<td>row state-hidden or not hidden</td>
</tr>
<tr>
<td>Labeled State</td>
<td>positive integer or zero</td>
<td>row state-labeled or not labeled</td>
</tr>
<tr>
<td>Color State</td>
<td>integer</td>
<td>row state color</td>
</tr>
<tr>
<td>Marker State</td>
<td>integer 0-15 (dark) 16-31 (gray)</td>
<td>row state marker</td>
</tr>
<tr>
<td>Selected State</td>
<td>positive integer or zero</td>
<td>row state-selected or not selected</td>
</tr>
</tbody>
</table>
Using Functions

To process and store row state data using a formula:

1. Make sure rows in your data table have at least one characteristic (see “Assigning Characteristics to Rows and Columns,” p. 129).
2. Make sure your columns have the correct data type. Use the table above to determine which data type (row state, numeric, or integer) to assign columns. To create row state data table columns, see “Using Row State Columns,” p. 162. To create numeric and integer columns, see “About Data Types,” p. 57, and “How to Assign Data and Modeling Types,” p. 58.
3. Open the formula editor by right-clicking a column name in the data grid and selecting Formula.
4. Select an expression in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
5. Click the drop-down menu on the function browser and select Row State, as shown in Figure 9.19. The row state functions now appear in the list below the drop-down menu.

**Figure 9.19** Select Row State from the Function Browser List

6. Use the table above to help select which function to insert in the formula. For descriptions of each function, see “Row State Functions,” p. 466.

<table>
<thead>
<tr>
<th>Function Name</th>
<th>Argument Type Required</th>
<th>What the Function Returns (Your Column Data Type Should be This Type)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hue State</td>
<td>integer</td>
<td>row state hue</td>
</tr>
<tr>
<td>Shade State</td>
<td>integer 1-5</td>
<td>row state intensity</td>
</tr>
<tr>
<td>Excluded</td>
<td>Row State() or row state column</td>
<td>numeric 0 (not excluded) or 1 (excluded)</td>
</tr>
<tr>
<td>Hidden</td>
<td>Row State() or row state column</td>
<td>integer 0 (not hidden) or 1 (hidden)</td>
</tr>
<tr>
<td>Labeled</td>
<td>Row State() or row state column</td>
<td>integer 0 (not labeled) or 1 (labeled)</td>
</tr>
<tr>
<td>Color Of</td>
<td>Row State() or row state column</td>
<td>color map integer</td>
</tr>
<tr>
<td>Marker Of</td>
<td>Row State() or row state column</td>
<td>marker map integer</td>
</tr>
<tr>
<td>Selected</td>
<td>Row State() or row state column</td>
<td>integer 0 (not selected) or 1 (selected)</td>
</tr>
</tbody>
</table>
Using Assignment Functions

Assignment functions work in place. That is, the result returned by the operation (on the right of the operator) is stored in the argument on the left of the operator and replaces its current value.

Assignment statements are most often used in conjunction with other commands to build a JMP Scripting Language (JSL) script. You can use the formula editor to create and execute a script in that column, but this is not recommended because of dependencies and ambiguities that can result. Most often, scripts are stored as .jsl files, and can be saved with a data table (see “Creating Scripts,” p. 86, for details). See the JMP Scripting Guide for documentation of all scripting commands.

Note: The first argument of an assignment function must be capable of being assigned. This means you cannot have an assignment such as 3+=4, because 3 is a constant value that cannot be reassigned. You must first create a variable (a table variable or local variable) whose value is 3. (See “Adding Table Variables,” p. 83, for details on table variables. See “Referencing Columns and Table Variables,” p. 279, for details on local variables). Then use that variable as the left-hand argument of the assignment function.

To build a formula that contains an assignment function:
1. Open the formula editor by right-clicking a column name in the data grid and selecting Formula.
2. Select an expression in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
3. Click the drop-down menu on the function browser and select Assignment, as shown in Figure 9.20. The assignment functions now appear in the list below the drop-down menu.

Figure 9.20 Select Assignment from the Function Browser List

4. Select which function to insert in the formula. For descriptions of each function, see “Assignment Functions,” p. 469.
Ordering Expressions in Formulas

As you build a formula, keep in mind that all functions have an order of precedence shown in the following table, where level one is the highest order of precedence. Expressions with a high order of precedence are evaluated before those at lower levels. When an expression has operators of equal precedence, it is evaluated from left to right. You can use parentheses to override other precedence rules when necessary because any expression within parentheses is always evaluated first. Terms have no order of precedence because they cannot be evaluated further. Use the table below to understand levels one through six in the order of precedence.

Table 9.3 Order of Precedence of Operators in Formulas

<table>
<thead>
<tr>
<th>Level 1</th>
<th>Parentheses</th>
</tr>
</thead>
<tbody>
<tr>
<td>Level 2</td>
<td>Functions in the function browser lists except for those listed in other levels</td>
</tr>
<tr>
<td>Level 3</td>
<td>*, ÷, Modulo</td>
</tr>
<tr>
<td>Level 4</td>
<td>+, −</td>
</tr>
<tr>
<td>Level 5</td>
<td>Comparisons: &lt;, ≤, =, ≠, ≥, ≤ x &lt;, &lt; x ≤, &lt; x &lt;</td>
</tr>
<tr>
<td>Level 6</td>
<td>Logical Functions: And, Not, Or</td>
</tr>
</tbody>
</table>

Note: When a function has an expression as its argument, the argument has a higher order of precedence than it would if enclosed in parentheses outside the function.

Building a Formula in Order of Precedence

It is best to build a formula starting with any expression that serves as an argument. This is because functions have a high order of precedence and are always grouped with their corresponding arguments. It is also a good idea to create expressions working from highest to lowest order of precedence when possible. If you need parentheses, be sure to type the left parenthesis before entering the expression to be enclosed.

For example, given a data table with the columns A, B, and C, use the following steps to compose the expression $A(B + C)$. Note that this expression is not the same as $A \times B + C$, which evaluates as $(A \times B) + C$. To enter the expression:

1. Select Table Columns from the formula element browser list.
2. Click column A in the Table Columns list.
3. Click the multiplication button (\( \times \)) in the formula editor keypad.
4. Type an open parenthesis—(.
5. Click column B in the Table Columns list.
6. Click the addition button (\( + \)) in the formula editor keypad.
7. Click column C in the Table Columns list.

\[ A \times (B + C) \]
Because order of precedence determines which arguments are affected by each function, order of precedence also affects the grouping of expressions. Select functions in the formula to verify how the order of precedence rules have been applied.

**Structuring Formulas for Efficient Evaluation**

Usually, it is not necessary to structure formulas with efficient evaluation in mind. Most formulas evaluate almost instantaneously regardless of their structure. This is because statistical functions and constant expressions are evaluated only once when a column's values are calculated.

However, when you are creating conditional expressions, keep in mind that **Match** evaluates faster and uses less memory than an equivalent **Condition** function, **If**. (Note that **Match** ignores trailing spaces, while **If** does not.)

Consider two formulas for predicting a child's height from his age shown in Figure 9.21. In each case there is a base height of 58.125 inches to which a quantity is added depending on the value of the **age** variable.

**Figure 9.21** The Match Conditional Evaluates Faster Than the If Function

The **Match** conditional evaluates faster than the **If** function because the **age** variable is evaluated only once for each row in the data table. The **If** condition must evaluate the **age** variable at each **if** clause for each row until a clause evaluates as true.

**Using Formula Editor Options**

There are several options the formula editor makes available to you as you create formulas. The following sections discuss each of these options.

**Calculating Derivatives**

JMP's formula editor can find and display the derivative of a function. The derivative is found with respect to the function argument (a single variable name) you highlight. Thus, in order to differentiate with respect to **x**, **x** must be one of the arguments in the expression. The red triangle icon found above the keypad contains the **Derivative** command, as shown in Figure 9.22.
Chapter 9

The Formula Editor

Using Formula Editor Options

301

Figure 9.22 Select Derivative from the Keypad Menu Commands

To calculate a derivative:
1. Enter a function.
2. Highlight a variable.
3. Select Derivative from the menu. Figure 9.23 shows the completion of these steps.

Figure 9.23 Using the Derivative Option

Simplifying Complex Formulas

When the formula editor contains a complex formula, JMP can simplify it using various algebraic rules. It can find constant expressions, distribute multiplication over addition, combine terms, and more.

To simplify complex formulas, select a portion or all of the formula, click the red icon above the keypad, and select Simplify from the drop-down menu that appears, as shown in Figure 9.24.
Evaluating Formulas

By default, JMP evaluates each formula you create, checking behind your formula creation to ensure that it is valid. You can turn this evaluation off, or you can implement it before you have finished creating a formula.

Suppressing Evaluation

Turning off evaluation is a useful formula development mode for building complex formulas. You can turn off evaluation and build sections of a formula, and evaluate only to test it. In particular, you can close the formula editor and reopen it at a later time to continue building a formula without JMP evaluating it.

To suppress formula evaluation, click the red icon above the keypad and select Suppress Eval from the drop-down menu that appears, as shown in Figure 9.25.

Figure 9.25 Select Suppress Evaluation
When evaluation is suppressed, the formula icon appears greyed ( on Windows/Linux; ( ) on Macintosh):

- If the icon appears to the right of the red triangle icon in the formula editor, it indicates that formula evaluation is suppressed for that formula.
- If the icon appears beside the column name in the column panel, it indicates that the values in the column result from a formula. When formula evaluation is suppressed, this plus icon becomes grey (see “Iconic Indicators,” p. 139, for details).

**Note:** The **Apply** button ignores the formula evaluation setting. Thus, when formula evaluation is suppressed, clicking the **Apply** button overrides the suppression and evaluates the formula before it is applied to the column.

**Ignoring Errors**

Once you construct a formula and click **OK**, JMP checks behind the formula for error and alerts you of any errors that it finds. An error message appears for each error and asks if you want to ignore further errors.

There might be times where you could like to suppresses error messages while a formula is under development. This is useful in situations where you want to see an evaluation for some rows and don't want to see an error message for every row where the formula evaluation finds problems.

To have JMP ignore any errors it finds:

1. Create a formula.
2. Click the red triangle icon above the keypad and select **Ignore Errors**, as shown in Figure 9.26.

![Figure 9.26 Select Ignore Errors from the Keypad Menu Commands](image)

**Viewing a Formula’s Values from the Formula Editor**

Once JMP has evaluated a formula, you can select an expression to see its value. This is true for both parameters and expressions that evaluate to a constant value. To view values:
1. While in the formula editor, select the expression you want to know about.
2. Right-click (Ctrl-click on the Macintosh) the selected expression. This displays the menu in Figure 9.27.
3. Select Evaluate. The current value of the selected expression appears in a yellow box until you move the cursor.

**Figure 9.27 Right-Click to See the Value of an Expression**

---

**Viewing a Formula in JSL**

You have the option of entering or changing any part of a formula in text mode. Text mode displays the formula in JMP Scripting Language (JSL). The entire formula (or any of its terms) appears in text mode when you double-click the white space inside the boxed formula area. The elements of that box appear as plain text and you can then edit the formula as you would in any text editor.

Any element of a formula can be displayed as a scripting command and then edited. After editing formula scripting commands, click outside the formula to see its formatted form. For example, the text for the standardization of weight is `(:weight - Col Mean(:weight)) / Col Std Dev(:weight)`.

Any element of a formula can be displayed as a scripting command and then edited. After editing formula scripting commands, click outside the formula to see its formatted form. For example, the text for the standardization of weight is `(:weight - Col Mean(:weight)) / Col Std Dev(:weight)`.

To enter an If statement in text form, add pairs of arguments for each If/Then clause in the statement, and a single last argument for the else clause if needed. In text form, the If statement in Figure 9.28 looks like this: `If(total !== 0, (count/total)*100, 0)`.

**Figure 9.28 An If Statement in Formula Mode**

---

**Editing Formulas**

If you need to change a formula after you have exited the formula editor, right-click (Ctrl-click on the Macintosh) the column name in the data grid and select Formula.

**Correcting Mistakes**

If you make a mistake while entering a formula, select Edit > Undo. Undo reverses the effect of the last (undo-able) command.
There are other editing commands to help modify formulas:

- Click the delete button ( deleter) on the formula editor keypad to remove the selected expression.
- Use the cut, copy, and paste shortcut commands or right-click a highlighted part of the formula and select Cut, Copy, or Paste from the menu.
- To rearrange terms or expressions, click to see the hand ( seleter) grab the term. Drag to move formula pieces.

Selecting Expressions

Use the keyboard arrow keys to select expressions for editing or to view the formula's order of precedence when parentheses are not present or the boxing option is not in effect (see “Hiding and Showing Boxing,” p. 307).

Clicking an operator (+, −, *, ÷) in an expression selects the operator and its operands. Once an operator is selected:

- The left and right arrow keys move the selection across other associative operations having equal precedence within the expression.
- The left arrow extends the selection to include the next operand and operator of higher precedence to the selection, until the entire formula is selected.
- The up arrow extends the current selection by adding the operand and operator of higher precedence to the selection.
- The down arrow reduces the current selection by removing an operand and operator from the selection.

Deleting Functions

Deleting a function also deletes its arguments. Deleting a required argument or missing term from a function sometimes deletes the function as well.

You can peel a function to delete it from its argument. To peel a function from a single argument:

1. Select the function.
2. Click the peel button ( peeler) from the formula editor keypad (Figure 9.29). Or, use the hand tool to drag the argument on top of its function.

Figure 9.29 Peeling an Argument

3. Complete formula changes.
4. Click Apply, and the new values fill the data table column automatically.
5. Once you have created a formula, you can change values in columns that are referenced by your formula. JMP automatically recalculates all affected values in the formula's column.
Cutting, Copying, and Pasting

You can cut or copy any expression or an entire formula and paste it into another formula display. Use the cut, copy, and paste shortcut commands or right-click a highlighted part of the formula and select Cut, Copy, or Paste from the menu, as shown in Figure 9.30. The following apply when you cut, copy, and paste a formula:

- When you paste it into another formula display, the formula appears in formatted form.
- The formula is saved on the clipboard as a JSL statement. Thus, if you copy it into other applications, it appears as a JMP Scripting Language (JSL) statement.
- When using a European locale setting, commas are copied and pasted along with numbers.

Note: Press the Shift key on your keyboard, then click the red triangle to reveal a command called Copy As SAS Formula.

Figure 9.30 Cut, Copy, and Paste Commands

Clicking and Dragging

You can drag any part of a formula that can be selected to any other location that can be selected. To click and drag:

1. Place the arrow cursor inside an expression.
2. Click the expression. It is highlighted and the cursor changes to a hand cursor.
3. Drag across the formula. Destination expressions are highlighted.
4. Drag the selected expression to the new desired location. The selected expression is copied to the new location, where it replaces the existing expression.
Customizing Formulas

There are several ways you can customize formulas in the formula editor. The following sections describe how to change font size, show and hide boxing, change the orientation of the formula, and close arguments.

Changing the Font Size

You can incrementally increase or decrease the font used to display the formatted formula by clicking the red triangle icon above the keypad and selecting Larger Font or Smaller Font, as shown in Figure 9.31. Repeat this process to further increase or decrease the font size.

Figure 9.31 Select Larger or Smaller Font

Hiding and Showing Boxing

By default, JMP outlines specific terms within the formula. This is called boxing. Boxing is useful when you want to select and modify a specific portion of a formula, or need to determine the order of evaluation that takes place. To turn boxing on or off:

1 Build a formula.
2 Click the red triangle icon above the keypad and select Show Boxing, as shown in Figure 9.32. When a check appears on the menu beside Show Boxing, the outline appears in the formula. When it does not, the outline does not appear.
Changing a Formula’s Orientation

By default, JMP gauges the size of a formula and displays it in the formula editor in the best orientation (horizontally or vertically). However, if you create a long formula, you may want to display it in a layout that satisfies your preference.

To change a formula’s orientation:

1. Build a formula.
2. Highlight an argument or formula.
3. Right-click (Ctrl-click on the Macintosh) what you have highlighted.
4. Select **Orientation** from the menu that appears, as shown in Figure 9.33.
5 Select from the Orientation options: Best, Horizontal, or Vertical.

Opening and Closing Arguments

You can close formulas and arguments so they become minimized. This is useful when you have a large formula or large arguments and you want to fit the entire formula on the screen. To close an argument:

1 Build a formula.
2 Highlight an argument or formula.
3 Right-click (Ctrl-click on the Macintosh) what you have highlighted.
4 Select Close or Close Arguments from the menu that appears, as shown in Figure 9.34.
Examples and Tutorials

To better familiarize yourself with building formulas, you can review the following examples and tutorials.

Using Basic Formula Editor Features

The following example uses Big Class.jmp to walk you through using the basic features of the formula editor. You can find Big Class.jmp by looking in a folder named Sample Data, which was installed when you installed JMP.

Big Class.jmp has a column called weight. Suppose you want a new column that computes standardized weight values. To create this column using a formula to obtain its values:

1. Open Big Class.jmp.
2. Select Cols > New Column.
3. Type the new name, Standard Weight, in the box beside Column Name.
4. Select Formula from the Column Properties drop-down menu, as shown in Figure 9.35.
Figure 9.35 Create a New Formula

5 Click the empty formula element in the formula editing area to select it, as shown in Figure 9.36. When you create a formula and Show Boxing is checked (see “Hiding and Showing Boxing,” p. 307), the selected portion of the formula is outlined with a thin red line. All terms within the smallest nesting box relative to the place you clicked become selected, and the subsequent action applies to those combined elements.

Figure 9.36 Select the Empty Formula Element

Next, enter the formula that standardizes the weight values by following these steps:

1 While the initial missing term is selected, click weight in the formula element browser column selector list.
2 Click the minus button (−) in the formula editor keypad. A new missing term appears after the minus sign as shown in Figure 9.38.
3 Click weight again.
4 Click the function browser drop-down, and select Statistical.
5 Select Col Mean from the Statistical list, as shown in Figure 9.37.
6. Select the entire expression. The red box should now enclose the whole formula.

7. Click the division button (÷) in the keypad. The result gives a selected missing denominator for the whole expression.

8. Click weight again from the column selector list. It becomes selected in the denominator.

9. Select Col Std Dev from the Statistical list. The completed formula should look like that in Figure 9.38.

10. Close the formula editor by clicking OK. The new column fills with values. When a weight value changes, the calculated std weight value automatically recalculates.

Using Local Variables in a Formula

Suppose you have variables $x$ and $y$ and you want to compute the slope in a simple linear regression of $y$ on $x$ using the standard formula shown in Figure 9.39. One way to do this is to create two local variables (see “Using Local Variables,” p. 280), call them XY and Xsqr. Then assign them to the numerator and the denominator calculations of the slope formula. Delimit each assignment with a semicolon, as described in Figure 9.39. (Statements in the formula editor are actually JSL programming statements. Multiple statements in a formula must be separated by a semicolons.) The slope computation is simplified to XY divided by Xsqr.
Using the Munger Function

The following examples show uses of the Munger function. In these examples, assume that there is a character column of names with “Veronica Layman” as one of its values. To simplify the examples, the literal name “Veronica Layman” is the search string instead of a column name.

See “Adding Character Arguments and Returning Character Strings,” p. 290, for instructions on how to incorporate Character functions, such as Munger, into a formula.

Inserting Characters

This Munger example finds the blank between the first and last name, and inserts the middle initial “J.” The formula Munger("Veronica Layman", 1, "", " J. ") inserts the middle initial J., and evaluates as Veronica J. Layman.

Double quotes are required by the Munger function for literal strings, including strings that consist of a blank or when leading or trailing blanks are part of a string.

Deleting Characters

To delete one or more characters from a string, designate the characters to delete as the Find string in the Munger function, and enter a Replace string that is two quotation marks to indicate a null string. For example, the function, Munger("Veronica Layman", 1, "onic", "") removes the “onic” from Veronica and evaluates as Vera Layman.

Note: A Replace field with a null (no value) string enclosed in quotation marks is different from a Replace field with no value. If you delete the Replace string altogether, Munger shows the argument name ("Replace") in the formula editor window and behaves as if that optional argument doesn’t exist. The resulting data type may also change from character to numeric, depending on the value of the Find/Replace argument.
Finding the Position (Index) of a Value

When the Find/Length field contains characters, Munger behaves like an index function and returns the numeric position of the first instance of the search string if it exists. For example, Munger("Veronica Layman", 1, " ") searches for a single blank and finds it in position nine. If the search string is not found, Munger returns a zero. This use of Munger produces the same result as the Contains function, as shown in “Adding Character Arguments and Returning Character Strings,” p. 290.

Finding a Substring

Munger can extract substrings. For example, to see the first name only, Munger("Veronica Layman", 1, 8,) starts at position one, reads through position eight, and ignores the remaining characters because the replace argument is not defined. This yields “Veronica” and produces the same result as the Substring, as shown in “Adding Character Arguments and Returning Character Strings,” p. 290.

An alternative way to find a substring is with a start value, any negative find value, and a no replace argument. Munger("Veronica Layman", 9, -1,) returns “Layman”.

Using the Match Conditional Function

To follow this example, open Big Class.jmp from the Sample Data folder that was installed when you installed JMP. To assign character literals to age values in the Big Class data table, your formula would look like Figure 9.40.

Figure 9.40  Conditional Expression

To use a shortcut for building Match conditionals:

1. Select a column in the column selector list.
2. Press the Shift key and select Match in the Conditional functions list.

For example, suppose you want a Match conditional for the nominal variable Type from the Hot Dogs.jmp data table (also found in the Sample Data folder), which has values Beef, Meat, and Poultry. First select the column Type from the column selector list. Then with Type selected in the formula display, Shift-click Match to see the formula shown in Figure 9.41.
Using Keyboard Shortcuts

You can use the keyboard shortcuts shown below to replace a selected expression with a function or argument.

Table 9.4 Keyboard Shortcuts in the Formula Editor

<table>
<thead>
<tr>
<th>Replace a Selected Item with</th>
<th>Using This Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>A missing element (*)</td>
<td>Delete</td>
</tr>
<tr>
<td>Subscript</td>
<td>[</td>
</tr>
<tr>
<td>( set of parentheses</td>
<td>(</td>
</tr>
<tr>
<td>) set of parentheses</td>
<td>)</td>
</tr>
<tr>
<td>*</td>
<td>* on keypad or keyboard</td>
</tr>
<tr>
<td>+</td>
<td>+ on keypad or keyboard</td>
</tr>
<tr>
<td>−</td>
<td>− on keypad or keyboard</td>
</tr>
<tr>
<td>÷</td>
<td>/ on keypad or keyboard</td>
</tr>
<tr>
<td>+/-</td>
<td>Shift-minus</td>
</tr>
<tr>
<td>And</td>
<td>&amp;</td>
</tr>
<tr>
<td>Not</td>
<td>!</td>
</tr>
<tr>
<td>Or</td>
<td></td>
</tr>
<tr>
<td>Power</td>
<td>^</td>
</tr>
<tr>
<td>New argument</td>
<td>,</td>
</tr>
<tr>
<td>x&lt;y</td>
<td>&lt;</td>
</tr>
<tr>
<td>x=y</td>
<td>=</td>
</tr>
<tr>
<td>x&gt;y</td>
<td>&gt;</td>
</tr>
</tbody>
</table>

Glossary of Terms

Remember that:

- Functions always operate upon selected expressions.
- Arguments are always grouped with functions.
To find which expressions serve as a function's arguments, select that function in the formula.

The boxed groupings show how order of precedence rules apply and show which arguments are deleted when you delete a function. See “Ordering Expressions in Formulas,” p. 299, for details.

The following is a list of terms used for the parts of the formula itself:

**Element**  The name of a constant, table variable, table column, local variable, or parameter that appears in the element browser list.

**Argument** Any element or an entire expression (including mathematical operands) that is operated on by a function.

**Term** Indivisible parts of an expression, such as constants and variables.

**Expression** Any part of a formula that can be selected as a single unit, including terms, missing terms, and functions grouped with their arguments, as well as the entire formula.

**Clause** A complete segment in a conditional function.

**Function** A mathematical or logical operation that performs a specific action on one or more arguments. Functions include most items in the function browser list and all keypad operators. Functions always operate upon selected expressions, and arguments are always grouped with functions. To find which expressions serve as a function's arguments, select that function in the formula. The boxed groupings also show how order of precedence rules apply and show which arguments are deleted when you delete a function.

**Missing term** Any empty place holder for an expression, represented by an empty box.
**Missing value**  Excluded or null data consisting of the missing value mark (○) for numeric data or null character strings for character data.

<table>
<thead>
<tr>
<th>batch</th>
<th>yield</th>
</tr>
</thead>
<tbody>
<tr>
<td>large</td>
<td>82</td>
</tr>
<tr>
<td>large</td>
<td></td>
</tr>
<tr>
<td>small</td>
<td>104</td>
</tr>
<tr>
<td>small</td>
<td>98</td>
</tr>
</tbody>
</table>

Missing values
This chapter describes ways to tailor JMP to fit your personal preferences.

- JMP preferences enable you to specify general and specific settings and save the settings so they are associated with your JMP session.
- Complete customization of menus and toolbars give the flexibility to show only the commands you need or to set up JMP for groups with special interests (Windows only).

To change preferences

1. Select **File > Preferences** (Windows/Linux) or **JMP > Preferences** (Macintosh). The window in Figure 10.1 appears with the **General** preferences category showing.
2. Click a category and make selections. Click **Apply** to see the results, and then click **OK**.

**Figure 10.1** The General Preferences Window (Windows)
Contents

Changing Startup Preferences ......................................................... 321
Preferences for Opening Excel Files .................................................. 322
Changing Formula and Scripting Options .............................................. 324
Changing Data Table Options ........................................................... 325
  Highlight Movement ......................................................................... 325
  Scroll Bar Styles (Windows Only) ..................................................... 326
  Numeric Formats ............................................................................ 326
  Data Table Print Format ................................................................... 327
  Toolbar Positions (Windows Only) ...................................................... 327
Changing Report Options ................................................................. 327
  Customizing Analysis Settings ......................................................... 327
  Report Explanations ....................................................................... 328
  Menu Tips (Windows and Linux Only) ............................................... 328
  Dates, Times, Names and Notes ....................................................... 328
  Table Styles .................................................................................. 329
  Marker Sizes .................................................................................. 329
  Closing and Saving Sessions ........................................................... 329
  Closing and Saving Reports ............................................................. 330
  Laser Pointer Options ..................................................................... 330
  Marker Drawing Speed Threshold .................................................... 331
  Saving Text Files Without Using Unicode ........................................ 331
Changing Color Schemes ................................................................. 332
Customizing Fonts and Languages .................................................... 333
Specifying Graphic Formats ............................................................. 335
Adjusting Communications Settings (Windows and Linux Only) ............. 336
Adjusting Proxy Settings (Linux Only) ................................................ 337
Specifying File Locations and Associations ......................................... 337
Customizing Text Import/Export Options ............................................ 339
Specifying Settings for SAS Integration .............................................. 340
Personalizing Toolbars (Macintosh) ................................................... 342
Personalizing Toolbars (Windows and Linux) ...................................... 343
Customizing Menus (Windows and Linux Only) .................................... 353
Saving Menus/Toolbars (Windows and Linux) ....................................... 360
Changing Startup Preferences

You can change the system defaults so when JMP starts, it displays only information you specify.

Tip of the Day Window

To change the default setting for the Tip of the Day window:

1. Select File > Preferences (Windows/Linux) or JMP > Preferences (Macintosh).
2. Click the General category.
3. Check Show Tip of the Day at Startup to show the window. Uncheck it to hide the window at startup. For details on the Tip of the Day, see “The Tip of the Day Window,” p. 9.

Splash Window

To change the default setting for the splash window that appears when you start JMP:

1. Select File > Preferences (Windows/Linux) or JMP > Preferences (Macintosh).
2. Click the General category.
3. Check Initial Splash Window to show the initial splash window at startup. Uncheck it to hide the window at startup.

JMP Starter Window

To change the default setting for the JMP Starter window:

1. Select File > Preferences (Windows/Linux) or JMP > Preferences (Macintosh).
2. Click the General category.
3. Check Initial JMP Starter Window to show the JMP Starter window at startup. Uncheck it to hide the window at startup. For details on the JMP Starter window, see “The JMP Starter Window,” p. 10.
The Window List (Windows Only)

JMP provides access to a window list, which is a pane at the left side of the JMP application that lists each open JMP window. The list makes it easy to see your open windows and navigate from one window to another.

To view the window list, select View > Window List.

Or, to change JMP’s default behavior so the list always appears:
1. Select File > Preferences.
2. Click the General category.
3. Check Initial Window List to show the list at startup. Uncheck it to hide the list at startup.

To use the window:
• Click the name of a window to bring it to the front of the screen.
• Right-click the name of a window in the list to close, rename, redraw, move, or hide it (Figure 10.2).
• Click the close icon in the upper right corner of the list to close it.

Figure 10.2 The Open Windows Panel

Preferences for Opening Excel Files

When opening Excel files, JMP gives you the flexibility to change some preferences related to how the file is opened.
Preferences for Opening Excel Files

**Importing Excel Labels as JMP Column Names (Windows and Macintosh Only)**

When JMP opens a Microsoft Excel file, it places the first line of data into the first row in JMP. However, you may have an Excel file that contains labels in its first line. In that case, you may want to use those labels as column names in JMP. To have JMP automatically use Excel labels as its column names:

1. Select File > Preferences (Windows) or JMP > Preferences (Macintosh).
2. Click the General category, as shown in Figure 10.3.
3. Click the box beside Use Excel Labels as Headings.

**Excel Workbook/Worksheet Selection (Windows and Macintosh Only)**

When JMP opens a Microsoft Excel workbook that contains multiple worksheets, it opens all of the worksheets by default. If you would like to open only certain worksheets:

1. Select File > Preferences (Windows) or JMP > Preferences (Macintosh).
2. Click the General category.
3. Click the box beside Select Individual Excel Worksheets. You can now specify which sheets to import when you open an Excel workbook, as shown in Figure 10.4. For details on opening Excel files, see “Opening Excel and OpenOffice Files,” p. 21.
Changing Formula and Scripting Options

When creating formulas and scripts, you may want to set some of JMP’s preferences to meet your ongoing needs. This section describes some preferences JMP provides.

Formula Evaluation

To change the default setting for evaluating formulas upon opening a data table:
1 Select File > Preferences (Windows/Linux) or JMP > Preferences (Macintosh).
2 Click the Tables (Windows/Linux) or General (Macintosh) category, as shown in Figure 10.5.
3 Check Suppress Formula Eval On Open to suppress evaluation of formulas when a data table is opened. Uncheck it to have JMP evaluate the formulas upon opening the table.

Figure 10.5 Changing Formula and Scripting Options

Script Evaluation

To change the default setting for evaluating scripts upon opening a data table:
1 Select File > Preferences (Windows/Linux) or JMP > Preferences (Macintosh).
2 Click the Tables category, as shown in Figure 10.5.
3 Check Suppress OnOpen Script Eval to suppress automatically executing scripts when the table is opened.

Auto Bracket Matching

JMP can automatically include a closed bracket whenever you type an open bracket in a script. To set up this feature:
1 Select File > Preferences.
2 Click the Script Editor category, as shown in Figure 10.6.
3 Check Auto-complete Parenthesis and Braces.
Saving Scripts in Different Languages

Non-English versions of JMP can save scripts in either English or your local language. User-specified values (such as column names and text strings) in these scripts appear as they do in the data table, but command words (such as Distribution and Set Value) appear in English rather than the local language in order for the script to run on JMP in English. JMP properly displays non-Roman characters (such as Japanese variable names) in JMP in English when the fonts support the necessary characters.

To specify that a script be saved in English when using a non-English version of JMP:

1. Select File > Preferences.
2. Click the General category.
3. Check Save Scripts in English.

Changing Data Table Options

JMP allows you to make changes to the way elements operate in the data table. This section lists the changes and how to make them.

Highlight Movement

When a data table cell is highlighted and you press the Enter/Return key on the keyboard, the highlight moves down. Pressing either the Tab key or the Enter key on the numeric keypad located to the right of the keyboard moves the highlight to the right.

However, you can change the default so pressing the Enter key on the numeric keypad moves the highlight down instead of to the right.
To change the default:
1 Select **File > Preferences**.
2 On Windows/Linux, click the **Tables** category.
   On Macintosh, click the **General** category.
3 Place a check beside **Numeric keypad Enter key moves down** (Windows and Linux) or **Enter Key moves down** (Macintosh).

## Scroll Bar Styles (Windows Only)
To specify the arrow styles JMP uses in its scroll bars:
1 Select **File > Preferences**.
2 Click the **General** category.
3 Check one of the following:

**Scroll bar arrow style**
Selecting **Traditional** places arrows at the top and bottom of the vertical scroll bar and the left and right of the horizontal scroll bar. Selecting **Cluster Up** places both arrows at the top of the vertical scroll bar and at the left of the horizontal scroll bar. Selecting **Cluster Down** places both arrows at the bottom of the vertical scroll bar and at the right of the horizontal scroll bar. See Figure 10.7 for examples.

**Scroll bar thumb style**
Selecting **Proportional** causes the scroll bar to display a thumb that is proportional to the length of the window’s content. Selecting **Traditional** causes the scroll bar to display a thumb that is a constant size, regardless of the length of the window’s content. See Figure 10.7 for examples.

### Figure 10.7 Scrollbar Styles

**Numeric Formats**
JMP has the ability to store numeric data in as few as 8 bits (one byte). This option makes short-integer formats available to you when you select **Cols > Column Info** and assign a column a data type. When
you use the correct short-integer format for your data, you will not see any difference in how the numbers display, but they will occupy less disk space. See “Using Short-Integer Format,” p. 60, for details.

1. Select File > Preferences (Windows/Linux) or JMP > Preferences (Macintosh).
2. Click the Tables category.
3. Check Allow short numeric data format.

**Data Table Print Format**

To print the JMP data table as it appears on the screen instead of resizing column widths to accommodate the content width:

1. Select File > Preferences (Windows/Linux) or JMP > Preferences (Macintosh).
2. Click the Tables category.
3. Check Print Data Grid as is.

**Toolbar Positions (Windows Only)**

To specify that the position of the toolbars stay the same between JMP sessions:

1. Select File > Preferences.
2. Click the General category.
3. Check Retain Exact Tool Positions.

**Changing Report Options**

You can customize settings for JMP reports so they are customized for your preferences. The sections below describe ways you can customize reports.

**Customizing Analysis Settings**

Each report analysis has a variety of plot and table options that are shown by default. However, there might be additional options you want to see each time you run a particular analysis. For example, a bivariate analysis shows points by default, but you might also always want to see a linear fit each time. By selecting the Platforms option in the left panel of the Preferences window, you can set the default options for analyses. (Analyses are run by evoking platforms, such as the Bivariate platform; thus, the name of this category is Platforms.)

To set the default options for analyses:

1. Select File > Preferences (Windows/Linux) or JMP > Preferences (Macintosh).
2. Click the Platform category, as shown in Figure 10.8.
3. Highlight an analysis name in the Select a Platform list. Its available options appear in an Options box with the defaults checked.
4 Click the option(s) you want to automatically appear when you run an analysis on the highlighted platform.

**Figure 10.8 Platforms Tab**

---

**Report Explanations**

Making a small circle with the arrow cursor over some report tables reveals an explanation of the analysis results. To enable and disable this feature:

1. Select **File > Preferences** (Windows/Linux) or **JMP > Preferences** (Macintosh).
2. Click the **Reports** category.
3. Check **Show Explanations**.

---

**Menu Tips (Windows and Linux Only)**

To change the default setting for the menu tips that appear when you pause your mouse over a red triangle menu item:

1. Select **File > Preferences**.
2. Click the **General** category.
3. Check **Show menu tips** to show the menu tips. Uncheck it to hide the tips.

---

**Dates, Times, Names and Notes**

To automatically add the date and time an analysis occurred at the top of an output report:

1. Select **File > Preferences** (Windows/Linux) or **JMP > Preferences** (Macintosh).
2. Click the **Reports** category.
3. Check **Date Title on Output** to display the date and time the analysis occurred.
   Check **Data Table Title on Output** to place the name of the data table and notes, if there are any, at the top of the report’s output.

### Table Styles

To set the default table style for all reports.

1. Select **File > Preferences** (Windows/Linux) or **JMP > Preferences** (Macintosh).
2. Click the **Reports** category.
3. Click the menu beside **Report Table Style** and select an option.

### Marker Sizes

To set the default marker size for all plots:

1. Select **File > Preferences** (Windows/Linux) or **JMP > Preferences** (Macintosh).
2. Click the **Reports** category.
3. Click the menu beside **Graph Marker Size** and select an option.

### Closing and Saving Sessions

Each time you use JMP, it is called a *session*. By default, JMP asks if you would like to save the state of your session each time you exit the program. If saved files are open when you exit, when you return to JMP it will reopen those saved files and rerun any analyses. This allows you to quit JMP, then return to it later without manually having to open the files with which you were previously working.

To change the default method of saving sessions:

1. Select **File > Preferences** (Windows/Linux) or **JMP > Preferences** (Macintosh).
2. Click the **Reports** category.
3. Click the menu beside **Save the session when exiting** (Figure 10.9) and select an option.
   - **Always**: When you quit JMP, it is always automatically saved.
   - **Never**: When you quit JMP, it is never saved.
   - **Prompt**: When you quit JMP, you are asked if you would like to save it.

For details on JMP sessions, see “Saving JMP Sessions,” p. 120.
Figure 10.9 Closing and Saving Reports and Sessions

Closing and Saving Reports

When you close reports, you may want JMP to treat them like other documents, or as disposable views of your data. JMP has preferences that you can set so it treats reports in ways that best fit your needs. These preferences include customizing what happens when you close or save a report.

To customize how JMP treats reports when you close them:
1. Select File > Preferences (Windows/Linux) or JMP > Preferences (Macintosh).
2. Click the Reports category.
3. Click the menu beside Close report action (Figure 10.9) and select an option.
   - Prompt When you close a report, JMP asks you if you would like to save it.
   - Discard When you close a report, JMP never saves it.
   - Save / Auto-save When you close a report, JMP always automatically saves it according to how you have selected in the menu beside Auto-save the report to.

To customize how JMP saves reports:
1. Select File > Preferences (Windows/Linux) or JMP > Preferences (Macintosh).
2. Click the Reports category.
3. Click the menu beside Auto-save the report to (Figure 10.9) and select an option.
   - Prompt When you close a report, JMP asks you if you would like to save it.
   - Datatable Script When you close a report, JMP saves it as a script in the open data table. To open the report again, right-click the script in the data table and select Run Script.
   - Journal Window When you close a report, JMP saves it to a journal window. For information on journals, see “Importing Data,” p. 13, and “Saving Using the Journal Command,” p. 113.
   - Log Window When you close a report, JMP writes it to the log window. For information on log windows, see “Saving a Log Window,” p. 126.

For details on saving JMP reports, see “Saving Reports,” p. 112.

Laser Pointer Options

JMP has a built-in laser pointer that allows you to visually emphasize parts of a report. It is off by default. To turn it on:
1. Select File > Preferences (Windows/Linux) or JMP > Preferences (Macintosh).
2. Click the Reports category.
3. From the Laser pointer menu, select to turn it off, or select the color you want the laser pointer to
To use the laser pointer, click and drag anywhere on a report where the cursor is a left-pointing arrow. The colored line of the laser pointer persists until you release the mouse button.

**Marker Drawing Speed Threshold**

When JMP refreshes a report window, it can draw markers on a plot at two different speeds: normal and fast. If JMP is in normal drawing mode and the number of markers in a graph are more than the specified threshold number, JMP automatically switches to fast mode.

To change the threshold number:

1. Select **File > Preferences** (Windows/Linux) or **JMP > Preferences** (Macintosh).
2. Click the **Reports** category.
3. Type the threshold number in the box beside **Fast Marker Threshold**.

For more information about normal and fast drawing mode, see “Changing the Marker Drawing Mode and Transparency,” p. 188

**Saving Text Files Without Using Unicode**

JMP uses the Unicode character set, which supports special characters such as é and ½. It saves files without special Unicode characters as plain text automatically. However, files that contain Unicode characters can be saved from JMP so that they can be opened in older applications that do not support Unicode (such as JMP 5.1.2 and earlier). To do this, first disable Unicode feature in JMP 7:

1. Select **File > Preferences** (Windows/Linux) or **JMP > Preferences** (Macintosh).
2. Click the **General** category.
3 Uncheck the box beside Save Text Files as Unicode. Your text files will now be saved as plain (legacy) text.

Changing Color Schemes

JMP allows you to customize the background color of its graphs and reports. It also lets you alter the color of the title bars. This section describes how to customize these color schemes.

Changing Graph Colors

You can set a background color that, by default, applies to all graphs:

1 Select File > Preferences.
2 Click the Reports category.
3 Click the Graph Background Color button.
4 Click a color in the palette (Figure 10.10). Or, on Windows and Linux, create a custom color by entering numbers for a new color values and clicking Add to Custom Colors.
5 Click OK.

Figure 10.10 Custom Color Palette on Windows and Linux (Left) and Macintosh (Right)

Changing Window Colors (Windows and Linux Only)

On Windows and Linux, you can set a background color that, by default, applies to all windows:

1 Select File > Preferences.
2. On Windows, click the **Windows Specific** category and click the **Choose Color...** button. On Linux, click the **Linux Specific** category and click the **Window Background** button.

3. Click a color in the palette (Figure 10.10). Or, create a custom color by entering numbers for a new color values and clicking **Add to Custom Colors**.

4. Click **OK**.

**Changing Title Bar Colors (Windows Only)**

To give title bars in the data table and report windows a light shade of grey:

1. Select **File > Preferences**.

2. Click the **Windows Specific** category.

3. Click the box beside **Highlight Outline Headers**.

4. Click the **Apply** button on the Preferences window to preview the result.

---

**Customizing Fonts and Languages**

One way you can customize the appearance of reports, data tables, and scripts is to change text styles using the **Fonts** category (Figure 10.11), which lists the fonts and sizes available in your system and the regular, bold, italic, and bold italic styles. Your specifications are then used as the default settings.

**Figure 10.11** The Fonts Tab (Windows)

---

**Changing Font Types and Sizes**

To change the default font types and sizes:
1 Select **File > Preferences** (Windows/Linux) or **JMP > Preferences** (Macintosh).
2 Click the **Fonts** category.
3 Select the area to which you want to make changes.
   - **Text**  Sets the font for the text portion of a JMP analysis report.
   - **Heading**  Sets the font for the heading of columns in an analysis report.
   - **Title**  Sets the font for the title shown in all title bars.
   - **Small**  Sets the font for small text. The blue diamond shaped icon is the disclosure button. Click the disclosure button to close the side panels of the data table and reveal the small text in the upper left corner of the data grid.
   - **Mono**  Sets the font for the font used in the JMP Scripting Language (JSL) editor for script commands.
   - **Formula Editor**  Sets the font for the expressions entered into the formula editor.
   - **Annotation**  Sets the default font used in annotations.
   - **Axis**  Sets the font information for the axis labels.
   - **Menu (Linux Only)**  Sets the font for the JMP main menu, labels on checkboxes, and other textual objects.

**Note:** To quickly change the font size from anywhere in JMP, press Ctrl-Shift-+ (plus sign) to increase and Ctrl-Shift-- (minus sign) to decrease the size. On Macintosh, press Command-+ (plus sign) and Command-- (minus sign).

### Using Underlines and Strikeouts on Windows

To view the underline and strikeout text options on Windows:

1 Select **File > Preferences**.
2 Click the **Fonts** category.
3 Check **Enable special font effects**.
4 Select the area to which you want to make changes (**Text**, **Heading**, **Title**, etc.).
5 In the window that appears, place a check beside **Strikeout** and/or **Underline**.

### Using Greek Letters and Math Symbols

To enable and disable the use of Greek letters and math symbols in JMP:

1 Select **File > Preferences**.
2 Click the **Fonts** category.
3 Check **Use Greek Letters** and/or **Use Math Symbols**.
Switching Between English and Japanese (Japanese Windows Only)

If you are running the Japanese version of JMP on Windows, you can change between viewing JMP in English and Japanese. This provides a quick way to view certain portions of JMP in English without having to reset your regional language settings:

1. Select **File > Preferences**.
2. Click the **Windows Specific** category.
3. Click **OK**. You must restart JMP for the changes to take effect.

Specifying Graphic Formats

You can specify a default format for JMP to use when placing graphics on the clipboard or saving as .rtf and .html files.

To specify the default formats:

1. Select **File > Preferences** (Windows/Linux) or **JMP > Preferences** (Macintosh).
2. On Windows, click the **Windows Specific** category (Figure 10.12).
   - On the Macintosh, click the **MacOS Settings** category.
   - On Linux, click the **Graphic Formats** category.
3. Select one of these formats:

<table>
<thead>
<tr>
<th>Action to be Taken on Graphic</th>
<th>How to Set Up the Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a certain format when dragging and dropping or copying and pasting graphic into another application (Windows only)</td>
<td>Click to place a check beside the desired formats in the Copy/Drag Graphic Formats area.</td>
</tr>
<tr>
<td>Use a certain format for graphics when saving a JMP report as a .rtf file or .html file (Windows only)</td>
<td>Select a format beside Graphic Format for RTF/HTML Files.</td>
</tr>
<tr>
<td>Have graphics appear larger or smaller than their original size when they are saved as .rtf files or dragged and dropped into another application</td>
<td>In the Graphics Scale Factor % text box (Windows /Macintosh) or the Scale text box (Linux), enter the percentage at which you want graphics to appear in another application. This feature may not work with all versions of your chosen application.</td>
</tr>
</tbody>
</table>
Adjusting Communications Settings (Windows and Linux Only)

The communications settings only need to be specified if you are using an instrument to read data from an external source. To specify the settings:

1. Select **File > Preferences**.
2. Click the **Communications** category.

Refer to the documentation for your instrument to find the appropriate settings. See the *JMP Statistics and Graphics Guide* for details.
Adjusting Proxy Settings (Linux Only)

You can import data from Internet sites, Intranet sites, servers, and FTP addresses by selecting File > Internet Open. If you are using a proxy server to connect to the Internet on Linux, you may need to set up your proxy settings before opening files:

1. Select File > Preferences.
2. Click the Proxies category.
3. Enter your proxy server address.

Specifying File Locations and Associations

You can change the default locations of JMP system files, and you can also set the file associations of JMP files so they are always opened using this release of JMP. The sections below provide information on how to make these changes.
Specifying File Locations (Windows and Linux Only)

Although you should leave most installed files in the default installation directory, you can change the
default locations of JMP system files. Instances when you might want to move them include:

- You want to move large files, such as the help files (for example, the `jmp.chm` file on Windows and
  the `.html` files on Linux), to somewhere other than your hard drive.
- Information in the installation directory is needed by technical support.
- You want to designate a directory where the preferences file directory (`jmp.pfs` on Windows and
  `jmpPreferences` on Linux) should be stored. You can point to a directory even if there is no `jmp.pfs`
  or `jmpPreferences` file already in it. When JMP saves the preferences, it will create the `jmp.pfs` or
  `jmpPreferences` file in that directory.

Additionally, you can set the associations so that when you open a file, JMP always starts the path in a
specified location.

To change the default file association:

1. Select **File > Preferences**.
2. Click the **File Location** category, as shown in Figure 10.14.
3. Highlight the item in the list whose location you would like to change. Its current location appears
   in the text box.

   **Note:** On Windows, select **Data Files directory** or **Save As directory for Data/Journals** when
you want JMP to use the specified directory every time you select **File > Open**, **Save**, or **Save As**.
You must also check the box beside **Always go to this directory when the File Open is displayed**
or **Always go to this directory when Data/Journal Save As is displayed**.

   On Linux, select **Data Files directory** and set the directory path you want JMP to use every time
you select **File > Open**.

4. Click **Browse**.
5. Navigate into a directory where the file should be stored and select it.

   **Note:** To reset the file location settings to the default location, delete the path of the current location
and leave the box empty.
Resetting the File Associations (Windows Only)

To set the file associations of JMP files so they are always opened using this release of JMP, select File > Preferences > Windows Specific, and click the Reset Associations button. This ensures that when you double-click JMP files or you use automation commands (and JMP is not open), the file is opened with the desired release.

You may need to set file association if:
- You have more than one release of JMP installed
- You are using automation commands to open JMP files
- You previously altered the JMP file type associations using the Windows operating system interface and now want to restore them

Customizing Text Import/Export Options

When you import or export text files to and from JMP, it uses the default rules to interpret end of field and end of line delimiters. To change these rules and specify the settings you would like JMP to use when importing and exporting text files:

1. Select File > Preferences (Windows/Linux) or JMP > Preferences (Macintosh).
2. Click the Text Data Files category, as shown in Figure 10.15.
3 Make your selections, referencing “Opening Text Files,” p. 13, for details on available options.

**Figure 10.15** The Text Data Files Tab

---

**Specifying Settings for SAS Integration**

To change the default settings for working with SAS servers, click the SAS Integration category in Figure 10.16. For details on using the SAS Integration capabilities, see “SAS Integration,” p. 363.
To set your preferences for connecting to a SAS Metadata Server

1. To always connect to a SAS Metadata Server, select I want to connect to a SAS Metadata Server. To connect to a SAS server directly, uncheck this checkbox. Note: This option is checked by default, and we suggest you use a metadata server rather than connect directly to SAS servers.

2. Fill in the Default SAS Metadata Connection Information area. The System Administrator for the SAS Metadata Server will give you this information.
   - **Machine**: The address for the machine that hosts the SAS Metadata Server.
   - **Port**: The port for access to the machine.
   - **Authentication Domain**: The name of the authentication domain you belong to.
   - **Repository**: Where the metadata server resides.
   - **User Name**: Your user name for the metadata server.

3. To allow JMP to remember and use your password so you don’t have to enter it every time you connect to the SAS Metadata Server, select Allow passwords to be remembered. If you change your password, click Clear saved passwords to be prompted to enter your new one.

Other settings:

- **Append SAS log to JMP log after submit**: Add the SAS log after running the script to the JMP log so you can see any errors, warnings, or other important information. This applies to both submitting SAS code and to running stored processes.

- **Use SAS column labels for column names during data import**: When importing a SAS data set into a JMP data table, use the column labels in the SAS data set as the JMP data table column names.

- **Warn before closing unsaved imported data**: Asks you if you want to save any SAS data sets you've imported into JMP before closing, if you haven't already done so.
To specify formats for your results from stored processes
1 Select a report format: HTML, RTF, or PDF.
2 Select a graph format: ActiveX Image (only available on a Windows-based SAS server), Java image, PNG, JPEG, or GIF.

Personalizing Toolbars (Macintosh)

On the Macintosh, you can add and delete items from the toolbar at the top of JMP report, journal, and layout windows. To personalize toolbars:

1 Right-click the toolbar and select Customizer Toolbar from the menu, as shown in Figure 10.17.

Figure 10.17 Personalizing Toolbars

2 The window shown in Figure 10.18 appears. The list in the window contains items that can be dragged from the list into your active toolbar.

Figure 10.18 The Customize JMP Toolbar on the Macintosh
Personalizing Toolbars (Windows and Linux)

Under Windows and Linux, there are many ways to personalize toolbars. For example, you can hide or show them, delete or rearrange their buttons, create new bars or new buttons. You can create toolbar buttons for menu items, providing you with an easy way to access these frequently-selected items.

You can also eliminate or rearrange the toolbar and then save it for use at any time during a JMP session.

To restore the default toolbar, select **Edit > Customize > Revert to Factory Defaults**.

**Figure 10.19** Restoring Default Toolbars

<table>
<thead>
<tr>
<th>Customize</th>
<th>Exit JMP</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menus Toolbars</td>
<td>Revert to Factory Defaults</td>
</tr>
</tbody>
</table>

Showing/Hiding Toolbars

To show or hide toolbars on Windows and Linux:

1. Select **View > Show Toolbars**.
2. Click next to the toolbar(s) you want to appear in JMP, as shown in Figure 10.20.

**Note:** To quickly hide and show toolbars on Linux, right-click a toolbar and select the toolbar to show or hide.

**Figure 10.20** Choosing **Show Toolbars** Displays the Show Toolbars CheckBox Options

- **File>Edit**
  Displays a toolbar containing icons for commands found in the **File** and **Edit** menus.

- **Analyze**
  Displays a toolbar containing icons for commands found in the **Analyze** menu.
Graph
Displays a toolbar containing icons for commands found in the Graph menu.

Tools
Displays a toolbar containing icons of tools you can click and use as your cursor.

Data_Tables_List
Displays a list of all open data tables. This is useful when you have multiple data tables open. You select a data table in this list to make it the current table. Note that the current table is not necessarily the front window. To bring a table (or any window) to the front, select its name from the list in the Window menu.

Tables
Displays a toolbar containing icons for commands in the Tables menu.

DOE
Displays a toolbar containing icons for commands in the DOE menu.

Browser (Windows only)
Displays standard browser buttons such as forward, backward, and home, to use when an internet page is open in a browser within JMP. See “Opening a File from the Internet or Intranet,” p. 34, for details.

URL_List (Windows only)
Lists the browser pages you have requested during the current JMP session. When this toolbar item is open, you can type a URL into the text area to open a new web page in the JMP browser and press the Enter key to access that page. Or, you can select one of the previously-visited web pages. See “Opening a File from the Internet or Intranet,” p. 34, for details.

Search_List_Control (Windows only)
Keeps track of all the data table searches performed on the current data table. When you enter a value in this text area and click the search icon button, the action is the same as using the Edit > Search > Find command. Continuous clicks of the Search icon button does same as Edit > Search > Find Next.

Colors (Windows only)
Displays a list of colors available for points in a graph.
Markers (Windows only)

Displays a list of markers available for points in a graph.

Rearranging Toolbars

Using JMP under Windows and Linux, you can position visible toolbars anywhere. To rearrange toolbars:

1. Click the upper left corner of the toolbar. An outline appears around it.
2. Drag the toolbar to the desired location: either to another location in the toolbar area at the top of the screen or off the toolbar area (as shown in Figure 10.21).

**Figure 10.21** Moving the File_Edit Toolbar Off the Toolbar Area

**Tip:** To quickly realign the toolbars on Linux, right-click the toolbar and select Line Up.

Rearranging Buttons

**On Windows**

On Windows, rearrange buttons on existing toolbars by clicking and dragging:

1. Select Edit > Customize > Menus and Toolbars. The Menus list appears on the left (Figure 10.22).
Figure 10.22 Customize Toolbars

2 Click the plus sign to open Toolbars.
3 Click the plus sign to open the specific toolbar you want to customize (for example, File_Edit).
4 Click and drag the button near the location you want to move it, then release the mouse button. A menu appears, prompting you to specify where you want to place the button.

5 Select either Move Before or Move After to place the button you are moving before or after the highlighted button. Or, select Cancel to not move the button.
6 Repeat this for as many buttons as you would like to move.
7 Click Apply at the top of the Menus list to apply the change.
8 When you close the Menus list, you are prompted to save your changes. Click Yes to save them, or No to discard them.

On Linux

On Linux, rearrange buttons on existing toolbars by clicking buttons:

1 Select Edit > Customize > Toolbars.
2 Highlight the name of the toolbar whose buttons you would like to rearrange. The buttons belonging to the highlighted toolbar appear in the list on the right, as shown in Figure 10.23.
Figure 10.23 Customize Toolbars (Linux)

3 Highlight a button in the list on the right.
4 Click the appropriate button (Move Up, Move Down, etc.) to rearrange the buttons.

Deleting Toolbars

You can delete a toolbar so it does not appear at the top of the screen under the main menu.

On Windows

To delete toolbars on Windows:
1 Select Edit > Customize > Menus and Toolbars. The Menus list appears on the left (Figure 10.22).
2 Right-click the name of the toolbar you want to delete, and select Delete from the menu.
3 Click Apply at the top of the Menus list to apply the change.
4 When you close the Menus list, you are prompted to save your changes. Click Yes to save them, or No to discard them.

On Linux

To delete toolbars on Linux:
1 Select Edit > Customize > Toolbars.
2 Highlight the name of the toolbar you would like to delete. The buttons belonging to the highlighted toolbar appear in the list on the right.
3 Click the Delete button.

Note: If you accidentally delete the Edit menu and need to come back to the customization feature, right-click an empty area in JMP and select Customize > Revert to Factory Defaults.
Deleting Buttons

On Windows

To delete toolbar buttons on Windows:

1. Select **Edit > Customize > Menus and Toolbars**. The Menus list appears on the left (Figure 10.22).
2. Right-click the name of the button you want to delete, and select **Delete** from the menu.
3. Click **Apply** at the top of the Menus list to apply the change.
4. When you close the Menus list, you are prompted to save your changes. Click **Yes** to save them, or **No** to discard them.

On Linux

To delete toolbar buttons on Linux:

1. Select **Edit > Customize > Toolbars**.
2. Highlight the name of the toolbar you would like to delete. The buttons belonging to the highlighted toolbar appear in the list on the right.
3. In the list on the right, highlight the name of the button you would like to delete.
4. Click the **Delete** button.

Adding Toolbars

On Windows

To add a new toolbar using JMP on Microsoft Windows:

1. Select **Edit > Customize > Menus and Toolbars**. The Menus list appears on the left (Figure 10.22).
2. Right-click a toolbar next to which you want to add a new toolbar.
3. Select **Insert Before** or **Insert After**.
   - A new, empty toolbar is added to the list named Untitled.
4. To re-name the toolbar, double-click it. In the window that appears, enter the new name and click **OK**.
5. Click **Apply** at the top of the Menus list to apply the change.
6. When you close the Menus list, you are prompted to save your changes. Click **Yes** to save them, or **No** to discard them.

On Linux

To add a new toolbar on Linux:

1. Select **Edit > Customize > Toolbars**.
2. Highlight a toolbar in the list on the left. Make sure nothing in the list on the right is highlighted.
3. Click **Insert Before** or **Insert After**.
4. Rename the toolbar from Untitled to something else by clicking Properties.

Adding Buttons

On Windows

On Windows, create a new button for an existing toolbar by following the steps below:

Step 1: Create a Placeholder Button

1. Select Edit > Customize > Menus and Toolbars. The Menus list appears on the left (Figure 10.22).
2. Right-click the toolbar next to which you want to add a button.
3. From the menu, select Insert into Toolbar.
4. Click Apply at the top of the Menus list to apply the change.
5. When you close the Menus list, you are prompted to save your changes. Click Yes to save them, or No to discard them.

Note: You can copy a button and paste an exact duplicate of it elsewhere. Right-click on the button and select Copy, then right-click on a button next to which you want to add the copy and select Paste. From the menu that appears, select Copy before or Copy after to place the button.

Step 2: Identify the Button Type

1. Right-click the placeholder toolbar button and select Properties. The Properties window appears, as shown in Figure 10.24.

Figure 10.24 The Toolbar Button Properties General Tab

2. Under the General tab, select either Command or Separator to specify whether you want the button to be a command or separator button.
   - Command buttons are the buttons you click to execute a command.
Separator buttons (Ⅲ) are lines you can add between command buttons to help separate or group them. Separators will not issue any commands and cannot be clicked.

**Step 3: Apply a Caption and Tooltip**

A caption is the name that you give your toolbar button. A tooltip is the text that appears when you position the cursor over the button. To add a caption and tooltip to your button:

1. Under the **General** tab, type a unique name for the menu in the **Caption** box. You cannot have two or more toolbar buttons with the same name, including the name Untitled.
2. Type a description of the button into the **Tooltip** box. Note that if you do not enter tooltip text in this box, JMP will use the text you enter for the caption as the tooltip text.

**Step 4: Assign Button Functionality**

When clicked, JMP’s toolbar buttons can either execute a predefined command, or it can run a JSL script. Use this table to help you specify what you want a button to do.

<table>
<thead>
<tr>
<th>Table 10.2 Assigning Actions to Toolbar Buttons</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
</table>
| Have the toolbar button access an existing JMP command when clicked | 1. From the **General** tab, select **Builtin command** from the **Action to be Performed When This Command is Selected** box.  
2. Click the drop-down menu and select a command from the list, which contains all platform level commands in JMP, including those that appear in submenus, such as **Nonlinear** or **Partition**. |
| Have the toolbar button run a JSL script that is found in a separate file | 1. From the **General** tab, select **Run JSL in this file** from the **Action to be Performed When This Command is Selected** box.  
2. Click the **Browse** button and specify the path to the file containing the JSL. |
| Run a JSL script that you type in and save with the button | 1. From the **General** tab, select **Execute this JSL** from the **Action to be Performed When This Command is Selected** box.  
2. Type in the JSL. |

**Step 5: Give the Button an Icon**

Your button can contain a graphic that indicates what it will do when clicked. This graphic can be a generic one that JMP provides, or it can be any graphic that resides on your computer. To give the button an icon:

1. Click the **Icon** tab in the Toolbar Button Properties window, as shown in Figure 10.25.
2 Select one of the following:

- **None**  Select this option if you do not want the toolbar button to have an icon.
- **Built-in Icon ID**  Select this if you want the toolbar button to have an icon that JMP provides. Click the drop-down menu and select an icon id to assign the button one of JMP’s predefined icons.
- **Use Bitmap**  Select this if you want the toolbar button to have an icon that you have stored as a bitmapped image on your computer. Click Browse then select your bitmapped image file and click OK.

**Step 6: Assign the Button a Shortcut Key**

If you would like, you can give the button a shortcut key so you can access the command by using only the keyboard. To assign a shortcut:

1 Click the **Shortcut** tab in the Toolbar Button Properties window, as shown in Figure 10.26. Note that items in the **Current Accelerators** list are shortcut keys that are already being used in JMP. Therefore, you cannot create a new shortcut using any of the combinations in this list.
2 Type the character portion of the shortcut you are creating in the box beside 
Accelerator Key.
3 In the Modifiers area, click the key you would like to include as the modifier portion of the shortcut
key you are creating.
4 Click OK.

To remove a shortcut from a button’s properties, click Clear.

On Linux

On Linux, create a new button for an existing toolbar by following the steps below:
1 Select Edit > Customize > Toolbars.
2 Highlight the toolbar to which you’d like to add a button(s).
3 If the toolbar already contains button(s), highlight a button and click Insert Before or Insert After.
   If the toolbar does not contain any buttons, highlight the toolbar name in the list on the left and
   click Insert Into Toolbar.
4 Highlight the newly-added button and click Properties to identify the button type, apply a caption
   and tooltip, assign functionality, and give it an icon.

Importing Customized Toolbars (Windows Only)

On Windows, if you are a previous JMP user and have customized toolbars, you can import them into
your current version of JMP and use them. To import toolbars:
1 Select Edit > Customize > Menus and Toolbars. The Menus list appears on the left
   (Figure 10.22).
2 From the red triangle menu for the Menus list, select Merge Menus from Previous Versions.
3 Browse to the folder where your custom menus and toolbars were saved and select the .jmpcmd file.
4 Navigate to where your custom menus and toolbars file is located. By default, customized toolbars
   files are named .jmpcmd.
Customizing Menus (Windows and Linux Only)

On Windows and Linux, all main menus and their submenus can be rearranged or eliminated from the menu bar. These customized menus can be saved and used anytime during a JMP session.

You can also restore the default menus at any time by selecting Edit > Customize > Revert to Factory Defaults.

Figure 10.27 Restoring Default Menus

Rearranging Menu Items

On Windows and Linux, you can rearrange the order that the commands are listed in menus. For example, under the File menu, Open could be moved to be positioned before New.

Furthermore, you can also rearrange the order in which the menus themselves appear in JMP. For example, the Tables menu could be moved to appear in the main menu bar on the left of Edit.

On Windows

On Windows, rearrange buttons on existing toolbars by clicking and dragging:

1. Select Edit > Customize > Menus and Toolbars. The Menus list appears on the left (Figure 10.22).
2. Click the plus sign to open Menus.
3. Click and drag the menu near the location you want to move it, then release the mouse button. A menu appears, prompting you to specify where you want to place the button.
4. Select either Move Before or Move After to place the menu you are moving before or after the highlighted menu. Or, select Cancel to not move the menu.
5. Repeat this for as many menus as you would like to move.
6. Click Apply at the top of the Menus list to apply the change.
7. When you close the Menus list, you are prompted to save your changes. Click Yes to save them, or No to discard them.

5. Click OK.
6. Click Apply at the top of the Menus list to apply the change.
7. When you close the Menus list, you are prompted to save your changes. Click Yes to save them, or No to discard them.
On Linux

On Linux, rearrange menus by clicking buttons:

1. Select **Edit > Customize > Menus**.
2. Highlight the name of the menu whose submenu you would like to rearrange. The submenus belonging to the highlighted menu appear in the list on the right, as shown in Figure 10.28. Note that the ampersand (&) represents the shortcut key associated with that command.

![Customize Menus (Linux)](image)

Figure 10.28 Customize Menus (Linux)

3. Highlight a submenu.
4. Click the appropriate button (Move Up, Move Down, etc.) to rearrange the buttons.

**An Example**

Suppose you are using Windows and want to simplify the **Analyze** menu, shown in Figure 10.29, by eliminating **Survival and Reliability** and **Modeling** but keep **Modeling**'s **Nonlinear** command.

![The Factory Default Analyze Menu](image)

Figure 10.29 The Factory Default Analyze Menu

1. Select **Edit > Customize > Menus and Toolbars**. The Menus list appears on the left (Figure 10.22).
2. Click the plus sign to open **Main Menu**.
3. Click the plus sign to open **Analyze**.
4 Click **Survival and Reliability** and select **Delete**.
5 Click **Yes** when asked if you’re sure you want to delete the menu.
6 Click the plus sign to open **Modeling**.
7 Click and drag **Nonlinear** and release the mouse button on top of the Multivariate Methods menu.
8 From the menu, select **Move After “Multivariate Methods”**.
9 Click **Modeling** and select **Delete**.
10 Click **Yes** when asked if you’re sure you want to delete the menu.
11 Click **Apply** at the top of the Menus list to apply the change.

**Figure 10.30** The Rearranged Analyze Menu

12 When you close the Menus list, you are prompted to save your changes. Click **Yes** to save them, or **No** to discard them.

**Deleting Menus**

**On Windows**

On Windows, you can delete an entire menu, or you can delete submenu(s). To delete:

1 Select **Edit > Customize > Menus and Toolbars**. The Menus list appears on the left (Figure 10.22).
2 Click the plus sign to open **Main Menu**.
3 Right-click the menu name (such as **File, Edit, Tables**, etc.) or a submenu name (such as **New, Open, Save**, etc.) you would like to delete.
4 Select **Delete**.
5 Click **Yes** when asked if you’re sure you want to delete the menu.
6 Click **Apply** at the top of the Menus list to apply the change.
7 When you close the Menus list, you are prompted to save your changes. Click **Yes** to save them, or **No** to discard them.

**On Linux**

To delete menus on Linux:

1 Select **Edit > Customize > Menus**.
2 Highlight the name of the menu you would like to delete. The submenus belonging to the highlighted menu appear in the list on the right.
3 To delete a menu, make sure nothing is highlighted in the list on the right and click **Delete**.
To delete a submenu, highlight the name of the button you would like to delete in the list on the right and click **Delete**.

### Adding Menus

#### On Windows

On Windows, you can create your own menu and add it to the main menu bar in JMP:

1. Select **Edit > Customize > Menus and Toolbars**. The Menus list appears on the left (Figure 10.22).
2. Right-click a menu next to which you want to add a new menu.
3. Select **Insert Before** or **Insert After**.
   A new, empty menu is added to the list named Untitled.
4. To re-name the menu, double-click it. In the window that appears, enter the new name and click **OK**.
5. Click **Apply** at the top of the Menus list to apply the change.
6. When you close the Menus list, you are prompted to save your changes. Click **Yes** to save them, or **No** to discard them.

You can now build the menu by adding menu items, as described in “Adding Menu Items,” p. 356.

#### On Linux

To add a new menu on Linux:

1. Select **Edit > Customize > Menus**.
2. Highlight a menu in the list on the left. Make sure nothing in the list on the right is highlighted.
3. Click **Insert Before** or **Insert After**.
4. Rename the menu from Untitled to something else by clicking **Properties**.

### Adding Menu Items

#### On Windows

On Windows, you create a new menu item for an existing menu by following the steps below:

**Step 1: Create a Placeholder Menu Item**

1. Select **Edit > Customize > Menus and Toolbars**. The Menus list appears on the left (Figure 10.22).
2. Right-click the menu to which you want to add a menu item.
3. From the menu, select **Insert into Submenu**.
4. Click **Apply** at the top of the Menus list to apply the change.
5. When you close the Menus list, you are prompted to save your changes. Click **Yes** to save them, or **No** to discard them.
Note: You can copy a button and paste an exact duplicate of it elsewhere. Right-click on the button and select Copy, then right-click on a button next to which you want to add the copy and select Paste. From the menu that appears, select Copy before or Copy after to place the button.

Step 2: Identify the Menu Type
1. Right-click the placeholder menu item and select Properties. The Properties window appears, as shown in Figure 10.31.

Figure 10.31 The Menu Item Properties General Tab

2. Under the General tab, select either Command, Submenu, or Separator.
   - Command menu items are the items you click to execute a command.
   - Submenu items are menu items that you click to reveal more menu options. An example of a menu item that is of the submenu type is the File menu item. Also, within the file menu, New is a submenu item because it also contains other menu items.
   - Separator menu items (_____) are lines you can add between menu items to help separate or group them. Separators will not issue any commands and cannot be clicked.

Step 3: Apply a Caption
A caption is the name that you give your menu item. It is the name that will appear in the main menu. To give the menu item a caption, type a unique name for the menu in the Caption box under the General tab. You cannot have two or more menu items with the same name, including the name Untitled.

Note: You cannot apply captions to separator menu items.

Step 4: Assign Menu Item Functionality
When selected, JMP’s menu items can either execute a predefined command, or it can run a JSL script. Use the table below to specify what you want your command menu item to do:
Step 5: Give the Menu Item an Icon

Your menu item can contain a graphic that indicates what it will do when selected. This graphic will be placed on the left side of the menu item in its menu.

To give the menu item an icon:

1. Click the **Icon** tab in the Menu Item Properties window, as shown in Figure 10.32.

**Figure 10.32** The Icon Tab

2. Select from the following options:

   - **None** Select this option if you do not want the menu item to have an icon.
   - **Built-in Icon ID** Select this if you want the menu item to have an icon that JMP provides. Click the drop-down menu and select an icon id to assign the menu item one of JMP’s predefined icons.
Use Bitmap  Select this if you want the menu item to have an icon that you have stored as a bit-mapped image on your computer. Click Browse, select your bitmapped image file, then click OK.

Step 6: Assign the Menu Item a Shortcut Key

You might want to give a menu item a shortcut key so you can access it by using only the keyboard.

To assign a shortcut:

1. Click the Shortcut tab in the Menu Item Properties window, as shown in Figure 10.26. Note that items in the Current Accelerators list are shortcut keys that are already being used in JMP. Therefore, you cannot create a new shortcut key using any of the combinations in this list.

Figure 10.33  Adding Shortcuts to a Menu Item

2. Type the character portion of the shortcut key you are creating in the box beside Accelerator Key.
3. In the Modifiers area, click the key you would like to include as the modifier portion of the shortcut key you are creating.
4. Click OK.

To remove a shortcut from a menu item’s properties, click Clear.

On Linux

On Linux, create a new menu item by following the steps below:

1. Select Edit > Customize > Toolbars.
2. Highlight the menu to which you’d like to add an item.
3. If the menu already contains item(s), highlight an item and click Insert Before or Insert After. If the menu does not contain any items, highlight the menu name in the list on the left and click Insert Into Submenu.
4. Highlight the newly-added item and click Properties to identify the menu type, apply a caption and tooltip, assign functionality, give it an icon and assign it a shortcut key.
Renaming Menu Items

Menu names are the text you see on menu items, such as New, Open, and Save. On Windows and Linux, you can change these names to your preference.

On Windows

To rename menu items on Windows:
1. Select Edit > Customize > Menus and Toolbars. The Menus list appears on the left (Figure 10.22).
2. Right-click the menu name (such as File, Edit, Tables, etc.) or open the menu to display the submenus and click the submenu name (such as New, Open, Save, etc.) you would like to rename.
4. Type a new name for the submenu in the Caption box. You cannot have two or more submenus with the same name.
5. Click OK, and your menu system will reflect the change.

On Linux

To rename menu items on Linux:
1. Select Edit > Customize > Toolbars.
2. Highlight the menu you’d like to rename.
3. Click Properties.

Saving Menus/Toolbars (Windows and Linux)

On Windows and Linux, JMP saves customized menu and toolbar configurations in a file called .jmpmenu. On Windows, this file is usually located in the user local application data folder. On Linux, this file is usually located in the user’s home directory in the .jmp folder.

You can select Edit > Customize > Revert to Factory Defaults at any time to restore the factory default main menu and toolbars. When you do, a backup copy of your customized menu and toolbar configuration is saved.

Using a Separate Customized File (Windows Only)

If you do not want to alter the menu and toolbar settings that appear on startup by default, you can store your customized settings in a separate file, such as one named mymenus.jmpmenu. If you do not apply the changes, the settings will not appear when you start JMP. To view them after saving you must open the file from within JMP.

The sections below describe how to create the file, and then how to open and close the file.
Creating the File

1. Select **Edit > Customize > Menus and Toolbars**.
2. Customize your menus or toolbars.
3. From the red triangle menu, select **Export Main Menu and Toolbar List**.
4. Type a new name for the file and save it.
5. Close the Menus list without applying the changes.

Your menus and toolbars are the same as they were before you saved the .jmpmenu file, but that file contains your custom menus and toolbars, which you can share with other JMP users, or load and use yourself at any time.

Using a Customized File

After you have created a new .jmpmenu file, you can use it at any time during a JMP session.

To load the file:

1. Select **Edit > Customize > Menus and Toolbars**.
2. From the red triangle menu, select **Import Menu Archive**.
3. Select the file name and click **Open**.
4. Click **Apply**.
5. Close the Menus window and click Yes when asked if you want to save your changes.

Changing the Default Location of .jmpmenu File

You might want to change the default location where JMP stores the .jmpcmd files on Windows. The original default location is the same folder as where the JMP application is stored.

To change the default location:

1. Select **File > Preferences**.
2. Click the **File Locations** category.
3. Select **Preferences file directory**. The current default location appears in the box above **Browse**, as shown in Figure 10.34.
4 Change the location by typing into the box or clicking **Browse**, navigating to the directory, and clicking **Select**.

5 Click **OK**.

6 If you click **Yes** when asked if you want to save your current settings into this new directory, JMP will both change the default location and overwrite the existing file in that directory with the current toolbar and menu settings. If you click **No**, your current menu and toolbar settings will not be saved into this directory. The next time you start JMP, toolbar and menu settings will be taken from your newly-specified location.
Chapter 11

SAS Integration

Working with SAS data from JMP

You can connect to a SAS server and work directly with SAS data sets:

- Import whole SAS data sets or portions of data sets;
- Make changes and save those changes directly in the original SAS data set;
- Run stored processes;
- Submit SAS code from JMP.

Access SAS options from the File > SAS menu:

- **Browse Data**  
  Browse and import data residing on a SAS Business Intelligence Server.
- **Browse Stored Processes**  
  Browse and run SAS stored processes.
- **Server Connections**  
  Administer connections to SAS servers.

You can also find shortcuts for SAS options on the SAS page of the JMP Starter. You can save certain settings pertaining to SAS Integration on the SAS Integration page of the Preferences window (File > Preferences). For more information on setting your SAS Integration preferences, see “Specifying Settings for SAS Integration,” p. 340 in the “Personalizing JMP” chapter.
Contents

Connecting to SAS .......................................................... 365
  Connect to a SAS Metadata Server .................................. 365
  Connect to a SAS Server on a Remote Machine .................. 367
  Connect to SAS on Your Local Machine (Windows Only) ........ 368
Opening SAS Data Sets .................................................... 369
  SAS Data Information .................................................. 370
  Open a SAS Data Set in JMP ......................................... 371
Running Stored Processes ................................................ 374
Submitting SAS Code ...................................................... 376
Connecting to SAS

You can either connect to a SAS metadata server or directly to a SAS workspace server. Once connected to a SAS metadata server, you can browse through SAS servers, libraries, and data sets.

Note: We recommend that you connect to SAS metadata server version 9.1.3. If you have a different version, call Technical Support.

To connect to a SAS server, click File > SAS > Server Connections. The JMP: SAS Server Connections dialog in Figure 11.1 appears. All connections are made in this window.

Figure 11.1 SAS Server Connection Dialog

Connect to a SAS Metadata Server

To connect to a metadata server

1. Click Metadata Server Connection.

The JMP: Connect to SAS Metadata Server dialog in Figure 11.2 appears.
2 Fill in the information needed to connect to a SAS metadata server. Your SAS metadata server administrator should have this information.

**Machine name**  The name of the machine that hosts the metadata server. (Example: myserver.mycompany.com)

**Port**  The port through which you should connect to the machine. (Example: 8561)

**Authentication Domain**  The domain you, as a user, belong to.

**User name**  Your username for the metadata server.

**Password**  Your password.

3 If you want this to be your default connection, check the **Save this connection information as the default** checkbox. When checked, all the above information (except the password) is saved, and when you connect in the future, this window will be filled out for you.

4 Optional: If you have checked **Allow passwords to be remembered** on the SAS Integration page of the Preferences window (File > Preferences), you may select the **Remember my password** to have your password saved with the other information. Doing so means that you will be connected automatically and not asked for your password. **Note:** This is not as secure as having to provide your password to connect.

5 Click **Connect**.

   If you receive an error, ensure that you have entered all the information correctly.

At this point, you are connected to the metadata server.

6 In the SAS Server Connections window, select the workspace server to connect to (see Figure 11.3).
Figure 11.3 Open a connection to a Workspace Server

7 Click **Connect**.

Under Open Connections, the workspace server is shown as the current default connection (see Figure 11.4).

Figure 11.4 Current Default Connection

8 Click **Close**.

To change the default connection

**Note:** The default connection is what is used to submit SAS code or handle SAS script commands.

To change default connections, you first need to be connected to another server.

1 Under Establish New Connection, select another SAS server.
2 Click **Connect**.
3 Click the drop-down menu and select the other server under Open Connections.
4 Click the **Set as Default** button.
5 Click **Close**.

To disconnect from a workspace server

1 In the SAS Server Connections window, select the workspace server to disconnect under Open Connections.
2 Click **Disconnect**.

To disconnect from the metadata server

1 In the SAS Server Connections window, click **Metadata Server Connection**.
2 Click **Disconnect**.

**Connect to a SAS Server on a Remote Machine**

You can also connect directly to a SAS workspace server, instead of going through a metadata server.
To connect to a SAS server

1. Open the SAS Server Connections window (File > SAS > Server Connections).
2. Under Establish New Connection, select **Connect to remote SAS server on**.

**Figure 11.5** Open a Connection to a Remote SAS Server

3. Enter the machine name and the port number. The SAS server administrator has this information.
4. Click **Connect**.

The **JMP: Connect to SAS Server** dialog appears (see Figure 11.6).

**Figure 11.6** Connect to SAS Server

5. Enter your user name and password.
6. Click **OK**.
7. Click **Close** in the SAS Server Connections window.

To disconnect from a SAS server

1. In the SAS Server Connections window, select the server to disconnect under Open Connections.
2. Click **Disconnect**.

**Connect to SAS on Your Local Machine (Windows Only)**

You can also connect directly to SAS on your local machine. Through this connection, you can only submit SAS code from a script window.

**To connect to SAS on your computer**

1. Open the SAS Server Connections window (File > SAS > Server Connections).
2. Under Establish New Connection, select **Connect to SAS on this machine**.
3. Click **Connect**.
4. Click **Close** in the SAS Server Connections window.
To disconnect from SAS on your computer
1. In the SAS Server Connections window, select Local under Open Connections.
2. Click Disconnect.

Opening SAS Data Sets

Once you have a connection to a SAS metadata server (or a physical server), you can browse through servers, libraries, and data sets, and import data into JMP.

Tip: To open a data set when you’re connected locally, select Open from the File menu and select your data set.

To see what’s available from the metadata server, select File > SAS > Browse Data. The Browse SAS Data window appears (see Figure 11.7).

Figure 11.7 Browse SAS Data

The window is initially populated with a list of servers the SAS metadata server provides (if connected). Any physical connections are also shown (as listed in Figure 11.5 “Open a Connection to a Remote SAS Server,” p. 368).

- Select a server to see a list of libraries that server contains.
- Select a library to see a list of data sets within that library.
- Select a data set to see a list of columns within that data set.

At any time, you can select a different data set, library, or server.
Tip: If a server is unavailable, or if the connections failed, the server’s name is shown in light, italic text. Click it to try to re-establish the connection.

SAS Data Information

You can select a SAS data set and see information about its contents before opening it using Column Details and Data Preview.

Column Details

To see information on a particular column in the data set, select it. The Column Details outline shows you some basic information (see Figure 11.8).

Figure 11.8 Column Details

<table>
<thead>
<tr>
<th>Name</th>
<th>Label</th>
<th>Type</th>
<th>Length</th>
<th>Sort Order</th>
<th>Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>Title</td>
<td>Character</td>
<td>40</td>
<td>Unsorted</td>
<td>Data Preview (10 of 50 rows, 6 columns)</td>
</tr>
</tbody>
</table>

- **Name**: Column name from the SAS data set.
- **Label**: Descriptive column label. The label can be longer than the name, and is often helpful to determine what the column name means.
- **Type**: Specifies whether the column has a character or numeric data type.
- **Length**: The length of the field.
- **Sort Order**: How the column is sorted in SAS.
- **Format**: The format for the SAS column, such as DOLLAR8. This format field also contains information on the column width and the number of decimal places.
Data Preview

When you select a data set, the Data Preview outline shows you the first ten rows and columns in the data set (see Figure 11.9).

Figure 11.9 Data Preview

Open a SAS Data Set in JMP

You can import SAS data sets directly into JMP.

1. Select a data set.
2. Click Import.

The SAS data set is imported into a JMP data table. When SAS data is imported, JMP attempts to make the best match to the SAS format.

If you only want to import a portion of a data set, you can select by column or by using a WHERE clause.
To import by column

1. Open the Import Options outline (see Figure 11.10).

**Figure 11.10 Import Options**

2. Click **Select Columns**.
   The Select Columns window appears (see Figure 11.11)

**Figure 11.11 Select Columns**

3. Select the columns you want to import.
   To select more than one column at a time, Control-click (Windows and Linux) or ⌘-click (Macintosh) each column.

4. Click **Add**.

5. When you have added all the columns you want, click **OK**.

6. In the Browse SAS Data window, click **Import**.

Only the columns you selected from the SAS data set are imported into a JMP data table.

**To import using a WHERE clause**

1. Click **Where**.

2. Use the WHERE clause editor to construct your WHERE clause.

3. Click **OK** to return to the Browse SAS Data window.

4. Click **Import**.

Only the data that matches your WHERE clause are imported into a JMP data table.

For information on constructing WHERE clauses and using the WHERE clause editor, see “Using the WHERE Clause Editor,” p. 32
To import using SQL statements
1. Open the Custom SQL outline.
2. In the text window, enter the SQL statements you want to use.
3. Click Execute Custom SQL.

For information on using SQL statements, see “Retrieving Data Using SQL Statements,” p. 27

**Import Options**

There are additional options you can use to specify how SAS data is imported into JMP.

**Use labels for imported column names**  When selected, this option switches the column name, which has a limited length and might be difficult to decipher, with the column label. This option is turned on by default. To use the SAS data column names as column names in JMP, uncheck this box.

**Add SQL table variable to imported table**  When selected, this option adds SQL queries to the data table panel. This option is turned on by default. If you turn off this option, when you import the data table, you will have only two variables: the SAS server and the data set.

**Tip:** If your data is password-protected, you may want to turn this option off, because your password may be shown in the SQL.

**Table variables**

After you import the JMP data table, table variables appear in the upper left panel of the data table. These variables show the SAS server, data set, and SQL query.

**Custom SQL**

You can also open a SAS data set using a custom SQL statement.

1. Open the Custom SQL outline under the Import Options outline (see
2 Enter your SQL into the window.
3 Click **Execute Custom SQL**.

**Note:** Your SQL is run on the selected server but is not restricted to any selected library or data set.

---

**Running Stored Processes**

Stored processes are scripts saved on the SAS server you are connected to. You can run them from JMP and see the results of the script in JMP.

**Note:** If the stored process code fails to execute properly, and you have turned on the option **Append SAS log to JMP log after submit** on the SAS page in Preferences, the SAS log content is sent to the JMP log window.

You must be connected to a metadata server to view and run stored processes. If you select **File > SAS > Browse Stored Processes** without such a connection, you are prompted to make one:

**Figure 11.13** Browse SAS Stored Processes
Click **Close** to cancel browsing stored processes, or click **Connect** to open the Connect to SAS Metadata Server window.

**To select and run a stored process**

1. Select **File > SAS > Browse Stored Processes**.

   The **Browse SAS Stored Processes** window appears (see Figure 11.14).

**Figure 11.14** Browse SAS Stored Processes

![Browse SAS Stored Processes Window](image)

2. Browse through the stored processes to find the one you want to run.
3. Select it.
4. Click **Run**.

On Windows, you can also right-click a stored process and select **Run**.

On Windows, you can right-click a stored process and select **Copy Metadata Path**, which copies the path to the clipboard. You can then paste it into a script window to include it as a parameter for the JSL operator `Meta Get Stored Process()`. For more information, see the *JMP Scripting Guide*.

**Note:** Static graphs may not appear in the results returned from a SAS stored process when streaming output is selected. The “Sample:” programs shown in Figure 11.14 are provided for the SAS Information Delivery Portal, and produce streaming output by default. The graphs in these examples may not display correctly in JMP.

Stored processes send reports to HTML by default, but you can select RTF or PDF instead on the SAS Integration page of the Preferences window (**File > Preferences**).
Submitting SAS Code

You can submit SAS code to directly from JMP. When you submit SAS code, the SAS output window is automatically opened. The SAS code submission example in Figure 11.15 shows two script windows. One contains SAS code (Code), while the other contains JSL code (Script 1).

**Figure 11.15** SAS Code Submission Example

To run SAS code using a JSL script
1. Write your SAS code and save it.
2. In JMP, write JSL that runs your saved SAS code using SAS Integration.
3. Run the JSL script.

To run SAS code directly from JMP
1. Write your SAS code directly in JMP’s script editor.
2. From the Edit menu, select **Submit to SAS**.
   - You can also press the **F8** key (⎹-shift-R on Macintosh).
When the JMP application opens, you see the JMP Starter. The JMP Starter, as illustrated below, is a good way to get started if you haven’t used JMP before. It gives alternative access to most commands found on the main menu or on toolbars.

This chapter gives an overview of the JMP Starter and briefly describes its tabbed pages and the items or commands on them.
## Contents

- **Overview of the JMP Starter Window** ................................................................. 379
- **The File Category** ............................................................................................... 379
- **The Basic Category** ............................................................................................ 381
- **The Model Category** ........................................................................................... 382
- **The Multivariate Category** ................................................................................. 384
- **The Survival Category** ........................................................................................ 386
- **The Graph Category** ........................................................................................... 386
- **The Surface Category** ........................................................................................ 388
- **The Measure Category** ....................................................................................... 389
- **The Control Category** ........................................................................................ 391
- **The DOE Category** .............................................................................................. 392
- **The Tables Category** .......................................................................................... 394
- **The SAS Category** .............................................................................................. 395
Overview of the JMP Starter Window

When JMP opens, the JMP Starter appears behind the Tip of the Day window. The JMP Starter gives alternative access to most commands found on the main menu or on toolbars. You can close the JMP Starter if you want; it is not required for running JMP.

To open and close the JMP Starter, select View > JMP Starter on Windows and Linux or Window > JMP Starter under Macintosh.

The JMP Starter categories are organized in a way similar to the main menu, as illustrated in Figure A.1. The four categories that follow the File category correspond with options available under the Analyze menu. They lead you step by step from your data to an appropriate analysis. The next four categories correspond with the Graph menu. The next two correspond with the DOE and Tables menu.

Figure A.1  JMP Starter Categories

The File Category

The JMP Starter first appears with the File category showing, as in Figure A.2. Most commands in the File category correspond to File menu commands on the main menu bar.

The commands in the File category open JMP data tables or other kinds of JMP windows, which is often what you need to do first.
Figure A.2 JMP Starter File Page

**New Data Table**  Opens an empty untitled data table. See “Creating New Data Tables,” p. 10, for details.

**Open Data Table**  Displays a window you use to locate the file you want to open. This window also lets you specify the file format of the incoming file. See “Opening Existing JMP Files,” p. 11, for details.

**Open Database Table**  (Windows only)  Opens a connection to any database on your system that has an ODBC driver. See “Opening Data from a Database,” p. 25, and “Saving Data Tables to a Database,” p. 111, for details.

**New Script**  Opens a new empty script window, which is an editable text window to enter and submit JMP Scripting Language (JSL) commands. See the *JMP Scripting Guide* for details on JSL.

**Open Script**  Displays a specialized open file window to locate the script you want to open. See “Opening Existing JMP Files,” p. 11, for details.

**New Journal**  Opens an empty journal window. See “Saving Using the Journal Command,” p. 113, for details.

**Open Journal**  Displays a specialized open file window to locate the journal you want to open. See “Opening Existing JMP Files,” p. 11, for details.

**New Project**  Opens an empty project. See “Creating a JMP Project,” p. 122, for details.

**Open Project**  Displays a specialized open file window to locate the project you want to open. See “Opening Existing JMP Files,” p. 11, for details.
Preferences  Enables you to specify general and specific settings and save the settings so they are associated with your JMP session. See “To change preferences.” p. 319, for details.

The Basic Category

The Basic category (Figure A.3) addresses univariate and bivariate analyses. You see how to examine variables one at a time by looking at distributions and comparing them to known distributions. When there are two variables, a single response ($y$) and a single factor ($x$), JMP performs the appropriate bivariate analysis according to whether the variables are continuous or categorical. These analyses can be run by clicking their buttons on the Basic category, as shown in Figure A.3.

Figure A.3  JMP Starter Basic Category

Distribution  Clicking the Distribution button, or choosing Analyze > Distribution, launches the Distribution platform, which describes the distribution of values in a data table column using histograms and other graphical and text reports. See “Initial Text Reports” of JMP Statistics and Graphics Guide.

Two-Sample t-Test  Clicking the Two-Sample t-Test button takes you directly to a window for setting up a oneway analysis. Use this button rather than clicking Analyze > Fit Y by X.

Matched Pairs  Clicking the Matched Pairs button, or choosing Analyze > Matched Pairs, looks at the mean difference between two (or more) columns. It plots the points in a rotated scatterplot that presents them in terms of the differences and means of two variables.

The JMP Statistics and Graphics Guide discusses matched pairs and shows a unique graphical representation for that kind of analysis.
**The JMP Starter**

**The Model Category**

**Fit Y by X**  Clicking the **Fit Y by X** button, or choosing **Analyze > Fit Y by X**, launches a report platform for each pair of columns in the active data table that are assigned x and y roles for the analysis.

The four sub-buttons under **Fit Y by X** lead directly to one of the four models within the Fit Y by X platform:

- **Oneway**  If x has a nominal or ordinal analysis type and y is continuous, clicking the **Oneway** button and making your selections in the window plot the distribution of y values for each discrete value of x and computes a one-way analysis of variance table.

- **Bivariate**  If both x and y have continuous analysis types, clicking the **Bivariate** button and making your selections in the window displays a scatterplot.

- **Contingency**  If both x and y have a nominal or ordinal modeling type, clicking the **Contingency** button and making your selections in the window displays a contingency table and a mosaic bar chart.

- **Logistic**  If x is continuous and y is nominal or ordinal, clicking the **Logistic** button and making your selections in the window performs a logistic regression and displays a family of logistic probability curves.

The chapters “Bivariate Scatterplot and Fitting,” “One-Way ANOVA,” “Contingency Tables Analysis,” and “Simple Logistic Regression” of *JMP Statistics and Graphics Guide* cover these four cases.

---

**The Model Category**

The **Model** category (Figure A.4) gives choices for fitting all types of models—from simple regression and analysis of variance to complex nonlinear fits.
Figure A.4 JMP Starter Model Category

Fit Model  Clicking the Fit Model button, or choosing Analyze > Fit Model, fits one or more $y$ variables to a model of $x$ variables.


Screening  Clicking the Screening button, or choosing Analyze > Modeling > Screening, helps select a model to fit to a two-level screening design by showing which effects are large.


Nonlinear  Clicking the Nonlinear button, or choosing Analyze > Modeling > Nonlinear, lets you specify nonlinear models, which are models that are nonlinear in their parameters. You orchestrate the fitting process as a coordination of three important parts of JMP: the data table, the formula editor, and the nonlinear fit platform.


See the chapter “Nonlinear Regression” of JMP Statistics and Graphics Guide for more about nonlinear fitting.

Time Series  Clicking the Time Series button, or choosing Analyze > Modeling > Time Series, looks at the relationship between a value and its lagged values. The data must be sorted and have equal intervals between time periods. Time Series plots the time series and autocorrelations, shows a variogram, and shows the spectral density.

The Multivariate Category

The Multivariate category introduces ways to look at continuous variables when they are considered as responses only; there are no factor or independent variables. Multivariate exploration with correlations and cluster analysis lets you look at many variables at the same time.

Figure A.5 JMP Starter Multivariate Category
**Multivariate**  Clicking the Multivariate button, or choosing Analyze > Multivariate Methods > Multivariate, gives you ways to explore how several variables relate to each other. The platform begins with a standard correlation matrix and gives additional options for correlations and other techniques for looking at several variables.

**Hierarchical Cluster and K-Means Cluster**  Clustering is a technique of grouping rows together that share similar values across a number of variables. It is an exploratory technique to help you understand the clumping structure of your data. Clicking the Hierarchical Cluster or K-Means Cluster buttons, or choosing Analyze > Multivariate Methods > Cluster produces a window that lets you select whether to run a K-means cluster or a hierarchical cluster.

- Hierarchical clustering is appropriate for small tables, up to several hundred rows. It combines rows in an hierarchical sequence portrayed as a tree. In JMP, the tree, also called a dendrogram, is a dynamically responding graph. You can specify the number of clusters after the tree is built.

- K-means clustering is suitable for larger tables, up to hundreds of thousands of rows. It begins with a cluster seed point. Then the clustering process iterates between assigning points to the number of clusters you specify and recalculating cluster centers. After the clustering process is complete, you can save the cluster assignments to the data table or use them to set colors and markers for the data table rows.

See the chapters “Correlations and Multivariate Techniques,” and “Clustering” of JMP Statistics and Graphics Guide for a detailed discussion of multivariate relationships and clustering.

**Principal Components**  Clicking the Principal Components button, or choosing Analyze > Multivariate Methods > Principal Components, helps derive a small number of independent linear combinations (principal components) of a set of variables that capture as much of the variability in the original variables as possible.


**Discriminant**  Clicking the Discriminant button, or choosing Analyze > Multivariate Methods > Discriminant, starts a discriminant analysis. The technique is based on how close a set of measurement variables are to the multivariate means of the levels being predicted. Optionally, you can do stepwise discriminant analysis.

**PLS**  Clicking the PLS button, or choosing Analyze > Multivariate Methods > PLS, fits models using the partial least squares (PLS) method that balances the two objectives of explaining response variation and explaining predictor variation. The PLS techniques work by extracting successive linear combinations of the predictors, called factors (also called components or latent vectors) that address one or both of these two goals. The PLS platform in JMP also enables you to select the number of extracted factors by cross validation, which involves fitting the model to part of the data and minimizing the prediction error for the unfitted part.

**Item Analysis**  Clicking the Item Analysis button, or choosing Analyze > Multivariate Methods > Item Analysis, provides analysis of test items using the Item Response Theory.
The Survival Category

Survival data contain duration times until the occurrence of a specific event and are sometimes referred to as event-time response data. The event can be failure, such as the failure of an engine or death of a patient.

Figure A.6 JMP Starter Survival

The buttons on the Survival category, also found under Analyze > Survival and Reliability, can help you analyze survival data several ways:

- **Survival/Reliability** (Univariate survival analysis) Is used for a univariate survival analysis using product-limit (Kaplan-Meier) life table survival computations with estimation of Weibull, log-normal, and exponential parameters.
- **Parametric Regression** Is used for an analysis that tests the fit of an exponential, Weibull, or lognormal distribution.
- **Proportional Hazards** Is used for a regression analysis that fits a Cox model.
- **Recurrence** Starts an analysis that looks at the age of a system when it requires a repair. A system can have multiple repairs, each with its associated age, and is followed until it is no longer in service. A typical system might be some component of an engine or appliance.

**Note:** You can also use the nonlinear platform to handle nonlinear models with loss functions for other parametric survival modeling.

See the chapter “Survival and Reliability Analysis I” of JMP Statistics and Graphics Guide for more about the survival platform.

The Graph Category

The Graph category, shown in Figure A.7, corresponds with commands in the main menu that produce plots and charts of summarized data, a three-dimensional spinning plot, contour, and ternary plots.
The Graph Category

**Chart**
Clicking the **Chart** button, or choosing **Graph > Chart**, and completing the window gives a chart for every numeric y specified where the y's are statistics to chart. The x-values are always treated as discrete values. **Chart** automatically updates when values change in the current data table and you then activate the chart window.

**Overlay Plot**
Clicking the **Overlay Plot** button, or choosing **Graph > Overlay Plot**, and making your selections in the window gives an overlaid plot of a single numeric or categorical x column and all numeric y variables. Optionally, the plots for each y can be shown separately, with or without a common x-axis. Plots can be modified with range and needle options, color, log axes, and grid lines. Overlay plots automatically update when you change values in the current data table and then activate the overlay plot report window.

**Scatterplot 3D**
Clicking the **Scatterplot 3D** button, or choosing **Graph > Scatterplot 3D**, displays a three-dimensional view of data and an approximation of higher dimensions through principal components. The plot is a rotatable display of the values of numeric columns in the current data table. The Scatterplot 3D platform displays three variables at a time from the columns you select.

To help capture and visualize variation in higher dimensions, the Scatterplot 3D platform displays a biplot representation of the points and variables when you request principal components. See *JMP Statistics and Graphics Guide* for details.

**Contour Plot**
Clicking the **Contour Plot** button, or choosing **Graph > Contour Plot**, and making your selections in the window constructs a contour plot for a response variable, y, for the values of two x variables. A contour plot requires two variables for the x- and y-axes and a third variable (denoted y in the Contour Plot window) for contours.

**Ternary Plot**
Clicking the **Ternary Plot** button, or choosing **Graph > Ternary Plot**, creates ternary plots, which display the distribution and variability of three-part compositional data. Examples of compositional data are the proportion of sand, silt, and clay in soil, or the proportion of...
three chemical agents in a trial drug. You can use data expressed in proportions, or in absolute measures. The ternary plot platform converts absolute values to proportions.

The ternary plot in JMP also has a contour feature, which means you can use a response measure at each point to form a contour plot within the ternary structure.

See JMP Statistics and Graphics Guide for details and examples of ternary plots.

**Parallel Plot**  Clicking the **Parallel Plot** button, or choosing **Graph > Parallel Plot**, draws a parallel coordinate plot, which shows connected line segments representing each row of a data table.

**Cell Plot**  Clicking the **Cell Plot** button, or choosing **Graph > Cell Plot**, produces a rectangular array of cells drawn with a one-to-one correspondence to data table values.

**Tree Map**  Clicking the **Tree Map** button, or choosing **Graph > Tree Map**, displays tree maps, which can be thought of as bar charts that have been folded over in two dimensions, leaving no unused space. It is useful when there are a lot of categories. Tree maps are a graphical technique of observing patterns among groups that have many levels. They are especially useful in cases where histograms are ineffective.

**Bubble Plot**  Clicking the **Bubble Plot** button, or choosing **Graph > Bubble Plot**, displays a scatter plot which represents its points as circles (bubbles). Optionally the bubbles can be sized according to a another column, colored by another column, aggregated across groups defined by one or more other columns, and dynamically indexed by a time column. With the opportunity to see up to five dimensions at once (x position, y position, size, color, and time), bubble plots can produce dramatic visualizations and make interesting discoveries easy.


**Histograms**  Clicking the **Histograms** button, or choosing **Analyze > Distribution**, which lets you construct an analysis that shows a distribution of values with histograms and other graphical and textual reports.

**Scatterplot Matrix**  Clicking the **Scatterplot Matrix** button, or choosing **Analyze > Multivariate Methods > Multivariate**, explores how multiple variables relate to each other and how points fit that relationship. This platform helps you see correlations between two or more response (y) variables, look for points that are outliers, and examine principal components to look for factors.

**Mosaic Plot**  Clicking the **Mosaic Plot** button when you have nominal or ordinal x and y values produces a contingency table and a mosaic bar chart.

The **Surface Category**

The **Surface** category, shown in Figure A.8, corresponds with commands in the main menu that produce multi-dimensional graphs, such as profilers and surface plots.
Surface Plot  Clicking the **Surface Plot** button, or choosing **Graph > Surface Plot**, produces plots with smooth, three-dimensional surfaces.

Profiler  The report that results from clicking the **Profiler** button, or choosing **Graph > Profiler**, produces a prediction profiler for the effect variables in a model, with one or more $y$ variables. The prediction profiler displays prediction traces for each $x$ variable. A prediction trace is the predicted response as one variable is changed while the others are held constant at the current values. If you save the prediction equations for a model, you can access the prediction profiler for that data table directly with **Graph > Profiler** without rerunning the model.

Contour Profiler  The report that results from clicking the **Contour Profiler** button, or choosing **Graph > Contour Profiler**, does interactive contour profiling. This is useful for optimizing response surfaces graphically. This interactive plot lets you adjust both multiple responses and multiple factors simultaneously and shows acceptable factor setting regions for response values you specify. If you save the prediction equations for a model, **Graph > Contour Profiler** accesses the contour profiler for that data table directly without rerunning the model.


Custom Profiler  Clicking the **Custom Profiler** button, or choosing **Graph > Custom Profiler**, displays an interface for interacting with and optimizing a prediction formula.

### The Measure Category

The **Measure** category, shown in Figure A.9, accesses the commands on the **Graph** menu that are used in statistical quality control, except for the **Capability** button, which accesses the **Distribution** command found on the **Analyze** menu.
Variability Chart  Clicking the Variability Chart button on the Measure page, or choosing Graph > Variability/Gage Chart, performs a variability analysis, also called a Gage R&R analysis. In a variability analysis, a number of parts assumed to be identical are taken from a production line. Each one is measured several times by a number of operators using different measuring instruments. You want to know the magnitudes of the variation due to operators, parts, and instruments.

The chapter “Variability Charts” of JMP Statistics and Graphics Guide documents the plots and reports produced by the variability platform.

Attribute Chart  Click the Attribute Chart Button, or select Graph > Variability/Gage Chart and choose Attribute from the drop-down menu, when your response values are binary or categorical. For example, a circuit might be measured as pass/fail. Because different reports are generated on the raters, raters each need to be in different columns. The chapter “Variability Charts” of JMP Statistics and Graphics Guide documents the plots and reports produced by the variability platform.

Capability  Clicking the Capability button on the Measure page, or choosing Analyze > Distribution, gives a platform option for capability analysis for quality control applications. A capability study measures the deviation of a process from given specification limits. A window prompts you for the lower spec limit, upper spec limit, and target. You can also enter a known value for sigma, the process standard deviation.

See the chapter “Univariate Analysis” of JMP Statistics and Graphics Guide for examples of capability analysis.

Pareto Plot  Clicking the Pareto Plot button on the Measure page, or choosing Graph > Pareto Plot, creates a bar chart (Pareto chart) that displays the severity (frequency) of problems in a quality-related process or operation. A Pareto chart is a statistical quality improvement tool that shows frequency, relative frequency, and cumulative frequency of problems. The defining characteristic of Pareto plots is that the bars are in descending order of values, which visually emphasizes the most important measures or frequencies.

Diagram  Clicking the Diagram button on the Measure page, or choosing Graph > Diagram, constructs Ishikawa charts, also called fishbone charts, or cause-and-effect diagrams. These charts are useful to organize the sources (causes) of a problem (effect), perhaps for brainstorming, or as a preliminary analysis to identify variables in preparation for further experimentation.

The chapter “Ishikawa Diagrams” of JMP Statistics and Graphics Guide describes creating these diagrams.

The Control Category

The Control category, shown in Figure A.10, accesses the commands that are used in statistical quality control.

Figure A.10  The JMP Starter Control Category

Run Chart  Clicking the Run Chart button, or clicking Graph > Overlay Plot, gives an overlay of a single numeric or categorical x column and all specified numeric y variables.

XBar  Clicking the XBar button offers a combination of X-, R-, and S-charts. The X-chart plots subgroup means (averages), the R-chart plots subgroup ranges, and the S-chart plots subgroup standard deviations.

IR  Clicking the IR button gives either an individual measurement chart, which displays individual measurements, or a moving range chart, which displays moving ranges of two or more successive measurements.

UWMA  Clicking the UWMA button gives a Uniformly Weighted Moving Average (UWMA) chart, also called a Moving Average chart. Each point on a UWMA chart is the average of the w most recent subgroup means, including the present subgroup mean.

EWMA  Clicking the EWMA button gives an Exponentially Weighted Moving Average (EWMA) chart, also referred to as a Geometric Moving Average (GMA) chart. Each point on an EWMA chart is the weighted average of all the previous subgroup means, including the mean of the present subgroup sample. The weights decrease exponentially going backward in time.
CUSUM  Clicking the CUSUM button gives a Cumulative Sum control chart, which displays cumulative sums of the deviations of measurements or subgroup means from a target value.

Presummarize  Clicking the Presummarize button summarizes the process column into sample means and/or standard deviations, based either on the sample size or sample label chosen. Then it charts the summarized data in individuals and/or moving range charts.

Levey Jennings  Clicking the Levey Jennings button gives a plot that shows a process mean with control limits based on a long-term sigma. The control limits are placed at 3\(\sigma\) distance from the center line.

Multivariate Control Chart  Clicking the Multivariate Control Chart button gives a t-squared control chart, which measures how far a multivariate point is from the target with respect to the covariance structure.

P  Clicking the P button gives \(p\)-charts, which display the proportion of nonconforming (defective) items in subgroup samples which can vary in size. Since each subgroup for a \(p\)-chart consists of \(N\) items, and an item is judged as either conforming or nonconforming, the maximum number of nonconforming items in a subgroup is \(N\).

NP  Clicking the NP button gives \(np\)-charts, which display the number of nonconforming (defective) items in constant sized subgroup samples. Since each subgroup for a \(np\)-chart consists of \(N_i\) items, and an item is judged as either conforming or nonconforming, the maximum number of nonconforming items in subgroup \(i\) is \(N_i\).

C  Clicking the C button gives \(c\)-charts, which display the number of nonconformities (defects) in a subgroup sample that usually consists of one inspection unit. The maximum number of defects is unlimited.

U  Clicking the U button gives \(u\)-charts, which display the number of nonconformities (defects) per unit in subgroup samples that can have a varying number of inspection units. The maximum number of defects is unlimited.

OC Curves  Clicking the OC Curves button accesses a set of JSL scripts that compute and plot operating characteristic curves. The chapter “Statistical Control Charts” of JMP Statistics and Graphics Guide gives details about how to run the OC curves scripts.

The DOE Category

The DOE category, shown in Figure A.11, corresponds to the commands in the DOE main menu. These commands construct classical and custom experimental designs and save them in a JMP table. Selecting a design type presents an environment for describing the factors, responses and other specifications needed to make a design of that type.

See JMP Design of Experiments for complete documentation of DOE in JMP.
Custom Design  Clicking the Custom Design button, or choosing DOE > Custom Design, generates a \( D \)-optimal design for the design you specify and, optionally, an \( I \)-optimal design for response surface designs. Custom designs can have continuous factors and categorical factors with arbitrary numbers of level, interactions, and mixture ingredients. A design can also have covariates, which are factors that already have unchangeable values; a design is built around the covariate. You can construct custom design models, including interaction terms and polynomial terms for continuous factors. Factors can have inequality constraints. You can also specify the number of experimental runs, which can be any number greater than or equal to the number of terms in the model.

Screening Design  Clicking the Screening Design button, or choosing DOE > Screening Design, allows you to specify continuous factors, two- and three-level factors, and categorical factors. It creates a table of classical screening designs from which you can pick.

Response Surface Design  Clicking the Response Surface Design button, or choosing DOE > Response Surface Design, lets you define a number of continuous factors. This environment then offers a table of classical response surface designs from which to select.

Nonlinear Design  Clicking the Nonlinear Design button, or choosing DOE > Nonlinear Design, lets you create an optimal design for models that are nonlinear in the parameters.

Space Filling Design  Clicking the Space Design Filling button, or choosing DOE > Space Filling Design, lets you run experiments for modeling systems that are deterministic or near deterministic. You can choose to emphasize spreading points apart, mimic the uniform distribution, or choose a compromise between the two.

Full Factorial Design  Clicking the Full Factorial Design button, or choosing DOE > Full Factorial Design, lets you specify a set of continuous and categorical factors with arbitrary numbers of levels. JMP creates the design containing all possible combinations of those factors.

Taguchi Arrays  Clicking the Taguchi Arrays button, or choosing DOE > Taguchi Arrays, guides you through the definition of signal and noise factors. The signal factors form the inner array and
the noise factors form the outer array. The inner and outer array designs are the traditional Taguchi orthogonal arrays such as L4, L8, L16, etc.

**Mixture Design**  Clicking the Mixture Design button, or choosing DOE > Mixture Design, lets you define a set of factors that are ingredients in a mixture. JMP creates a new window for choosing among several classical mixture design approaches such as simplex, extreme vertices, and lattice. For the extreme vertices approach, you can supply a set of linear inequality constraints limiting the geometry of the mixture factor space.

**Augment Design**  Clicking the Augment Design button, or choosing DOE > Augment Design, lets you modify existing designs. You can add center points, replicate the design, create a foldover design, and add runs to the design using a model with more terms than the original design.

**Sample Size and Power**  Clicking the Sample Size and Power button, or choosing DOE > Sample Size and Power, computes power, sample size, or the effect size you want to detect for a given alpha and error standard deviation. You supply two of these values and the sample size and power feature computes the third. If you supply only one of these values, the result is a plot of the other two. This feature is available for the single sample, two sample, and k sample situations.

---

**The Tables Category**

The Tables category (Figure A.12) corresponds to the commands in the Tables main menu. See the chapter “Reshaping Data,” p. 221, for detailed descriptions and examples for each Tables menu command.

**Figure A.12**  JMP Starter Tables Category

The buttons on the Tables page can help you analyze data in several ways:
Summary  Creates a summary table, which summarizes columns from the active data table, called its source table. The summary table has a single row for each level of a grouping variable you specify. Optionally, you can add columns of summary statistics to this table and request summary statistics.

Tabulate  Creates a tabulated table from the active data table. It calculates, sorts, and displays totals and subtotals for you in a report format, rather than in a data table.

Subset  Creates a new data table formed by the selected rows and columns or by a random sample in the active data table.

Sort  Sorts a data table by one or more columns.

Stack  Creates a new data table from the active table by stacking specified columns into a single column.

Split  Creates a new data table from the active table by dividing one or more columns to form multiple columns.

Transpose  Creates a new data table that has the columns of the active table as its rows and the rows of the active table as its columns.

Concatenate  Creates a new data table from two or more open data tables by combining them end to end.

Join  Creates a new data table by merging (joining) two tables side by side.

Update  Updates one table with data from a second table without producing a new data table.

Missing Data Pattern  Shows a pattern that your missing data creates. The pattern may help you make discoveries about your data.

The SAS Category

The SAS category (Figure A.13) corresponds to the commands in the File > SAS menu. See the chapter “SAS Integration,” p. 363, for detailed descriptions and examples for each File > SAS menu command.

Figure A.13  JMP Starter SAS Category

New SAS Program  Creates a new SAS program to be run by the default SAS server.
Open SAS Program  Open a SAS program file into JMP’s script editor.
Open Local SAS Data  Import a SAS data set into a JMP data table.
Import Data from Server  Import SAS data from a SAS server into a JMP data table.
Run Stored Process  Run a SAS program registered on a SAS metadata server.
Server Connections  Connect to and disconnect from SAS servers and set the default server.
This chapter gives an overview of commands in the JMP main menu bar, which is located at the top of the screen.
## Contents

<table>
<thead>
<tr>
<th>Menu</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>The JMP Menu (Macintosh Only)</td>
<td>399</td>
</tr>
<tr>
<td>The File Menu</td>
<td>399</td>
</tr>
<tr>
<td>The Edit Menu</td>
<td>402</td>
</tr>
<tr>
<td>The Tables Menu</td>
<td>405</td>
</tr>
<tr>
<td>The Rows Menu</td>
<td>406</td>
</tr>
<tr>
<td>The Cols Menu</td>
<td>408</td>
</tr>
<tr>
<td>The DOE Menu</td>
<td>410</td>
</tr>
<tr>
<td>The Analyze Menu</td>
<td>412</td>
</tr>
<tr>
<td>The Graph Menu</td>
<td>417</td>
</tr>
<tr>
<td>The Tools Menu</td>
<td>422</td>
</tr>
<tr>
<td>The View Menu</td>
<td>424</td>
</tr>
<tr>
<td>On Microsoft Windows and Linux</td>
<td>424</td>
</tr>
<tr>
<td>On Macintosh</td>
<td>425</td>
</tr>
<tr>
<td>The Window Menu</td>
<td>425</td>
</tr>
<tr>
<td>On Microsoft Windows and Linux</td>
<td>425</td>
</tr>
<tr>
<td>On Macintosh</td>
<td>427</td>
</tr>
<tr>
<td>The Help Menu</td>
<td>428</td>
</tr>
<tr>
<td>The Layout Menu</td>
<td>429</td>
</tr>
</tbody>
</table>
The JMP Menu (Macintosh Only)

**About JMP**
Opens JMP’s About window, which contains the release, the copyright, the operating system, and the JMP license owner.

**U.S. Government Notice**
Displays the restricted rights notice.

**Deauthorize Computer**
Revokes JMP’s license to run on the current computer. After deauthorizing the computer, you may activate the license on another machine.

**Preferences**
Lets you change start-up items, analysis destination, output information, table styles, fonts, graphic formats, and more. See “Personalizing JMP,” p. 319, for details of the Preferences command.

**Services**
JMP does not support the Services menu.

**Hide JMP**
Hides all of JMP’s windows and brings the most recently-used application to the foreground.

**Hide Others**
Hides the windows of all other running applications.

**Show All**
Brings all open applications into view.

**Quit JMP**
Closes all JMP windows, allowing you to review and/or save modified documents, and quits JMP.

The File Menu
The File menu has commands that perform file management or affect the JMP environment.
New

Reveals a submenu with options to create a new data table or a new script window. The submenu contains:

- **Data Table**  Opens an empty untitled data table. See “Creating New Data Tables,” p. 10, for details.
- **Script**  Opens a new empty script window, which is an editable text window to enter and submit JMP Scripting Language (JSL) commands.
- **Journal**  Opens an empty journal window. See “Importing Data,” p. 13, for details.
- **Project**  Opens the Projects pane on the left side of JMP and opens an empty project. See “Working with JMP Projects (Windows Only),” p. 122 in the “How To Save Tables, Reports & Sessions” chapter.

Open

The Open command displays a specialized open file window to locate the file you want to open and specify the file format of the incoming file. The Open window displays information appropriate for the incoming file type. The Open command directly reads JMP data tables, JMP journal files, JMP script files, SAS data sets, SAS transport files, text files with any column delimiter, and Microsoft Excel files. On Windows, it also opens Windows menu files, which are created when you modify the JMP main menu and save the results (they are saved as .jmpmenu). See “Opening Existing JMP Files,” p. 11, for details of the Open command.

Open Recent

(Macintosh and Linux only)  Reveals a submenu that lists the JMP tables and scripts most recently opened. When you click a table name in this list, JMP opens the table. When you click a script name in this list, JMP opens the script. Some scripts automatically run. To open these scripts without running, press Ctrl (Option on the Macintosh) while making the selections.

Close

Closes the active window. It is the same as clicking the close box of the active window.

**Note:** On the Macintosh, the Close command on the File menu closes the active window. Option-File displays the Close All command, which closes all data tables. Additionally, you can Option-click the close box to close all data tables.

Import as Data

Writes an open text file to a JMP data table. See “Importing Text as Data,” p. 20, for details.

Save

Writes the active data table, journal, or layout to a file. See “Saving Data Tables,” p. 107, and “Saving Reports,” p. 112, for details.
Save As

Writes the active data table, journal, or layout to a file after prompting you for a name and file type. See “Saving Data Tables,” p. 107, for details on saving tables and “Saving Reports,” p. 112, for details on saving reports.

On the Macintosh, Option-File displays the Save Selection As command for saving highlighted graphics from a data table, report, journal, or layout in Macintosh picture or JPEG graphics format. On Windows and Linux, the Save Selection As command is located in the Edit menu.

Revert (Windows/Linux) or File > Revert to Saved (Macintosh)

Restores the current data table to its condition when it was last saved. This command is dimmed on the File menu unless a data table has been edited.

Export (Macintosh Only)


Database

Opens a connection to any database on your system that has an ODBC driver. See “Opening Data from a Database,” p. 25, and “Saving Data Tables to a Database,” p. 111, for details. Selecting File > Database reveals a submenu with options to open or save to any database on your system that has an ODBC driver. The submenu contains:

- Open Table  Displays the Database Open Table window, which lets you connect to a database from which you want to open a table.

- Save Table  Displays the Database Save Table window, which lets you connect to a database. You can then save the data table to this location.

Internet Open

Lets you open an internet browser within JMP. See “Opening a File Using the Internet,” p. 34, for details.

Preferences

Opens the Preference Settings window, which lets you set preferences for start-up options, graph defaults, colors, fonts, file locations, etc. For more information on customizing JMP using the Preference Settings window, see the chapter “Personalizing JMP,” p. 319.

Print

Prints the active window. It displays the standard window for printing. The appearance of the window depends on your operating system and printer driver. See “Printing Reports,” p. 175, for details.

Print Preview

(Windows only)  Displays the active window in the form it will print. Print Preview is dimmed on the File menu unless there is an open window.
The Main Menu

Appendix B

The Edit Menu

Print Setup (Windows) or Page Setup (Macintosh)
Displays the standard window for setting printed page characteristics. The form of the window depends on your operating system and current printer driver.

Send
(Windows only) Submits reports and data tables to the email application you define. See “Emailing Tables and Reports (Windows Only),” p. 39, for details.

Recent Files
(Windows only) Reveals a submenu that lists the JMP tables, scripts, and journals most recently opened. When you click a table name in this list, JMP opens the file.

Save Session Script
Creates a JSL script to re-open all currently open files and re-run all currently open analyses and graphs.

Exit
(Windows and Linux) Closes all JMP windows (prompting you to save changes) and quits the JMP application. On the Macintosh, the Quit command is located in the JMP menu.

The Edit Menu

The Edit menu contains standard commands that operate on selected rows and columns, on selected areas of reports, on scripts and text, and on selected formula elements in the formula editor. The commands operate on entire rows if no columns are selected. Likewise, they operate on whole columns if no rows are selected. When both rows and columns are selected, Edit commands affect the subset of values defined by the intersection of those rows and columns.

The Edit menu in conjunction with JMP tools can be used to copy all or part of active analysis report windows. See “The Tools Menu,” p. 422, for details.

Undo
Cancels the effect of the most recent reversible Edit, Rows, or Columns command. Most destructive data table operations (such as cut, paste, or delete rows) are reversible. Undo dims when the most recent command is irreversible.

Redo
Reverses the effect of the Undo command.
Cut

Copies selected fields from the active data table to the clipboard and replaces them with missing values. It is equivalent to Copy, then Clear. You can also use the Cut command to copy all or part of a report. However, Cut works like Copy in reports; it does not clear the copied image.

Copy

Copies the values of selected data cells from the active data table to the clipboard. It captures graphs and tables in reports defined by the area selection tool ( ) in the Tools menu.

Copy as Text

Copies all text (no graphs) from the active report window as unformatted text on the clipboard. On the Macintosh, the Copy as Text command appears only when applicable.

Copy with Labels (Windows and Linux) or Copy with Column Names (Macintosh)

Preserves the data table's column labels in the copied image. Use Shift-Paste with Labels (Paste with Column Names on the Macintosh) to paste the information into a new column with the column name intact. See “Copying, Cutting, and Pasting,” p. 78, for details.

Paste

Pastes information from the clipboard to the selected area in a JMP data table. Paste can be used with the Copy command to duplicate rows, columns, or any subset of cells defined by selected rows and columns.

Paste with Labels (Windows and Linux) or Paste with Column Names (Macintosh)

Uses the first line of information on the clipboard as column headers.

Clear (Windows/Linux), Edit > Delete (Macintosh)

Clears all selected cell values from the active data table and replaces them with missing values. The values are not copied to the clipboard.

Select All

When a data table is the active window, the Select All command selects (highlights) all the rows in the current data table. When a report, a layout, or a journal is the active window, Select All selects points on plots or all the objects in the layout or journal window.

Save Selection As

On Windows, the Save Selection As command saves highlighted portions of an analysis window in a graphic format. On the Macintosh, Option-File displays the Save Selection As command. See “Saving Parts of a Report in a Graphic Format,” p. 119, for details.
Encrypt Script and Decrypt Script

Places a cryptic encoding in your script so it can only be opened and/or run if the person opening the script possesses a password. For details, see the JMP Scripting Guide.

Run Script

Submits a text file containing JMP Scripting Language (JSL) commands. You create a JSL script in one of two ways:

- Select File > New > Script and manually type JSL commands.
- Complete an analysis, click a report’s red triangle icon, and select Save Script to Script Window. This lets you save a script that describes the whole analysis report or a part of the report. To submit a portion of a script, first drag to highlight the portion you want and then select Edit > Run Script. If no script commands are highlighted, the entire script is submitted.

See the JMP Scripting Guide for details.

Stop Script

Stops running a JSL script. It appears when a script is running.

Import as Data

Writes an open text file to a JMP data table. See “Importing Text as Data,” p. 20, for details.

Search

Gives you the ability to find and replace text in data tables and scripts (including column names) in the usual way found in most word processing and editing programs. See “Using the Search/Find Command,” p. 93, for details.

Go to Line

When a script window is open, the Go to Line command displays a window that lets you enter the line number of the script, then sets the edit focus on that line.

Balance

Selects everything all text within a pair of brackets that include the cursor.

Journal

Saves a report just as it appears in the report window. See “Saving Using the Journal Command,” p. 113, for details.

Layout

Lets you edit or manipulate the report before you save, allowing you to combine several reports into one or rearrange the report elements. When a layout window is the active (front-most) window, the Layout menu appears between the Edit and Tables menus (Windows and Macintosh) or between the

Customize

(Windows and Linux only) Reveals a submenu to customize menus and toolbars. Revert to Factory Defaults resets the menus and toolbars to the arrangement when you first installed JMP. See “Personalizing JMP,” p. 319, for further discussion and examples of customizing JMP menus.

The Tables Menu

The Tables menu commands modify or create a new JMP table from one or more existing tables. This section gives you an overview of each Tables menu command.

Summary

Creates a JMP window that contains a summary table, which summarizes columns from the active data table, called its source table. See “Summarizing Columns,” p. 257, for details.

Subset

Creates a new data table that is a subset of the active data table. To quickly create a subset table, highlight the rows you would like to subset, press the Shift key and select Tables > Subset. JMP creates a linked subset table without asking you to complete the Subset window. See “Creating a Subset Table,” p. 223, for details on creating subsets.

Sort

Sorts a JMP data table by one or more columns. The Sort command displays a window for you to specify columns as sort fields. See “Sorting Data Tables,” p. 225, for details.

Stack

Creates a new data table from the active table by stacking specified columns into a single new column. The values in other columns are preserved in the new data table. In addition, Stack creates an ID column that identifies each row in the new table with values that are the corresponding column names from the original table. Stack does the reverse of Split. See “Stacking Columns,” p. 227, for details.

Split

Creates a new data table from the active table by dividing one or more columns to form multiple columns. The new columns correspond to the values (levels) of an ID variable. Split requires one or more columns whose combined values identify each row in the new table. See “Splitting Columns,” p. 230, for details.
The Rows Menu

You can access commands that affect highlighted rows from the Rows menu. Most of these commands can also be found by clicking the red triangle icon on the rows panel to the left of the data table or by clicking the red triangle icon in the upper-left corner of the data table above the row numbers.

Exclude/Unexclude

Excludes selected rows from statistical analyses. See “Excluding Rows and Columns,” p. 129, for details.

Hide/Unhide

Suppresses (hides) rows so they do not appear in plots and graphs. See “Hiding Rows and Columns,” p. 131, for details.

Label/Unlabel

The Label/Unlabel command labels or identifies points on all scatterplots. See “Labeling Rows and Columns,” p. 132, for details.

Transpose

Creates a new data table whose columns of the original table are the rows of the new table, and the original table rows are the new table's columns. See “Transposing Rows and Columns,” p. 232, for details.

Concatenate

Creates a new data table from two or more open tables by combining them end to end. See “Attaching Tables (Concatenating),” p. 236, for details.

Join

Creates a new data table by merging (joining) two tables side by side. See “Joining Tables,” p. 238, for details.

Update

Updates one data table with values from a second table. See “Updating a Table,” p. 250, for details.

Tabulate

Displays descriptive statistics in tabular format. See “Tabulating Data,” p. 262, for details.

Missing Data Pattern

Creates a new data table showing the pattern that the missing data in your data table creates. In the original data table, missing character data is represented with a blank and missing numerical data is represented with a black dot. See “Viewing Patterns of Missing Data,” p. 73, for details.
Colors
Changes highlighted points in all scatterplots to the colors you select. See “Giving Rows a Color,” p. 134, for details.

Markers
Assigns a character from the JMP markers palette to replace the standard points in scatterplots and spinning plots. See “Adding Markers to Rows,” p. 135, for details.

Next Selected
Locates the first selected row after the current row and causes it to flash. See “Locating Next and Previously-Selected Rows,” p. 95, for details.

Previous Selected
Behaves the same as Next Selected but locates the first selected row before the current row and causes it to flash. See “Locating Next and Previously-Selected Rows,” p. 95, for details.

Row Selection
Reveals a submenu with selection options:
- **Go to Row**  A specific row number
- **Invert Row Selection**  All previously deselected rows
- **Select All Rows**  All rows in a data table
- **Select Excluded, Hidden, or Labeled**  A subset of rows based on the excluded, hidden, or labeled row states
- **Select Where**  A subset based on criteria you enter
- **Select Matching Cells**  Rows in the active data table with values that are similar to the highlighted row(s)
- **Select All Matching Cells**  Rows in all open data table with values that are similar to the highlighted row(s)
- **Select Randomly**  Randomly select rows

See “Selecting Rows and Columns,” p. 89, for details.

Clear Row States
Clears all active row states in the data table. All rows become included, visible, unlabeled, and show in plots as black dots. It does not affect row states saved in row state columns.

Color or Mark by Column
Lets you color or mark points in plots. See “Assigning Colors or Markers to Rows According to Column Values,” p. 135, for details.
**The Cols Menu**

You can access commands that affect selected columns from the **Cols** main menu, from the Columns panel to the left of the data table, or from the triangular icon in the upper-left corner of the data table.

**New Column**

Gives a window in which you can enter new column information, such as column name and characteristics. See “**Adding and Deleting Columns**,” p. 66, for details.

**Add Multiple Columns**

Displays a window that lets you add more than one column at a time to a table. See “**Adding and Deleting Columns**,” p. 66, for details.

**Go to**

Highlights a specific column in the table.

**Column Info**

Displays the window used by the **New Column** command, except there is no **Next** button for adding new columns. See “**Assigning Properties to Columns**,” p. 149, for details.
Preselect Role

Assigns a role to the selected column and saves the role with the data table. See “Giving Columns a Pre-selected Analysis Role,” p. 138, for details.

Formula

Displays the column's formula editor to create a formula that computes column values. See “Giving Columns a Formula to Compute Values,” p. 141, and “The Formula Editor,” p. 277, for details.

Validation

Lets you set up a column so that it only accepts certain values. See “Validating Column Data,” p. 143, for details.

Label/Unlabel

Is a toggle command that labels or identifies points on all scatterplots. See “Labeling Rows and Columns,” p. 132, for details.

Scroll Lock/Unlock

Locks the selected column in place so when you scroll horizontally, the column remains visible. See “Locking Columns in Place,” p. 137, for details.

Hide/Unhide

Is a toggle command that suppresses (hides) columns so they do not appear in plots and graphs. See “Hiding Rows and Columns,” p. 131, for details.

Exclude/Unexclude

Is a toggle command used to exclude selected columns from statistical analyses. See “Excluding Rows and Columns,” p. 129, for details.

Standardize Attributes

Lets you apply attributes (which include data type, modeling type, numeric format, etc.) and properties (which include formulas, lists, notes, list and range checks, etc.) to multiple columns. See “Standardizing Attributes and Properties Across Columns,” p. 161, for details.

Reorder Columns

Lets you move columns according to the selection you make from its submenu:

- **Move Selected Columns**  Moves the selected columns To first (left-most in the data table), To last (right-most in the data table), or After: (after a column you identify) in the Move Selected Columns window.

- **Original Order**  Returns the columns to the order they were in at the time the data table was last saved.
Reorder by Name  Arranges the columns (except for row state columns) from left to right in alphabetical order by column name.

Reorder By Data Type  Arranges the columns from left to right in alphabetical order by data type (Character, Numeric, Row State).

Reorder By Modeling Type  Arranges the columns from left to right in alphabetical order by modeling type (continuous, ordinal, nominal). Row State columns have no modeling type, and are shown last.

Reverse Order  Reverses the order of the data table columns.

If you mistakenly move one or more columns, use the Undo command in the Edit menu to restore the previous order.

Delete Columns

Removes selected columns from the data table. See “Adding and Deleting Columns,” p. 66, for details.

Recode

Lets you quickly recode data that is coded incorrectly (for example, contains typos or incorrect wording) so it adheres to a consistent format. See “Recoding Data,” p. 72, for details.

The DOE Menu

The Design of Experiments (DOE) menu in JMP is an environment for describing the factors, responses and other specifications needed to create a designed experiment and saving them in a JMP data table. The specific designs are described briefly here and covered in detail in the JMP Design of Experiments.

Custom Design

Provides the most flexibility of all design choices. With this option you can have continuous factors, categorical factors with any number of levels, interactions, mixture ingredients, and covariates (factors that have unchangeable fixed values). You can construct custom-designed models that include interaction terms and polynomial terms for continuous factors. You can also specify inequality constraints on the factors, and the number of experimental runs, which can be any number greater than or equal to the number of terms in the model. See the JMP Design of Experiments for details.

Screening Design

Allows you to specify continuous factors, and two- and three-level categorical factors. It creates a table of classical screening designs from which you can pick. See the JMP Design of Experiments for details.

Response Surface Design

Lets you define a number of continuous factors. This environment then offers a table of classical response surface designs from which to select. See the JMP Design of Experiments for details.
Full Factorial Design
You specify a set of continuous and categorical factors with arbitrary numbers of levels. JMP creates the design containing all possible combinations of those factors. See the *JMP Design of Experiments* for details.

Mixture Design
Lets you define a set of factors that are ingredients in a mixture. JMP creates a new window for choosing among several classical mixture design approaches, such as simplex, extreme vertices, and lattice. For the extreme vertices approach, you can supply a set of linear inequality constraints limiting the geometry of the mixture factor space. See the *JMP Design of Experiments* for details.

Space Filling Design
Creates a design by spreading the design points out to the maximum distance possible between two points. Prevents replicate points and spaces them uniformly. See the *JMP Design of Experiments* for details.

Nonlinear Design
Lets you create an optimal design for models that are nonlinear in the parameters. See the *JMP Design of Experiments* for details.

Taguchi Arrays
Guides you through the definition of signal and noise factors. The signal factors form the inner array and the noise factors form the outer array. The inner and outer array designs are the traditional Taguchi orthogonal arrays, such as L4, L8, L16, etc. See the *JMP Design of Experiments* for details.

Augment Design
Lets you modify existing designs. You can add center points, replicate the design a specified number of times, create a foldover design, and add runs to the design using a model with more terms than the original design. See the *JMP Design of Experiments* for a discussion of each type of design, with details and examples.

Sample Size and Power
Computes power, sample size, or the effect size you want to detect for a given alpha and error standard deviation. You supply two of these values and the sample size and power feature computes the third. If you supply only one of these values, the result is a plot of the other two. This feature is available for the single-sample, two-sample, and *k*-sample situations. See the *JMP Design of Experiments* for a discussion of prospective power analysis and examples.
The Analyze Menu

Each Analyze command launches a platform. A platform is an interactive window you use to analyze data, work with points on plots, and save results. The reports in a JMP analysis are organized hierarchically. Methods unfold that suit the context of your data. Many results appear automatically, and more are offered through drop-down menus.

Distribution

Choosing Distribution launches the Distribution platform, which describes a distribution of values with histograms and other graphical and textual reports:

- Continuous columns display a histogram and box plots. You can test the mean and standard deviation of the distribution and select from a variety of distribution fits. For continuous variables, capability analysis is available.
- Nominal or ordinal columns are shown with a histogram of relative frequency for each level of the ordinal or nominal variable. You have the option to view a mosaic (stacked) bar chart as well as options to test probabilities.


Fit Y by X

Fit Y by X studies the relationship of two variables. This platform shows plots with accompanying analyses for each pair of $x$ and $y$ variables. The kind of analysis done depends on the modeling types (continuous, nominal, or ordinal) of the $x$ and $y$ columns.

- If both $x$ and $y$ have continuous modeling types, Fit Y by X displays a scatterplot. Using options, you can explore various regression fits for the data and select the most suitable fit for further analysis. Each fit is accompanied by tables with supporting statistical analyses and parameter estimates.
- If $x$ is nominal or ordinal and $y$ is continuous, Fit Y by X plots the distribution of $y$-values for each discrete value of $x$. You can use options to see means diamonds and a box plot for each $x$-value and to compare group means with comparison circles. Accompanying text reports show a one-way analysis of variance table. Optionally, you can request nonparametric analyses, view multiple comparisons, and test homogeneity of variance.
- If $x$ has continuous values and $y$ has nominal or ordinal values, Fit Y by X performs a logistic regression and displays a family of logistic probability curves. Tables show the log likelihood analysis and parameter estimates for each curve.

Note: Logistic regression of ordinal columns is parameterized differently from logistic regression of nominal columns and sometimes produces different results.

- If both $x$ and $y$ are nominal or ordinal values, Fit Y by X shows a contingency table and a mosaic bar chart. Accompanying tables show statistical tests, frequency, proportion, and Chi-squared values for each cell. Optionally, you can request a correspondence analysis.

Individual chapters in the JMP Statistics and Graphics Guide describe each type of analysis given by the Fit Y by X command.
Matched Pairs

The Matched Pairs command handles bivariate data in the special situation where the two responses form a pair of measurements coming from the same experimental unit or subject. For example, a matched pair might be a before-and-after blood pressure measurement from the same subject. The responses are correlated, and the statistical method called the paired t-test takes that into account.

The Matched Pairs platform displays the data as a scatterplot of the difference between each pair ($y$) by the mean of each pair ($x$) and includes the standard paired t-test, which is equivalent to testing that the mean difference between the paired values is zero. See the *JMP Statistics and Graphics Guide* for details.

Fit Model

Fit Model lets you tailor an analysis using a model specific for your data. You select columns, assign roles, and build the model to fit in the Fit Model window.

Fit Model fits one or more $y$ variables to a model of $x$ variables. You select the kind of model appropriate to your data from the menu of fitting personalities given in the Fit Model window. The fitting personalities available depend on the kind of responses you select. The following list briefly describes the different fitting techniques:

- **Standard Least Squares**  
  Gives a least squares fit for a single continuous response, accompanied by leverage plots and an analysis of variance table.

- **Screening**  
  Produces an exploratory screening analysis for single or multiple $y$ columns with continuous values.

- **Stepwise**  
  Gives a stepwise regression for a single continuous or categorical $y$ and all types of effects.

- **Manova**  
  Performs a multivariate analysis of variance for multiple continuous response columns. Manova displays a window that lets you fit multivariate models interactively.

- **Loglinear Variance**  
  Is for a single continuous response and estimates parameters that optimize both a mean and a variance.

- **Nominal Logistic**  
  Fits a single nominal response with nominal regression by maximum likelihood.

- **Ordinal Logistic**  
  Fits a single ordinal response with ordinal cumulative logistic regression by maximum likelihood.

- **Proportional Hazard**  
  Performs a proportional hazard (Cox) model fit for survival analysis of censored data with a single continuous response.

- **Parametric Survival**  
  Tests the fit of an exponential, Weibull, or lognormal distribution.

Individual chapters in the *JMP Statistics and Graphics Guide* document each technique offered by the model fitting platform.

Modeling

The Modeling command has a submenu that launches these platforms:

- **Screening**  
  Helps select a model to fit to a two-level screening design by showing which effects are large. For details, see *JMP Statistics and Graphics Guide*. 

Nonlinear  Fits nonlinear models, which are models that are nonlinear in their parameters. You orchestrate the fitting process as a coordination of three important parts of JMP: the data table, the formula editor, and the Nonlinear platform.

You define the nonlinear prediction formula with the formula editor. Then select Nonlinear with the response variable as $y$ and the model column with its fitting formula in the $x$ role. You interact with the platform through the Nonlinear Fitting control panel using:

- Buttons to start, stop, and step through the fitting process, and to reset parameter values
- Fitting options to specify loss functions and computational methods
- A processing messages area
- A list of current and limit convergence criteria and step counts, current parameter estimates, and error sum of squares
- Options to specify the alpha level for confidence intervals and delta for numerical derivatives

The Nonlinear platform can show the model and the derivatives of the model with respect to each of its parameters, and the fitting solution reports. There are features that give confidence intervals on the parameters and plot the resulting function if it is of a single variable. You can also save the SSE values in a data table with a grid for plotting them. The chapter “Nonlinear Regression” of *JMP Statistics and Graphics Guide* describes the Nonlinear command in detail and gives examples.

Neural Net  Is a standard type of neural network. It is a particular case of a back propagation feed-forward multilayer-perception neural net. The neural network is a set of nonlinear equations that predict output variables ($y$) from input variables ($x$) in a flexible way using layers of linear regressions and S-shaped functions. JMP fits the neural net using standard nonlinear least-squares regression methods. See the *JMP Statistics and Graphics Guide* for details.

Gaussian Process  Models the relationship between a continuous response and one or more continuous predictors. These models are common in areas like computer simulation experiments, such as the output of finite element codes, and they often perfectly interpolate the data. Gaussian processes can deal with these no-error-term models.

The Gaussian Process platform fits a spatial correlation model to the data, where the correlation of the response between two observations decreases as the values of the independent variables become more distant.

The main purpose for using this platform is to obtain a prediction formula that can be used for further analysis and optimization. For details, see *JMP Statistics and Graphics Guide*.

Partition  Recursively partitions rows into groups according to $x$ values that associate with $y$ values. This partitioning creates a tree of partitions.

The factor columns ($x$) can be either continuous or categorical (nominal or ordinal). If an $x$ is continuous, then the splits (partitions) are created by a cutting value, which divides the sample into values below and values above this cutting value. If the $x$ is categorical, then the sample is divided into two groups of levels.

The response column ($y$) can be either continuous or categorical (nominal or ordinal). If $y$ is continuous, then the platform fits means, and creates splits which most significantly separate the means by the sums of squares due to the means differences. If $y$ is categorical, then the response rates become the fitted value. The most significant split can be determined by the largest likeli-
hood ratio Chi-squared statistic. In either case, the split is chosen to maximize the difference in the responses between the two. See the *JMP Statistics and Graphics Guide* for details.

**Time Series**  
Lets you explore, analyze, and forecast univariate time series. The launch window (role assignment window) requires that one or more continuous variables be assigned as the time series. Optionally, you can specify a time ID variable, which is used to label the time axis. If a time ID variable is specified it must be continuous, sorted ascending, and evenly spaced with no missing values.

The analysis begins with a plot of the points in the time series. In addition, the platform displays graphs of the autocorrelations and partial autocorrelations of the series. These indicate how and to what degree each point in the series is correlated with earlier values in the series. You can interactively add:

- Variograms—characterizations of process disturbances
- AR coefficients—autoregressive coefficients
- Spectral density plots—period and frequency plots with white noise tests

These graphs can be used to identify the type of model appropriate for describing and predicting (forecasting) the evolution of the time series. The model types include:

- ARIMA—autoregressive integrated moving-average, often called Box-Jenkins models
- Seasonal ARIMA—ARIMA models with a seasonal component
- Smoothing Model—several forms of exponential smoothing and Winters Method

See *JMP Statistics and Graphics Guide* for details.

**Categorical**  
Tabulates and summarizes categorical response data, including multiple response data, and calculates test statistics. It is designed to handle survey and other categorical response data, including multiple response data like defect records, side effects, and so on. For details, see *JMP Statistics and Graphics Guide*.

**Multivariate Methods**

The **Multivariate Methods** submenu has the commands shown above that launch the following platforms:

**Multivariate**  
Explores how multiple variables relate to each other and how points fit that relationship. This platform helps you see correlations between two or more response ($y$) variables, look for points that are outliers, and examine principal components to look for factors.

The multivariate platform appears showing correlations and a scatterplot matrix. Options give:

- Inverse, partial, nonparametric, and pairwise correlations with accompanying bar charts.
- A matrix of bivariate scatterplots with a plot for each pair of $y$-variables.
- A Mahalanobis distance outlier plot.
A jackknifed multivariate distance outlier plot where the distance for each point is calculated excluding the point itself. There are options with these plots to save the distance scores.

You can also request principal components, standardized principal components, rotation of a specified number of components, and factor analysis information.

The chapter “Correlations and Multivariate Techniques of JMP Statistics and Graphics Guide” describes the Multivariate command.

Cluster  Clusters rows of a JMP data table. Cluster can perform a hierarchical or a $k$-means clustering method. The hierarchical cluster platform displays results as a tree diagram of the clusters called a dendrogram followed by a plot of the distances between clusters. The dendrogram has a sliding cluster selector that lets you identify the rows in any size cluster. There are options to save the cluster number of each row. Hierarchical clustering uses these five clustering methods:

- Average linkage computes the distance between two clusters as the average distance between pairs of observations, one in each cluster.
- Centroid method computes the distance between two clusters as the squared Euclidean distance between their means.
- Ward’s minimum variance method (the default) uses the distance between two clusters as the ANOVA sum of squares between the two clusters added over all the variables.
- Single linkage uses the distance between two clusters that is the minimum distance between an observation in one cluster and an observation in the other cluster.
- Complete linkage uses the distance between two clusters that is the maximum distance between an observation in one cluster and an observation in the other cluster.

The $k$-means clustering approach finds disjoint clusters on the basis of Euclidean distances computed from one or more quantitative variables. Every observation belongs to only one cluster—the clusters do not form a tree structure as with hierarchical clustering. You specify the number of clusters you want.

The cluster platform also has options to do normal mixture clustering and SOMs (self-organizing maps).

The chapter “Clustering” of JMP Statistics and Graphics Guide describes the Cluster command in detail and shows clustering examples.

Principal Components Derives a small number of independent linear combinations (principal components) of a set of variables that capture as much of the variability in the original variables as possible. JMP also offers several types of orthogonal and oblique Factor-Analysis-Style rotations to help interpret the extracted components.

For details, see JMP Statistics and Graphics Guide.

Discriminant Provides a method of predicting the level of a one-way classification based on known values of the responses. The technique is based on how close a set of measurement variables are to the multivariate means of the levels being predicted. Optionally, you can do stepwise discriminate analysis. See the JMP Statistics and Graphics Guide for details.

PLS (Partial Least Squares) Fits models using the partial least squares (PLS) method that balances the two objectives of explaining response variation and explaining predictor variation. The PLS techniques work by extracting successive linear combinations of the predictors, called factors.
(also called components or latent vectors) that address one or both of these two goals. The PLS platform in JMP also enables you to select the number of extracted factors by cross validation, which involves fitting the model to part of the data and minimizing the prediction error for the unfitted part. See the *JMP Statistics and Graphics Guide* for details.

**Item Analysis**  Allows you to estimate parameters for test items using Item Response Theory (IRT). Also, choosing this allows you to access logistic 1PL, 2PL, and 3PL models.

**Survival and Reliability**

The **Survival and Reliability** submenu has a submenu with the following commands:

**Survival/Reliability**  Performs a univariate survival analysis using product-limit life table survival computations with estimation of Weibull, lognormal, and exponential parameters.

**Fit Parametric Survival**  Launches the Fit Model window, with the Parametric Survival fitting personality in effect. The analysis tests the fit of an exponential, Weibull, or lognormal distribution.

**Fit Proportional Hazards**  Launches the Fit Model window, with the Proportional Hazards fitting personality in effect. This regression analysis fits a Cox model.

**Recurrence Analysis**  Looks at the age of a system when it requires a repair. A system can have multiple repairs, each with its associated age, and is followed until it is no longer in service. A typical system might be some component of an engine or appliance.

**Note:** You can also use the Nonlinear platform to handle nonlinear models with loss functions for other parametric survival modeling. See the *JMP Statistics and Graphics Guide* for details.

---

**The Graph Menu**

**Graph** menu commands produce windows that contain specialized graphs or plots with supporting tables and statistics. For a detailed discussion of each **Graph** menu command, see the *JMP Statistics and Graphics Guide*.

**Chart**

The **Chart** command gives a chart for every numeric y variable specified where the y's are statistics to chart. The x values are always treated as discrete values. By default, a vertical bar chart appears, but there are options to show horizontal bar charts, line charts, step charts, needle charts, point charts, or pie charts.

You can specify up to two x variables for grouping on the chart itself. The first x is the group variable, and the second x is the level (subgroup) variable. If there is no x variable, then each row is a bar. The chapter “Bar, Line, and Pie Charts” of *JMP Statistics and Graphics Guide* describes the **Chart** command and shows examples.
Overlay Plot

The Overlay Plot command gives an overlay of a single numeric or categorical x column and all specified numeric y variables. The axis can have either a linear or a log scale. Optionally, the plots for each y can be shown separately, with or without a common x-axis.

By default, the values of the x variable are in ascending order, and the points are plotted in that order. You have the option of plotting the x values as they are encountered in the data table.

Note: For scatterplots of two variables with regression fitting options, use the Fit Y by X command instead of Overlay Plot.

The chapter “Overlay Plots” of JMP Statistics and Graphics Guide describes the Overlay Plot command in detail and shows examples of plotting data.

Scatterplot 3D

Scatterplot 3D produces a three-dimensional spinnable display of values from any three numeric columns in the active data table. It also produces an approximation to higher dimensions through principal components, standardized principal components, rotated components, and biplots. There are options to save principal component scores, standardized scores, and rotated scores.

The Scatterplot 3D platform also gives factor-analysis-style rotations of the principal components to form orthogonal combinations that correspond to directions of variable clusters in the space. The method used is called a varimax rotation, and is the same method that is traditionally used in factor analysis.

JMP Statistics and Graphics Guide describes the Spinning Plot command in detail and shows examples of plotting data and computing principal components.

Contour Plot

The Contour Plot command constructs a contour plot for one or more response variables, y, for the values of two x variables. Contour Plot assumes the x values lie in a rectangular coordinate system, but the observed points do not have to form a grid. Some contour plot options are:

- Show or hide data points
- Show or hide triangulation and boundary
- Specify and label levels
- Show a line contour or fill areas

The chapter “Contour Plot” of JMP Statistics and Graphics Guide describes the Contour Plot command in detail and shows examples of plotting data.

Bubble Plot

A Bubble Plot is a scatter plot which represents its points as circles (bubbles). Optionally the bubbles can be sized according to another column, colored by another column, aggregated across groups defined by one or more other columns, and dynamically indexed by a time column. With the opportunity to see up to five dimensions at once (x position, y position, size, color, and time), bubble plots can produce dramatic visualizations and make interesting discoveries easy.
Parallel Plot
The **Parallel Plot** command draws a parallel coordinate plot, which shows connected line segments representing each row of a data table.

Cell Plot
Produces a rectangular array of cells drawn with a one-to-one correspondence to data table values.

Tree Map
The **Tree Map** command displays tree maps, which can be thought of as bar charts that have been folded over in two dimensions, leaving no unused space. It is useful when there are a lot of categories. Tree maps are a graphical technique of observing patterns among groups that have many levels. They are especially useful in cases where histograms are ineffective.

Scatterplot Matrix
The **Scatterplot Matrix** command allows quick production of scatterplot matrices. These matrices are orderly collections of bivariate graphs, assembled so that comparisons among many variables can be conducted visually. In addition, the plots can be customized and decorated with other analytical quantities (like density ellipses) to allow for further analysis.

These matrices can be square, showing the same variables on both sides of the matrix or triangular, showing only unique pairs of variables in either a lower or upper triangular fashion. In addition, you can specify that different variables be shown on the sides and bottom of the matrix, giving maximum flexibility for comparisons.

For details, see *JMP Statistics and Graphics Guide*.

Ternary Plot
The **Ternary Plot** command constructs a plot using triangular coordinates. The ternary platform uses the same options as the contour platform for building and filling contours. In addition it a specialized crosshair tool that lets you read the triangular axes values.

The chapter “Ternary Plots” of *JMP Statistics and Graphics Guide* describes the **Ternary Plot** command in detail and shows ternary plot examples.

Diagram
The **Diagram** platform is used to construct *Ishikawa charts*, also called *fishbone charts*, or *cause-and-effect diagrams*. These charts are useful when organizing the sources (causes) of a problem (effect), perhaps for brainstorming, or as a preliminary analysis to identify variables in preparation for further experimentation. See *JMP Statistics and Graphics Guide* for examples of Ishikawa charts.
Control Chart

The Control Chart menu has a sub-menu that creates dynamic plots of sample subgroups as they are received and recorded. Control charts are a graphical analytic tool used for statistical quality improvement. Control charts can be broadly classified according to the type of data analyzed:

- Control charts for variables are used when the quality characteristic to be analyzed is measured on a continuous scale.
- Control charts for attributes are used when the quality characteristic is measured by counting the number of nonconformities (defects) in an item or by counting the number of nonconforming (defective) items in a sample.

The concepts underlying the control chart are that the natural variability in any process can be quantified with a set of control limits, and that variation exceeding these limits signals a special cause of variation. In industry, control charts are commonly used for studying the variation in output from a manufacturing process. They are typically used to distinguish variation due to special causes from variation due to common causes.

The control chart platform offers the following kinds of charts:

- Mean, range, and standard deviation
- Individual measurement and moving range (run chart, XBar Chart, and IR)
- $p$-chart, $np$-chart, $c$-chart, and $u$-chart
- UWMA and EWMA
- CUSUM
- Presummarized
- Levey-Jennings
- Multivariate Control Charts

The “Statistical Control Charts” of JMP Statistics and Graphics Guide describes the Control Charts command in detail.

Variability/Gage Chart

In a variability analysis, a number of parts assumed to be identical are taken from a production line. Each one is measured several times by a number of operators using different measuring instruments. You want to know the magnitudes of the variation due to operators, parts, and instruments. In the same way that a Shewhart control chart can identify processes which are going out of control over time, a variability chart can help identify operators, parts, and instruments.

Variability or Continuous Gage charts are for responses whose values can be measured on a continuous scale. For example, the width of a washer might be measured as 2.3 mm.

Attribute Gage charts are for responses whose values are binary or categorical. For example, a circuit might be measured as pass/fail. Because different reports are generated on the raters, raters each need to be in different columns. The chapter “Variability Charts” of JMP Statistics and Graphics Guide describes the Variability/Gage Chart command in detail.
Pareto Plot

The Pareto Plot command creates a bar chart (Pareto chart) that displays the severity (frequency) of problems in a quality-related process or operation. Pareto plots compare quality-related measures or counts in a process or operation. The defining characteristic of Pareto plots is that the bars are in descending order of values, which visually emphasizes the most important measures or frequencies.

Pareto Plot uses a single $y$ variable, called a process variable, and gives:

- A simple Pareto plot when you do not specify an $x$ (classification) variable
- A one-way comparative Pareto plot when you specify a single $x$ variable
- A two-way comparative plot when there are two $x$ variables

The Pareto Plot command does not distinguish between numeric and character variables or between modeling types. All values are treated as discrete, and bars represent either counts or percentages.

The chapter “Pareto Plots” of *JMP Statistics and Graphics Guide* describes the Pareto Plot command in detail.

Capability

Capability analysis, used in quality control, measures the conformance of a process to given specification limits. Using these limits, you can compare a current process to specific tolerances and maintain consistency in production. Graphical tools such as the goalpost plot and box plot give you quick visual ways of observing within-spec behaviors.

For details, see *JMP Statistics and Graphics Guide*.

Profiler

The Profiler is available for tables with columns whose values are computed from model prediction formulas. Usually, a profiler plot results when you do a Standard Least Squares analysis and then request it. However, if you save the prediction equation from the analysis, you can access the prediction profile later from the Graph menu and look at the model using the response column with the saved prediction formula.

The prediction profiler displays prediction traces for each $x$ variable. A prediction trace is the predicted response as one variable is changed while the others are held constant at the current values. The prediction profiler is a way of changing one variable at a time and looking at the effect on the predicted response. You interact with the prediction profiler; as you vary the value of an $x$ variable, the prediction profiler recomputes:

- The low and high values show on the $x$-axis for each factor, showing its current value.
- The current predicted value of each $y$ variable for the current values of the $x$ variables.
- Lines and markers within the prediction plots show how the predicted value changes when you change the current value of an individual $x$ variable and include the 95% confidence interval for the predicted values shown by error bars above and below each marker.

Prediction profiles are useful in multiple-response models to help judge which factor values can optimize a complex set of criteria. See the *JMP Statistics and Graphics Guide* for details.
The Main Menu

Appendix B

The Tools Menu

The Contour Profiler command works the same as the Profiler command. It is usually accessed from the Fit Model platform when a model has multiple response. However, if you then save the prediction formulas for the responses, you can access the Contour Profiler at a later time from the Graph menu and specify the columns with the prediction equations as the response columns. See JMP Statistics and Graphics Guide for examples of the Profiler and the Contour Profiler.

Surface Plot

The Surface Plot command plots surfaces and points in three dimensions based on formulas or data. The JMP Statistics and Graphics Guide describes the Surface Plot in detail and shows examples.

Custom Profiler

The Custom Profiler command is available for tables with columns whose values are computed from model prediction formulas. The Custom Profiler is useful in multiple-response models to help judge which factor values can optimize a complex set of criteria. The JMP Statistics and Graphics Guide describes the Custom Profiler in detail and shows examples.

The Tools Menu

The Tools menu are palettes of special tools whose form the cursor can take. There are general tools and specific graphics tools that operate on points in plots. The default tool is the arrow. Click a tool in the Tools menu to activate it.

Arrow

The cursor is the standard arrow when it is in the panels area to the left of the data table, in the triangular rows and columns area in the upper-left corner of the data grid, or on the title bar of the tables panel. Also, click and drag with the arrow to select points in plots. Outside of plots, click and drag to draw a temporary line. When you release, the line disappears.

Help

The question mark icon accesses the JMP help system. Select the help tool and then click a place in a data table or report on which you need assistance. Context-sensitive help tells about the items located near the location of your click.

Selection

Use the large plus (selection tool) to select rows and columns in the data table or areas of a report. When you click, the row or column is highlighted. Click and drag to highlight multiple rows and columns, and Ctrl-click (Command-click on the Macintosh) to select discontinuous rows or columns. Clicking near the edge of the report highlights the entire report. To deselect, click a second time in a highlighted area.
Scroller

Drag the scroller tool to scroll reports up or down and show only the results you want to see. The scroller is a precise way to perform the same function as the vertical and horizontal scroll bars. The scroller reverts to the arrow after one click. Press and hold the Shift key while selecting the scroller to have the cursor continue to have the scroller form after multiple clicks.

Grabber

The hand (grabber) tool is for direct manipulation of plots, charts, axes, and formula components. Use the hand tool to change the displayed range of axis values. On a y-axis, dragging \( \text{scrolls the } y\text{-axis; dragging } \text{or } \text{ scales the } y\text{-axis; dragging } \text{or } \text{scales the } x\text{-axis.}

Brush

The brush tool is for highlighting an area of points in plots. When you click, a rectangle appears. Move the rectangle over points to highlight them. Shift-click to extend the selection. Alt-click (Option-click on the Macintosh and Alt-Shift-click on Linux) to change the size of the selection rectangle and also extend the selection. See “Selecting a Rectangular Area of Points,” p. 184, for details.

Lasso

The lasso tool lets you highlight an irregular area of points in plots. Drag the lasso around any set of points. When you release the lasso, it automatically closes and highlights the points within the enclosed area. See “Selecting an Irregular-Shaped Area of Points,” p. 185, for details.

Magnifier

The magnifier (zoom) tool lets you automatically zoom in on any area of a plot. When you click the magnifier, the point or area where you click becomes the center of a new view of the data. Alt-click (Option-click on the Macintosh) to restore the original plot. On a ternary plot, drag the magnifier tool to zoom the triangular axes.

Crosshairs

The crosshairs tool is a movable set of axes used to measure points and distances in graphs. The values where the crosshairs intersect the vertical and horizontal axis appear automatically as you drag the crosshairs within a plot. On a ternary plot, this tool displays triangular crosshair lines.

Annotate

The annotate tool adds editable text notes to a JMP report, journal, or layout window. See “Adding an Annotative Note,” p. 210, for details. The annotate tool reverts to the arrow after one click. Press and hold the Shift key while selecting the annotate tool to have the cursor continue to have the annotate form after multiple clicks.
**Line, Polygon, and Simple Shape**

The line, polygon, and simple shape tools add editable lines, polygons, and simple shapes (ovals or rectangles) to a JMP report, journal, or layout window. See “Adding Shapes,” p. 212, for details. The shape tools revert to the arrow after one click. Press and hold the Shift key while selecting the shape tool to have the cursor continue to have the shape form after multiple clicks.

---

**The View Menu**

The **View** menu lets you view or hide certain windows or panes.

---

**On Microsoft Windows and Linux**

On Windows and Linux, you find these commands in the **View** menu:

**JMP Starter**

The **JMP Starter** command opens and closes the JMP Starter. You can also close the JMP Starter with **File > Close** when it is the active window or by clicking its close box. On the Macintosh, the **JMP Starter** command is located in the **Window** menu. For more details, see “The JMP Starter Window,” p. 10.

**Window List (Windows only)**

The **Window List** command displays a pane at the left side of the JMP window that lists the name of each window you have open in JMP. Right-click the title of a window in the list to close, rename, redraw, or hide it. For more details, see “The Window List (Windows Only),” p. 322.

**File System (Windows and Linux only)**

The **File System** command displays a pane at the left side of the JMP window that shows your PC’s file system. You can drag and drop files from here into a project.

**Projects (Windows and Linux only)**

The **File System** command displays a pane at the left side of the JMP window that lists all open projects.

**Log**

The **Log** command displays a pane at the bottom of the JMP window that monitors JSL statements (JSL scripts) as they execute. The log window is editable. For example, you can use the log to locate errors in the script, correct the code, copy it and paste it back into the script window, submit the corrected script. To detach or re-attach the log window to the bottom of the screen, right-click it and select **Float Log Window** or **Dock Log Window**.
Show Toolbars

The Show Toolbars command displays a window that lists all available toolbars with a checkbox to show or hide them. On Windows, Edit > Customize > Toolbars lets you change and rearrange the tool icons that show on each toolbar. See “Personalizing Toolbars (Windows and Linux),” p. 343, for a complete discussion of customizing the toolbars on Windows.

Status Bar

The Status Bar command hides and shows the status bar at the bottom window edge.

On Macintosh

On the Macintosh, you find these commands in the View menu:

New Data View

The New Data View command displays a duplicate view of an open data table. The new view is linked to the original view and all corresponding reports. Changes made to a new view reflect on the original view when it is made active. On Windows, the New Data View command is located in the Window menu.

Redraw Window

The Redraw Window command redraws the active window. It is useful for cleaning up both data table views and graphs that have accumulated stray imperfections resulting from high-speed, dynamic handling of windows.

Make Text Bigger, Make Text Smaller

The Make Text Bigger and Make Text Smaller commands increase and decreases the size of text in JMP.

The Window Menu

The Window menu helps you organize the windows produced during a JMP session.

On Microsoft Windows and Linux

On Windows and Linux, you find these commands in the Window menu:

New Data View

The New Data View command displays a duplicate view of an open data table. The new view is linked to the original view and all corresponding reports. Changes made to a new view reflect on the original
view when it is made active. On the Macintosh, the New Data View command is located in the View menu.

**Close All Data Tables (Windows Only)**

On Windows, the Close All Data Tables command closes all data tables when the active window is a data table. If the JMP Starter is the active window, this command is Close Starter. If a report is the active window, this command is Close All Reports. If a script is the active window, this command is Close All Scripts.

**Close All**

The Close All command closes all open windows.

**Arrange (Windows Only)**

On Windows, the Arrange command helps you organize the open windows within JMP. Choose from one of the submenu items:

- **Cascade**  Arranges open windows so that the title bar of each window is visible.
- **Tile**  Arranges open windows side by side so all of them are visible. Tile Horizontally stacks the windows and Tile Vertically arranges the windows side by side.
- **Arrange Icons**  Arranges minimized icons into row(s) at the bottom of the JMP window.

**Cascade (Linux Only)**

The Cascade command arranges open windows so that the title bar of each window is visible. On Windows, this command is found under Window > Arrange > Cascade.

**Tile (Linux Only)**

The Tile arranges open windows side by side so all of them are visible. On Windows, this command is found under Window > Arrange > Tile.

**Redraw**

The Redraw command redraws the active window. It is useful for cleaning up both data table views and graphs that have accumulated stray imperfections resulting from high-speed, dynamic handling of windows. On the Macintosh, the Redraw command is located in the View menu.

**Font Sizes (Windows and Linux Only)**

On Windows and Linux, the Font Sizes command gives you a quick way to change the font size JMP uses. Choose from one of the submenu items:

- **Increase Font Size**  Increases the font size. Select again to increase the font size again.
- **Decrease Font Size**  Decreases the font size. Select again to decrease the font size again.
Move to Back

The **Move To Back** command moves the active window behind all other windows generated by the current JMP session, leaving the next window in the sequence showing.

Set Title

The **Set Title** command lets you change the name of any active JMP window. This is useful if you generate multiple output reports and need to distinguish among them during the JMP session. For options on changing the title of data tables, see "Changing Table Names," p. 82. For options on changing the title of JMP output reports, see "Renaming a Report," p. 172.

Hide

The **Hide** command suppresses the display of the active window but does not close it. On Windows, hidden windows do not appear in the list of open JMP windows found on the bottom of the **Window** menu.

Unhide (Windows Only)

To reshow a hidden window, select its name from the list displayed by the **Unhide** command. Choosing **All** from the **Unhide** menu displays all JMP windows.

List All

The **List All** command allows you to select the window you want to be the active window. This command is useful if you have a large number of open windows, where the windows might be data tables, reports, journals, and layouts. On Microsoft Windows, hidden windows do not appear in the list. The last section of the **Window** menu lists all available windows. On Windows, windows that are hidden are not displayed in this list. Bring any window to the front by clicking on it in this list.

On Macintosh

On the Macintosh, you find these commands in the **Window** menu:

Minimize

The **Minimize** command shrinks the window into an icon on the dock. To unroll or expand the window, select **Minimize** again.

Zoom

The **Zoom** command enlarges the window to use the available monitor screen. To reduce the window size, select **Zoom** again.

Bring All to Front

The **Bring All to Front** command moves all JMP windows to the front of the screen.
Set Report Title

The Set Title command lets you change the name of any active JMP window. This is useful if you generate multiple output reports and need to distinguish among them during the JMP session.

JMP Starter

The JMP Starter command opens and closes the JMP Starter. You can also close the JMP Starter with File > Close when it is the active window or by clicking its close box.

The last section of the Window menu lists all unhidden available windows. Bring any window to the front by clicking on it in this list.

Log

The Log command displays a pane at the bottom of the JMP window that monitors JSL statements (JSL scripts) as they execute. The log window is editable. For example, you can use the log to locate errors in the script, correct the code, copy it and paste it back into the script window, submit the corrected script.

The Help Menu

The Help menu provides links to information about JMP, from the online help system to JMP tutorials.

Contents, Search, and Index (Windows and Linux) and JMP Help (Macintosh)

Access the JMP help system. The help system provides navigable online JMP documentation.

Tip of the Day


Indexes

Displays the following sources for your reference:

Statistics Index  Accesses references that give definitions of statistical terms. Once you are in the Statistics Index window, click the Topic Help button to go to the place in the online help that describes the highlighted topic. Click the Script button to view or hide the script associated with the highlighted topic. Click Launch to run the script that corresponds to the item you have highlighted in the list. Click Example to view an example of the highlighted topic.

JSL Operators Index  Presents a list of JSL operators, such as Sin, Cos, Sqrt, and Abbrev Date that you would use when writing JSL. Highlight an operator name to see a description of the operator appears in the window on the right. Click the Topic Help button to locate the topic in the online help.
**Object Scripting Index**  Presents a list of JSL objects. These are scriptable JSL building blocks. Highlight an object name and messages the object recognizes appear in the window on the right.

**DisplayBox Scripting Index**  Presents a list of the elements that make up a JMP report. These elements are the JSL building blocks with which you build output. Highlight a Display Box and available messages for each object appear in the window on the right.

**Tutorials**
Contains a submenu that open JMP tutorials.

**Books**
Opens .pdf files of the JMP documentation.

**Sample Data Directory**
Opens the directory where sample data files are stored.

**JMP.com and JMP User Community**
Open the default browser and takes you to the JMP web site at www.jmp.com and to JMP user forums online.

**About JMP**
Displays a panel that shows the release, the copyright, the operating system, and the owner of the copy of JMP that is running.

*Note:* On Macintosh, About JMP is on the JMP menu.

---

**The Layout Menu**

If you want to copy a JMP window to a separate window and manipulate pieces of it, you would use the Layout command. See “Saving Using the Layout Command,” p. 116, for details.

**Group**
The Group command combines selected objects into a single object or group.

**Ungroup**
The Layout window begins with all report elements grouped into a single object. When you click on the layout, the group is highlighted. The Ungroup command ungroups selected objects.

The first time you use Ungroup, the title of the analysis becomes an object, and is the outermost outline level of the analysis. The remaining nesting levels become an object. You can continue to select any portion of the layout window and use the Ungroup command repetitively to ungroup the analysis into its smallest elements.
Align

The Align command aligns selected objects according to the type of alignment you select from the Align submenu. You can select as many objects as you want for alignment. However, objects overlap if they are positioned on the layout window in such a way as to conflict with the alignment request.

Clean Up

Layout objects can be moved to any position in the Layout window, which means objects can overlap. When objects overlap, the front-most object hides some or all of the objects beneath it. The Clean Up command moves selected objects such that they are in separate positions in the layout window, and are all showing.

Move Forward, Move To Front, Move Backward, Move To Back

The Move Forward and Move Backward commands change the layer level of the selected objects forward or backward one layer at a time. Move to Front moves the selected objects to lay on top of all other objects. Move to Back moves the selected objects to lie beneath all other objects. Note that when objects are overlaid, the front most objects can hide objects beneath them.
You can add functions to a formula. All of these functions are organized in the function browser, which groups collections of functions and features in lists organized both alphabetically (Functions (all)) and by topic (Functions (grouped)), as shown below.

For instructions on how to create a formula that contains a function, see “Creating a Formula,” p. 279. This chapter gives a description of functions in the formula editor.
Row Functions

Adding a row function to a formula lets you reference specific rows or cells within specific rows. See the *JMP Scripting Guide* for details on syntax.

**Sequence**

Produces an arithmetic sequence of numbers across the rows in a data table, where the start value, ending limit, and increment are specified as arguments.

**Count**

Creates a list of values beginning with the *from* value and ending with the *to* value. The number of *steps* specifies the number of values in the list between and including the *from* and *to* values. Each value determined by the first three arguments of the count function occurs consecutively the number of times you specify with the *times* argument. When the *to* value is reached, *Count* starts over at the *from* value.

Optionally, you can add the *times* argument with the insert button ( ) on the keyboard. This argument is one by default, but repeats the count process as many times as you specify, as illustrated by the Count4 column in the data table in Figure C.1. To add any argument to the *Count* function, highlight the argument preceding the one you want to enter and either type a comma or use the insert button ( ) on the formula editor keypad.

The columns in the data table below result from the following formulas:

- Count (1, 9, 2) gives Count 1
- Count (1, 9, 3) gives Count 2
- Count (1, 9, 9) gives Count 3
- Count (1, 9, 3, 3) gives Count 4

**Figure C.1 Example of the Count Function**

<table>
<thead>
<tr>
<th></th>
<th>count1</th>
<th>count2</th>
<th>count3</th>
<th>count4</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>9</td>
<td>5</td>
<td>2</td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>1</td>
<td>9</td>
<td>3</td>
</tr>
<tr>
<td>4</td>
<td>4</td>
<td>9</td>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td>5</td>
<td>5</td>
<td>1</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td>6</td>
<td>6</td>
<td>9</td>
<td>9</td>
<td>6</td>
</tr>
<tr>
<td>7</td>
<td>7</td>
<td>1</td>
<td>1</td>
<td>7</td>
</tr>
<tr>
<td>8</td>
<td>8</td>
<td>9</td>
<td>5</td>
<td>8</td>
</tr>
<tr>
<td>9</td>
<td>9</td>
<td>1</td>
<td>9</td>
<td>9</td>
</tr>
</tbody>
</table>

The *Count* function is useful for generating a column of grid values. For example, the following formulas create a square grid of increment NRow() (the *Row* function that gives the total number of rows in the data table) and axes that range from –5 to 5:

- Count (-5, 5, Root(NRow()))
- Count (-5, 5, Root(NRow(), Root(NRow())))
Lag

Returns the value of the first argument in the row defined by the current row less the second argument. The default Lag is one, which you can change to any number. The value returned for any lag that identifies a row number less than one is missing. Note that Lag(X, n) gives the same result as the subscripted notation, XRow( )–n.

Dif

Returns the difference between the value of the first argument in the current row and its value in the row defined by the current row less the second argument. The default Dif is one, which you can change to any number. Note that Dif(X, n) gives the same result as XRow()–XRow()–n, or as XRow()–Lag(X, n).

Subscript

Enables you to use a column’s value from a row other than the current row. After choosing Subscript from the list, enter a numeric expression into the subscript argument. Subscripts that evaluate to nonexistent row numbers produce missing values. Column names with no subscript refers to the current row. To remove a subscript, select the subscript and delete it. Then delete the missing box.

The formula CountRow() – CountRow()–1, where Row() is the row number as described below, uses subscripts to calculate the difference between each pair of values from the column named Count. This result is the same as that given by the Dif() function. When Row() is 1, the computation produces a missing value.

The formula below calculates a column called Fib, which contains the terms of the Fibonacci series (each value is the sum of the two preceding values in the calculated column).

\[
\text{If } \begin{cases} \text{Row()} \leq 2 & \Rightarrow 1 \\ \text{else} & \Rightarrow \text{Fib}_{\text{Row()}-1} + \text{Fib}_{\text{Row()}-2} \end{cases}
\]

It shows the use of subscripts to do recursive calculations. A recursive formula includes the name of the calculated column, subscripted such that it references only previously evaluated rows (rows 1 through \((i-1)\)). The calculation of the Fibonacci series shown includes a conditional expression and a comparison. See the sections “Using Conditional Clauses,” p. 292, and “Comparing Values,” p. 291, for details.

Row

Returns the current row number when an expression is evaluated for that row. You can use Row() in any expression, including column name subscripts. The default subscript of a column name is Row() unless otherwise specified.

NRow

Returns the total number of rows in the active data table.
Numeric Functions

You can create a formula that contains arithmetic operators that are commonly used in formulas. See the JMP Scripting Guide for details on syntax.

Abs

Returns a positive number of the same magnitude as the value of its argument. For example, |5| and |–5| both result in 5.

Modulo

Returns the remainder when the second argument is divided into the first. For example, Modulo(6, 5) results in 1.

Ceiling

Returns the smallest integer greater than or equal to its argument. For example, Ceiling(2.3) results in 3, while Ceiling(–2.3) results in –2.

Floor

Returns the largest integer less than or equal to its argument. For example, Floor(2.7) results in 2, but Floor(–0.5) results in –1.

Round

Rounds the first argument to the number of decimal places given by the second argument. For example, Round(3.554, 2) rounds to 3.55 and Round(3.555, 2) rounds to 3.56.

Transcendental Functions

You can create a formula that supports transcendental functions, such as logarithmic functions for any base, functions for combinatorial calculations, the Beta function, and several gamma functions. See the JMP Scripting Guide for details on syntax.

Exp

Raises e to the power you specify. Thus, Exp(1) = e.

Log and Log10

Calculates the natural logarithm (base e). To change the default base, highlight the argument and type a comma or click the insert key on the keypad. The base appears and is editable. The Log argument can be any numeric expressions. The expression Log(e) evaluates as 1, and Log2(32) is 5. The Log10 function calculates the logarithm of base 10 only.
Squish \( \text{Squish}(x) \)

Is an efficient computation of the function \( 1 / (1+e^{-x}) \), where \( x \) is any numeric column, variable, or expression.

Root \( \sqrt[2]{\text{number}} \)

Calculates the root of its argument as specified by the index. Root initially shows with an index of 2. To change the index, highlight the index argument and enter the value you want.

Factorial \( \text{Factorial}(x) \)

Returns the product of all numbers 1 through the argument you specify. For example, \( \text{Factorial}(5) \) evaluates as 120.

\( \text{NChooseK}(n, k) \)

Returns the number of \( n \) things taken \( k \) at a time (\( n \) select \( k \)) and is computed in the standard way using factorials, as \( n! / (k!(n - k)!) \). For example, \( \text{NChooseK}(5,2) \) evaluates as 10.

\( \text{Beta}(m, n) \)

Adds the two parameter Beta function and is written terms of the Gamma function as:

\[
B(m, n) = \frac{\Gamma(m)\Gamma(n)}{\Gamma(m+n)}
\]

\( \text{Gamma}(i) \)

Adds the Gamma function, denoted \( \Gamma(i) \), and is defined as:

\[
\Gamma(i) = \int_{0}^{\infty} (x^{i-1})(e^{-x})dx
\]

In JMP, this formula computes gamma for each row using the current row number as \( i \). The current row number is used in the formula for the gamma distribution and other probability distributions. (Gamma with a single argument is the same as \( \text{Gamma}(x, \infty) \). The optional second argument changes the upper integer from infinity to the value you enter.) Other interesting gamma function relationships are

- for any \( \alpha > 1 \), \( \Gamma(\alpha) = (\alpha-1) \cdot \Gamma(\alpha-1) \)
- for any positive integer, \( n \), \( \Gamma(n-1) = n! \) factorial, denoted \( n! \)
- \( \Gamma(0.5) = \) the square root of \( \pi \)

\( \text{LGamma}(\text{Gamma}) \)

Is the natural log of the result of the gamma function evaluation. You get the same result using the Log (natural log) function with the Gamma function. However, the LGamma function computes more efficiently than do the Log (natural log) and the Gamma functions together. \( \text{NChooseK} \) is imple-
mented using `LGamma` functions. The result is not always an exact integer. If the result is close to an integer, it is rounded up using the `Floor` function.

**Arrhenius** \( \text{Arrhenius}(\square) \)

Applies the Arrhenius transformation to the argument. The Arrhenius transformation is

\[
T^* = \frac{11605}{T + 273.15}
\]

**ArrheniusInv** \( \text{ArrheniusInv}(\square) \)

Applies the inverse Arrhenius transformation.

\[
T^* = \frac{11605}{T - 273.15}
\]

**Logit** \( \text{Logit}(\square) \)

Applies the logit transformation to the argument using

\[
\text{logit}(x) = \log \frac{x}{1-x}
\]

**ScheffeCubic** \( \square \)

Is used in fitting certain models. **Scheffe Cubic** \((X1, X2)\) is equivalent to \(X1 \times X2 \times (X1 - X2)\).

---

### Trigonometric Functions

You can create a formula that supports transcendental functions, such as logarithmic functions for any base, functions for combinatorial calculations, the **Beta** function, and several gamma functions. See the **JMP Scripting Guide** for details on syntax.

**Sine, Cosine, Tangent** \( \text{Sine}(\square) \text{ Cosine}(\square) \text{ Tangent}(\square) \)

The **Sine** and **Cosine** functions calculate the sine and cosine of their respective arguments given in radians. For example, the expression **Sine(0)** evaluates as 0, and **Cosine(0)** evaluates as 1. The tangent function calculates the tangent of an argument given in radians. The expression **Tan(.25)** evaluates as 0.255342.

**ArcSine, ArcCosine, ArcTangent** \( \text{ArcSine}(\square) \text{ ArcCosine}(\square) \text{ ArcTangent}(\square) \)

The **ArcSine** and **ArcCosine** functions return the inverse sine and inverse cosine of their respective arguments. The returned value is measured in radians. For example, both expressions **ArcSine(1)** and **ArcCosine(0)** evaluate as 1.57080. The **ArcTangent** function returns the inverse tangent of its argument. The returned value is measured in radians. The expression **ArcTangent(0.5)** evaluates as 0.46364.
The SinH and CosH functions return the hyperbolic sine and hyperbolic cosine of their respective arguments. The expression SinH(1) evaluates as 1.175201, and CosH(0) evaluates as 1.0. The TanH function returns the hyperbolic tangent of its argument. The expression TanH(1) evaluates as 0.761594.

The ArcSinH and ArcCosH functions return the inverse hyperbolic sine and inverse hyperbolic cosine of their respective arguments. The expression ArcSinH(1) evaluates as 0.881374, and ArcCosH(1) is 0. The ArcTanH function returns the inverse hyperbolic tangent of its argument. The expression ArcTanH(0.5) evaluates as 0.549306.

Character Functions

You can create a formula that accepts character arguments or returns character strings and converts the data type of a value from numeric to character, or character to numeric. See the JMP Scripting Guide for details on syntax.

Char

Produces a character string that corresponds to the digits in its numeric argument. For example, Char(1.123) evaluates as 1.123. See Table 3.25 “Functions to store or evaluate expressions,” p. 118 in the JMP Scripting Guide, for details.

Concat, Concat Items

Concatenates character strings to produce a new string with the function’s second character argument appended to the first. For example, "Dr." || " " || name produces a new string consisting of the title Dr. followed by a space and the contents of the name string.

Concat Items converts a list of string expressions into one string, with each item separated by a delimiter. The delimiter is a blank, if unspecified.

Contains

Returns the numeric position within the first argument of the first instance of the second argument, if it exists. The second argument can contain one or more characters. If the second argument does not exist, Contains returns a zero. For example, Contains("Veronica Layman", "ay") evaluates as 11. Contains("Lillie Layman", "L") evaluates as 1. The third argument is optional and is a numeric value that specifies the starting position. If offset is negative, Contains searches backward from offset from the end of the string.

Munger

Computes new character strings from existing strings by inserting or deleting characters. It can also produce substrings, calculate indices, and perform other tasks depending on how you specify its arguments. The Munger function treats uppercase and lowercase letters as different characters.
Text is a character expression. Munger applies the other three arguments to this string to compute a result.

Offset is a numeric expression indicating the starting position to search in the string. If Offset is greater than the position of the first instance of the find argument, the first instance is disregarded. If Offset is greater than the search string’s length, the string’s length is the offset.

Find/Length is a character or numeric expression. Use a character string as search criterion, or use a positive integer to return that number of consecutive characters starting from the Offset position. If you specify a negative integer as the Length value, Munger returns all characters from the Offset through to the end of the string.

Replace (optional argument) can be a string or unspecified. If it is a string and the Find/Offset value is numeric, Munger replaces the search criterion with the Replace string to form the result. If the Find/Offset value is numeric and no string is specified, Munger calculates a substring. If the Find/Length value is a character string, Munger always returns the numeric offset, disregarding the Replace value if it exists. To insert the Replace argument, click any argument in the Munger function and then click the insert button. Use the delete key on your keyboard or the delete button ( ) on the formula editor keypad to remove the Replace argument.

Lowercase, Uppercase

The Lowercase function converts any uppercase character found in its argument to the equivalent lowercase character. For example, Lowercase("VERONICA LAYMAN") evaluates as veronica layman. The Uppercase function converts any lowercase character found in its argument to the equivalent uppercase character. For example, Uppercase("Veronica Layman") evaluates as VERONICA LAYMAN.

Length

Calculates the length of its argument. For example, Length("Veronica") evaluates as 8. If the argument is

- a string, length returns the number of characters;
- a list, length returns the number of items in the list;
- a blob (binary object), the number of bytes.

Num

Produces a numeric value that corresponds to its character string argument when the character string consists of numbers only. If a character string contains a non-numeric value, the result is a missing value. For example, Num("1.123") evaluates as 1.123.

Substr

Extracts the characters that are the portion of the first argument beginning at the position given by the second argument and ending based on the number of characters specified in the third argument. The first argument can be either a character column or a literal value. The starting argument and the length argument can be numbers of expressions that evaluate to numbers. For example, to show the first name only, Substr("Veronica Layman", 10, 6) starts at position 11 and reads through position 16, which yields Layman.

If start is negative, Substr searches backward from start from the end of the string. If length is negative or absent, Substr returns a string that begins with start and continues to the end of s.
**Substr** may also be used with lists.

**Trim**  
Produces a new character string from its argument, removing any trailing blanks. For example, \texttt{Trim("john \text{\ })\text{\}} evaluates as john.

**Word**  
Extracts the \textit{$n$}th word from a character string. One or more spaces define where each word begins and ends unless the optional \texttt{delimiters} argument is specified. For example, \texttt{Word(2, "Veronica Layman")} returns Layman.

To insert the \texttt{delimiters} argument, click on any argument in the **Word** function and then click on the insert button on the keypad. Use the delete key on your keyboard or the delete button on the formula editor keypad to remove the \texttt{delimiters} argument. If you do not specify a delimiter, whitespace is used as the delimiter. If you define the delimiter as an empty string, each character is treated as a separate word.

Most special characters act as single delimiters. You can enter any character or set of characters to act as a word delimiter. For example, to extract the last name in the following example, use a comma and blank together as the delimiting characters and ask for the first word. \texttt{Word(1, "Layman, Veronica", ", ")} returns the word Layman.

**Left, Right**  
Returns a substring of the left-most or right-most \textit{$n$} characters of the string \textit{text}, respectively. Both functions also work with lists.

**Starts With, Ends With**  
Returns 1 if \textit{whole} begins or ends with \textit{part}, respectively. Returns 0 otherwise. Both functions also work with lists.

**Item**  
Is different than the **Word** function because of the way it treats word delimiters. If a delimiter is found multiple times, or you enter a delimiter with multiple characters, the **Word** function treats them as a single delimiter. The **Item** function uses each delimiter to define a new word position. To compare, suppose a name is of the form lastname, firstname. The delimiter is a comma followed by a blank, such as: \texttt{Item(2, "Layman, Veronica", ", ")} \texttt{Word(2, "Layman, Veronica", ", ")}

The **Item** function returns a missing value because it treats the comma and blank separately and finds nothing between them. The **Word** function treats the comma and blank as a single delimiter and finds Veronica as the second word.

If you do not specify a delimiter, whitespace is used as the delimiter. If you define the delimiter as an empty string, each character is treated as a separate item.

**Char to Hex, Hex, Hex to Char, Hex to Number**  
Converts between Hex and other formats.
**Hex** returns the hex representation of its argument. If the argument is character (in quotes), then the result is a character string twice as long containing the hexadecimal codes for the character values. For example, `Hex("A")` returns the string 41.

If the argument is numeric, the Hex function returns an 8-hex-character representation of the integer returned. For example, `Hex(12)` returns the string 0000000C (Macintosh) or 0C000000 (Windows and Linux).

**Hex to Char** converts hexadecimals to characters. The resulting character string may not be valid display characters. All the characters must be in pairs, in the ranges 0-9,A-Z, and a-z. Blanks and commas are allowed and skipped.

**Char to Hex** converts characters to hexadecimals.

**Hex to Number** converts hexadecimals to numbers.

For details, see “Internal functions (calculator functions)” in the “Syntax Reference” chapter of the *JMP Scripting Guide*.

**Repeat**

```
Repeat([ ], [ ])
```

Creates a string that is the first argument repeated the number of times specified by the second argument. The first argument can be either a character literal, a character variable, or a character expression. For example, `Repeat("Katie", 3)` creates KatieKatieKatie.

A third argument applies when `Repeat` is used in a JSL script to repeat a matrix. When the first argument is a matrix, the second argument is the row-wise repeat and the third argument is the column-wise repeat.

**Insert, Insert Into**

```
Insert([ ], )
Insert Into([ ], )
```

**Insert** inserts a new item into the list or expression at the given position. If position is not given, it is inserted at the end.

**Insert Into** is the same as insert, but it inserts in place.

**Remove, Remove From**

```
Remove([ ])
Remove From([ ])
```

**Remove** the character(s) at the indicated position. If n is omitted, the item at position is deleted. If position and n are omitted, the item at the end is removed. There are three possible arguments: the string, followed by the position, followed by the number of characters to be removed.

**Remove From** returns items removed in place. The function returns the removed item(s), but you don’t have to assign them to anything. The first argument is a variable name, followed by the position, followed by the number of characters to be removed.

**Shift, Shift Into**

```
Shift([ ])
Shift Into([ ])
```

**Shift** shifts an item or n items from the front to the back of the list or expression. Shifts items from back to front if n is negative. **Shift Into** shifts items in place.

**Reverse, Reverse Into**

```
Reverse([ ])
Reverse Into([ ])
```

**Reverse** reverses the characters in the string. **Reverse Into** reverses the characters in place.
Substitute, Substitute Into

The first argument is a string, the second is a pattern, and the third is a replacement string. Substitute finds all matches to the pattern in the string, and replaces them with the replacement string. Substitute Into does the same substitution in place.

Regex Match

The first argument is a string, the second is a pattern. Regex Match matches the pattern string.

Hex to Blob, Char to Blob, Blob to Char

Hex to Blob converts the hexadecimal to a blob (Binary Large Object).

Char to Blob converts the string to a blob. You can specify the encoding in an optional second argument. Supported encodings are: utf-8, utf-16le, utf-16be, us-ascii, iso-8859-1, and ascii-hex.

Blob to Char converts the blob to a string. You can specify the encoding in an optional second argument. Supported encodings are: utf-8, utf-16le, utf-16be, us-ascii, iso-8859-1, and ascii-hex.

Blob Peek

Creates a new blob from a sub-range of bytes of the first argument, which is a blob. The second argument specifies the offset (which is zero-based), and the third specifies the length (number of bytes).

Character Pattern Functions

These functions provide powerful pattern matching abilities.

Pat Any

Constructs a pattern that matches a single character in the argument.

Pat Not Any

Constructs a pattern that matches a single character that is not in the argument.

Pat Break

Constructs a pattern that matches zero or more characters that are not in its argument; it stops or breaks on a character in its argument. It fails if a character in its argument is not found (in particular, it fails to match if it finds the end of the source string without finding a break character).

Pat Span

Constructs a pattern that matches one or more (not zero) occurrences of characters in its argument. It is greedy; it always matches the longest possible string. It fails rather than matching zero characters.

Pat String

Constructs a pattern that matches its string argument.
### Character Pattern Functions

- **Pat Len** \(\text{Pat Len}[\;n\;]\)
  Constructs a pattern that matches \(n\) characters.

- **Pat Pos** \(\text{Pat Pos}[\;n\;]\)
  Constructs patterns that match the null string if the current position is \(n\) from the left end of the string, and fail otherwise.

- **Pat R Pos** \(\text{Pat R Pos}[\;n\;]\)
  Constructs patterns that match the null string if the current position is \(n\) from the right end of the string, and fails otherwise.

- **Pat Tab** \(\text{Pat Tab}[\;n\;]\)
  Constructs a pattern that matches forward to position \(n\) in the source string. It can match 0 or more characters. It fails if it would have to move backwards or beyond the end of the string.

- **Pat R Tab** \(\text{Pat R Tab}[\;n\;]\)
  Constructs a pattern that matches up to position \(n\) from the end of the string. It can match 0 or more characters. It fails if it would have to move backwards or beyond the end of the string.

- **Pat Test** \(\text{Pat Test}[\;\text{expr}\;]\)
  Constructs a pattern that succeeds and matches the null string if \(\text{expr}\) is not zero and fails otherwise.

- **Pat At** \(\text{Pat At}[\;\text{varName}\;]\)
  Constructs a pattern that matches the null string and stores the current position in the source string into the specified JSL variable (\text{varName}). The assignment is immediate, and the variable can be used with expr() to affect the remainder of the match.

- **Pat Rem** \(\text{Pat Rem}[\;\;]\)
  Constructs a pattern that matches the remainder of the string. It is equivalent to patRTab(0).

- **Pat Arb** \(\text{Pat Arb}[\;\;]\)
  Constructs a pattern that matches an arbitrary string. Initially it will match the null string. It will match one additional character each time the pattern matcher backs into it.

- **Pat Succeed** \(\text{Pat Succeed}[\;\;]\)
  Constructs a pattern that always succeeds, even when the matcher backs into it. It matches the null string.

- **Pat Fail** \(\text{Pat Fail}[\;\;]\)
  Constructs a pattern that fails whenever the matcher attempts to move forward through it. The matcher backs up and tries different alternatives. If and when there are no alternatives left, the match will fail and patMatch will return 0.
**Pat Abort**  
Constructs a pattern that immediately aborts the pattern match. The matcher does not back up and retry any alternatives. Conditional assignments are not made. Immediate assignments that were already made are kept.

**Pat Fence**  
Constructs a pattern that succeeds and matches the null string when the matcher moves forward through it, but fails when the matcher tries to back up through it. It is a one-way trap door that can be used to optimize some matches.

**Pat Arb No**  
Constructs a pattern that matches zero or more copies of pattern.

**Pat Repeat**  
Matches pattern between minimum and maximum times.

**Pat Conditional**  
Saves the result of the pattern match, if it succeeds, to a variable named as the second argument (type) after the match is finished.

**Pat Immediate**  
Saves the result of the pattern match to a variable named as the second argument (varName) immediately.

**Pat Altern**  
Constructs a pattern that matches any one of the pattern arguments.

**Pat Concat**  
Constructs a pattern that matches each pattern argument in turn.

**Pat Regex**  
Constructs a pattern that matches the regular expression in the quoted string argument.

**Pat Match**  
PatMatch executes the Pattern against the SourceText. The pattern must be constructed first, either inline or by assigning it to a JSL variable elsewhere.

---

**Comparison Functions**

You can create a formula that compares the values of two arguments by using the comparison function. Each comparison relationship evaluates as **true** or **false** based on numeric magnitudes or character rankings. A true relationship evaluates as one, and false evaluates as zero.
Comparisons are useful when you include them in conditional expressions, but they can also stand alone as numeric expressions if neither term in comparison is missing. See the *JMP Scripting Guide* for details on syntax.

- `<` Less than
- `>` Greater than
- `<=` Less than or equal to
- `>=` Greater than or equal to
- `==` Equal to
- `!=` Not equal to

\[
\begin{align*}
\text{a} < \text{b} &\leq \text{c} \\
\text{a} &\leq \text{b} < \text{c}
\end{align*}
\]

*Is Missing* \(\text{Is Missing}\) Returns a one (1) if the value of the argument for the current row is missing, and a zero if the value is not missing. The formula editor excludes missing numeric values from its statistical calculations.

### Conditional Functions

You can include conditional expressions (called *conditionals* for short) in your formulas. These expressions let you build a sequence of clauses paired with result expressions. Constructing a sequence of clauses is the way you conditionally assign values to cells in a calculated column. See the *JMP Scripting Guide* for details on syntax.

Use the insert and delete clause buttons on the formula editor panel to expand the expression. For maximum efficiency, list the most frequently evaluated clause/result pairs first in the sequence.

**Note:** *Interpolate, Step, For, and While* are most often used in conjunction with other commands to build a JSL script. You can use the formula editor to create and execute a script in that column, but this is not recommended because of dependencies and ambiguities that can result. Most often, scripts are stored as .JSL files, and can be saved with a data table as a table property. See “The Table Panel,” p. 50, for details on table properties, and see the *JMP Scripting Guide* for documentation of all scripting commands.

**If**

Shows a single *If* condition with a missing expression and a missing *then clause*. Highlight either *expr* or *then clause* and enter a value. For example, to calculate count as a percentage of total when total is not 0, enter the conditional expression (using columns called *count* and *total*) in Figure C.2.

**Figure C.2** A Conditional Expression

\[
\begin{align*}
\text{If} &\quad \text{total} = 0 \\
\text{else} &\quad \frac{\text{count}}{\text{total}} \times 100
\end{align*}
\]
To add a new condition to the If conditional, highlight then clause and click the insert button ( ) on the formula editor keypad. Initially, this changes the existing else condition to an expr clause. Click the insert button again to add an else clause. Highlighting then or else and repetitively clicking the insert button changes the else to expr or adds a new expr clause.

To delete a clause, select the then clause above it and press the delete key on your keyboard or click the delete button ( ) on the formula editor keypad.

By definition, expressions that evaluate as zero are false. If an expression evaluates as missing, no clauses are executed and missing is returned. All other numeric expressions are true.

Match

Compares an expression to a list of clauses and returns the value of the resulting expression for the first matching clause encountered. You provide the matching expression only once and then give a match value for each clause. When you select Match, the formula editor shows a single Match condition with a missing expression and a missing then clause, as shown in Figure C.3.

Figure C.3  An Example of Using the Match Function

After you select Match, you should highlight either expr, value, or then clause, then enter an expression. (Or, if you highlight an expression and click Match, the formula editor creates a new Match conditional with the original highlighted expression as expr and nothing for the value and else clause.) Also, keep in mind that:

- **Match** evaluates faster and uses less memory than an equivalent If because the variable is evaluated only once for each row in the data table. The If condition must evaluate the variable at each If clause for each row until a clause evaluates as true. See “Comparing Values,” p. 291, for a comparison of Match and If conditionals.

- With If and Match, the formula editor searches down from the top of the sequence for the first true clause and evaluates the corresponding result expression. Subsequent true clauses are ignored.

For example, consider the following two formulas for predicting a child’s height from his age. In each case there is a base height of 58.125 inches to which a quantity is added depending on the value of the age variable.

\[
58.125 + \text{Match}(\text{age}) \begin{cases} 
12 \Rightarrow 0 \\
13 \Rightarrow 2.16071428571425 \\
14 \Rightarrow 6.041666666666666 \\
15 \Rightarrow 6.44642857142654 \\
16 \Rightarrow 6.208333333333333 \\
17 \Rightarrow 8.541666666666665 \\
\text{else} \Rightarrow .
\end{cases}
\]

\[
58.125 + \text{If}(\text{age}) \begin{cases} 
\text{age} == 12 \Rightarrow 0 \\
\text{age} == 13 \Rightarrow 2.16071428571425 \\
\text{age} == 14 \Rightarrow 6.041666666666666 \\
\text{age} == 15 \Rightarrow 6.44642857142654 \\
\text{age} == 16 \Rightarrow 6.208333333333333 \\
\text{age} == 17 \Rightarrow 8.541666666666665 \\
\text{else} \Rightarrow \text{else clause}
\end{cases}
\]

**Note:** Match ignores trailing spaces, while If does not.
Although `Match` returns missing for any missing values, you can also specifically match missing values.

**Choose**

`Choose` is a special case of `Match` in which the arguments of the condition are a sequence of integers starting at one. The value of `clause` replaces the match condition. An example of a `Choose` condition is shown in Figure C.4. With `Choose`, the formula editor goes directly to the correct choice clause and evaluates the result expression.

**Figure C.4** Example of a `Choose` Condition

When you highlight an expression and click `Choose`, the formula editor creates a new conditional expression with one `clause`. Use the insert (` Insert`) and delete (` Delete`) buttons on the keypad to add new clauses or remove unwanted clauses, as described previously for the `If` conditional.

`Choose` evaluates the `choose` expression and goes immediately to the corresponding result expression to generate the returned value. With `Choose`, you provide a choosing expression that yields sequential integers starting at 1 only once, then you give a choice for each integer in the sequence.

**And  \&**

Evaluates as 1 when both of its arguments are true. Otherwise it evaluates as 0 (see Figure C.7). The formula in Figure C.5 labels Group 1 as drivers only if both comparisons are true.

**Figure C.5** Creating an `And` Function

<table>
<thead>
<tr>
<th>sex == &quot;M&quot; &amp; age &gt; 13</th>
<th>&quot;Group 1&quot;</th>
</tr>
</thead>
<tbody>
<tr>
<td>else</td>
<td>&quot;Group 2&quot;</td>
</tr>
</tbody>
</table>

**Or  \|**

Evaluates as 1 when either of its arguments is true. If both of its arguments are false, then the `Or` expression evaluates as 0 (see Figure C.7). The formula in Figure C.6 assigns males and all participants over 13 to Group 1.

**Figure C.6** Creating an `Or` Function

<table>
<thead>
<tr>
<th>sex == &quot;M&quot;</th>
<th>age &gt; 13</th>
<th>&quot;Group 1&quot;</th>
</tr>
</thead>
<tbody>
<tr>
<td>else</td>
<td></td>
<td>&quot;Group 2&quot;</td>
</tr>
</tbody>
</table>

The truth tables on the left in Figure C.7 illustrate the results of the `And` (\&) and `Or` (\|) functions when both arguments have nonmissing values that evaluate to true or false. The table on the right illustrates the result when either the left or right expression (call them `a` and `b`) or both have missing values.
Not \texttt{!} \hfill  
Evaluates as 1 when its argument is false. Otherwise, \texttt{Not} evaluates as 0. When you apply the \texttt{Not} function, use parentheses where necessary to avoid ambiguity. For example, \texttt{!(weight==64)} can be either true or false (either 1 or 0), but \texttt{(!weight)==64} is always false (0) because \texttt{Not} can only return 0 or 1. Expressions such as \texttt{!(weight==64)} can also be entered as \texttt{weight != 64}.

\textbf{Interpolate} \hfill  
Linearly interpolates the \textit{y}-value between two points, \textit{x}1, \textit{y}1 and \textit{x}2, \textit{y}2 that corresponds to the arguments you give. You can insert additional pairs of \textit{x}, \textit{y} arguments with the insert key. \texttt{Interpolate} finds the pair of \textit{x}, \textit{y} points that correspond to the \textit{x}-value and completes the interpolation.

\textbf{Step} \hfill  
is like \texttt{Interpolate} except that it returns the \textit{y}-value corresponding to the greatest \textit{x}-value less than or equal to the \textit{x}, \textit{y}-arguments. That is, it finds the corresponding \textit{y} for a given \textit{x} from a step function rather than a linear fit between points. Like \texttt{Interpolate}, you can have as many \textit{x}, \textit{y}-argument pairs as you want.

\textbf{Repeats the statements in the body argument as long as the while condition is true. The \texttt{init} and \texttt{next} control the iterations.} \hfill  
\textbf{Repeatedly tests the expr condition and executes the body until expr is no longer true.}
Probability Functions

You can create a formula that calculates quantiles for the Tukey HSD and quantiles and probabilities for beta, Chi-squared, $F$, gamma, normal, Student’s $t$, and Weibull distributions. See the *JMP Scripting Guide* for details on syntax.

**Beta Density**

Requires a quantile argument, shape parameters alpha and beta, and optionally accepts a threshold parameter, theta, and a scale parameter, sigma > 0. It returns the value of the beta probability density function (pdf) for the given arguments. The beta density is useful for modeling the probabilistic behavior of random variables such as proportions constrained to fall in the interval $[0, 1]$. Examples of densities for several combinations of $\alpha$ and $\beta$ are shown in Figure C.8.

**Figure C.8** Overlay Plot of Three Beta Density Curves

**Beta Distribution**

Has a positive density only for an $x$ interval of finite length, unlike normal and gamma which have positive density over an infinite interval. The theoretical beta distribution has a shape parameter, $\alpha > 0$ and a scale parameter, $\beta > 0$, and constants $a \leq x \leq b$ that define the interval for which the distribution has values. The beta distribution function accepts the response variable argument $x$, whose range defines the interval for the distribution. The standard beta distribution occurs in the interval $[0, 1]$. The beta distribution function is the inverse of the beta quantile function.

**Beta Quantile**

Accepts a probability argument, $p$, and shape and scale parameters, $\alpha > 0$ and $\beta > 0$. It returns the $p^{th}$ quantile from the standard beta distribution. The beta quantile function is the inverse of the beta distribution function.

**ChiSquare Density**

Accepts a quantile argument from the range of values for the Chi-squared distribution, a degrees of freedom argument, and optionally, a noncentrality parameter. It returns the value of the Chi-squared
density function (pdf) for the arguments. Figure C.9 shows the shape of three Chi-squared curves, with degrees of freedom (DF) 4, 6, and 10.

**Figure C.9** Overlay Plot of Three Chi-squared Density Curves

ChiSquare Distribution

Accepts a response argument (range of \( x \) values) and three parameter arguments: a quantile, a degrees of freedom, and a noncentrality parameter. It returns the probability that an observation from the Chi-squared distribution with the specified noncentrality parameter and degrees of freedom is less than or equal to the given quantile. For example, the expression `ChiSquare Distribution(11.264, 5)` returns the probability that an observation from the Chi-squared distribution centered at 0 with 5 degrees of freedom is less than or equal to 11.264. The expression evaluates as 0.95361.

Furthermore, the `ChiSquare Distribution` function accepts integer and noninteger degrees of freedom. It is centered at 0 by default. The `ChiSquare Distribution` function is the inverse of the `ChiSquare Quantile` function.

ChiSquare Quantile

Accepts three arguments: a probability \( p \), a degrees of freedom, and a noncentrality parameter. It returns the \( p \)th quantile from the Chi-squared distribution with the specified noncentrality parameter and degrees of freedom. For example, the expression `ChiSquare Quantile(.95, 3.5, 4.5)` returns the 95% quantile from the Chi-squared distribution centered at 4.5 with 3.5 degrees of freedom. The expression evaluates as 17.50458.

The `ChiSquare Quantile` function accepts integer and noninteger degrees of freedom. It is centered at 0 by default. The `ChiSquare Quantile` function is the inverse of the `ChiSquare Distribution` function.

F Density

Accepts a quantile argument from the range of values for the \( F \)-distribution, numerator and denominator degrees of freedom arguments, and optionally, a noncentrality parameter. It returns the value of the \( F \)-density function (pdf) for the arguments. Figure C.10 shows the shape of three \( F \)-density curves, with degrees of freedom (5, 10), (10, 20), and (20, 50).
**F Distribution**

Accepts four arguments: a quantile, a numerator and denominator degrees of freedom, and a noncentrality parameter. It returns the probability that an observation from the $F$-distribution with the specified noncentrality parameter and degrees of freedom is less than or equal to the given quantile. For example, the expression $F\text{ Distribution}(3.32, 2, 3)$ returns the probability that an observation from the central $F$-distribution with 2 degrees of freedom in the numerator and 3 degrees of freedom in the denominator is less than or equal to 3.32. The expression evaluates as 0.82639.

The $F$-distribution function accepts integer and noninteger degrees of freedom. By default it is centered at 0 and has 1 numerator degree of freedom. The $F$-distribution function is the inverse of the $F\text{ Quantile}$ function.

**F Quantile**

Accepts four arguments: a probability $p$, a numerator and denominator degrees of freedom, and a noncentrality parameter. It returns the $p$th quantile from the $F$-distribution with the specified noncentrality parameter and degrees of freedom. For example, the expression $F\text{ Quantile}(0.95, 2, 10, 0)$ returns the 95% quantile from the $F$-distribution centered at 0 with 2 degrees of freedom in the numerator and 10 degrees of freedom in the denominator. The expression evaluates as 4.1028.

The $F\text{ Quantile}$ function accepts integer and noninteger degrees of freedom. By default, it is centered at 0 and has 1 numerator degree of freedom. The $F\text{ Quantile}$ function is the inverse of the $F\text{ Distribution}$ function.

**Gamma Density**

Requires a quantile argument. Optionally the $\text{Gamma Density}$ function accepts a shape parameter $a$, which defaults to 1, a scale parameter $b$ with a default 1, and a threshold parameter with default zero. Figure C.11 shows the shape of gamma probability density functions for shape parameters of 1, 3, and 5. The standard gamma density function is strictly decreasing when $\alpha$ (shape) $\leq 1$. When $\alpha > 1$ the density function begins at zero when $x$ is 0, increases to a maximum, and then decreases.

**Gamma Distribution**

Is based on the standard gamma function, and accepts a single argument with a quantile value. Optionally, the $\text{Gamma Distribution}$ function accepts shape, scale, and threshold parameters, with defaults as
described previously in the discussion of the **Gamma Density** function. It returns the probability that an observation from a standard gamma distribution is less than or equal to the specified $x$. The **Gamma Distribution** function is the inverse of the **Gamma Quantile** function.

**Gamma Quantile**

Accepts a probability argument $p$, and returns the $p^{th}$ quantile from the standard gamma distribution with the shape parameter you specify. The **Gamma Quantile** function is the inverse of the **Gamma Distribution** function.

**Figure C.11** Overlay Plot of Gamma Density with Shape Parameter 1, 3, and 5

---

**Normal Density**

Accepts a quantile argument from the range of values for the standard normal distribution. It returns the value of the standard normal probability density function (pdf) for the argument. For example, you can create a column of quantile values ($x$) with the formula `count(-3, 3, nrow())` and a second column computed as **Normal Density(X)** to generate density values. Then select **Graph > Overlay** to plot the normal density by $x$. Figure C.12 shows an overlay plot of normal density curves with various means and standard deviations.

**Normal Distribution**

Accepts a quantile argument from the range of values for the standard normal distribution with mean 0 and standard deviation 1. It returns the probability that an observation from the standard normal distribution is less than or equal to the specified quantile. For example, the expression `Normal Distribution(1.96)` returns 0.975, the probability that an observation from the standard normal distribution is less than or equal to the $1.96^{th}$ quantile. Optionally, you can specify mean and standard deviation parameters to obtain probabilities from nonstandard normal distributions. The **Normal Distribution** function is the inverse of the **Normal Quantile** function.

**Normal Quantile (Probit)**

Accepts a probability argument $p$, and returns the $p^{th}$ quantile from the standard normal distribution. For example, the expression `Normal Quantile(0.975)` returns the 97.5% quantile from the standard normal distribution, which evaluates as 1.96. Optionally, you can specify parameter values for the mean
and standard deviation to obtain quantiles from nonstandard normal distributions. The \textit{Normal Quantile} function is the inverse of the \textit{Normal Distribution} function.

\textbf{Figure C.12} Overlay Plots of Normal Density Curves

\begin{figure}[h]
\centering
\includegraphics[width=\textwidth]{normal_density_curves}
\caption{Overlay Plots of Normal Density Curves}
\end{figure}

\textbf{t Density}

Accepts a quantile argument from the range of values for the \textit{t}-distribution, a degrees of freedom argument, and optionally, a noncentrality parameter. It returns the value of the \textit{t}-density function (pdf) for the arguments. To compare a \textit{t}-density with 5 df with a standard normal distribution, you can create a column of quantile values ($x$) with the formula \texttt{count(-3, 3, nrow())}, a second column computed as \textit{t Density}(X), and a third column computed as \textit{Normal Density}(X). Then select \texttt{Graph > Overlay} to plot the \textit{t}-density and the normal density by $x$ to see the plot shown in Figure C.13. You can see that the \textit{t}-density has slightly more spread than the normal.

\textbf{t Distribution}

Accepts three arguments: a quantile, a degrees of freedom, and a noncentrality parameter. It returns the probability that an observation from the Student's \textit{t}-distribution with the specified noncentrality parameter and degrees of freedom is less than or equal to the given quantile. For example, the expression \textit{t Distribution}(0.9, 5) returns the probability that an observation from the Student's \textit{t}-distribution centered at 0 with 5 degrees of freedom is less than or equal to 0.9. The expression is evaluated as 0.79531. \textit{t}-distribution accepts integer and noninteger degrees of freedom. It is centered at 0 by default, but you can enter a value for the noncentrality parameter. The \textit{t Quantile} function is the inverse of the \textit{t Distribution} function.

\textbf{t Quantile}

Accepts three arguments: a probability $p$, a degrees of freedom, and a noncentrality parameter. It returns the $p^{th}$ quantile from the Student's \textit{t}-distribution with the specified noncentrality parameter and degrees of freedom. For example, the expression \textit{Student's t Quantile}(0.95, 2.5) returns the 95\% quantile from the Student's \textit{t}-distribution centered at 0 with 2.5 degrees of freedom. The expression evaluates as 2.558219. The \textit{t Quantile} function is the inverse of the \textit{t Distribution} function. This function also accepts integer and noninteger degrees of freedom. It is centered at 0 by default, but you have the option to enter a value for the noncentrality parameter. The \textit{t Distribution} function is the inverse of the \textit{t Quantile} function.
Weibull Density

Accepts a quantile argument from a range of values for the Weibull distribution. It returns the value of the Weibull probability density function (pdf), which is the probability that an observation from a Weibull distribution is less than or equal to the specified quantile argument.

Weibull Distribution

Uses an argument with a quantile value and, optionally, a value for the scale parameter $\alpha$ and the shape parameter $\beta$. It returns the probability that an observation is less than or equal to the specified $x$ for Weibull distribution with the shape and scale parameters you specified. The Weibull Distribution function is the inverse of Weibull Quantile function.

The Weibull distribution has different shapes depending on the values of $\alpha$ (a scale parameter that affects the $x$ direction) and $\beta$ (a shape parameter). It often provides a good model for estimating the length of life, especially for mechanical devices and in biology. The two-parameter Weibull is the same as the three-parameter Weibull with a threshold of zero. Figure C.14 shows examples of several combinations of shape and scale parameter values, with the threshold parameter equal to zero. The extreme value distribution is a two-parameter Weibull ($\alpha$, $\beta$) distribution with the transformed parameters: $\delta = 1 / \alpha$ and $\gamma = \ln(\beta)$.
The Weibull distribution has two parameters, $\alpha > 0$ and $\beta > 0$. When $\alpha = 1$ the pdf reduces to the exponential distribution (with $\gamma = 1 / \beta$). The exponential distribution is a special case of both the gamma and Weibull distributions. However, there are Weibull distributions that are not exponential distributions.

**Weibull Quantile**

Accepts a probability argument $p$, and returns the $p^{th}$ quantile from the Weibull distribution with the shape and scale parameters you specify. The **Weibull Quantile** function is the inverse of the **Weibull Distribution** function.

**Johnson Su Distribution**

Returns the probability that a Johnson Su-distributed random variable is less than $q$.

**Johnson Su Quantile**

Returns the quantile whose value for which the probability is $p$ that a random value would be lower.

**Johnson Su Density**

Returns the density at $q$ of a Johnson Su distribution.

**Johnson Sb Distribution**

Returns the probability that a Johnson Sb-distributed random variable is less than $q$.

**Johnson Sb Quantile**

Returns the quantile whose value for which the probability is $p$ that a random value would be lower.

**Johnson Sb Density**

Returns the density at $q$ of a Johnson Sb distribution.

**Johnson Sl Distribution**

Returns the probability that a Johnson Sl-distributed random variable is less than $q$. 

---

**Figure C.14  Comparison of Weibull Curves**

![Weibull Curves Graph](image-url)
Johnson Sl Quantile
Returns the quantile whose value for which the probability is \( p \) that a random value would be lower.

Johnson Sl Density
Returns the density at \( q \) of a Johnson Sl distribution.

Binomial Distribution
Returns the probability that an observation from a binomial distribution with parameters \( p \) and \( n \) is less than or equal to \( k \). In general, the binomial functions accept arguments that are the probability of success \( p \) (the event of interest), the number of trials \( n \), and the number of successes \( k \).

Binomial Probability
Computes the probability that a random variable from a binomial distribution is equal to \( k \). In general, the binomial functions accept arguments that are the probability of success \( p \) (the event of interest), the number of trials \( n \), and the number of successes \( k \).

Binomial Quantile
Returns the quantile, which is the percentile of the probability of observing a binomial\((p,n)\) random variable of equal or smaller value.

NegBinomial Distribution
Computes the probability that a random variable from a negative binomial distribution is less than or equal to \( k \). In general, the negative binomial functions accept an argument that is the probability of success \( p \), a number of trials \( n \), and the count of interest \( k \), which is the number of failures that precede the \( i^{\text{th}} \) success.

NegBinomial Probability
Computes the probability that a random variable from a negative binomial distribution is equal to \( k \). In general, the negative binomial functions accept an argument that is the probability of success \( p \), a number of trials \( n \), and the count of interest \( k \), which is the number of failures that precede the \( i^{\text{th}} \) success.

Hypergeometric Distribution
Computes the probability that a random variable from a hypergeometric distribution is less than or equal to \( x \). The hypergeometric distribution models the total number of successes in a fixed sample drawn without replacement from a finite population. The hypergeometric functions accept as arguments the size of the population \( N \), the total number of items with the desired characteristic in the population, \( K \), the number of samples drawn \( n \), and the number of successes in the sample \( x \).

Hypergeometric Probability
Computes the probability that a random variable from a hypergeometric distribution is equal to \( x \).

Poisson Distribution
Computes the probability that a random variable from a Poisson distribution with mean lambda is less than or equal to the count of interest. In general, Poisson functions accept an argument that is the count of interest, and lambda, the mean parameter.
Poisson Probability
Computes the probability that a random variable from a Poisson distribution with mean lambda is equal to the count of interest.

Poisson Quantile
Returns the quantile, which is the percentile of the probability of observing a poisson(lambda) random variable of equal or smaller value.

Tukey HSD Quantile
Accepts a probability argument \( p \), and returns the \( p \)th quantile from Tukey’s HSD test for the parameters you specify. The \( \alpha \) argument is the significance level you want, \( nGroups \) is the number of groups in a study, and \( df\) is the error degrees of freedom (based on the total study sample). This is the quantile used to calculate least significant difference in Tukey’s multiple comparisons test.

F Power and F Sample Size
The F Power function calculates the power from a given situation that involves an \( F \)-test or \( t \)-test, and the F Sample Size function computes the sample size. The arguments are the values you specify for computation of a prospective power analysis. (These functions perform the same computations as if you selected DOE > Sample Size and Power. See the JMP Design of Experiments for a discussion of power and sample size.) The arguments include:

- \( \alpha \) The significance level you are willing to tolerate (often 0.05).
- \( dfh \) The hypothesis degrees of freedom. It is one (1) for a \( t \)-test.
- \( dfm \) The model degrees of freedom (such that \( df\) = \( n \) – \( dfm \)).
- SquaredSize The squared effect size scaled by the error variance, which is used for making the noncentrality argument for the \( F \)-distribution. For this argument, use squared size = \( \Delta^2/\sigma^2 \) where \( \sigma^2 \) is the error variance. That is, use:
  \[
  \Delta^2 = (\bar{x} - \mu)^2 \quad \text{for a one-sample } t\text{-test}
  \]
  \[
  \Delta^2 = \frac{(\bar{x}_1 - \bar{x}_2)^2}{2} \quad \text{for a two-sample } t\text{-test}
  \]
  \[
  \Delta^2 = \sqrt{\frac{k}{k-1}} \sum_{i=1}^{k} \frac{(\bar{x}_i - \bar{x})^2}{k} \quad \text{for a } k\text{-sample } F\text{-test}
  \]
- \( n \) (found only in the F Power function) The total number of observations (runs, experimental units, or samples) you expect to have. Power (in the F Sample Size function) is the probability you want to have of declaring a significant result.

Statistical Functions
See the JMP Scripting Guide for details on syntax.
Col Mean \( \text{Col Mean}(\square) \)

Calculates the mean (or arithmetic average) of the numeric values identified by its argument. The formula \( \text{Col Mean}(\text{age}) \) calculates the average of all nonmissing values in the \text{age} column.

Col Std Dev \( \text{Col Std Dev}(\square) \)

Measures the spread around the mean of the distribution identified by its argument. In the normal distribution, about 68% of the distribution is within one standard deviation of the mean, 95% of the distribution is within two standard deviations of the mean, and 99% of the distribution is within three standard deviations of the mean.

Col Number \( \text{Col Number}(\square) \)

Counts the number of nonmissing values in the column you specify. A missing numeric value occurs when a cell has no assigned value or is the result of an invalid operation (such as division by zero). Missing values show on the spreadsheet as a missing value mark (\(\ast\)). Missing character values are null character strings. In formulas for row state columns, an excluded row state characteristic is treated as a missing value. The formula editor interprets other missing values according to their data types.

Col NMissing \( \text{Col NMissing}(\square) \)

Counts the number of missing values in the column you specify. A missing numeric value occurs when a cell has no assigned value or is the result of an invalid operation (such as division by zero). Missing values show in the data grid with a missing value character (\(\ast\)). Missing character values are null character strings.

Col Sum \( \text{Col Sum}(\square) \)

Computes the sum of the values in its numeric argument. Missing values are ignored.

Col Minimum and Col Maximum \( \text{Col Minimum}(\square), \text{Col Maximum}(\square) \)

Takes the minimum of its numeric arguments. \text{Col Minimum} ignores missing values. \text{Col Maximum} takes the maximum of a numeric column argument and ignores missing values.

Col Quantile \( \text{Col Quantile}(\square, \text{quantile}) \)

Computes the value at which a specific percentage of the values is less than or equal to that value. For example, the value calculated as the 50% quantile, also called the median, is greater than or equal to 50% of the data. Half of the data values are less than the 50th quantile.

The \( \text{Col Quantile} \) function’s quantile argument represents the quantile percentage divided by 100. The 25% quantile, also called the lower quartile, corresponds to \( p = 0.25 \), and the 75% quantile, called the upper quartile, corresponds to \( p = 0.75 \).

The formula editor computes a quantile for a column of \( n \) nonmissing values by arranging the values in ascending order. The subscripts of the sorted column values, \( y_1, y_2, \ldots, y_n \), represent the ranks in ascending order.

The \( p^{th} \) quantile value is calculated using the formula \( p(n + 1) \) where \( p \) is the quantile and \( n \) is the total number of nonmissing values. If \( I \) is an integer, then the quantile value is \( y_p = y_I \). If \( I \) is not an integer,
then the value is interpolated by assigning the integer part of the result to \( i \), and the fractional part to \( f \) and by applying the formula 
\[
qp = (1 - f)y_i + fy_{i+1}.
\]
For example, suppose a column has values 2, 4, 6, 8, 10, 12, 14, 16, 18, and 20. The 50% quantile is calculated as 
\[
0.5(10 + 1) = 5.5.
\]
Because the result is fractional, the 50% quantile value is interpolated as
\[
(1 - 0.5) x 10 + (0.5) x 12 = 0.510 + 0.512 = 6 + 5 = 11
\]
The following are example \( \text{ColQuantile} \) formulas:

- \( \text{ColQuantile}(\text{age}, 1) \) Calculates the maximum age.
- \( \text{ColQuantile}(\text{age}, 0.75) \) Calculates the upper quartile age.
- \( \text{ColQuantile}(\text{age}, 0.5) \) Calculates the median age.
- \( \text{ColQuantile}(\text{age}, 0.25) \) Calculates the lower quartile age.
- \( \text{ColQuantile}(\text{age}, 0) \) Calculates the minimum age.

The \( \text{ColQuantile} \) argument can be any expression that evaluates to a value between (and including) 0 and 1. For example, the first formula in Figure C.15 calculates quantile values of age in ascending order for each row. The column then contains the interpolated values of \( \text{age} \) in ascending order in the calculated column. The second formula lists the interpolated values of age in descending order.

**Figure C.15** Examples of the Quantile Function

\[
\text{Col Quantile}\left[ \text{age}, \frac{\text{Row()}-1}{\text{NRow()}-1} \right] \quad \text{Col Quantile}\left[ \text{age}, \frac{\text{NRow()}-\text{Row()}}{\text{NRow()}-1} \right]
\]

**Col Standardize**

Performs the usual standardization on its numeric expression. For each row \( i \), \( \text{Col Standardize} (\text{height}) \) is 
\[
(\text{HeightRow()} - \text{Col Mean(Height)})/\text{Col Std Dev(Height)}.
\]

**Mean**

Calculates the arithmetic average of the nonmissing arguments you specify. The arguments can be constants, numbers, or expressions. The \( \text{Mean} \) function initially shows with a single argument. You add arguments with the insert button ( ) on the formula editor keypad or by typing a comma.

**Std Dev**

Computes standard deviation of the list of arguments you specify. The arguments can be constants, numbers, or expressions. The \( \text{Std Dev} \) function initially shows with a single argument. You add arguments by clicking the insert button ( ) on the formula editor keypad or by typing a comma.

**Number**

Counts the number of nonmissing values in the list of arguments you specify.

**Sum**

Returns the sum of the arguments.
Quantile  \text{Quantile} [0.1, 0.2, 0.3, 0.4]  
Calculates the quantile given by its first argument for all the following arguments given.

Summation (S)  
Evaluates for an explicit range of values in a column, as given by the summation indices, as opposed to all other statistical functions (except Product), which always evaluate on every row. The Summation function uses the summation notation shown in Figure C.16. To calculate a sum, replace the missing body term with an expression containing the index variable \(i\), or an index variable you assign. Summation repeatedly evaluates the expression for \(i = 1, i = 2, \ldots, i = \text{NRow()}\) and then adds the nonmissing results together to determine the final result.

You can replace \text{NRow()}\), the number of rows in the active spreadsheet, and the index constant, \(i\), with any expression appropriate for your formula. For example, the summation formula in Figure C.16 computes the total for each row of all revenue values for rows 1 through the current row number, filling the calculated column with the cumulative totals of the revenue column.

\textbf{Figure C.16} Example of the \textbf{Summation} function

Product (P)
Evaluates for an explicit range of values in a column, as given by the summation indices, as opposed to all other statistical functions (except Summation), which always evaluate on every row. Product uses the notation shown in the formulas on the right in Figure C.17. To calculate a product, replace the missing body term with an expression containing the index variable \(j\). Product repeatedly evaluates the expression for \(i = 1, i = 2, \ldots, i = n\) and multiplies the nonmissing results together to determine the final result.

You can replace \text{NRow()}\), the number of rows in the active spreadsheet and the index constant, \(i\), with any expression appropriate for your formula.

For example, the expression second product example in Figure C.17 calculates \(i!\) (each row number’s factorial).

\textbf{Figure C.17} Examples of the \textbf{Product} Function

Minimum and Maximum  \text{Minimum}  \text{Maximum}  
Return the minimum and maximum value, respectively, from the list of nonmissing arguments you specify.
N Missing  
Counts the number of missing values in the list of arguments you specify.

Desirability  
Are smooth piece-wise functions that are crafted to fit the control points. The minimize and maximize functions are three-part piece-wise smooth functions that have exponential tails and a cubic middle. The target function is a piece-wise function that is a scale multiple of a normal density on either side of the target (with different curves on each side), which is also piece-wise smooth and fit to the control points.

Random Functions

You can create formulas that generate real numbers by effectively “rolling the dice” within the constraints of the specified distribution. The random numbers are generated using the Mersenne-Twister technique. See Matsumoto and Nishimura (1998) in the reference section of the JMP Statistics and Graphics Guide for details. Also see the JMP Scripting Guide for details on syntax.

Random Uniform  
Generates random numbers uniformly between 0 and 1. This means that any number between 0 and 1 is as likely to be generated as any other. The result is an approximately even distribution. You can shift the distribution and change its range with constants. For example, 5 + Random Uniform()*20 generates uniform random numbers between 5 and 25.

Random Normal  
Generates random numbers that approximate a normal distribution with a mean of 0 and standard deviation of 1 if no arguments are used, or with the mean and standard deviation entered as arguments. The normal distribution is bell shaped and symmetrical. You can also modify the Random Normal function with constants if no arguments are entered to give a normal distribution with specific mean and standard deviation. For example, the formula Random Normal()*5 + 30 generates a random normal variable with a mean of 30 and a standard deviation of 5.

Random Exp  
Generates a single parameter exponential distribution for the distribution parameter lambda=1. You can modify the exponential function to use a different lambda. For example, 0.1*Random Exp()-0.1 generates an exponential distribution for lambda=0.1. The exponential distribution is often used to model simple failure time data, where lambda is the failure rate.

Random Gamma  
Gives a gamma distribution for the parameter, alpha, you enter as the function argument. The gamma distribution describes the time until the $k^{th}$ occurrence of an event. The gamma distribution can also have a scale parameter, beta. A gamma variate with shape parameter alpha and scale beta can be gener-
ated with the formula $\text{beta} \times \text{Random Gamma}(\alpha)$. If $2\alpha$ is an integer, a Chi-squared variate with $2\alpha$ degrees of freedom is generated with the formula $2\times \text{Random Gamma}(\alpha)$.

Random Beta

Generates a pseudo-random number distributed Beta (alpha, beta).

Random Cauchy

Generates a Cauchy distribution with location parameter 0 and scale parameter 1. The Cauchy distribution is bell shaped and symmetric but has heavier tails than the normal distribution. A Cauchy variate with location parameter alpha and scale parameter beta can be generated with the formula $\alpha + \beta \times \text{Random Cauchy()}$.

Random Johnson Su

Returns a random number from the Johnson Su distribution.

Random Johnson Sb

Returns a random number from the Johnson Sb distribution.

Random Johnson Sl

Returns a random number from the Johnson Sl distribution.

Random Triangular

Generates a triangular distribution of numbers between 0 and 1, with the midpoint you enter as the function argument. You can add a constant to the function to shift the distribution and multiply to change its span.

Random Integer

Generates a uniform distribution of integers between 1 and the argument you enter as $n_1$, if nothing is entered for $n_2$. If you enter both $n_1$ and $n_2$ ($n_1 < n_2$), Random Integer generates a uniform distribution of the integers between and including $n_1$ and $n_2$.

Random Binomial

Generates random numbers from a binomial distribution with parameters you enter as function arguments. The first argument is $n$, the number of trials in a binomial experiment. The second argument is $p$, the probability that the event of interest occurs. When $n$ is 1, the binomial function generates a distribution of Bernoulli trials. For example, $n = 1$ and $p = 0.5$, give the distribution of tossing a fair coin. The mean of the binomial distribution is $np$, and variance is $np(1 - np)$.

Random Negative Binomial

Generates a negative binomial distribution for the parameters you enter as function arguments. The first parameter is the number of successes of interest ($r$) and the second argument is the probability of success ($p$). The random variable of interest is the number of failures that precede the $r$th success. In contrast to the binomial variate, where the number of trials is fixed and the number of successes is vari-
able, the negative binomial variate is for a fixed number of successes and a random number of trials. The mean of the negative binomial distribution is \( (r(1 - p))/p \) and the variance is \( (r(1 - p))/p^2 \).

**Random Geometric**

Returns random numbers from the geometric distribution with the parameter you enter as the function argument. The parameter, \( p \), is the probability that a specific event occurs at any one trial. The number of trials until a specific event occurs for the first time is described by the geometric distribution. The mean of the geometric distribution is \( (1-p)/p \), and the variance is \( (1 - p)/p^2 \).

**Random Poisson**

Generates a Poisson variate based on the value of the parameter, lambda, you enter as the function argument. Lambda is often a rate of events occurring per unit time or unit of area. Lambda is both the mean and the variance of the Poisson distribution.

**Random Weibull**

Returns a random number from a Weibull distribution.

**Random LogNormal**

Returns a LogNormal-distributed random number with location parameter \( \mu \) and scale parameter \( \sigma \).

**Random Reset**

Restarts the random number sequences with a seed you specify.

**Random Seed**

Lets you start a random number sequence with a seed you specify. To use the Random Seed function, assign its argument and use it in an if conditional function. Then use the random number function you want as the else clause. The example in Figure C.18 uses the number 1234567 as the seed to generate a sequence of uniform random numbers.

**Figure C.18 Generating a Sequence of Uniform Random Numbers**

```
If (Row() == 2) => Random Seed [1234567]
```

**Random Seeded Uniform and Random Seeded Normal**

These functions generate uniform and normal random numbers with an older seeded random number generator. They are important when you want the same series of random numbers generated repeatedly for testing. Note that for compatibility, JMP 3 data tables with Random Uniform() and Random Normal() functions are converted to the new names for the old functions, RandomSeededUniform() and RandomSeededNormal.
Col Shuffle \texttt{Col Shuffle()}

Selects a row number at random from the current data table. Each row number is selected only once. When \texttt{Col Shuffle} is used as a subscript, it returns a value selected at random from the column that serves as its argument. Each value from the original column is assigned only once as \texttt{Shuffle}'s result.

For example, to identify a 50% random sample without replacement, use the formula in Figure C.19.

**Figure C.19** Formula Identifying 50% Random Sample

\[
\begin{align*}
\text{In Row}() &= \frac{\text{NRow}()}{2} \\
\text{else} &\Rightarrow \text{Col Shuffle()}
\end{align*}
\]

The formula in Figure C.19 selects half the values \((n/2)\) from the column \(x\) and assigns them to the first half of the rows in the computed column. The remaining rows of the computed column fill with missing values.

\textbf{Resample Freq} \texttt{Resample Freq( )}

Generates a random selection with replacement frequency counts, suitable for use in bootstrapping. For example, it supports a second \texttt{Freq Column} argument, allowing it to do bootstrap samples relating to a pre-existing frequency column specified in the second argument. \texttt{Resample Freq()} generates 100% resample. \texttt{Resample Freq(fraction)} generates \(\text{fraction} \times nrow\) frequency sample, and \texttt{Resample Freq(n)} generates an \(n \times nrow\) frequency sample.

**Date Time Functions**

See the \textit{JMP Scripting Guide} for details on syntax.

\textbf{In Minutes, In Hours, In Days, In Weeks, In Years} \texttt{In Minutes(minutes)} \texttt{In Hours(hours)} \texttt{In Days(days)} \texttt{In Weeks(weeks)} \texttt{In Years(years)}

Converts from the units of the function name to the equivalent number of seconds for the argument. The argument must be a number or numeric expression. For example, \texttt{In Minutes(2)} yields 120, and \texttt{In Years(1)} yields 31,557,600 (60 seconds * 60 minutes * 24 hours * 365.25 days).

\textbf{Date DMY, Date MDY} \texttt{Date DMY(day, month, year)} \texttt{Date MDY(month, day, year)}

Accepts numeric expressions for day, month, and year and return the associated JMP date. For example, \texttt{Date DMY(20, 3, 1991)} and \texttt{Date MDY(3, 20, 1991)} evaluate to 2,752,272,000.

\textbf{Today} \texttt{Today( )}

Returns the number of seconds between January 1, 1904 and the current date. For example, at midnight on March 20, 1991 (a Wednesday), the \texttt{Today} function returns 2752272000 (2,752,272,000 seconds) and continues counting. If you evaluate the \texttt{Today} function later in the day, it reflects the additional seconds.
Day, Month, Year

\[ \text{Day}(x), \text{Month}(x), \text{Year}(x) \]

Returns the day of the month, the month (as a number from 1 to 12), and a four-digit year, respectively. The argument for these functions is interpreted as a JMP date. For example, on March 20, 1991:

- \( \text{Day}(2752272000) \) returns the number 20.
- \( \text{Month}(2752272000) \) returns the number 3.
- \( \text{Year}(2752272000) \) returns the number 1991.

Hour, Minute, Second

\[ \text{Hour}(x), \text{Minute}(x), \text{Second}(x) \]

Returns the hour, the minute, and the seconds of a date-time value, respectively. The argument for these functions is interpreted as a JMP date. For example, on March 20, 1991:

- \( \text{Hour}(2752572649) \) returns the number 11.
- \( \text{Minute}(2752572649) \) returns the number 30.
- \( \text{Second}(2752572649) \) returns the number 49.

Day of Week, Day of Year, Week of Year, Time of Day

\[ \text{Day Of Week}(x), \text{Day Of Year}(x), \text{Week Of Year}(x), \text{Time Of Day}(x) \]

The argument for these functions is a JMP date. \( \text{Day Of Week}(x) \) returns a number from 1 to 7, where 1 represents Sunday. \( \text{Day Of Year}(x) \) returns the number of days from the beginning of the year. \( \text{Week Of Year}(x) \) returns a number from 1 to 52. \( \text{Time Of Day}(x) \) returns a number from 0 to 86399 (time of day in seconds). For example, on Wednesday, March 20, 1991:

- \( \text{Day Of Week}(2752272000) \) returns the number 4.
- \( \text{Day Of Year}(2752272000) \) returns the number 79.
- \( \text{Week Of Year}(2752272000) \) returns the number 12.
- \( \text{Time Of Day}(2752272000) \) returns the number 0.

Informat

\[ \text{Informat}(x, \text{formatName}) \]

The argument for the \text{Informat} function is a date character string. For example, \text{Informat}("03/20/1991") returns the appropriate JMP date value, 2752272000. JMP can read all the date formats except for \text{Abbrev Date} and \text{Long Date}.

Abbrev Date, Long Date, Short Date

\[ \text{Abbrev Date}(x), \text{Long Date}(x), \text{Short Date}(x) \]

The argument for these date functions is a JMP date. They return character strings that are the formatted representation of the argument. For example:

- \( \text{Abbrev Date}(2752272000) \) returns Wed, Mar 20, 1991.
- \( \text{Long Date}(2752272000) \) returns Wednesday, March 20, 1991.
- \( \text{Short Date}(2752272000) \) returns 3/20/91.

Format

\[ \text{Format}(x, \text{formatName}) \]

The first argument in the \text{Format} function is a JMP date. This function returns the character string representation of the date by the date format you specify in the second argument, which is a quoted
string. If you apply this formula to a numeric column, JMP automatically changes the column’s data type to character.

You can also supply a column for the first argument and leave the rest blank. The result is the formatted value of the column reference. This can be used to extract value labels of a column when the value labels are turned off.

**MDYHMS**

The argument of **MDYHMS** is a JMP date. This function shows all date and time fields, appending zeros as time fields if no time information is present. This is useful if a date column is formulated such that not all date information is displayed. The **MDYHMS** function can be used to see all available date and time information.

### Row State Functions

There are six characteristics that rows in a data table can have: selected, hidden, excluded, labeled, colored, and marked. If you give rows one or more of these characteristics (see “Assigning Characteristics to Rows and Columns,” p. 129) and then create row state data table columns (see section “Using Row State Columns,” p. 162), you can then create a formula that computes and saves row state conditions. This formula processes row state data just as it would process character and numeric data. See the JMP Scripting Guide for details on syntax.

**Table C.1**

**Row State**

Returns the active row state condition of the current row as true or false. You can use this function to conveniently write conditional clauses that depend on the status of the current row. For example, Figure C.20 assigns a 1 to rows that are currently selected and labeled and 0 otherwise.

**Figure C.20  Row State**

<table>
<thead>
<tr>
<th>Selected( Row State[ ] ) &amp; Labeled( Row State[ ] )</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td>else</td>
<td>0</td>
</tr>
</tbody>
</table>

**As Row State**

Converts a numeric argument to a row state or set of row state conditions. Row states are stored internally in JMP as a 16-bit number, with each bit assigned to represent one of the possible row states as illustrated in Figure C.2. For example, the binary representation of 1327 is 000001010010111. **As Row State(1 3 2 7)** would therefore set the row state as selected, excluded, hidden, labeled, with marker 2 and color 10.

**Combine States**

Generates a row state combination with two or more arguments. Use the insert button ( ) on the formula editor keypad or type a comma to add arguments to the **Combine States** function. The currently
selected expression becomes the first argument when you select **Combine States**. Replace each argument with an expression that evaluates to a row state. This formula:

```
Combine States(  
    Selected State(Modulo(Row(),2),  
    Labeled State(Modulo(Row()+1,2))  
)
```

alternately labels or selects each row in the calculated row state column. The **Selected State** and **Labeled State** functions are defined later in this section. Use the insert (_attach_13342) and delete (_attach_13343) buttons on the formula editor keypad to add more arguments or remove unwanted arguments.

If you include conflicting row states in a combination, the results are unpredictable.

**Excluded State**

Interprets a numeric argument as true or false. When an argument evaluates as true, the **Excluded State** function assigns the excluded condition as the value of the column for that row. For example, `Excluded State(Modulo(Row(),2))`, assigns the excluded row state as the value of the row state column for each odd numbered row.

**Hidden State**

Assigns the hidden row state condition when its argument is greater than zero. If the argument is zero, the value in the column for that row is not hidden.

**Labeled State**

Gives the labeled row state condition when its argument is greater than zero. If the argument is zero the row value in the column for that row is not labeled.

**Color State**

Returns the color from the JMP color map that corresponds to its integer argument. JMP colors are numbered 0 through 84, but larger integers that map to color indices are treated as modulo 84. Zero maps to black.

**Marker State**

Returns markers from the JMP marker map that correspond to its integer argument. JMP markers are numbered 0 through 16, but larger integers that map to marker indices are treated as modulo 16. The formula `Marker State(Row())` assigns all the row state markers in a repeating sequence determined by the current row number to the calculated row state column. A row state column can have multiple row states as a value.

**Selected State**

Gives the selected row state condition when its argument is greater than zero. If the argument is zero, the value in the column for that row is not selected.

**Hue State**

Returns the color from the JMP hue map that corresponds to its integer argument. JMP hues are numbered 0 through 11 but larger integers are treated as modulo 12. The **Hue State** function does not map to black, gray, or white. A hue of zero maps to red and hue of 11 maps to magenta. The formula on the left in Figure C.21 assigns row state colors in a chromatic spread based on the value of $z$. The **Hue State** function used with a row state data type column.
Shade State

Assigns five shade levels to a color or hue. A shade of –2 is darkest and shade of +2 is lightest. A shade of zero is a pure color. The formula on the right in Figure C.21 assigns shade values based on the value of \( z \).

**Figure C.21** Examples of Hue and Shade Functions

![Figure C.21](image)

To assign all shades of all the colors in the colors palette, you need to use the **Hue State** and **Shade State** assignments together. The formula in Figure C.22 uses the **Combine States** function described at the beginning of this section. The first argument in the **Combine States** function is the **Hue State** formula shown previously, and the second argument is the **Shade State** formula. In addition, the **Marker State** function with an argument of 2 assigns the \( X \) marker to each row, and the **Selected State** function with an argument of 1 selects each row.

**Figure C.22** Combine States Example For Using Both Hue State and Row State

![Figure C.22](image)

**Excluded, Hidden, Labeled, and Selected**

Accepts a row state expression argument (row state column or row state constant) that evaluates as either 1 or 0 (true or false). These characteristics are inactive by default. Often, the **Row()** function is the argument, which detects the active row state condition of each row. For example, in Figure C.23, the formula assigns 99 whenever a row is actively selected, and 0 otherwise. Note that this formula is used in a column that has a numeric data type.

**Figure C.23** Example of a Formula Using the **Selected** Function

![Figure C.23](image)

The example in Figure C.24 assigns row state conditions to a row state column. The formula for the row state column (in the columns called **row state col**) checks to see if the active row state is either **Hidden** or **Excluded**, and if so, assigns the **Labeled** row state.
Figure C.24  Calculate Row State Information in a Row State Column

Color Of
Accepts any row state expression or column, or the \texttt{Row State()} function as its argument and returns a number from the JMP color map that corresponds to the active color state, or a missing value if there is no assigned color.

Marker Of
Accepts any row state expression or column, or the \texttt{Row State()} function as its argument and returns a number from the JMP marker map that corresponds to the active marker or a missing value if there is no assigned marker.

Table C.2  Row States Stored as 16-Bit Numbers: Each Bit Represents a Row State

<table>
<thead>
<tr>
<th>Bit</th>
<th>Row State</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Unselected (0) or Selected (1)</td>
</tr>
<tr>
<td>1</td>
<td>Unexcluded (0) or Excluded (1)</td>
</tr>
<tr>
<td>2</td>
<td>Unhidden (0) or Hidden (1)</td>
</tr>
<tr>
<td>3</td>
<td>Unlabeled (0) or Labeled (1)</td>
</tr>
<tr>
<td>4-7</td>
<td>Marker</td>
</tr>
<tr>
<td>8-14</td>
<td>Color</td>
</tr>
</tbody>
</table>

Assignment Functions

Assignment functions work in place. That is, the result returned by the operation (on the right of the operator) is stored in the argument on the left of the operator and replaces its current value.

Assignment statements are most often used in conjunction with other commands to build a JSL script. See the \textit{JMP Scripting Guide} for details on syntax.

- \texttt{=}  \textbf{(assign)}  Puts the value of \(b\) into \(a\). For example, \((a=b)\).
- \texttt{+=}  \textbf{(add to)}  Adds the value of \(b\) to \(a\) and puts the result back into \(a\). For example, \((a+=b)\).
- \texttt{-=}  \textbf{(subtract to)}  Subtracts the value of \(b\) and puts the result back into \(a\). For example, \((a-=b)\).
- \texttt{*=}  \textbf{(multiply to)}  Multiplies \(b\) with \(a\) and puts the result back into \(a\). For example, \((a*=b)\).
Parametric Model Functions

This category is a short cut to create three parametric models that are linear functions of set of dialog-selected columns.

Linear Model, Quadratic Model, Quadratic Mixture Model

Selecting each of these opens a column selection box that lets you select one or more columns to be included in the model. The function then creates and populates the chosen model.
### Symbols

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>!= (Not equal to)</td>
<td>function 445</td>
</tr>
<tr>
<td>&amp; (And)</td>
<td>function and conditional clauses 447</td>
</tr>
<tr>
<td>*= (Multiply To)</td>
<td>function 469</td>
</tr>
<tr>
<td>+= (Add to)</td>
<td>function 469</td>
</tr>
<tr>
<td>/= (Divide To)</td>
<td>function 470</td>
</tr>
<tr>
<td>= (Assign)</td>
<td>function 469</td>
</tr>
<tr>
<td>== (Equal to)</td>
<td>function 445</td>
</tr>
<tr>
<td>&gt; (Greater than)</td>
<td>function 445</td>
</tr>
<tr>
<td>&gt;= (Greater than or equal to) function</td>
<td>445</td>
</tr>
<tr>
<td>? tool</td>
<td>3, 5, 422</td>
</tr>
<tr>
<td>^.</td>
<td>See Insert button on keypad</td>
</tr>
<tr>
<td></td>
<td>(Or) function</td>
</tr>
</tbody>
</table>

### Numerics

- 1, 2, and 4-byte integers 61
- 3D scatterplots
  - menu item 418

### A

- A tool. See annotate tool
- Abbrev Date function 465
- about JMP 429
- Abs function 435
- Add Database Query 124
- Add Document 124
- Add Folder 124
- Add to (+=) function 469
- Add URL 124
- Add Window 124
- adding
  - columns 67–69, 408
  - graphics and graphics scripts 215
  - rows 66, 408
  - statistics columns 260
- Aggregate functions (SQL) 30
- aligning elements in layout view
- allowing short numeric formats 61, 327
- analysis roles 138

### Analyze

- menu 412
- toolbar 343
- And (&) function and conditional clauses 447
- annotate tool 210, 423
- annotations
  - creating 210
  - setting the default font 334
- appending horizontally. See joining appending tables. See concatenating tables
- Arc functions 437–438
- arguments
  - definition 316
  - opening and closing 309
- arithmetic buttons on keypad 284
- arranging icons and windows on desktop 426
- arrays. See Taguchi Arrays
- Arrhenius function 437
- ArrheniusInv function 437
- arrow
  - cursor tool 57, 422
  - double arrow tool 57
- As Row State function 296, 466
- Assign (=) function 469
- Assignment functions 298, 469–470
- assignment table property 183
- asterisk beside p-values 174
- asterisk icon 54, 140
- attaching tables. See concatenating tables attributes, standardizing 161
- Augment Design 394, 411
- automatically matching brackets in script editor 324
- Auto-save the report to command 330
- axis
  - adjusting 169, 199, 423
  - copying and pasting settings 204
  - customizing 199
  - divider lines and frames 208
  - gridlines 205
  - increments 201
labels 202, 334
minimum and maximum values 200
numeric format 200
scale 199
scrolling 198
specifications for columns 147
tick marks 204

B
background colors 196, 332
backwards compatibility 107–108, 332
bar chart. See plots and graphs
bars, histogram colors 196
base e 435
Basic category on JMP Starter 381–382
beginners tutorial 3
Bernoulli trials 462
best numeric formats 63
Beta distributions and quantiles 449
Beta functions 436
BETWEEN statement (SQL) 30
beveled report tables 181
Big Class.jmp 310, 314
Binomial functions 456
Bivariate button on JMP Starter 382
Blink button in row editor 82
borderers, adding to report tables 180
books of JMP documentation 429
bouncing selection rectangle 185
boxes around formulas 307
brackets, in script editor 324
brackets, matching 324
browser toolbar 35–36, 344
brush tool 184, 423
building formulas 279
buttons, adding to toolbars 349
By Matching Columns option. See joining

C
Cartesian join. See joining
cascading windows 426
categorical modeling 384
category on JMP Starter 394
Cauchy distribution 462
Ceiling function 435
cell formulas 71
cell plots 419
Char function 438
Char to Hex function 440
character data types 58
character sets 107–108, 332
characteristics, rows and columns 139–140
Chart button on JMP Starter 387
Chart menu item 417
charts
  Control 420
  Gage 420
  See also plots and graphs
  Variability 420
ChiSquared functions 449–450
Choose function 447
circle with strikethrough icon 55, 129
classes 316
cleaning data 73
cleaning up layout of windows 430
closing
  all windows 426
  files 400
  JMP Starter window 9–10
  levels in a report 170
  reports 330
  reports, default action 330
  sessions 329
cluster, scroll bars 326
clustering, hierarchical and K-means 385, 416
coding, column property 152
Coefficient of Variation 261
Col functions 458, 464
Color function 297, 467, 469
Color State function 296
color values 149
colors
  backgrounds 196, 332
  graphs 332
  histogram bars 196
  markers 186
  point values 193
  ranges across values 149
  rows and columns 134, 407
  shapes added to reports 212–215
toolbars 344
  windows 332
Cols menu 408
column
  factor changes (DOE) 157
Column ID, importing text files 17
Column Info menu item 408
columns
  adding 67–69, 408
  adjusting widths 50
attributes 161
axis specifications 147
characteristics 129–140
context menu 79
control limits 154
deleting 67
design roles 156
duplicating 80
excluding 129
factors for mixture experiments 153
fonts used in headings 334
formulas 141, 279
hiding 131
joining 238
labeling 132
list checking 143
locking 137, 142
measuring units 159
moving 80
names 50, 72
notes 142
order of data in reports 153
panel 54–55
preselected analysis roles 138
properties 140, 160–161
range checking 145
reordering 78–79, 409
response limits 154
row state 162–164
selecting 90–91
showing and hiding in report tables 180
Sigma values 158
Sort command 79
sorting 78–79, 409
source column 237
spec limits 154
splitting 230
stacking 227
transposing 232
validating data 143–146
value labels 146
columnwise statistics functions 294
Combine States function 296, 466
commas, locale settings 306
communications settings 34, 336
Comparison functions 291, 445
compositional data. See Ternary Plots
Concat function 438
concatenating tables 236, 406
conditional clauses 292
Not conditional clause 448
Conditional functions 292, 445–448
Connections, database. See database connection constants, inserting in formulas 282
Contains function 438
context menu for rows and columns 79
Contingency button on JMP Starter 382
continuous modeling types 59
Continuous Scale command 193
contour plot 387, 418
contour profiler. See Profiler
Control category on JMP Starter 391
Control Charts 420
control limits 154
Copy As SAS Formula 306
Copy Formula button, using when
creating a subset 224
joining tables 224, 228, 231, 240
copying
axis frame settings 204
graph contents 203
pasting 79, 335, 403
row states 164
text 120, 176, 403
correcting mistakes in formulas 304
correlations. See Multivariate menu item
Cosine functions 437
Count (in a formula) 434
Count column 75
creating source columns (when concatenating tables) 237
crosshairs tool 198, 423
currency formats 63
cursor forms 57, 422
Custom Design
button on JMP Starter 393
menu item 410
customizing
axes 199
menus 353
results 116
See also preferences
toolbars 342

D
data
grid 50
missing 74
properties 140–160
recoding 73
data tables
concatenating 236, 406
creating data table from report table 182
creating new data grid 50–58
ingoing 72–78
elements of data tables 50
joining 238
locking 53, 83
names and notes, placing on reports 329
names, changing 83
opening 11
panels 51
properties 52, 183
saving 107
sorting 225
splitting 230
stacking 228
summarizing 257
transposing 232
updating 250
Data Tables List toolbar 344
data types
character formats 58
date and time formats 61
numeric formats 61
row states 58, 163
specifying 58
database connection 25–28, 111, 401
datafeed. See communications settings
Date functions 464–465
dates and times
formats 61, 63
in formulas 295
inserting on report window 329
Day function 465
Day of Week and Year functions 465
decreasing font sizes 173
decrypting scripts 404
defaults. See factory defaults
delete button, on formula editor keypad 285
deleting
columns 67–69, 410
functions 305
rows 66, 408
delimited incoming data 15
dendrograms. See clustering
derivatives 300
descriptive statistics. See statistics columns
deselecting parts of a report 170
Design of Experiments. See DOE 152
design roles 139, 156
Design, table variable 52, 83
Desirability function 461
desirability values, as column properties 155
desktop, arranging icons 426
diagram
JMP Starter 391
diamond icon, on a report 171
Dif function 434
disclosure control. See diamond icon
discontiguous selection 90–91, 101
Discriminant
gate on JMP Starter 385
DisplayBox scripting index 5, 429
Distribution button on JMP Starter 381
Divide To (/=) function 470
DOE (Design of Experiments)
coding 152
gate on JMP Starter 392
toolbar 344
D-optimal design. See Custom Design
downsaving 107–108, 332
dragging and dropping
in data table 80
into formulas 305
into other programs 120, 175
drawing speed of markers 188
drawing tools 212–215
dropping
columns when splitting tables 231
columns when stacking tables 228
duplicates when joining tables 239
duplicating cells and columns 80
duration, time and numeric formats 65

E
Edit menu 402
Edit Notes 125
editing
column names 72
formulas 304
names of data tables 83
names of report tables 182
reports 170
rows, individually. See row editor
ccripts or script names 89
table variables 87
tables 72–78
WHERE clauses 32
effect size. See Sample Size and Power
efficient evaluations 300
elements and element browser in formula 280, 316
eliminating missing rows (when stacking tables) 227
emailing tables or reports 39, 45
embossed report tables 181
encrypting scripts 404
End of Field and End of Line options 16
end-to-end merging. See concatenating tables
Enter Key moves down option 326
Equal to (==) function 445
equation editor. See formula editor
errors, ignoring in formulas 303
Euclidean distances. See clustering
evaluating columns’ formulas
viewing evaluations in formulas 304
when creating subsets 224
when joining tables 241
when splitting columns 231
when stacking columns 228
Example button
Index help 5, 428
examples, formulas 310
Excel
opening worksheets 323
Excel, importing data 21
Excel, selecting worksheets when opening 323
Excluded functions 296–297, 467–468
excluding
columns when splitting tables 231
columns when stacking tables 228
duplicates when joining tables 239
rows and columns from analyses 129,
406–409
Execute this JSL option 350, 358
exiting JMP 402
Exp function 435
explanations, showing alongside analyses 328
exponent button on keypad 285
export 115
exporting column names to text file 109, 339
exporting files 107, 112, 401
journal 115
expressions 316
extreme vertices. See mixture design
F
F Density function 450
F Distribution function 451
F Power function 457
F Quantile function 451
F Sample Size function 457
factor
column 157–158
for mixture experiments 153
factor changes 157
factor, split plots 157
factory defaults
menus 353
min and max axis values 201
paths (file locations) 337
toolbars 343
fast marker
drawing speed 188
threshold 331
fat plus tool 57, 422
Fibonacci series 434
field widths
in report tables 181
of tick mark labels 206
file
associations and locations 339
formats 112
locations preferences 337
File menu 379, 399–402
File_Edit toolbar 343
files
importing 15
opening 107–108, 332
saving without Unicode 107–108, 332
Files of type list 12
filling columns with data 69
Find/Length expression 439
finding and replacing values 75
Finding values in a data table. See Search/Find
Fit Model
button on JMP Starter 383
menu item 413
Fit Nonlinear
button on JMP Starter 383
See also nonlinear fit
Fit Y by X
button on JMP Starter 382
menu item 412
fixed
decimal numeric formats 64
widths 15
Floor function 435
foldover design. See Augment Design
font sizes, increasing and decreasing 173, 426
fonts, changing in
  data tables 50
  defaults 333
  reports 333
For conditional clause 448
For quantile statistics option when summarizing tables 259
Format function 465
formats
  graphics 335
  numeric. See numeric formats
formula editor 279–315
formula element browser 280, 283
Formula menu item 409
formulas
  arguments, opening and closing 309
  assignment functions 298
  boxes, hiding and showing 307
  cell expressions 71
  comparing values 291
  conditional clauses 292
  constants, adding 282
  creating 141
    types of formulas 279
  data table elements, adding 279
dates and times, adding 295
editing 304
entering into cells 71
evaluating 299, 302, 324
examples 310
expressions 305
fonts 307, 334
functions, adding 286, 433–470
glossary of terms 315
JSL view 304
keyboard shortcuts 315
numeric terms, adding 288
opening and closing arguments 309
operators, adding 283
orientation in formula editor 308
quantiles and probabilities, adding 293
random numbers, generating 294
shortcuts, keyboard 315
statistical functions, adding 294
tutorials 310
viewing 304, 307
frame sizes of plots or graphs 194
Freq (Frequency). See preselected role
FTP sites 36
full factorial designs 393, 411
function browser 286
function types
  Abs 435
  Add to (+=) 469
  And 447
  Arc 437
  As Row State 466
  Assign (=) 469
  Assignment 298, 469
  Beta 436
  Binomial 436
  Ceiling 435
  Char 438
  ChiSquare 449
  Choose 447
  Col 458, 464
  Color 297, 467, 469
  Color State 296
  Combine States 296, 466
  Comparison 291, 445
  Concat 438
  Conditional 292
  Contain 438
  Cosine 437
  Date 464–465
  Day of Week and Year 465
  Divide To 470
  Equal to 445
  Excluded 296–297, 467–468
  Exp 435
  Floor 435
  Format 465
  Gamma 436
  Greater than 445
  Greater than or equal to 445
  Hidden 297, 467–468
  Hidden State 296
  Hue State 297, 467
  In Days, Hours, Minutes, Weeks, Years 464
  Informat 465
  Is Missing 291, 445
  Length 439
  logarithmic 289, 435–436
  Lowercase 439
  Marker 296–297, 467, 469
  Match 314, 446
  Modulo 435
Month 465
Multiply To (\*=) 469
N Missing 461
NegBinomial 456
Not equal to (!=) 445
NRow 434
Number 439, 459
Poisson 456
Post Decrement (--) and Increment (++) 470
Probability 449
Product 460
Random 462
Root 436
Round 435
Row State 466
Shade State 297, 468
Sine 437
Squish 436
statistical 294
t 433
Tangent 437
Today 464
trigonometric 289, 435–436
trim 440
Uppercase 439
Weibull 454
Year 465
functions
adding 286
aggregate (SQL) 30
Arrhenius 437
ArrheniusInV 437
columnwise statistics 294
deleting 305
glossary of terms 316
Logit 437
numeric 288
peeling 285, 305
referencing rows 287
Row States 296

G
Gage R&R. See Variability
Gamma functions 436, 451–452
gaussian process 384
general preferences 319
GIF 112
global variables, storing a report table 183
glossary of formula terms 315
Go To command 95, 408

Go To Line command 404
Go To Row command 29, 94, 407
goals for DOE (Design of Experiments) response variables 155
grabber tool. See hand (grabber) tool
Graph
marker sizes. See marker sizes menu 417–419
See also plots and charts tab on JMP Starter 386
toolbar 344
graphics
adding to reports 215
adding to toolbars 350
formats 335
saving reports as graphics 119
scripts 215
graphs
colors 332
copying and pasting contents 203
Greater than (> ) function 445
Greater than or equal to (>=) function 445
Greek letters 334
grid. See data grid
gridlines 205
GROUP BY command (SQL) 31
grouping objects 429
grouping variables
using when sorting tables 226
using when splitting tables 230

H
hand (grabber) tool
general definition 423
using in formula editor 305
using in reports 169
using to scroll axes 198
hard (factor changes), factor, hard or easy to change 157
HAVING command (SQL) 31
Help
menu 428
question mark (?) tool 422
using online help 3, 5
Hex function 440
Hex to Char function 440
Hex to Number function 440
Hidden functions 297, 467–468
Hidden State function 296
hiding
columns 131
results 171
rows 131, 406
toolbars 343
windows 427
hiding menu tips 328
hierarchical clustering. See clustering
higher dimensions. See Spinning Plots
Highlight Outline Headers option 333
highlight, direction of movement when pressing
Enter/Return 326
highlighting. See selecting 90
histograms, bar colors 196
horizontal
alignment in reports 170
formula display 308
Hot Dogs.jmp 314
HTML
graphic formats for HTML files 335
Hue State function 297, 467
Hypergeometric functions 456

I
I-beam cursors 57
icons
arranging 426
asterisk 54, 140
circle with strikethrough 55, 129
column characteristics 54, 139
column properties 54, 140
diamond (disclosure) 171
list check 54, 143
lock 54, 83
mask 54–55, 131
modeling types 54
plus 54, 142
preselected roles 139
range check 54
red triangle 176
tools 422
window icons 426
yellow tag 54, 133
ID column. See Source Label Column
If conditional clause 445
ignoring
errors 303
missing values (when updating tables) 251
importance values, entering 156
importing
customized toolbars 352
data 13–39
Excel files 21
ODBC 111
options 339
SAS files 22–25
scripts 20
text files 13
using a database 25
using SQL statements 27
In Days, Hours, Minutes, Weeks, Years
function 464
IN statement (SQL) 30
Include marginal statistics option 238
Include Non Matches option 240
increasing font sizes 173
Index tab on JMP Starter 4
indexes of statistics and scripting terms 428
Informat function 465
initial data values 69
initial JMP windows 321
input formats 61
insert button on keypad 285
insertion points 57, 72, 83
instruments, connecting 34, 336
international numeric formats 66
Internet
file formats 112
opening Internet files 36, 38
opening Internet files 34
Interpolate conditional clause 448
inverting selections 185
Is Missing function 291, 445
italics
column name in Columns panel 55
See also fonts
Item Analysis
button on the JMP Starter 385
menu item 417
Item function 440

J
JMP 4 toolbars 352
JMP 5 compatibility 107
JMP Projects 122–125
JMP Starter 10
hiding on startup 321
menu items 424
window 377
JMP.jmpcmd 360
JMP.PFS file 338
Index

Join menu item 406
joining
  by matching columns 239, 246
  by row number 239
  tables, methods 238
  using Cartesian join 239, 244
Joint Photographics Expert Group (JPEG, JPG) 113, 119
journal
  new 39
  saving 113
  window 112
Journal menu item 404
JPEG, JPG 113, 119
JSL operators 5, 428
JSL scripts
  adding 87
  creating from a report 177
  deleting 53, 89
  editing 53, 89
  editor setting (match brackets) 324
  fonts 334
  formula editor 304
  graphics scripts 215
  new 52
  opening 12
  running 53, 89, 404
    from menus 358
    from toolbars 350
  saving in data tables 52
  stopping 404
  suppressing automatic execution 424
  viewing in formula editor 304

K
Keep All option 231
Keep current colors or markers command 193
keypad, formula editor 32, 283
K-means clustering. See clustering

L
L16, L4, and L8. See Taguchi Arrays
Label column in a transposed table 234
Label column name 228
Labeled and Labeled State functions 297, 467–468
labels
  axis 202, 334
  field widths 206
  icon 133, 191
  markers 190
  rows and columns 132, 406
  tick marks 204–208
  value labels 146
Lag function 434
languages 335
large plus cursor 57
laser pointer 330
lasso tool 185, 423
lattice. See mixture design
Launch button 5, 428
Layout menu and command 118, 429
legend colors, assigning 149
legends 193
Length function 439
Less Than function. See comparison functions
letters, Greek 334
LGamma function 436
library. See SAS transport files
LIKE statement (SQL) 30
limits, specification, control, response 154
line tool 212, 424
linear axis scale 199
lines
  width 196
  lines, dotted or dashed reference lines 209
linked data table 184, 224
list checking
  cursor 57
  setup 143
Little.jmp 247, 249
loading, SQL queries 31
local variables
  button on keypad 285
  using in formula 280, 312
locking
  columns in position on data table 409
  columns, preventing from being edited 142
  columns, preventing from being moved 137
  data tables 53, 83
Log window
  displaying 424, 428
  saving 126
Log window, saving reports to 330
Log, axis scale type 199
logarithm, natural 435
logarithmic and trigonometric functions 289, 435–436
Logistic button on JMP Starter 382
Logit function 437
Loglinear Variance 413
Long Date function 465
lower control limits (LCL) and spec limits 155
Lowercase function 439

M
magnifying glass tool 195, 423
Make Combined Table command 182
Make into Data Table command 182
Make into Matrix command 183
Make Window with Legend command 193
manipulating plots/graphs 194
Manova 413
marginal statistics 258
Marker functions 296–297, 467, 469
Marker toolbar 445
markers
adding 135
changing sizes 187
colors 186
default size 329
drawing speed/marker 188
excluding 190
hiding 190
highlighting in plots 184
labeling 190
legends 192
outlines 188
point values 193
shapes 135, 186
speed 188, 331
threshold 331
transparency 189
Markers menu item 407
mask icon 55, 131
Match Flag column 240
Match function 314, 446
Matched Pairs
button on JMP Starter 381
menu item 413
matching
brackets 324
cases while searching 76
columns when joining tables 246
targets 155
values of two data tables. See joining
whole words in search 76
matching specifications 239
math symbols 334
matrix 183
Max (summary statistics) 261
Maximum function 460
MDYHMS function 466
Mean (summary statistics) 261
Mean function 459
Measure tab on JMP Starter 389
measuring units, columns 159
Median (summary statistics) 261
members, importing 25
menu bar 397
menu tips 328
menus
defaults 353
deleting 355
personalizing (Windows) 353
rearranging 353
renaming 360
running JSL script 358
saving 360
separators 357
submenus 357
tips 6
merge horizontally. See joining
merge vertically. See concatenating
merging same name columns 240
Mersenne-Twister technique 295, 461
Microsoft Word and PowerPoint 120, 175
Min (summary statistics) 261
minimum and maximum axis values 200
Minimum function 460
missing
terms, in formulas 316
value comparison 291
values, in formulas 317
values, updating tables 251
missing data patterns 74
mistakes, correcting in formulas 304
mixture
designs 394, 411
experiments (column property) 153
mode, marker drawing 188
Model category on JMP Starter 382
modeling types
changing 54, 59
continuous 59
icons 54
nominal 59
ordinal 59
specifying 58
Modulo function 435
mono font 334
Month function 465
moving
cells and columns 80
columns 80
highlight in data table 326
objects, Layout menu 430
rows 81
windows to back 427
multiple releases of JMP on one machine 339
Multiple Series Stack 227
Multiply To (\*\=) function 469
Multivariate category on JMP Starter 384–385
Multivariate menu item 415
Munger function 438
example 313

N
N and N Missing (summary statistics) 261
N Missing function 461
naming
data tables 83
report tables 182
reports 172
natural logarithm 435
NChooseK function 436
needle plots. See Overlay Plots
NegBinomial functions 456
nested variables 259
nesting boxes, formula editor 311
Neural Net
button on JMP Starter 384
menu item 414
new
columns 67, 408
data tables 10, 400
data view 425
journal 400
project 400
rows 66
scripts 400
New Group 125
next selected 407
no-intercept model 153
nominal
logistic 413
modeling types 59
Non matches, include when joining tables 240
noncentrality 449–451, 453
nonlinear
fit 383, 393, 414
screening 383
Normal functions 452
Not conditional clause 448
Not equal to (!=) function 445
notes
as table variables 52, 84
displaying in report windows 329
saving in a column 142
NRow functions 434
Num functions 439, 459
Number of Series option 227
numeric
allowing short numeric 327
formats 61–66
in axes 200
in report tables 181
short 61
functions 288, 435
international formats 66
terms in formulas 288
Numeric Keypad Enter Moves Down option 326

O
Object Scripting Index 429
object scripting index 5
ODBC 26, 111
Offset expression 439
Oneway button on JMP Starter 382
Open All Below command 170
Open All Like This command 170
Open Database Connectivity 111
Open Office spreadsheets 13
opening
data in text editors 18
databases 26
Excel files 21
Excel worksheets 323
existing files 11
from the Internet 36, 38
Internet files 34
JMP files 11
JMP Starter window 9–10
journals 11
OpenOffice files 9–10
scripts 11
SAS files 22, 24
text files 13
Tip of the Day window 9
OpenOffice files 21
operating characteristic (OC) curves 392
operators 5
  adding 283
description 428
  in assignment functions 469
Or conditional clauses 447
ORACLE synonyms 27
order of operations 299
ordering
  columns 78–79, 409
  row order levels 153
  values 147
ordinal logistics 413
ordinal modeling types 59
orientation of formulas 308
orthogonal arrays. See Taguchi arrays outlines
  adding to markers 188
  adding to report tables 180
  structure of reports 171
Output Table option
  joining tables 240
  sorting tables 226
oval tool (simple shape tool) 212
overlay plots 387, 418

P
page
  breaks, inserting 115, 118, 170, 175
  setup 175, 402
paintbrush tool. See brush tool panels. See data table panels parallel plots 419
Parametric Regression button on JMP Starter 386
parametric survival 417
Pareto plots 390, 421
Partition button on JMP Starter 384
Partition menu item 414
password protected datasets 23
Paste Special command 120, 176
pasting with labels (column names) 80, 403
paths
  defaults 337
patterns of missing data 74
peel function 285, 305
percent of total (summary statistics) 261
picture file formats 112
plain
  report table styles 181
text files 113
plots and graphs
  annotations, adding 210
  appearances, altering 194
  graphics, adding 215
  markers, changing 186
  resizing 194
  shapes, adding 212
  statistics, adding 258, 260
PLS (partial least squares) 385, 416
plus icon 55
PNG 112, 119
point charts. See Charts points. See markers Poisson functions 456
Pollen.jmp 195
polygon (spline) tool 213–215, 424
Portable Network Graphics. See PNG Post Decrement (--) and Increment (++) functions 470
power. See Sample Size and Power PowerPoint 120, 175
precedence 299
prediction profiler. See Profiler prediction traces. See Profiler preferences 319–342, 401
preselected analysis roles 138
presentations, journal 41
principal components
  JMP Starter 385
printing 401
  page breaks 115, 118, 175
  previews 175, 401
  reports 112
  setup 175
probabilities, adding to formulas 293
Probability functions 449
Product function 460
Profiler 389, 419
properties 140–164
  creating with JSL 160
  removing 160
  standardizing 161
  table properties 183
Proportional Hazards 386, 413, 417
Proportional scroll bar thumb 326
proxy server settings 34, 337
pseudocomponent (mixture column property) 153
p-value indicator 174
PValue numeric format 63
quality improvement. See Pareto plots
Quantile functions 449–457, 460
quantile statistics 399
quantiles, adding for formulas 293
queries, SQL 31
question mark (?) tool 3
Quick Reference Guide 6
quotation marks in imported data 16

R
R&R. See variability
random data, adding 70
Random functions 294, 461–462
random number generating formulas 294
Random Reset function 463
random row selection 95
random sample (subset) 223
range checking 57, 145
ranges, summary statistics 261
read-only data 84
rearranging
cells and columns 80
results 116
recoding data 73
rectangle tool (simple shape tool) 212, 424
recurrence analysis 417
Recurrence button on JMP Starter 386
red triangle icon 176
Redo Analysis command 177
redrawing windows 426
reference lines, adding 209
refreshing windows. See redrawing windows
relative frequency. See Pareto Plots
release version 429
removing properties 160
renaming
data tables 83
report tables 182
reports 172
reordering
columns 78, 409
rows 179
Repeat function 441
Replace argument 439
replacing
tables (when sorting) 226
values in a data table 75
report tables. See tables
report windows
customizing 116
dates and times, adding 329
disclosure button 171
features 167
fonts 333
formatting 169
options 176
order of data 147, 153
rearranging results 116
red triangle icon 176
saving 112, 330
styles 329
tables 179
reports
closing 330
saving 330
rerunning an analysis 177
ResampleFreq 464
Reset Association button 339
resizing plots/graphs 194
response
surface design 393, 410
surfaces. See Contour Profiler
response limits 154
responses, multiple 156
restricting search to selected rows or columns 76
results. See report windows
reverting columns to original order 78
rich text format. See RTF
roles
design roles 156
preselected analysis roles 138
root button on keypad 285
Root function 436
Round function 435
row
editor 81, 173, 408
order levels 154
selection 91, 407
Row function 287, 433–434
row state
columns 59, 162–164
data types 59, 163
Row State functions 296, 466
rows
adding 66, 408
characteristics 129–140
coloring 134
context menu 79
<table>
<thead>
<tr>
<th>topic</th>
<th>page(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>deleting, editing, from a report</td>
<td>173</td>
</tr>
<tr>
<td>excluding</td>
<td>129</td>
</tr>
<tr>
<td>hiding</td>
<td>131</td>
</tr>
<tr>
<td>joining</td>
<td>238</td>
</tr>
<tr>
<td>labeling</td>
<td>132, 191</td>
</tr>
<tr>
<td>legends</td>
<td>192</td>
</tr>
<tr>
<td>markers</td>
<td>135</td>
</tr>
<tr>
<td>menu items</td>
<td>408</td>
</tr>
<tr>
<td>moving</td>
<td>81</td>
</tr>
<tr>
<td>order of data in reports</td>
<td>153</td>
</tr>
<tr>
<td>randomly selecting</td>
<td>95</td>
</tr>
<tr>
<td>referencing in formulas</td>
<td>287</td>
</tr>
<tr>
<td>selecting</td>
<td>90</td>
</tr>
<tr>
<td>sorting in data tables</td>
<td>225</td>
</tr>
<tr>
<td>sorting in report tables</td>
<td>179</td>
</tr>
<tr>
<td>subsetting</td>
<td>223</td>
</tr>
<tr>
<td>summarizing</td>
<td>257</td>
</tr>
<tr>
<td>transposing</td>
<td>232</td>
</tr>
<tr>
<td>rows panel</td>
<td>55–56</td>
</tr>
<tr>
<td>RTF (Rich Text Format) files</td>
<td>112, 335</td>
</tr>
<tr>
<td>Run Script button on JMP Starter</td>
<td>4</td>
</tr>
<tr>
<td>menu item</td>
<td>404</td>
</tr>
<tr>
<td>running scripts</td>
<td>53, 404</td>
</tr>
<tr>
<td>results to a database</td>
<td>111</td>
</tr>
<tr>
<td>scripts</td>
<td>177</td>
</tr>
<tr>
<td>scripts in English</td>
<td>325</td>
</tr>
<tr>
<td>selections</td>
<td>403</td>
</tr>
<tr>
<td>sessions</td>
<td>329–330</td>
</tr>
<tr>
<td>spec, control, and response limits</td>
<td>154</td>
</tr>
<tr>
<td>SQL queries</td>
<td>31</td>
</tr>
<tr>
<td>toolbars</td>
<td>360</td>
</tr>
<tr>
<td>Unicode</td>
<td>107–108, 332</td>
</tr>
<tr>
<td>saving and evaluating formulas (when concatenating tables)</td>
<td>236</td>
</tr>
<tr>
<td>Scalable Vector Graphic format</td>
<td>119</td>
</tr>
<tr>
<td>scaling</td>
<td>198</td>
</tr>
<tr>
<td>scatterplot 3d</td>
<td>387</td>
</tr>
<tr>
<td>scatterplots, 3D</td>
<td>418</td>
</tr>
<tr>
<td>menu item</td>
<td>418</td>
</tr>
<tr>
<td>ScheffeCubic function</td>
<td>437</td>
</tr>
<tr>
<td>scientific numeric formats</td>
<td>63</td>
</tr>
<tr>
<td>screening designs</td>
<td>393, 410</td>
</tr>
<tr>
<td>screening, fit model</td>
<td>413</td>
</tr>
<tr>
<td>Script button</td>
<td>4, 428</td>
</tr>
<tr>
<td>Script menu option</td>
<td>177</td>
</tr>
<tr>
<td>scripting index</td>
<td>429</td>
</tr>
<tr>
<td>scripts</td>
<td>325</td>
</tr>
<tr>
<td>scripts, graphics</td>
<td>215</td>
</tr>
<tr>
<td>scripts. See JSL scripts</td>
<td></td>
</tr>
<tr>
<td>scroll bar styles</td>
<td>326</td>
</tr>
<tr>
<td>scroll lock/unlock</td>
<td>137</td>
</tr>
<tr>
<td>scroller tool</td>
<td>423</td>
</tr>
<tr>
<td>scrolling</td>
<td>198</td>
</tr>
<tr>
<td>locking columns in position on data table</td>
<td>409</td>
</tr>
<tr>
<td>Search menu item</td>
<td>94, 404</td>
</tr>
<tr>
<td>Search/Find</td>
<td>75</td>
</tr>
<tr>
<td>using the row editor</td>
<td>82</td>
</tr>
<tr>
<td>Search/List_Control toolbar</td>
<td>344</td>
</tr>
<tr>
<td>Select Individual Excel Worksheets command</td>
<td>323</td>
</tr>
<tr>
<td>SELECT statement (SQL)</td>
<td>28</td>
</tr>
<tr>
<td>Selected function</td>
<td>297, 468</td>
</tr>
<tr>
<td>Selected State function</td>
<td>296, 467</td>
</tr>
<tr>
<td>selecting</td>
<td></td>
</tr>
<tr>
<td>cells</td>
<td>90–93, 101, 422</td>
</tr>
<tr>
<td>columns</td>
<td></td>
</tr>
<tr>
<td>in data tables</td>
<td>408</td>
</tr>
<tr>
<td>when joining tables</td>
<td>240</td>
</tr>
<tr>
<td>filters</td>
<td>24</td>
</tr>
<tr>
<td>parts of a report</td>
<td>170, 422</td>
</tr>
</tbody>
</table>

**S**

- Sample data directory: 429
- Sample size and power: 394, 411
- Sample size, in tabulate: 272

**SAS**

- Files: 22–24
- JMP Starter: 395
- Labels: 22
- Saving in SAS format: 109–110
- Transport files: 109
- Variable names: 22–24
- Save and Save As menu items: 107, 400
- Save As directory: 126
- Save Session Script: 121
- Save the session when exiting command: 329
- Saving
  - Column property: 152
  - Data tables: 107, 126
  - Journal: 115
  - Log windows: 126
  - Menus: 360
  - Reports: 112, 126, 330
  - Reports as graphics: 119
  - Results as column values: 173

**RTF (Rich Text Format) files:** 112, 335

**Run Script button on JMP Starter:** 4, 395

**Save As directory:** 126

**Save Session Script:** 121

**Save the session when exiting command:** 329

**Select Individual Excel Worksheets command:** 323

**SELECT statement (SQL):** 28
points in plots 184, 422
random rows 95
rows and columns in data tables 57, 90, 96, 403, 407
rows and columns in plots 184, 403
selection (large plus) cursor 57
sending tables or reports via email 39
separators 357
sequence data, adding 70
Sequence function 433
server settings 337
sessions
saving 329
sessions, saving 120, 330
setting
colors according to point values 193
markers according to point values 193
preselected roles 409
report titles 427–428
settings. See preferences
severity analysis. See Pareto Plots
Shade State function 297, 468
shapes. See drawing tools
Short Date function 465
short, allowing short numeric 61, 326–327
shortcuts, keyboard 315
short-integer format 327
showing
boxes around formulas 311
explanations 328
hidden windows 427
results 171
toolbars 35, 425
Sigma, assigning values 158
signal and noise factors. See Taguchi Arrays
simple shape tool (oval or rectangle) 212, 424
simplex mixture design. See mixture designs
simplify formulas 301
Sine functions 437
sizing/scaling 194
slope computation 312
Sort context-menu command 79
Sorting
results by fields in a database (SQL) 29
sorting
data tables 225, 405
order 226
report table columns 179
source columns 237
Source Flag column 240
Source Label Column 228
spec limits 154
specifying
columns when importing text files 17
fields when importing text files 17
graphic formats 335
speed, marker 188, 331
spinning plots 387
menu item 418
splash window 321
Split Label Col 231–232
splitting columns 230, 405
SQL statements 27–28
SQL WHERE clause editor 32
Squish function 436
stacking columns 227
Standard Deviation 261, 459
Standard Error 261
standard least squares 413
standardizing, attributes and properties 161, 409
startup windows 321
statistical
functions 294
index 4, 428
Statistics button 238, 260
statistics column 258–260
status bar 425
Std Dev and Std Err (summary statistics) 261
Step conditional clause 448
Stepwise 413
stopping scripts 404
stripping enclosing quotes on imported data 16
subgroups, summary statistics 259
submenus, customizing 357
Subqueries (SQL) 31
Subscript function 434
Subset menu item 405
subsetting
from a data table 223
from a histogram 224
Substr function 439
Subtract To (=) function 469
Sum function 459
Sum Wgt (summary statistics) 261
Summary menu item 405
summary table, creating 258
Summation function 460
suppressing formula evaluation in data tables 53
on open 324
when creating a subset 224
when creating formulas 302
when joining tables 241
when splitting columns 231
when stacking columns 228
surface plots 422
survival
  analyses 417
Survival category on JMP Starter 386
SVG 113
switch terms button on keypad 285
symbols, math 334
synonyms (ORACLE) 27
system tables (ORACLE) 27

t Density function 453
t Distribution function 453
t Quantile function 453
table variables
  adding 84–87
  creating 52, 85
  editing 86
  in formulas 85, 280
  notes 85
tables
  concatenating 236
  fonts 333
  menu item 405
  panel 51, 54
  report tables 179, 182, 334
  See also data tables
toolbar 433
  tabulating data 262
  Taguchi arrays 393, 411
tangent functions 437
target value 155
terms, formula 316
terms, switching in a formula 285
ternary plots 387, 419
text
  editing windows 18
  exporting 109
  importing 14, 339
  mode for formulas 304
  opening text files 13
  saving as text 108
  three-dimensional scatterplots 387
  menu item 418
  threshold of markers 331
  thumb styles 326
  tick marks 204
tile windows 426
tiling windows 426
time series 383, 415
  See also Multivariate
time, adding to reports 329
Tip of the Day window
  description 6, 9
  hiding and showing 321, 328
title bar fonts 334
Today function 464
toolbars
  adding buttons 349
  adding toolbars 348
  Analyze toolbar 343
defaults 343
deleting buttons and toolbars 347–348
  File_Edit toolbar 343
importing 352
personalizing (Macintosh) 342
personalizing (Windows) 343
rearranging toolbars and buttons 345
running JSL script 350
saving 360
showing and hiding 343
Tools toolbar 344
types of 343, 422
tools, cursor 57, 210, 422
Topic Help button 4
Topic Help button in Statistics Index 428
traditional scroll bar styles 326
transcendental functions 289, 435–436
transparency, markers 189
transposing rows and columns 232, 406
tree map 419
Trial1.jmp 242, 247
Trial2.jmp 242
triangle icon 176
trigonometric functions 289
Trim function 440
truth tables 448
Tukey HSD 449
Tukey HSD Quantile function 457
tutorial 3
tutorials 429
  creating formulas 310
  learning JMP 3
two-digit year rule, importing data 17
two-way table of summary statistics 259
TXT (text) file types 113
**U**

unary sign function button on keypad 285

**Undo command** 304, 402

**Ungroup command** 118, 429

Unicode 107–108, 332

units 159

univariate statistics 258, 260

updating data tables 250

upper control limits (UCL) 155

upper spec limits 155

Uppercase function 439

URL_List toolbar 35–36, 344

US Population.jmp 281

Use Excel Labels as Headings 323

User Tables, database connections 27

**V**

validating data 143–146, 409

value colors 149

value labels 146

values

  - high and low for columns (in DOE) 152

  - minimum and maximum 200

  - ordering 147

Variability button on JMP Starter 390

Variability/Gage Chart menu item 420

variable names 22, 24

variables

  - local 280

  - table. See table variables

Variance (summary statistics) 261

version number 429

versions, multiple versions of JMP 339

vertical, formula display 308

View menu 424–425

Views, database 27

**W-Z**

web page, JMP 429

Weibull functions 454

weight, preselected roles 139

weight, response importance 156

WHERE clause editor 32

WHERE statement (SQL) 29

While conditional clause 448

widths

  - field width of columns 182

  - fields in report tables 181

fixed width incoming data 15

tick mark labels 206

Window list 424

windows 321

  - arranging on desktop 426

  - colors 332

  - JMP Starter 321

  - menu 425–428

  - redrawing/refreshing 426

  - splash 321

Windows list 322

Windows Metafile 113, 119

WMF (Windows Media File) format 113, 119

Word function 440

Word. See Microsoft Word

worksheets and workbooks (Excel) 323

worksheets, selecting 323

WWW. See Internet

Year function 465

yellow tag icon 55, 133, 191

zooming 195