应用常见问题

1. 应按何种思路使用JMP的菜单?

答:为了更好地帮助用户使用统计分析方法进行科学分析,降低对用户统计学专业知识的要求,让未经历过太多统计知识培训的人员也能使用JMP分析和解决问 题,JMP对菜单设置进行了精心安排,它不像一般的统计软件那样在菜单中罗列统计工具,让用户根据情况判断需要使用何种统计工具。JMP菜单按照解决问题 的思路进行安排,能很好地预防用户因为使用错误统计工具而得到错误的分析结果。

JMP菜单如下图:

JMP Menu Chinese

“文件”和“编辑”两个菜单与常用软件对应的菜单内容相似。
“表”菜单主要用来对需要分析的数据进行清洗和整理。
“试验设计”菜单主要供用户制定科学的试验计划使用,试验设计是JMP最具特色的功能之一。
“分析”菜单是JMP主要的数据分析功能菜单,其下拉菜单如下:

Menu Analysis Chinese
  • “分布”子菜单主要用来分析单列数据中的信息,如计算均值、方差或进行单样本假设检验等
  • “以X拟合Y”子菜单主要用来分析两列变量之间的关系,如一元回归分析、列联表、Logistic Regression、假设检验等
  • “模型拟合”子菜单主要用于多元变量之间的统计建模和分析
  • “建模”子菜单主要用于高级统计建模,如时间序列分析,决策树(Decision Tree),神经网络等
  • “图形”菜单主要用于图形可视化分析,在这里,您可以使用各种图形对数据进行分析
2. JMP中是否自带了一部分案例数据?是否有一些使用手册?

答:JMP自带的数据可以在JMP的菜单里找到:帮助->样本数据目录。

JMP的使用手册(pdf文件)也可以在JMP的菜单里找到: 帮助->手册;帮助->教程。

3. 用JMP打开Excel文件时有哪些常用注意事项?

答:JMP可以直接打开Excel文件,还能将Excel工作表中的第一行自动作为JMP表格的标签,以及让您选择您需要打开Excel文件中的哪张工作表。具体操作如下:

  • 文件->打开->选择文件类型->在如下的对话框中进行预设置
  • 如果您希望将Excel文件的第一行作为JMP数据表标签,请在“最佳推测”/始终/从不之间进行选择
  • 如果您的Excel文件中有多张工作表,而您想只打开指定工作表,请选择“允许选择单个工作表
Open Excel Chinese
4. 如何最方便地查看所有数据表及分析报告?

答:最简单的方式是通过JMP的“窗口列表”功能,在窗口列表中选中需要查看的数据表或分析报告,相应的内容就会在JMP主窗口中显示出来。打开“窗口列表”的方法为在JMP的界面中进行菜单操作:视图->窗口列表。

5. 如何在JMP的菜单中放入更多个性化功能按钮?

答:在JMP里,您可以将自己常用的分析工具进行重新组合,生成自己的个性化菜单,比如“六西格玛工具”菜单等。 您也可以将一个批处理命令的JSL脚本存储成一个菜单命令或者存储成工具栏中的一个按钮,之后,您只需要点击一两下鼠标就能轻松完成您需要实现的数据整 理、分析或自动报表展现功能。

要实现上述功能,您需要使用JMP的“菜单和工具栏自定义”功能。操作步骤如下:
编辑->自定义->菜单和工具栏->选择您要插入菜单(或工具)项的位置后插入新项目(图1)->鼠标右键单击新项目以编辑新项目的性质(图1)->点击“应用”即可。

Make Button Chinese
6. 如何连接数据库

答:JMP可以直接打开包括Excel、CSV、TXT等在内的近40种格式的文件。同时,JMP还可以自动从远程数据库获取数据。菜单操作为:文件->数据库->打开表->连接->在弹出的窗口中找到已经建立好的数据源文件打开即可。

您可以通过下面的方法实现建立好数据源:
(在Windows操作系统中)开始->设置->控制面板->管理工具->双击“数据源”。在这里就可以建立您需要的数据源了。

如果您还希望编写一些SQL命令对读取数据的条件进行限定和控制,可以点击“高级”按钮进入SQL语句编辑界面。如下图:

Connect Database Chinese
7. 如果我已经用JMP做出了一个分析结果或一幅图形,我应当如何调出我的分析过程以向别人解释我是如何做出来的呢?

答:至少有两种方法可以解决这个问题:
1. 如果您要解释的这个分析结果是刚刚做出来的,您可以重新进行一次分析,在命令设置窗口中点击“重新调用”按钮(如下图),那么您刚才的设置就可以看到了。

Re-use Chinese

2. 如果您在得到需要解释的分析结果后又做了其他分析,可以用下面的方式:点击分析结果左上角红色的三角形->脚本->将脚本保存至脚本窗口->显示在脚本窗口中的脚本程序将帮助您解释您的分析过程(如下图)。

JSL to Table Chinese
8. Excel如果有合并单元格或数据透视表,用JMP打开后会出现很多空白单元格,如何才能方便地填充这些单元格呢?

答:可以通过执行下面的jsl代码将这些空白单元格很快地进行填充,方法是在JMP中:文件->新建 ->脚本->将下面的JSL代码粘贴入脚本窗口->打开您需要填充的数据表->回到刚才的脚本窗口->点击JMP工具栏中 的“执行脚本”按钮->在如下图中的对话框中选择您需要填充的列->点击“确定”即可。当然您也可以将下面的脚本程序做成一个按钮,以后再要 进行这个操作只要点击一下这个按钮就可以了。

JSL Fill Blank Chinese
JSL Fill- Blank Chinese
9.JMP中英文双语版软件如何在中文界面和英文界面之间切换?
  1. 从中文切换到英文:
    进行菜单操作:文件->首选项->Windows特定->将“显示语言”改成English->确定->重新启动JMP
  2. 从英文切换到中文:
    进行菜单操作: File->Preferrence->Windows Specific->将"Display language"改成中文->OK->重新启动JMP

完成上述菜单操作后,如果发现操作界面只有部分内容完成了切换,请继续进行如下菜单操作:

  1. 中文切换到英文:进行菜单操作:编辑->自定义->恢复到出厂默认值
  2. 英文切换到中文: 进行菜单操作:Edit->Customize->Revert to factory defaults
10.为什么将界面语言选成“中文”后,操作窗口显示为中文,但菜单还是英文的?或者反之?

答:完成语言切换操作后,如果发现上述情况,请继续进行如下菜单操作:1. 中文切换到英文: 进行菜单操作:编辑->自定义->恢复到出厂默认值 2. 英文切换到中文: 进行菜单操作:Edit->Customize->Revert to factory defaults。

Back to Top